Community discussions

MikroTik App
 
ttaiw
just joined
Topic Author
Posts: 16
Joined: Mon Jun 29, 2009 5:48 pm

7.1rc3 - IPv6 Unable to Use

Wed Sep 15, 2021 6:53 am

My Router RB850Gx4 cannot use ipv6 after upgrade from 6.48.4
[admin@Ros] > /ipv6/address/print
Flags: D - DYNAMIC; G, L - LINK-LOCAL
Columns: ADDRESS, FROM-POOL, INTERFACE, ADVERTISE
# ADDRESS FROM-POOL INTERFACE ADVERTISE
0 G 2405:9800:b600:7d8a::/64 ipv6 ether2 no
1 DL fe80::2ec8:1bff:fec8:c236/64 ether5 no
2 DL fe80::2ec8:1bff:fec8:c232/64 ether1 no
3 DL fe80::2ec8:1bec:44c8:c232/64 pppoe-out1 no
4 DL fe80::2ec8:1bff:fec8:c233/64 ether2 no
5 DL fe80::7faf:141d:3d18:552d/64 <ovpn-heroG> no
6 DL fe80::98d6:44ff:fe8b:62c0/64 docker no
[admin@Ros] > ping 2404:6800:4001:80f::2003 interface=ether2
SEQ HOST SIZE TTL TIME STATUS
0 22 (Invalid argument)
1 22 (Invalid argument)
2 22 (Invalid argument)
3 22 (Invalid argument)
4 22 (Invalid argument)
5 22 (Invalid argument)
sent=6 received=0 packet-loss=100%


 
mducharme
Trainer
Trainer
Posts: 1432
Joined: Tue Jul 19, 2016 6:45 pm

Re: 7.1rc3 - IPv6 Unable to Use

Wed Sep 15, 2021 7:13 am

Hello,

Try going into IPv6->settings and check disable IPv6, then click Apply, and then uncheck it again and click Apply again, and see if there is any change.
 
ttaiw
just joined
Topic Author
Posts: 16
Joined: Mon Jun 29, 2009 5:48 pm

Re: 7.1rc3 - IPv6 Unable to Use

Wed Sep 15, 2021 7:22 am

Same result. Unable to use.
Hello,

Try going into IPv6->settings and check disable IPv6, then click Apply, and then uncheck it again and click Apply again, and see if there is any change.
[admin@Ros] > /ipv6/settings/print 
                  disable-ipv6: yes
                       forward: yes
              accept-redirects: yes-if-forwarding-disabled
  accept-router-advertisements: yes-if-forwarding-disabled
          max-neighbor-entries: 8192
[admin@1744a] > ping 2404:6800:4001:80f::2003 interface=ether2 
  SEQ HOST                                     SIZE TTL TIME       STATUS                                             
    0                                                              invalid interface or local address                 
    1                                                              invalid interface or local address                 
    sent=2 received=0 packet-loss=100% 

[admin@Ros] > /ipv6/settings/set disable-ipv6=no 
[admin@Ros] > /ipv6/settings/print 
                  disable-ipv6: no
                       forward: yes
              accept-redirects: yes-if-forwarding-disabled
  accept-router-advertisements: yes-if-forwarding-disabled
          max-neighbor-entries: 8192
[admin@Ros] > ping 2404:6800:4001:80f::2003 interface=ether2 
  SEQ HOST                                     SIZE TTL TIME       STATUS                                             
    0                                                              22 (Invalid argument)                              
    1                                                              22 (Invalid argument)                              
    2                                                              22 (Invalid argument)                              
    sent=3 received=0 packet-loss=100% 

[admin@Ros] > /ipv6/address/print 
Flags: D - DYNAMIC; G, L - LINK-LOCAL
Columns: ADDRESS, FROM-POOL, INTERFACE, ADVERTISE
#    ADDRESS                       FROM-POOL  INTERFACE     ADVERTISE
0  G 2405:9800:b600:7d8a::/64      ipv6       ether2        no       
1 DL fe80::2ec8:1bec:44c8:c232/64             pppoe-out1    no       
2 DL fe80::7faf:141d:3d18:552d/64             <ovpn-heroG>  no       
3 DL fe80::98d6:44ff:fe8b:62c0/64             docker        no       
4 DL fe80::2ec8:1bff:fec8:c236/64             ether5        no       
5 DL fe80::2ec8:1bff:fec8:c232/64             ether1        no       
6 DL fe80::2ec8:1bff:fec8:c233/64             ether2        no
Last edited by ttaiw on Wed Sep 15, 2021 12:08 pm, edited 1 time in total.
 
jookraw
newbie
Posts: 32
Joined: Mon Aug 19, 2019 3:06 pm

Re: 7.1rc3 - IPv6 Unable to Use  [SOLVED]

Wed Sep 15, 2021 10:40 am

Check your IPv6 routes, especially if you see 2 default routes on your WAN interface, with me, every time that my PPPoE connection restarts, I get a weird default route without a link-local address as nexthop the valid one should have a fe80:... as a nexthop/gateway not your interface, check if you see this as well.

like below:
> ipv6/route/print
Flags: D - dynamic; X - disabled, I - inactive, A - active; 
c - connect, s - static, r - rip, b - bgp, o - ospf, d - dhcp, v - vpn, m - mode>
H - hw-offloaded; + - ecmp 
 #       DST-ADDRESS              GATEWAY                  DISTANCE
   DAv + ::/0                     PPPoEv6                         1
   DAd + ::/0                     fe80::5a00:bbff:fe0b:...        1
 
ttaiw
just joined
Topic Author
Posts: 16
Joined: Mon Jun 29, 2009 5:48 pm

Re: 7.1rc3 - IPv6 Unable to Use

Wed Sep 15, 2021 12:15 pm

It worked.. need to disable "add-default-route" in DHCPv6 Client. Thank you very much
[admin@Ros] /ipv6> export 
# sep/15/2021 16:10:20 by RouterOS 7.1rc3
# software id = 
#
# model = RB450Gx4
# serial number = 
/ipv6 address
add from-pool=IPv6 interface=ether2
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1 pool-name=IPv6 request=prefix use-peer-dns=no
[admin@Ros] /ipv6> route/print 
Flags: D - DYNAMIC; A - ACTIVE; c, d, v, y - COPY; + - ECMP
Columns: DST-ADDRESS, GATEWAY, DISTANCE
     DST-ADDRESS               GATEWAY                             DISTANCE
DAd+ ::/0                      fe80::200:5eff:fe00:103%pppoe-out1         1
DAv+ ::/0                      pppoe-out1                                 1
DAc  2405:9800:b600:3531::/64  ether2                                     0
D d  2405:9800:b600:3531::/64                                             1

[admin@Ros] /ipv6> ping 2404:6800:4001:807::2003
bad command name ping (line 1 column 1)
[admin@Ros] /ipv6> /ping 2404:6800:4001:807::2003
  SEQ HOST                                     SIZE TTL TIME       STATUS                                                                                                          
    0                                                              22 (Invalid argument)                                                                                           
    1                                                              22 (Invalid argument)                                                                                           
    2                                                              22 (Invalid argument)                                                                                           
    sent=3 received=0 packet-loss=100% 

[admin@Ros] /ipv6> dhcp-client/set add-default-route=no numbers=0
[admin@Ros] /ipv6> export 
# sep/15/2021 16:11:27 by RouterOS 7.1rc3
# software id = -DATM
#
# model = RB450Gx4
# serial number = 
/ipv6 address
add from-pool=IPv6 interface=ether2
/ipv6 dhcp-client
add interface=pppoe-out1 pool-name=IPv6 request=prefix use-peer-dns=no
[admin@Ros] /ipv6> /ping 2404:6800:4001:807::2003
  SEQ HOST                                     SIZE TTL TIME       STATUS                                                                                                          
    0 2404:6800:4001:807::2003                   56 114 39ms100us  echo reply                                                                                                      
    1 2404:6800:4001:807::2003                   56 114 39ms19us   echo reply                                                                                                      
    2 2404:6800:4001:807::2003                   56 114 37ms531us  echo reply                                                                                                      
    sent=3 received=3 packet-loss=0% min-rtt=37ms531us avg-rtt=38ms550us max-rtt=39ms100us 

[admin@Ros] /ipv6> route/print 
Flags: D - DYNAMIC; A - ACTIVE; c, d, v, y - COPY
Columns: DST-ADDRESS, GATEWAY, DISTANCE
    DST-ADDRESS               GATEWAY     DISTANCE
DAv ::/0                      pppoe-out1         1
DAc 2405:9800:b600:3531::/64  ether2             0
D d 2405:9800:b600:3531::/64                     1
[admin@Ros] /ipv6> 

Check your IPv6 routes, especially if you see 2 default routes on your WAN interface, with me, every time that my PPPoE connection restarts, I get a weird default route without a link-local address as nexthop the valid one should have a fe80:... as a nexthop/gateway not your interface, check if you see this as well.

like below:
> ipv6/route/print
Flags: D - dynamic; X - disabled, I - inactive, A - active; 
c - connect, s - static, r - rip, b - bgp, o - ospf, d - dhcp, v - vpn, m - mode>
H - hw-offloaded; + - ecmp 
 #       DST-ADDRESS              GATEWAY                  DISTANCE
   DAv + ::/0                     PPPoEv6                         1
   DAd + ::/0                     fe80::5a00:bbff:fe0b:...        1
 
dksoft
Member Candidate
Member Candidate
Posts: 106
Joined: Thu Dec 06, 2012 8:56 am
Location: Germany

Re: 7.1rc3 - IPv6 Unable to Use

Wed Sep 15, 2021 12:18 pm

Setup: Dt. Telekom FTTH, CCR2004, CRS317, CRS328-24P-4S+RM, multiple WAP AC via CAPsMAN. MCTNA

Who is online

Users browsing this forum: fragtion, martix77, mikeeg02, Paternot, patrick7 and 12 guests