Community discussions

 
pbr3000
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Fri Jan 08, 2010 7:31 am

Re: 6.34 release candidate version topic!

Sat Dec 19, 2015 11:58 pm

This thread is to discuss about this candidate software version or to collect speculations and personal opinions about the stars in the sky ?!
Mikrotik does not like to share, only when "willing" to launch something new ....of course always late and incomplete but to improve definitelly over the time: always the same pattern.
The Zorro's reply is about "kernel - general improvement for core process scheduling" in the changelog from v6.34. From there he extrapolates to other issues that I found valid (and accurate).
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Mon Dec 21, 2015 8:19 am

General kernel improvement was an simple upgrade which can fix some of kernel failures on devices where CPU is 100% loaded.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Mon Dec 21, 2015 12:08 pm

6.34rc23 version is released.

Changes since previous version:
*) crypto - fixed kernel failure in talitos HW encryption;
*) net - do not allow to add new firewall rule before built-in (reverted);
*) wireless - regular “wireless” package is now retired and replaced by "wireless-fp" and "wireless-cm2";
*) winbox - include FP in fast-path column names.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2286
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.34 release candidate version topic!

Mon Dec 21, 2015 12:31 pm

6.34rc23 version is released.

*) wireless - regular “wireless” package is now retired and replaced by "wireless-fp" and "wireless-cm2";
What is this?

regular wireless was removed in 6.30
*) removed wireless package from routeros bundle package,
new wireless-fp is left in place and wireless-cm2 added as option;
LAN, FTTx, Wireless. ISP operator
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Mon Dec 21, 2015 12:45 pm

honzam - If you use wireless package then you will not be able to upgrade. You must install either "wireless-fp" or "wireless-cm2" on your device, remove "wireless" package and upgrade after that.

Previous change simply removed "wireless" package from bundle. Now "wireless" package does not exist at all. Until 6.34rc23 "wireless" package was still available in our download page under "Extra packages".
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2286
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.34 release candidate version topic!

Mon Dec 21, 2015 2:00 pm

Thank you for the explanation
LAN, FTTx, Wireless. ISP operator
 
raffav
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Oct 24, 2012 4:40 am

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 3:10 pm

Hello

i am unable to resolve DNS, using 6.34rc22-rc23 on the crs-125, but from crs i have internet access.
the CRS is connect to a 433 where get internet access
 resolve www.google.com
failure: dns server failure
11:13:06 system,info dns changed by Vaselli 
11:13:08 dns,packet --- sending udp query to 8.8.8.8:53: 
11:13:08 dns,packet id:e1d2 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error' 
11:13:08 dns,packet question: www.google.com:A:IN 
11:13:17 dns,packet --- sending udp query to 8.8.8.8:53: 
11:13:17 dns,packet id:84a6 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error' 
11:13:17 dns,packet question: cloud.mikrotik.com:A:IN 
11:14:17 dns,packet --- sending udp query to 8.8.8.8:53: 
11:14:17 dns,packet id:90e8 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error' 
11:14:17 dns,packet question: cloud.mikrotik.com:A:IN 
You do not have the required permissions to view the files attached to this post.
Last edited by raffav on Tue Dec 22, 2015 3:15 pm, edited 1 time in total.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 3:13 pm

console and Winbox use different DNS settings. Using the GUI you use the DNS Server configured in your Windows computer. Using the command line, you use "ip dns" settings.

So in this case I guess your Windows PC has another DNS configured, but the 192.168.99.1 DNS is not responding. Try to enter 8.8.8.8 in your "ip dns" menu
No answer to your question? How to write posts
 
raffav
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Oct 24, 2012 4:40 am

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 3:20 pm

console and Winbox use different DNS settings. Using the GUI you use the DNS Server configured in your Windows computer. Using the command line, you use "ip dns" settings.

So in this case I guess your Windows PC has another DNS configured, but the 192.168.99.1 DNS is not responding. Try to enter 8.8.8.8 in your "ip dns" menu

ignore the 192.168.99.1, it was not apllyed the server is 8.8.8.8

I am remotey accessing this CRS and 433 iam not in the same lan


CRS
[Vaselli@CRS] > resolve www.google.com
failure: dns server failure
[Vaselli@CRS] > ip dns print 
                servers: 8.8.8.8
        dynamic-servers: 
  allow-remote-requests: yes
    max-udp-packet-size: 4096
   query-server-timeout: 0ms
    query-total-timeout: 0ms
             cache-size: 2048KiB
          cache-max-ttl: 2d
             cache-used: 11KiB
[Vaselli@CRS] > ip dns cache print 
Flags: S - static 
 #   NAME        ADDRESS                                       TTL         
 0 S google      8.8.8.8                                       2d          
 1 S google      8.8.4.4                                       2d          
[Vaselli@CRS] > ip dns static print 
Flags: D - dynamic, X - disabled, R - regexp 
 #     NAME       ADDRESS                                      TTL         
 0     google     8.8.8.8                                      2d          
 1     google     8.8.4.4                                      2d  
 
RB433
[Vaselli@Raffa's MK] > resolve www.google.com
[Vaselli@Raffa's MK] > ip dns print          
                servers: 8.8.8.8
        dynamic-servers: 
  allow-remote-requests: yes
    max-udp-packet-size: 512
   query-server-timeout: 2s
    query-total-timeout: 10s
             cache-size: 2048KiB
          cache-max-ttl: 1w
             cache-used: 16KiB
[Vaselli@Raffa's MK] > ip dns cache print    
Flags: S - static 
 #   NAME       ADDRESS                                      TTL         
 0 S google     8.8.8.8                                      1d          
 1 S google     8.8.4.4                                      1d          
 2 S oi         200.222.122.132                              1d          
 3 S oi         200.222.123.100                              1d          
 4   therich... 192.237.140.116                              23h30m36s   
 5   cloud.m... 91.188.51.139                                1h26m10s    
 6   cloud.m... 81.198.87.240                                1h26m10s    
 7   costco.ca  170.167.8.7                                  4h8m53s     
 8   wikimap... 192.69.192.210                               20m33s      
[Vaselli@Raffa's MK] > ip dns static print 
Flags: D - dynamic, X - disabled, R - regexp 
 #     NAME      ADDRESS                                     TTL         
 0     Google    8.8.8.8                                     1d          
 1     Google    8.8.4.4                                     1d          
 2     OI        200.222.122.132                             1d          
 3     OI        200.222.123.100                             1d          
[Vaselli@Raffa's MK] > 
Last edited by raffav on Tue Dec 22, 2015 3:24 pm, edited 1 time in total.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 3:22 pm

How can I know what to ignore? Please post full and correct config so we can find the issue.
No answer to your question? How to write posts
 
raffav
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Oct 24, 2012 4:40 am

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 3:29 pm

How can I know what to ignore? Please post full and correct config so we can find the issue.
ok, what part of the conf do you whant ?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 3:38 pm

output of the command /export
and output of the ping to the DNS server that you will see in the export
No answer to your question? How to write posts
 
raffav
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Oct 24, 2012 4:40 am

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 3:50 pm

/interface ethernet
set [ find default-name=ether23 ] comment=\
    "TRUNK TO 433UAH -eth2 (old-TRUNK TO CCR)"
/ip neighbor discovery
set ether23 comment="TRUNK TO 433UAH -eth2 (old-TRUNK TO CCR)"
/interface vlan
add interface=ether23 l2mtu=1584 name=vlan99_MGT vlan-id=99
/interface ethernet
set [ find default-name=ether2 ] master-port=ether23
set [ find default-name=ether3 ] master-port=ether23
set [ find default-name=ether4 ] master-port=ether23
set [ find default-name=ether5 ] master-port=ether23
set [ find default-name=ether6 ] master-port=ether23
set [ find default-name=ether7 ] master-port=ether23
set [ find default-name=ether8 ] disabled=yes master-port=ether23
set [ find default-name=ether9 ] master-port=ether23
set [ find default-name=ether10 ] master-port=ether23
set [ find default-name=ether11 ] master-port=ether23
set [ find default-name=ether12 ] master-port=ether23
set [ find default-name=ether13 ] master-port=ether23
set [ find default-name=ether14 ] master-port=ether23
set [ find default-name=ether15 ] master-port=ether23
set [ find default-name=ether16 ] master-port=ether23
set [ find default-name=ether17 ] master-port=ether23
set [ find default-name=ether18 ] master-port=ether23
set [ find default-name=ether19 ] master-port=ether23
set [ find default-name=ether20 ] comment="DECODER TV OI" master-port=ether23
set [ find default-name=ether21 ] comment="TRUNK TO 433UAH -eth3" \
    master-port=ether23
set [ find default-name=ether22 ] comment="TRUNK TO OI FIBRA" master-port=\
    ether23
/ip neighbor discovery
set ether20 comment="DECODER TV OI"
set ether21 comment="TRUNK TO 433UAH -eth3"
set ether22 comment="TRUNK TO OI FIBRA"
/interface ethernet switch
set forward-unknown-vlan=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-128-cbc
/system logging action
set 0 memory-lines=10000
set 1 disk-file-name=""
/tool user-manager customer
set admin access=\
    own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether23 vlan-id=2
add tagged-ports=ether23 vlan-id=3
add tagged-ports=ether23 vlan-id=4
add tagged-ports=ether23 vlan-id=5
add tagged-ports=ether23 vlan-id=6
add tagged-ports=ether22,ether23 vlan-id=210
add tagged-ports=ether22,ether23 vlan-id=220
add tagged-ports=ether19,ether23 vlan-id=7
add tagged-ports=ether19,ether23,switch1-cpu vlan-id=99
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=2 ports=\
    ether2,ether3,ether4,ether5,ether6,ether7,ether8 sa-learning=yes
add customer-vid=0 new-customer-vid=4 ports=ether14 sa-learning=yes
add customer-vid=0 new-customer-vid=5 ports=ether15 sa-learning=yes
add customer-vid=0 new-customer-vid=6 ports=ether16 sa-learning=yes
add customer-vid=0 new-customer-vid=3 ports=\
    ether9,ether10,ether11,ether12,ether13 sa-learning=yes
add customer-vid=0 new-customer-vid=220 ports=ether20 sa-learning=yes
add customer-vid=0 new-customer-vid=7 ports=ether17,ether18 sa-learning=yes
/interface ethernet switch vlan
add ports=ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether23 vlan-id=2
add ports=ether9,ether10,ether11,ether12,ether13,ether23 vlan-id=3
add ports=ether14,ether23 vlan-id=4
add ports=ether15,ether23 vlan-id=5
add ports=ether16,ether23 vlan-id=6
add ports=ether22,ether23 vlan-id=210
add ports=ether20,ether22,ether23 vlan-id=220
add ports=ether19,ether23 vlan-id=7
add ports=ether19,ether23,switch1-cpu vlan-id=99
/interface wireless cap
set caps-man-addresses=192.168.99.1 certificate=request discovery-interfaces=\
    ether23 interfaces=*1 lock-to-caps-man=yes
/ip address
add address=192.168.88.2/24 interface=ether1 network=192.168.88.0
add address=192.168.99.2/24 interface=vlan99_MGT network=192.168.99.0
/ip cloud
set ddns-enabled=yes
/ip dns
set allow-remote-requests=yes cache-max-ttl=2d query-server-timeout=0ms \
    query-total-timeout=0ms servers=8.8.8.8
/ip dns static
add address=8.8.8.8 name=google ttl=2d
add address=8.8.4.4 name=google ttl=2d
/ip route
add distance=1 gateway=192.168.99.1
/ip service
set telnet address=\
    192.168.2.0/24,192.168.3.0/24,192.168.99.0/24,172.16.4.0/24
set ftp disabled=yes
set www port=8787
set ssh port=222
set api port=8730
set winbox port=8292
set api-ssl port=8731
/lcd
set backlight-timeout=15m
/lcd pin
set pin-number=8723
/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add
/system clock
set time-zone-autodetect=no time-zone-name=America/Sao_Paulo
/system identity
set name=CRS
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set vlan99_MGT disabled=yes display-time=5s
set wlan1 disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
set ether2 disabled=yes display-time=5s
set ether3 disabled=yes display-time=5s
set ether4 disabled=yes display-time=5s
set ether5 disabled=yes display-time=5s
set ether6 disabled=yes display-time=5s
set ether7 disabled=yes display-time=5s
set ether8 disabled=yes display-time=5s
set ether9 disabled=yes display-time=5s
set ether10 disabled=yes display-time=5s
set ether11 disabled=yes display-time=5s
set ether12 disabled=yes display-time=5s
set ether13 disabled=yes display-time=5s
set ether14 disabled=yes display-time=5s
set ether15 disabled=yes display-time=5s
set ether16 disabled=yes display-time=5s
set ether17 disabled=yes display-time=5s
set ether18 disabled=yes display-time=5s
set ether19 disabled=yes display-time=5s
set ether20 disabled=yes display-time=5s
set ether21 disabled=yes display-time=5s
set ether22 disabled=yes display-time=5s
set ether23 disabled=yes display-time=5s
set ether24 disabled=yes display-time=5s
set sfp1 disabled=yes display-time=5s
/system logging
add topics=dns,packet
/system ntp client
set enabled=yes primary-ntp=200.192.232.8 secondary-ntp=200.160.0.8
/tool romon
set enabled=yes
/tool romon port
add
/tool user-manager database
set db-path=user-manager
Vaselli@CRS] > ping 8.8.8.8
  SEQ HOST                                     SIZE TTL TIME  STATUS                                                                                                        
    0 8.8.8.8                                    56  52 4ms  
    1 8.8.8.8                                    56  52 5ms  
    2 8.8.8.8                                    56  52 6ms  
    3 8.8.8.8                                    56  52 6ms  
    4 8.8.8.8                                    56  52 6ms  
    5 8.8.8.8                                    56  52 6ms  
    6 8.8.8.8                                    56  52 5ms  
    7 8.8.8.8                                    56  52 6ms  
    sent=8 received=8 packet-loss=0% min-rtt=4ms avg-rtt=5ms max-rtt=6ms
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 4:08 pm

Your server query timeout values are 0.

Use:
/ip dns set query-server-timeout=2s query-total-timeout=10s
 
raffav
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Oct 24, 2012 4:40 am

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 4:23 pm

Your server query timeout values are 0.

Use:
/ip dns set query-server-timeout=2s query-total-timeout=10s

Thanks,
that "0s" was weird i dont touch the crs setting for a while i only set up to schedule to auto update the ros version
 
User avatar
SirDJNeo
just joined
Posts: 5
Joined: Tue Dec 08, 2015 12:25 pm
Location: South Africa

Re: 6.34 release candidate version topic!

Tue Dec 22, 2015 8:15 pm

Capture.JPG
This is really going to be an issue in the future if not resolved.

Can anyone give feedback as to the reason why the bytes limit has not been imported into per server profile?

Will save me extra scripting if it can be added into the server profile than being added as GLOBAL for all.

Means add something that scripted works better as it can be done per server profile where this locks it down completely.

Thanks
You do not have the required permissions to view the files attached to this post.
 
krisjanis
MikroTik Support
MikroTik Support
Posts: 391
Joined: Tue Feb 05, 2013 5:00 pm

Re: 6.34 release candidate version topic!

Wed Dec 23, 2015 6:00 pm

@SirDJNeo

What is the exact problem with modifying the values in default-trial user entry? It's values are applied to all new users that connect as trial clients.

Also it can be done with individual default-trial user for each server. Check wiki article for example on this:
http://wiki.mikrotik.com/wiki/Manual:Trial_user_limits
 
User avatar
SirDJNeo
just joined
Posts: 5
Joined: Tue Dec 08, 2015 12:25 pm
Location: South Africa

Re: 6.34 release candidate version topic!

Wed Dec 23, 2015 7:31 pm

@krisjanis

The issue is with it being globally set and not per server profile.

Meaning if I have 6 Server Profiles on one of my CCR1016's or CCR1009's then the ability to be able to set the trial byte limit per server profile would be useful vs forcing all 6+ on 250MB vs being able to set each one separately. Especially when all 6 profiles / hotspot seperations have different requirements.

Currently this can be done via scripting but seeing as the devs were nice enough to add a method to be able to set the users bytes limit with a "Default User" then ability to have it be able to set per profile like the uptime and reset time can be set per server profile would be nice.

But without being able to set it per server profile either entails that I need to put a 2nd CCR1016 next to it for a second server profile or just do it all via script.

If you understand what I mean.

EDIT:
Unless I am understanding incorrectly and that for every server profile one of the default user's automatically get added?
If so, I will retest again. But why would it not just be added directly into the server profile vs into the Users?
 
User avatar
SirDJNeo
just joined
Posts: 5
Joined: Tue Dec 08, 2015 12:25 pm
Location: South Africa

Re: 6.34 release candidate version topic!

Wed Dec 23, 2015 7:43 pm

Ah, I see... For 2nd server profile if you don't want the GLOBAL one then you have to set one manually....

Any comment on the reason why it was not implemented straight into the Server profile like the uptime limits have been set?

That being besides for the counters that get wiped in case of power outage anyway, especially here in wonderful South Africa...

#relieved for not needing more scripting

BUG for the GLOBAL one though:
XZ.JPG
The Server Profile for global can be changed, even with warning. but doesn't seem to have any affect besides the drop down name...
You do not have the required permissions to view the files attached to this post.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Mon Dec 28, 2015 11:07 am

6.34rc27 version has been released.

Changes since previous version:
*) sshd - resolved shared secret mismatch issue;
*) net - do not show L2MTU in VLAN compact export;
*) net - fixed net crash when firewall jump rule points to disabled custom chain;
*) net - apply slave config only if master config has been changed.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
krisjanis
MikroTik Support
MikroTik Support
Posts: 391
Joined: Tue Feb 05, 2013 5:00 pm

Re: 6.34 release candidate version topic!

Mon Dec 28, 2015 12:19 pm

@SirDJNeo

Thank you for the note on default-trial server change winbox bug.
 
foxch2
just joined
Posts: 19
Joined: Tue Dec 08, 2015 11:35 am

Re: 6.34 release candidate version topic!

Tue Dec 29, 2015 11:28 am

Yesterday I updated to 27 release

I have a script sending in the mail logs. Now error sending

12:00:32 system,e-mail,error Error sending e-mail <Log dec/29/2015>: invalid BODY

the text of the script
:log info "Log Backup Sended to email...";
:local sysname [/system identity get name];
:local sysver [/system package get system version];
#read log
:local logcontent
:foreach int in=[/log find ] do={
:set logcontent ("$logcontent\r\n" .[/log get $int time]. " - " .[/log get $int message])
}
#send email
/tool e-mail send to=**@*** subject=([/system identity get name] . " Log " . [/system clock get date]) body=("Log of $sysname\nRouterOS version: \
$sysver\nTime and Date stamp: " . [/system clock get time] . " " . [/system clock get date] . "\n " . \
$logcontent);

#delete old log
/system logging action set memory memory-lines=1
/system logging action set memory memory-lines=1000

:log info "System log cleared by email-log-backup script...";
the script text has not changed. Earlier notifications were sent
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Dec 29, 2015 12:35 pm

Exact same script works for me perfectly on same version.

Try to print body instead of sending message. Maybe you can notice something there:

:put ("Log of $sysname\nRouterOS version: \
$sysver\nTime and Date stamp: " . [/system clock get time] . " " . [/system clock get date] . "\n " . \
$logcontent)
 
foxch2
just joined
Posts: 19
Joined: Tue Dec 08, 2015 11:35 am

Re: 6.34 release candidate version topic!

Tue Dec 29, 2015 1:10 pm

Exact same script works for me perfectly on same version.

Try to print body instead of sending message. Maybe you can notice something there:

:put ("Log of $sysname\nRouterOS version: \
$sysver\nTime and Date stamp: " . [/system clock get time] . " " . [/system clock get date] . "\n " . \
$logcontent)
still error

launched through the terminal
/tool e-mail send to=**@*** subject=([/system identity get name] . " Log " . [/system clock get date]) body=(" ");
still error in body
 
foxch2
just joined
Posts: 19
Joined: Tue Dec 08, 2015 11:35 am

Re: 6.34 release candidate version topic!

Tue Dec 29, 2015 1:22 pm

even if i remove the "body" from the request , the error still in it
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Dec 29, 2015 2:41 pm

Try to send e-mail. After that generate supout file and together with problem description send it to support@mikrotik.com

Remember that this is users forum (where support team sometimes take a look to see if some common issues appears). To get actual help you have to contact support@mikrotik.com
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Dec 29, 2015 3:52 pm

Version 6.34rc29 will be released today.

Changes since previous version:
*) arm - fix usb modem modules on ARM;
*) dhcpv6-client - fixed stopped state;
*) net - fixed possible kernel failure/lock-up;
*) netinstall - sort packages by name.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: 6.34 release candidate version topic!

Tue Dec 29, 2015 9:36 pm

is there ANY chance to had manageable "disable reset button/hole" switch in newer versions?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Wed Dec 30, 2015 8:16 am

Zorro - Please create separate topics for questions like this. This is version related topic.

What you are asking for has been implemented already for a while:
http://wiki.mikrotik.com/wiki/Manual:Ro ... bootloader
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Wed Dec 30, 2015 2:24 pm

6.34rc30 version will be released today.

Changes since previous version:
*) chr - license fix for AWS and similar solutions.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
mistry7
Forum Guru
Forum Guru
Posts: 1288
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: 6.34 release candidate version topic!

Wed Dec 30, 2015 3:29 pm

Usermanger is missing in RC30 arm Zip file
 
neredera
just joined
Posts: 3
Joined: Thu Dec 31, 2015 12:05 am

Re: 6.34 release candidate version topic!

Thu Dec 31, 2015 12:33 am

6.34rc30 gives for a S+32LC10D wrong values as TX power:
  MikroTik RouterOS 6.34rc30 (c) 1999-2015       http://www.mikrotik.com/

[?]             Gives the list of available commands
command [?]     Gives help on the command and list of arguments

[Tab]           Completes the command/word. If the input is ambiguous,
                a second [Tab] gives possible options

/               Move up to base level
..              Move up one level
/command        Use command at the base level
[admin@MikroTik2] > interface ethernet monitor 25
                      name: sfpplus2-slave-local
                    status: link-ok
          auto-negotiation: done
                      rate: 10Gbps
               full-duplex: yes
           tx-flow-control: no
           rx-flow-control: no
               advertising: 
  link-partner-advertising: 
        sfp-module-present: yes
               sfp-rx-lose: no
              sfp-tx-fault: no
                  sfp-type: SFP-or-SFP+
        sfp-connector-type: LC
       sfp-link-length-9um: 10000m
           sfp-vendor-name: Mikrotik
    sfp-vendor-part-number: S+32LC10D
       sfp-vendor-revision: 1.0
         sfp-vendor-serial: MT50420H7983
    sfp-manufacturing-date: 15-05-10
            sfp-wavelength: 1330nm
           sfp-temperature: 43C
        sfp-supply-voltage: 3.181V
       sfp-tx-bias-current: 34mA
              sfp-tx-power: -40dBm
              sfp-rx-power: -5.613dBm

[admin@MikroTik2] > system routerboard print 
       routerboard: yes
             model: CRS226-24G-2S+
     serial-number: 4C7E045BC537
     firmware-type: qca8513
  current-firmware: 3.22
  upgrade-firmware: 3.22
[admin@MikroTik2] > 


[admin@MikroTik] > interface ethernet monitor 9
                      name: sfpplus2-slave-local
                    status: link-ok
          auto-negotiation: done
                      rate: 10Gbps
               full-duplex: yes
           tx-flow-control: no
           rx-flow-control: no
               advertising: 
  link-partner-advertising: 
        sfp-module-present: yes
               sfp-rx-lose: no
              sfp-tx-fault: no
                  sfp-type: SFP-or-SFP+
        sfp-connector-type: LC
       sfp-link-length-9um: 10000m
           sfp-vendor-name: Mikrotik
    sfp-vendor-part-number: S+23LC10D
       sfp-vendor-revision: 1.0
         sfp-vendor-serial: MT50420H7097
    sfp-manufacturing-date: 15-04-21
            sfp-wavelength: 1270nm
           sfp-temperature: 49C
        sfp-supply-voltage: 3.211V
       sfp-tx-bias-current: 37mA
              sfp-tx-power: -40dBm
              sfp-rx-power: -5.081dBm

[admin@MikroTik] > system routerboard print 
       routerboard: yes
             model: CRS210-8G-2S+
     serial-number: 583A05910292
     firmware-type: qca8513
  current-firmware: 3.22
  upgrade-firmware: 3.22
 
spacemind
Member Candidate
Member Candidate
Posts: 111
Joined: Mon Jul 07, 2008 8:33 pm

Re: 6.34 release candidate version topic!

Thu Dec 31, 2015 2:05 am

MicroSD is not detected on CCR1009 Desktop since 6.30.4, tried different cards and not working.

btw: whats smart card slot for ? which cards are supported ?
 
sx10
newbie
Posts: 28
Joined: Fri Jan 04, 2013 5:46 am
Location: Portland, OR USA

Re: 6.34 release candidate version topic!

Thu Dec 31, 2015 6:48 pm

6.34rc23 version is released.

Changes since previous version:
*) crypto - fixed kernel failure in talitos HW encryption;
Do you have any details on this? I reported an issue with kernel failures on tile when using AES GCM (back on 11/19) and I'm wondering if this is related. I never heard back from support other than saying they would try to fix it.
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1284
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.34 release candidate version topic!

Thu Dec 31, 2015 9:30 pm

6.34rc23 version is released.

Changes since previous version:
*) crypto - fixed kernel failure in talitos HW encryption;
Do you have any details on this? I reported an issue with kernel failures on tile when using AES GCM (back on 11/19) and I'm wondering if this is related. I never heard back from support other than saying they would try to fix it.
It appears so, I was able to move all of my VPNs back to GCM without any crashes.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
Qper
just joined
Posts: 16
Joined: Wed Nov 12, 2014 11:57 pm

Re: 6.34 release candidate version topic!

Sat Jan 02, 2016 11:54 am

why RoMON has a limitation in the name identity another Mikrotik ?

Image
 
User avatar
juanvi
Member Candidate
Member Candidate
Posts: 164
Joined: Mon May 05, 2014 6:55 pm
Location: SPAIN

Re: 6.34 release candidate version topic!

Mon Jan 04, 2016 11:56 am

why RoMON has a limitation in the name identity another Mikrotik ?

Image

I have similar issues with CapsMan CAp's Identity. Do not remember exactly, but long names and/or special characters were the cause.
¡vʞvdnX puv ···SOɹǝʇnoɹ ʞıʇoɹʞıW oʇ sʞuvHʇ
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Mon Jan 04, 2016 12:28 pm

Qper - This is not version related issue so please create another topic. What is the problem here? If router identity is default MikroTik then it will be shown also here. If you connect to router and change identity then you will see it also in RoMON neighbours list.
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1284
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.34 release candidate version topic!

Tue Jan 05, 2016 12:04 am

why RoMON has a limitation in the name identity another Mikrotik ?

Image
You have the default identity for all your routers. Change it, and the Identity will change in RoMON.
/system identity set name=Router_Name
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
mistry7
Forum Guru
Forum Guru
Posts: 1288
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: 6.34 release candidate version topic!

Tue Jan 05, 2016 3:01 pm

Usermanger Paket still missing in 6.34 RC30 for ARM Plattform
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Jan 05, 2016 3:29 pm

On ARM devices UserManager will not work within RouterOS v6. That is why packet is not available for download.

http://wiki.mikrotik.com/wiki/User_Mana ... er_Manager
"The MikroTik User Manager works on x86, MIPS, PowerPC and TILE processor based routers."
 
Qper
just joined
Posts: 16
Joined: Wed Nov 12, 2014 11:57 pm

Re: 6.34 release candidate version topic!

Tue Jan 05, 2016 10:41 pm

Qper - This is not version related issue so please create another topic. What is the problem here? If router identity is default MikroTik then it will be shown also here. If you connect to router and change identity then you will see it also in RoMON neighbours list.
If the name is long, RMON only displays mikrotik.
If the name has more than 31 characters displays only mikrotik.
Check it out
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Wed Jan 06, 2016 8:28 am

Qper - Now it is clear. Issue is reported to our developers. Thank you for your report. In future I suggest that you report directly to support@mikrotik.com
 
mistry7
Forum Guru
Forum Guru
Posts: 1288
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: 6.34 release candidate version topic!

Wed Jan 06, 2016 10:39 am

On ARM devices UserManager will not work within RouterOS v6. That is why packet is not available for download.

http://wiki.mikrotik.com/wiki/User_Mana ... er_Manager
"The MikroTik User Manager works on x86, MIPS, PowerPC and TILE processor based routers."

thats are bad news!
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Fri Jan 08, 2016 9:56 am

6.34rc32 version is released.

Changes since previous version:
*) net - fix bridge firewall chain check (broken since 6.33.2);
*) net - show fp counters in /interface monitor aggregate;
*) romon - allow to see device identity if it is longer than 31 character;
*) smb - fix crash when changing user which has open session;
*) tunnel - fix complaining about loop after ~248 days;
*) vrrp - make sure that VRRP gets state on bootup;
*) webfig - recognize properly CHR;
*) winbox - show only actual switch-cpu ports in switch setting combobox;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Fri Jan 08, 2016 2:17 pm

6.34rc34 version is released.

Changes since previous version:
*) upnp - fixed missing in-interface option for dynamic dst-nat rules;
*) upnp - added comment for dynamic dst-nat rules to inform what host/program required it;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
hurley12345
just joined
Posts: 19
Joined: Tue May 22, 2007 12:47 pm

Re: 6.34 release candidate version topic!

Sat Jan 09, 2016 2:16 pm

Version 6.34rc29

Changes since previous version:
*) arm - fix usb modem modules on ARM;
*) dhcpv6-client - fixed stopped state;
*) net - fixed possible kernel failure/lock-up;
*) netinstall - sort packages by name.

Can you please elaborate on
*) net - fixed possible kernel failure/lock-up;
as we have tile routers locking up and are at our wits end to isolate what triggers the lockup?
thanks
 
nescafe2002
Long time Member
Long time Member
Posts: 620
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: 6.34 release candidate version topic!

Sun Jan 10, 2016 2:16 pm

*) upnp - fixed missing in-interface option for dynamic dst-nat rules;
*) upnp - added comment for dynamic dst-nat rules to inform what host/program required it;
Nice enhancement!

Image
 
User avatar
ufm
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Fri Nov 15, 2013 12:02 pm
Location: Ukraine

Re: 6.34 release candidate version topic!

Mon Jan 11, 2016 7:36 am

6.34rc32 version is released.

Changes since previous version:
*) net - fix bridge firewall chain check (broken since 6.33.2);
Nice.
Where I can download 6.33.4 with bugfix?
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: 6.34 release candidate version topic!

Mon Jan 11, 2016 9:24 am

*) upnp - fixed missing in-interface option for dynamic dst-nat rules;
*) upnp - added comment for dynamic dst-nat rules to inform what host/program required it;
Nice enhancement!

Image
This enhancement got me in to "Teredo disabling spree" on all office PCs with Win10 this weekend... why it is enabled by default?
Yes, thanks for the feature it makes it much easier to manage dst-nat now.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: 6.34 release candidate version topic!

Tue Jan 12, 2016 2:46 am

*) upnp - fixed missing in-interface option for dynamic dst-nat rules;
*) upnp - added comment for dynamic dst-nat rules to inform what host/program required it;
Nice enhancement!

Image
This enhancement got me in to "Teredo disabling spree" on all office PCs with Win10 this weekend... why it is enabled by default?
Yes, thanks for the feature it makes it much easier to manage dst-nat now.
its funny, cuz its my favorite defaults (not only for Win10 machines).
using ADK or DISM or even better NTLite(which isn't free, sadly) - you can customize such(or many other things with ease in both installed machines and installation images/mediums).
but prohibiting unauthorized teredo, 6to4, isatap and other transitioning tech(including ipip, ipoe and other protocols, including restricting ipv6 itself) - is generally good practice not only from terms of security.

p.s.
you may also notice, that MS put into default win10 images somewhat quirky "debug adapter" and other WWAN miniports, annoying just like how WU repeatedly re-install ISATAP in past years. same about extra-protocols, that enabled and bound to interfaces "by default" aswell. or services(how many use "workstation" or "server" services in small offices, w/o AD usage ? for example).
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: 6.34 release candidate version topic!

Tue Jan 12, 2016 2:52 am

i not know what those "kernel improvements" mean exactly, but they improve things a Lot, actually.
even in trivial tasks, such as web broswing or using winbox(both generic stuff or using built-in wiki viewer ;) - response improved Notably. i not know how much MicroTik paid for updated SDK/Compiler for MIPS(i doubt they use GCC. especially for wireless module), but it definitely Worthy thing. i just hope its not break something other(like security flaws and etc).
 
vosgessystemes
just joined
Posts: 8
Joined: Tue Jan 05, 2016 12:08 pm

Re: 6.34 release candidate version topic!

Tue Jan 12, 2016 5:54 pm

@Mikrotik When do you get out the stable version of 6.34 ? This month ? After ?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Thu Jan 14, 2016 3:54 pm

6.34rc36 version will be released today.

Changes since previous version:
*) dhcpv6-client - fix ia lifetime check;
*) ipsec - fixed kernel failure after underlying tunnel has been disabled/enabled;
*) ipsec - prioritize proposals;
*) ipsec - support multiple DH groups for phase 1;
*) log - reopen log file if deleted;
*) netinstall - fix apply default config;
*) packing - fix tcp/udp checksums when simple packing is used;
*) tile - make sure that SFP rj45 modules that use forced 1G FD settings work correctly after system reboot;
*) tile - fix ipsec freeze after SA updates;
*) wireless - added WPS buttons support on hAP and hAP ac lite.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
sx10
newbie
Posts: 28
Joined: Fri Jan 04, 2013 5:46 am
Location: Portland, OR USA

Re: 6.34 release candidate version topic!

Thu Jan 14, 2016 6:56 pm

I'm really excited to see all these great enhancements and fixes, but is there any end in sight for 6.34? It's been in RC for over 2 months and you're still adding new features. I'd really like to get some of these enhancements in production. Any plans for a release date?
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: 6.34 release candidate version topic!

Thu Jan 14, 2016 7:40 pm

i was just only hope that WPS buttons support in newer RB - dind't become part of "default config", because its make wifi exploitable as hell :/
also would like bit reduced "default" TX powers in 2x and 3x WiFi-enabled devices (2-4Db should be enough? someone can do math better, perhaps)
(to avoid legal problems with early adopters/Rockie networkers, not familar with regulations/restrictions aswell as to reduce EMI).
 
ditonet
Forum Veteran
Forum Veteran
Posts: 839
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: 6.34 release candidate version topic!

Fri Jan 15, 2016 10:38 am

@strods
*) ipsec - prioritize proposals;
*) ipsec - support multiple DH groups for phase 1;
Can you explain it? How it works?

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5921
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: 6.34 release candidate version topic!

Fri Jan 15, 2016 11:26 am

Now you can choose multiple DH groups in phase1
and all the chosen protcols are sorted from strongest to weakest protocol before sending proposals to remote peer.
 
ditonet
Forum Veteran
Forum Veteran
Posts: 839
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: 6.34 release candidate version topic!

Fri Jan 15, 2016 4:14 pm

@mrz
Now you can choose multiple DH groups in phase1
and all the chosen protcols are sorted from strongest to weakest protocol before sending proposals to remote peer.
Thanks a lot, it looks that currently this option is supported only from command-line, not from Winbox.
And what about *) ipsec - prioritize proposals;?

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5921
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: 6.34 release candidate version topic!

Fri Jan 15, 2016 4:36 pm

second part of the sentence
all the chosen protocols are sorted from strongest to weakest protocol before sending proposals to remote peer.
 
ditonet
Forum Veteran
Forum Veteran
Posts: 839
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: 6.34 release candidate version topic!

Fri Jan 15, 2016 5:01 pm

@mrz
Thanks, I thought that it was separate functionality.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Jan 19, 2016 9:29 am

6.34rc39 version has been released.

Changes since previous version:

*) dude - The reports of my death have been greatly exaggerated;
*) dude - dude RouterOS package added for tile and x86 (CHR) architecture;
*) dude - initial work on dude integration into RouterOS;
*) chr - fix SSH key import on AWS;
*) crs212 - fix 1Gbps ether1 linking problem;
*) timezone - use backward timezone aliases;
*) lte - support serial port for DellWireless 5570;
*) lte - improved dhcp handling on interfaces that doesn't support it;
*) ipsec - allow my-id address specification in main mode;
*) dhcpv6 client - fix remove when client reappears on restart;
*) default config - fix for hAP family devices with one wireless;
*) firewall - added inversion support for "limit" option;
*) firewall - added bit rate matching for "limit" option;
*) firewall - improved performance for "limit" option.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
Ghazaryan
just joined
Posts: 2
Joined: Tue Jan 19, 2016 10:29 am

Re: 6.34 release candidate version topic!

Tue Jan 19, 2016 10:51 am

Hi everybody I have question about traffic flow in my router 6.32.3.In this version TX trafic does not show in ether2 (local) show only rx traffic, ether3 (internet) i can not see local trafic rx i know about it
( http://wiki.mikrotik.com/wiki/Manual:IP/Traffic_Flow ),i add more interfaces but dont see
how can i read local RX and TX traffics in the old version 4.11 it work ok
You do not have the required permissions to view the files attached to this post.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 9:42 am

Version 6.34rc41 has been released.

Changes since previous version:

*) mipsle - architecture support dropped (last fully supported version 6.32.3);
*) mac-telnet - fixed backspace when typing login username;
*) address-list - properly remove unused address-lists from drop-downs;
*) sstp - allow ECDHE when pfs enabled;
*) lte - fixed info command for Cinterion EHS5-E modem;
*) fast-path - fixed kernel crash on on/off;
*) fetch - fixed closure after 30 seconds;
*) ppp - fixed rare kernel crash (introduced in v6.33);
*) ppp - do not allow empty name ppp secrets;
*) licensing - fixed that some old 7 symbol keys could not be upgraded;
*) ssh - fixed possible kernel crash;
*) console - fixed crash on creating variable with "?" in it;
*) winbox - fixed tab names to correspond to console;
*) webfig - fixed firewall connection-bytes option;
*) webfig - fixed switch port "default vlan id" has missing "auto" value.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
dadaniel
Member Candidate
Member Candidate
Posts: 155
Joined: Fri May 14, 2010 11:51 pm

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 9:59 am

Why is to-adresses column not enabled by default? No need to write to-addresses in comment field...!

*) upnp - added comment for dynamic dst-nat rules to inform what host/program required it;
Nice enhancement!

Image
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 10:14 am

Why is to-adresses column not enabled by default? No need to write to-addresses in comment field...!
Now all views are saved, so you can select it yourself and use it. Each configuration have it's unique important fields, you can't keep everyone happy.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
serjrd
just joined
Posts: 15
Joined: Mon Nov 30, 2015 3:24 pm

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 10:37 am

CCR-1072, 6.34rc39
Just now got this message in my console:

jan/19/2016 10:25:21 system,error,critical System rebooted because of kernel failure
jan/19/2016 10:25:21 system,error,critical router was rebooted without proper shutdown, probably kernel failure

I can only attribute this to enabling fasttrack, but it wasn't an immediate reaction to that and happened in about 30-60 seconds after it.

Emailed you an autosupout.rif file.
Is there anything else I can send you to be able to track this down?
Last edited by serjrd on Wed Jan 20, 2016 10:42 am, edited 1 time in total.
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Wed Jan 20, 2016 10:42 am

Oh no. Mipsle support drop during subminor version development? What happened? Is it for always?
 
ebreyit
Member Candidate
Member Candidate
Posts: 120
Joined: Tue Apr 30, 2013 11:44 am
Location: Shropshire, United Kingdom

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 10:43 am

Is there anything else I can send you to be able to track this down?
If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.

Think they get everything they need from this unless it involves external factors where packet captures also come in handy
Last edited by ebreyit on Wed Jan 20, 2016 11:17 am, edited 1 time in total.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re:

Wed Jan 20, 2016 11:01 am

Oh no. Mipsle support drop during subminor version development? What happened? Is it for always?
It looks like it - same thing happened to 6.33.5 also - check download page.
anyway - support period was impressive, my last mipsle purchase was in 2008.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
raffav
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Oct 24, 2012 4:40 am

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 2:15 pm

*) address-list - properly remove unused address-lists from drop-downs;
how it suppose to work?

i create a address-list TEST1
set up a demo Nat with src-address-list=TEST1>apply>ok

delete the address-list TEST1
go to nat but the address-list=TEST1 on demo nat still there
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 2:25 pm

raffav - This change is for situation like this but after you have disabled address-list of firewall rule in past you could see this list still in drop down menu but now you can not.

Of course it will still exist in such case. You can type anything under address list fields in firewall rules. You do not have to have actual entries in address list.
 
raffav
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Oct 24, 2012 4:40 am

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 2:42 pm

raffav - This change is for situation like this but after you have disabled address-list of firewall rule in past you could see this list still in drop down menu but now you can not.

Of course it will still exist in such case. You can type anything under address list fields in firewall rules. You do not have to have actual entries in address list.
hum...

so to clean up the "old address-list" need to disable the address-list field on the rule and re enable it?


and what is the propose to type anything on the address-list? i.e: make a rule only work in some situation like dynamic address-list ?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Wed Jan 20, 2016 3:17 pm

raffav - if you set anything on any firewall rule address-list fields then it will show up as a hint in other firewall rules under address-list fields. In past if you did add something on this field and after that did remove it, then it still showed up in drop list even it was not active anywhere. Now that is fixed.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2286
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.34 release candidate version topic!

Thu Jan 21, 2016 2:02 pm

hAP ac lite - In Quick Set please make WISP AP DUAL
It is missing
You do not have the required permissions to view the files attached to this post.
LAN, FTTx, Wireless. ISP operator
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re:

Mon Jan 25, 2016 11:08 am

Oh no. Mipsle support drop during subminor version development? What happened? Is it for always?
some obsoleted mips branches - already deprecated by linux kernel and toolchain long ago
(some LTS kernels and compilers are remain slightly-maintained, but its not really as great a moving upstream are).
so apparently MikroTik - moved upstream and updated some code.
other xxk and smips - are still supported by, as you can notice.
i can only guess that implementing some things - may eventually break mipsle support, even without moving upstream(partially cause less maintained toolchain for, maybe)
but removing "legacy" 5.xx ROS from download for SMIPS - make no sense, contrary(and eventually result in series of "conspiraction theorists" "explanations" ;)
 
andriys
Forum Guru
Forum Guru
Posts: 1144
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: Re:

Mon Jan 25, 2016 11:40 am

but removing "legacy" 5.xx ROS from download for SMIPS - make no sense
Removing? SMIPS is a relatively recent beast, RouterOS v5.x for SMIPS has never existed.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Re:

Mon Jan 25, 2016 11:54 am

but removing "legacy" 5.xx ROS from download for SMIPS - make no sense
Removing? SMIPS is a relatively recent beast, RouterOS v5.x for SMIPS has never existed.
MIPS-LE was removed. Not SMIPS.

MIPS-LE were really old devices, like the RB112. They never worked good with v6.
SMIPS never existed for v5.
No answer to your question? How to write posts
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: Re:

Mon Jan 25, 2016 11:54 am

but removing "legacy" 5.xx ROS from download for SMIPS - make no sense
Removing? SMIPS is a relatively recent beast, RouterOS v5.x for SMIPS has never existed.
sorry, that MY mistake, obviously.
"thinking bout MIPSLE and looking intoo SMIPS" or/and vice versa effect, apparently, thanks to new "download" section appearance, which is more eye-stressfull, but direct.
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Re:

Mon Jan 25, 2016 10:11 pm

but removing "legacy" 5.xx ROS from download for SMIPS - make no sense
Removing? SMIPS is a relatively recent beast, RouterOS v5.x for SMIPS has never existed.
MIPS-LE was removed. Not SMIPS.

MIPS-LE were really old devices, like the RB112. They never worked good with v6.
SMIPS never existed for v5.
MIPS-LE is not only RB112, but for example RB133 or RB532 which are still well supported by 6.32.3. Maybe also by 6.33.x, but I dont have such experience as I do not use this version in production. Your statement that thay never worked good with v6 is obviously not true. I still do not understand why the support for MIPS-LE was dropped so suddenly.
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: 6.34 release candidate version topic!

Mon Jan 25, 2016 10:20 pm

Why dude opened ports are not shown / manageable by IP - Services? All services provided by router should be listed there.

Citation from documentation http://wiki.mikrotik.com/wiki/Manual:IP/Services:
This document lists protocols and ports used by various MikroTik RouterOS services. It helps you to determine why your MikroTik router listens to certain ports, and what you need to block/allow in case you want to prevent or grant access to the certain services. Please see the relevant sections of the Manual for more explanations.
I would like to see there also all PPP servers and other services like UPNP, DNS, DHCP, NTP, SNMP and all others (even not manageably) to have one place where all active ports on the device are shown at once giving full overview to the administrator to know what ports are currently opened. Well, this part is more a "feature request" for aligning the reality with documentation than question. I admit.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 8:48 am

jarda, ip services include RouterOS used servers (most of them), however some of them are not included that are configuration optional (for example PPTP server, OVPN server or The Dude server).
Thank you for the feature suggestion about The Dude, currently it will stay under /dude, later we will see what we can do.
 
bommi
just joined
Posts: 24
Joined: Fri Jan 24, 2014 9:13 am
Location: Germany
Contact:

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 12:29 pm

*) sstp - allow ECDHE when pfs enabled;
Does this mean you switched to a newer openssl library in this version?
When will it be possible to connect to the webinterface using pfs with dhe or ecdhe?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 2:31 pm

6.34rc45 version has been released.

Changes since previous version:

*) capsman - fix radius accounting stop message;
*) cerm - allow to sign certificates from imported CAs created with RouterOS;
*) ldp - fix MPLS PDU max length;
*) net - improve 64bit interface stats support;
*) routerboard - print factory-firmware version in routerboard menu;
*) snmp - add oid from ucd mib for total cpu load OID 1.3.6.1.4.1.2021.11.52.0;
*) winbox - add extra items automaticly to multiline fields if at least one of them is required;
*) winbox - implemented full ipv6 dhcp client;
*) winbox - update blocked flag if user changed blocked field in dhcp server lease;
*) winbox/webfig - fixed version column ordering in ip neighbors list.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1709
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 3:52 pm

*) routerboard - print factory-firmware version in routerboard menu;
Do I check correct menu ?
411.png
You do not have the required permissions to view the files attached to this post.
Real admins use real keyboards.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 3:55 pm

"print" refers to command line
No answer to your question? How to write posts
 
vosgessystemes
just joined
Posts: 8
Joined: Tue Jan 05, 2016 12:08 pm

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 4:05 pm

I have a 404 error on the Dude package URL : http://download.mikrotik.com/dude-6.34rc45-tile.npk

Normal ?

Br
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 4:06 pm

I have a 404 error on the Dude package URL : http://download.mikrotik.com/dude-6.34rc45-tile.npk

Normal ?

Br
Try this URL http://download2.mikrotik.com/routeros/ ... 34rc45.npk
No answer to your question? How to write posts
 
vosgessystemes
just joined
Posts: 8
Joined: Tue Jan 05, 2016 12:08 pm

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 4:08 pm

I have a 404 error on the Dude package URL :
http://download.mikrotik.com/dude-6.34rc45-tile.npk

Normal ?

Br
Try this URL http://download2.mikrotik.com/routeros/ ... 34rc45.npk
Perfect ! Have you a changelog for this package ? Any fix since dude-6.34rc41.npk ?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 4:10 pm

Perfect ! Have you a changelog for this package ? Any fix since dude-6.34rc41.npk ?
Special topic for that http://forum.mikrotik.com/viewtopic.php ... 82#p517782
No answer to your question? How to write posts
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1020
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: 6.34 release candidate version topic!

Tue Jan 26, 2016 4:40 pm

We have an issue that has been reported to support and wanted to see how many others are having the same issue.

When using MPLS Traffic Engineering tunnels and MP-BGP with VRFs, if the BGP peering goes down and back up, traffic stops forwarding until the Traffic Engineering interface is disabled and re-enabled.

When looking at a packet capture, it appears the outer label is missing in the MPLS label stack. Once the TE interface is bounced, the label shows back up in the capture.

Has anyone else run into this or similar issues with deploying Traffic Engineering tunnels?
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
jondavy
Member Candidate
Member Candidate
Posts: 125
Joined: Tue May 12, 2009 11:14 pm
Location: Brasil

Re: 6.34 release candidate version topic!

Wed Jan 27, 2016 2:50 am

Here we are using several VPLS and also this fall and coming back after a few minutes,
with version 6.33.5 (stable) in RB1100AHx2, RB1100AH
 
Ulypka
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Jan 09, 2013 8:26 am

Re: 6.34 release candidate version topic!

Wed Jan 27, 2016 2:41 pm

i have similar problem with mpls
i correct this problem delete route from bgp and then advertise again
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1815
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: 6.34 release candidate version topic!

Wed Jan 27, 2016 10:16 pm

We have an issue that has been reported to support and wanted to see how many others are having the same issue.

When using MPLS Traffic Engineering tunnels and MP-BGP with VRFs, if the BGP peering goes down and back up, traffic stops forwarding until the Traffic Engineering interface is disabled and re-enabled.

When looking at a packet capture, it appears the outer label is missing in the MPLS label stack. Once the TE interface is bounced, the label shows back up in the capture.

Has anyone else run into this or similar issues with deploying Traffic Engineering tunnels?
We have had the same problem.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
bclewl1ns
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Jul 06, 2013 7:38 am
Contact:

Re: 6.34 release candidate version topic!

Wed Jan 27, 2016 10:40 pm

so I have an issue that started with RC41. I have a CCR1036-12G-EM

after the RC41 upgrade. The router loses the ability to show files, resources and Authentication to the router takes about 3 min. I have reset the router, uninstalled Dude and rebuilt from scratch to have the same thing happen.

I was able to get it upgraded to RC45 today. Now about every 5 min the watchdog timer reboots the router.

anyone else having this issue??

I have downgraded to 6.33.5 to see if that resolves the problem.
Brett

What is understood need not be discussed.
 
User avatar
bclewl1ns
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Jul 06, 2013 7:38 am
Contact:

Re: 6.34 release candidate version topic!

Wed Jan 27, 2016 10:56 pm

A little more info. If I turn off the watchdog timer. the system loses the ability to reboot remotely. I have to manually power off the router.
Brett

What is understood need not be discussed.
 
User avatar
bclewl1ns
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Jul 06, 2013 7:38 am
Contact:

Re: 6.34 release candidate version topic!

Wed Jan 27, 2016 10:58 pm

It does seam that downgrading the router to 6.33.5 fixed the reboot and lockup problem.
Brett

What is understood need not be discussed.
 
User avatar
bclewl1ns
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Jul 06, 2013 7:38 am
Contact:

Re: 6.34 release candidate version topic!

Wed Jan 27, 2016 11:31 pm

So after a while running on 6.33.5 I upgraded to 6.34rc45 It took the router almost 5 min to reboot. When it did I am right back to were i started.

The router takes about 2 min to let me log in.
It takes the file list about 5 min before it shows any files.
I have lost the ability to create a sup file or to reboot the router
I can not reset the router remotely anymore.
The system resources show's no cpu's at all
The log shows timeout while waiting for program 20

Kind of frustrating as the system was working well under RC15 but since i upgraded to RC41 and on this has been a constant problem. Are these all tested before they are released?

Additionally, on the Winbox title bar it no longer shows the router model or Identity just the login and ip
Also if i open up a terminal box it takes about 5 min to get to a prompt.
winbox.tiff
You do not have the required permissions to view the files attached to this post.
Brett

What is understood need not be discussed.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1020
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: 6.34 release candidate version topic!

Thu Jan 28, 2016 6:46 pm

We have an issue that has been reported to support and wanted to see how many others are having the same issue.

When using MPLS Traffic Engineering tunnels and MP-BGP with VRFs, if the BGP peering goes down and back up, traffic stops forwarding until the Traffic Engineering interface is disabled and re-enabled.

When looking at a packet capture, it appears the outer label is missing in the MPLS label stack. Once the TE interface is bounced, the label shows back up in the capture.

Has anyone else run into this or similar issues with deploying Traffic Engineering tunnels?
We have had the same problem.
Glad to know someone else is having this issue, in working with MikroTik on the ticket we have open, it appears they have found the bug and fixed it and the fix will be included in 6.34.

Can't wait for 6.34 :-)
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
fragtion
just joined
Posts: 24
Joined: Fri Nov 13, 2009 10:08 pm

Re: 6.34 release candidate version topic!

Fri Jan 29, 2016 10:18 am

In the latest Mikrotik newsletter (https://indd.adobe.com/view/c0e6f614-be ... 0ef4539904), according to Page 3, "New version of RouterOS will support single radio AP/Client for repeater support", presumably on supported models only. When can we expect this feature / in which new version of RouterOS? The news is not clear as to whether it will be the upcoming version of RouterOS, or a future version somewhere later down the line? Thank you
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1218
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: 6.34 release candidate version topic!

Fri Jan 29, 2016 12:40 pm

Not specific to this release, but there should be a bus selection option for USB Power reset under WinBox for RB922 (and probably others using differentiated bus lines for USB and PCIe USB):
NetMetal_USB_Reset.jpg
This issue makes it impossible to use USB power reset from WinBox.
You do not have the required permissions to view the files attached to this post.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.34 release candidate version topic!

Fri Jan 29, 2016 2:30 pm

Who is online

Users browsing this forum: No registered users and 57 guests