Community discussions

 
bruins0437
just joined
Topic Author
Posts: 12
Joined: Thu Jul 13, 2017 4:30 am
Location: New Hampshire

Export seems to be broken? ROS 6.40rc38

Thu Jul 13, 2017 4:36 am

Hello,

First time posting here. I just upgraded to 6.40rc38 and was trying to export to a file. For some reason it will not generate the file. /export file=backup2017 I then tried just /export and copied / pasted into a text doc, saved it as mikrotik07122017.txt, uploaded it to mikrotik, and tried to run a reset system config with no defaults and no backup. It errors and says invalid file name (6). I then tried removing the extension and it still errors. Lastly, I tried with a know good export file and it error'd again.

I have a Routerboard 2011UiAS-RM

Any help would be greatly appreciated.

Regards,
Eric
 
msatter
Forum Guru
Forum Guru
Posts: 1308
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: Export seems to be broken? ROS 6.40rc38

Thu Jul 13, 2017 9:27 am

The extension of an export should be .rsc and the one generated by the backup is called .backup.

https://wiki.mikrotik.com/wiki/Manual:C ... escription
Two RB760iGS (hEX S) in series. One does PPPoE and both do IKEv2.
Running:
RouterOS 6.46Beta59 / Winbox 3.20 / MikroTik APP 1.3.7
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
bruins0437
just joined
Topic Author
Posts: 12
Joined: Thu Jul 13, 2017 4:30 am
Location: New Hampshire

Re: Export seems to be broken? ROS 6.40rc38

Thu Jul 13, 2017 2:36 pm

The extension of an export should be .rsc and the one generated by the backup is called .backup.

https://wiki.mikrotik.com/wiki/Manual:C ... escription
Right, I understand that, but for some reason I cannot generate any export files after upgrading to 6.40.rc38. Under /files print, no new files are created. I have tried:

/export file=test.rsc
/export verbose file=test.rsc
/export compact file=test.rsc

The biggest issue, is that I cannot run the /system reset-configuration from the menu, to reload my exported config (run-after). I get invalid file, I even tried .rsc extension.


Regards,
Eric
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Export seems to be broken? ROS 6.40rc38

Thu Jul 13, 2017 2:59 pm

Yes, everything that saves to file from console is broken, export to file print to file etc. We will try to fix this in future rc versions.
 
sid5632
Member
Member
Posts: 353
Joined: Fri Feb 17, 2017 6:05 pm

Re: Export seems to be broken? ROS 6.40rc38

Thu Jul 13, 2017 3:13 pm

We will try to fix this in future rc versions.
Try?
Try??
I think you mean "We will fix this in the next rc version.".

You do wonder how stuff like this gets broken in the first place, given that none of the relevant code has (apparently) been touched.
Is the whole thing structured so badly that you fix one thing and break another? I really find it very hard to believe.
 
bruins0437
just joined
Topic Author
Posts: 12
Joined: Thu Jul 13, 2017 4:30 am
Location: New Hampshire

Re: Export seems to be broken? ROS 6.40rc38

Tue Jul 18, 2017 4:09 pm

Looks like this has been resolved with 6.40rc41. I am now able to export to a file and use that file with run after (reset system-configuration).

Regards,
Eric

Who is online

Users browsing this forum: No registered users and 61 guests