Community discussions

MUM Europe 2020
 
kait
just joined
Topic Author
Posts: 15
Joined: Thu May 10, 2012 12:09 pm
Location: Czech Republic

Bridge HW-Offload and VLAN-Filtering with CRS226-24G-2S+RM at v6.41rc52

Thu Nov 16, 2017 10:59 am

Hi,

I would have bridge with hw-offload with vlan tagged trunk and untagged access ports. For example, ether1 as vlan trunk port, ether2 as vlan10 access port and ether3 as vlan20 access port:
/interface bridge add name=bridge1 vlan-filtering=no

/interface bridge port add bridge=bridge1 interface=ether1
/interface bridge port add bridge=bridge1 interface=ether2 pvid=10
/interface bridge port add bridge=bridge1 interface=ether3 pvid=20

/interface bridge vlan add bridge=bridge1 tagged=bridge1,ether1 untagged=ether2 vlan-ids=10
/interface bridge vlan add bridge=bridge1 tagged=bridge1,ether1 untagged=ether3 vlan-ids=20

/interface vlan add interface=bridge1 name=vlan10 vlan-id=10
/interface vlan add interface=bridge1 name=vlan20 vlan-id=20
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload 
 #     INTERFACE            BRIDGE            HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0   H ether1               bridge1           yes    1     0x80         10                 10       none
 1 I H ether2               bridge1           yes   10     0x80         10                 10       none
 2 I H ether3               bridge1           yes   20     0x80         10                 10       none
Up to this part all ports in bridge1 has hw-offload. When I turn ON vlan-filtering on bridge1, I can see all ports lost hw-offload (letter H).
/interface bridge set bridge1 vlan-filtering=yes
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload 
 #     INTERFACE            BRIDGE            HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     ether1               bridge1           yes    1     0x80         10                 10       none
 1 I   ether2               bridge1           yes   10     0x80         10                 10       none
 2 I   ether3               bridge1           yes   20     0x80         10                 10       none
Please let me know if I'm doing someting wrong. Thanks.

Firmware:
       routerboard: yes
             model: CRS226-24G-2S+
     serial-number: 707106456EF4
     firmware-type: qca8513
  factory-firmware: 3.22
  current-firmware: 6.41rc52
  upgrade-firmware: 6.41rc50
 
sid5632
Member
Member
Posts: 370
Joined: Fri Feb 17, 2017 6:05 pm

Re: Bridge HW-Offload and VLAN-Filtering with CRS226-24G-2S+RM at v6.41rc52  [SOLVED]

Thu Nov 16, 2017 4:37 pm

Please let me know if I'm doing someting wrong. Thanks.
No. The CRS226 and CRS125 are not listed as having VLAN filtering capability on the bridge without it killing hardware offload.
You have to do VLANs on the switch chip, as with 6.40 and earlier.
It would be nice if MikroTik said whether this was going to be a permanent restriction or not. I suspect it will be.

Who is online

Users browsing this forum: No registered users and 98 guests