Community discussions

 
eichpa91
just joined
Topic Author
Posts: 7
Joined: Tue Oct 17, 2017 9:06 pm

No POE Power Cycle @ hEX POE

Wed Mar 14, 2018 10:27 pm

Hello.

I have the problem, that in the actual stable release (6.41.3) the Power Cycle doesn't do anything.
I also testet it with the RC-Firmware (6.42rc41)
Is it a bug?

Thank You
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 958
Joined: Fri May 26, 2006 1:25 am

Re: No POE Power Cycle @ hEX POE

Sun Apr 01, 2018 7:04 am

Hi, I am seeing the same issue, see my thread on the same thing ( mt says they might look into it but they seem to be aware of the issue);

viewtopic.php?f=2&t=132238
:beep :beep :beep
 
walterav1984
just joined
Posts: 23
Joined: Thu Apr 12, 2018 11:26 am

Re: No POE Power Cycle @ hEX POE

Thu Apr 12, 2018 11:40 am

Also having the same problem on "hEX PoE RB960PGS" with 6.41.4 (Current) and 6.42rc56 where powercycle button does nothing, but as a workaround manually going back and forward form "auto/force on" to "power off" and back fixes it.

Tried both 24V/48V via PoE in and DC plug, using both passive PoE and 802.3af equipment all behave the same.

Please fix.
 
walterav1984
just joined
Posts: 23
Joined: Thu Apr 12, 2018 11:26 am

Re: No POE Power Cycle @ hEX POE

Thu Apr 12, 2018 12:54 pm

I'm also having this issue were the webinterface per etherport powercycle button is not responding on "hEX POE / RB960PGS" using both 6.41.4 (Current) and 6.42rc56 (Release candidate) tested in router/switch mode with 24/48v PoE in or DC plug with passive and 802.3af PoE equipment. Only workaround is manually switching from "auto on/force on" to "off" and back to "auto on/force on".
 
walterav1984
just joined
Posts: 23
Joined: Thu Apr 12, 2018 11:26 am

Re: No POE Power Cycle @ hEX POE

Thu Apr 12, 2018 1:09 pm

Besides the Power Cycle button I'm afraid the "Power Cycle Ping Enabled" is also broken on this model, could @eichpa91 or @jo2jo confirm this?
 
eichpa91
just joined
Topic Author
Posts: 7
Joined: Tue Oct 17, 2017 9:06 pm

Re: No POE Power Cycle @ hEX POE

Fri Apr 13, 2018 4:46 pm

Besides the Power Cycle button I'm afraid the "Power Cycle Ping Enabled" is also broken on this model, could @eichpa91 or @jo2jo confirm this?

Yes
 
User avatar
abrodkin
just joined
Posts: 12
Joined: Wed Nov 08, 2017 10:30 am

Re: No POE Power Cycle @ hEX POE

Wed Apr 25, 2018 3:16 am

Same here:
/interface ethernet poe> print detail 
 2 name="ether4-ipcam" poe-out=auto-on poe-priority=10 
   power-cycle-ping-enabled=yes power-cycle-ping-address=192.168.0.10 
   power-cycle-ping-timeout=5m power-cycle-interval=none 

/ping address=192.168.0.10
  SEQ HOST                                     SIZE TTL TIME  STATUS         
    0 192.168.0.10                                            timeout        
    1 192.168.0.10                                            timeout        
    2 192.168.0.10                                            timeout        
    sent=3 received=0 packet-loss=100% 
What the heck? The whole point of getting "hex POE" with all ports with POE-out was ability to control attached devices.
And now instead of having more stable system I see an obvious problem - after "hex POE" reset my webcam attached to its Ethernet4 port won't come up and to my surprise "power-cycle-ping" didn't help... good job, Mikrotik!
 
User avatar
lovehz
just joined
Posts: 9
Joined: Tue May 17, 2016 10:45 pm

Re: No POE Power Cycle @ hEX POE

Tue May 01, 2018 11:58 pm

+1 here

Just bought 3 of these for controlling unruly radio devices, but the danger of cutting myself off means I'll have to wait for the fix.

A workaround I've tried on 6.40.8 (bugfix only) is to use Safe Mode and turn off the POE on the port. If this disconnects your session the config will roll back, bringing the power back. I tested this on the bench, I wouldn't be so keen using it with a 10 hour round trip.
 
walterav1984
just joined
Posts: 23
Joined: Thu Apr 12, 2018 11:26 am

Re: No POE Power Cycle @ hEX POE

Fri May 11, 2018 10:15 am

@lovehz
Thanks for the safemode tip, to powercycle a port back to on if set manually to off(workaround) when session disconnects unexpected.

@all
I do have to say that USB-power reset is working for me even the default 1s, just tested on a RPI zero.
System>Routerboard>USB Power Reset
 
eichpa91
just joined
Topic Author
Posts: 7
Joined: Tue Oct 17, 2017 9:06 pm

Re: No POE Power Cycle @ hEX POE

Thu Jun 07, 2018 2:38 pm

Is there a new information? without this feature i can't use my set of hEX POE, and i have to return them to mikrotik.
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 958
Joined: Fri May 26, 2006 1:25 am

Re: No POE Power Cycle @ hEX POE

Thu Jun 07, 2018 9:53 pm

hi, I thought I confirm this in my opening post, but yes, ping power cycle does not work also ( seems to be any kind of automatic power cycling outside of manually by the user, switching from POE off to POE auto, does NOT work).

A temporary, rough, work around, that I have been using is a script i wrote that issues the two poe= commands , just as a manual user would, this does of course work.)

I am currently on my phone but will post the script later today when back at PC . ( it’s nothing fancy just a if/then ping check)

EDIT - here is my script (power cycles a poe splitter which powers this location's ISP modem), in first line i set the IP to ping/test (i use my ISPs GW, ie the 1st hop out on a traceroute, i changed this to x.x.x.x , also the email script i call at the end, that line can be removed, its just a 2nd script that emails me a mt LOG file, so i can look back and see history of these power cycles).

also i use netwatch, both UP/DOWN, to call this script (or you could use scheduler if u want). my Idea was if 1 ping happens to drop (as detected by netwatch), i may not necessarily need my biz modem power cycled (so the script checks for several pings lost, before power cycleing, or NOT power cycleing)

:local ipPing ("x.x.x.x")
:local pingip
#
# pingip below RUNS and sets the variable
# to number of successful pings ie 3 means 3 of 45 success
# can also use ($pingip > 1) or ($pingip >= 1) both TESTED
# ($pingip >= 1) means if only 1 or 0 pings do the IF, not the ELSE
#
:log info ("ping CHECK script IS RUNNING NOW")
# first delay 90 b4 ping test incase this is running at POWER UP
:delay 90
:set pingip [/ping $ipPing count=45]
:if ($pingip <= 3) do={
:log warning (">95% lost ping LOSS to isp GW IP x.x.x.x via ether5 so DO POE powerCYCLE")
/interface ethernet poe set ether5 poe-out=off
:delay 12
/interface ethernet poe set ether5 poe-out=auto-on
:delay 10
:log warning ("ether5 POE HAS BEEN TURNED BACK ON")
:delay 90
/system script run emailPOEresult
} else={
:log warning ("PoeCyclePINGcheck ELSE ran so no ping loss detected by script")
}
:beep :beep :beep
 
marekm
Member Candidate
Member Candidate
Posts: 203
Joined: Tue Feb 01, 2011 11:27 pm

Re: No POE Power Cycle @ hEX POE

Sat Jul 21, 2018 11:08 pm

I can confirm the same issue still in 6.42.6 on RB960PGS, PowerBox Pro, and OmniTik 5 PoE ac too. PoE Out off/auto-on/forced-on settings work normally, but Power Cycle does nothing as if MT simply forgot to implement it (tested both winbox and command line, doesn't even wait for the specified 5 seconds before returning to command prompt). It works fine on older devices with 100Mb ports (PowerBox non-Pro, OmnitikUPA, RB750UP).
 
eichpa91
just joined
Topic Author
Posts: 7
Joined: Tue Oct 17, 2017 9:06 pm

Re: No POE Power Cycle @ hEX POE

Wed Sep 19, 2018 9:40 pm

Is there any new information from Mikrotik for this bug?
 
marekm
Member Candidate
Member Candidate
Posts: 203
Joined: Tue Feb 01, 2011 11:27 pm

Re: No POE Power Cycle @ hEX POE

Fri Apr 05, 2019 8:42 pm

PoE power cycle still not working on OmniTik PoE 5 ac running 6.44.2.
Ticket#2019040522005742
 
yreks
just joined
Posts: 7
Joined: Sat Aug 16, 2014 5:53 pm

Re: No POE Power Cycle @ hEX POE

Wed Jun 12, 2019 9:38 am

Power920PGS, PowerBox Pro and OmniTik 5 PoE ac Power Cycle does not work
at 6.43.16. I have 3 pcs of PowerBox Pro and one OmniTik 5 PoE ac.

Who is online

Users browsing this forum: No registered users and 88 guests