Community discussions

 
aboiles
newbie
Topic Author
Posts: 42
Joined: Sat Nov 07, 2015 6:52 pm

/tool e-mail

Wed Sep 11, 2019 2:33 am

1. routeros-7.0beta1-arm.npk
2. RB4011iGS+5HacQ2HnD-IN
3. /tool e-mail Error sending email <>:invalid From address.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: /tool e-mail

Wed Sep 11, 2019 8:37 am

What is the full command you used, including the from address ?
No answer to your question? How to write posts
 
aboiles
newbie
Topic Author
Posts: 42
Joined: Sat Nov 07, 2015 6:52 pm

Re: /tool e-mail

Wed Sep 11, 2019 9:27 am

send from=antoniob@msn.com to=aboiles@hotmail.com subject="email test" body="email test"
works in 6.46b38 not in v7 though
 
User avatar
krisjanisj
MikroTik Support
MikroTik Support
Posts: 51
Joined: Wed Feb 20, 2019 2:53 pm
Contact:

Re: /tool e-mail

Wed Sep 11, 2019 9:37 am

send from=antoniob@msn.com to=aboiles@hotmail.com subject="email test" body="email test"
works in 6.46b38 not in v7 though
If Youre using "from=" variable in /tool e-mail send , You need to also specify "user=" and "password=", i.e
/tool e-mail send from=antoniob@msn.com to=aboiles@hotmail.com subject="email test" body="email test"  user="username" password="password"
or set everything up under "/tool e-mail" and only use "to=" variable in "/tool e-mail send"
* Wager of "The Holy War" against users who don't paste their config/export/print into [code][/code] blocks
* Avid coffee consumer
* Provider of stupid solutions for simple problems
 
aboiles
newbie
Topic Author
Posts: 42
Joined: Sat Nov 07, 2015 6:52 pm

Re: /tool e-mail

Wed Sep 11, 2019 9:46 am

So under v7 it no longer uses the settings saved in /tool e-mail?
All scripts now have to use user and password?
 
User avatar
krisjanisj
MikroTik Support
MikroTik Support
Posts: 51
Joined: Wed Feb 20, 2019 2:53 pm
Contact:

Re: /tool e-mail

Wed Sep 11, 2019 9:48 am

So under v7 it no longer uses the settings saved in /tool e-mail?
All scripts now have to use user and password?
Updated my previous post, but if You have everything saved under "/tool e-mail" it should work without needing "from=" parameter under "/tool e-mail send"
* Wager of "The Holy War" against users who don't paste their config/export/print into [code][/code] blocks
* Avid coffee consumer
* Provider of stupid solutions for simple problems
 
aboiles
newbie
Topic Author
Posts: 42
Joined: Sat Nov 07, 2015 6:52 pm

Re: /tool e-mail

Wed Sep 11, 2019 9:59 am

Same error with from or without.
Same error with user and password.
Also if Start TLS is set to yes, you get TLS handshake failed.
 
User avatar
krisjanisj
MikroTik Support
MikroTik Support
Posts: 51
Joined: Wed Feb 20, 2019 2:53 pm
Contact:

Re: /tool e-mail

Wed Sep 11, 2019 10:16 am

Same error with from or without.
Same error with user and password.
Also if Start TLS is set to yes, you get TLS handshake failed.
Please post the output from "/tool e-mail export hide-sensitive"
* Wager of "The Holy War" against users who don't paste their config/export/print into [code][/code] blocks
* Avid coffee consumer
* Provider of stupid solutions for simple problems
 
aboiles
newbie
Topic Author
Posts: 42
Joined: Sat Nov 07, 2015 6:52 pm

Re: /tool e-mail

Wed Sep 11, 2019 10:21 am

[admin@RB4011] > /tool e-mail export hide-sensitive
# sep/11/2019 00:20:25 by RouterOS 7.0beta1
# software id = 0BHM-Y5B5
#
# model = RB4011iGS+5HacQ2HnD
# serial number = 96B00AAFF9D5
/tool e-mail
set address=smtp.live.com from=antoniob@msn.com user=antoniob@msn.com
 
User avatar
krisjanisj
MikroTik Support
MikroTik Support
Posts: 51
Joined: Wed Feb 20, 2019 2:53 pm
Contact:

Re: /tool e-mail

Wed Sep 11, 2019 10:24 am

[admin@RB4011] > /tool e-mail export hide-sensitive
# sep/11/2019 00:20:25 by RouterOS 7.0beta1
# software id = 0BHM-Y5B5
#
# model = RB4011iGS+5HacQ2HnD
# serial number = 96B00AAFF9D5
/tool e-mail
set address=smtp.live.com from=antoniob@msn.com user=antoniob@msn.com
Youre missing these 2 things: port=587 tls=starttls
* Wager of "The Holy War" against users who don't paste their config/export/print into [code][/code] blocks
* Avid coffee consumer
* Provider of stupid solutions for simple problems
 
aboiles
newbie
Topic Author
Posts: 42
Joined: Sat Nov 07, 2015 6:52 pm

Re: /tool e-mail

Wed Sep 11, 2019 10:31 am

no change in results,
without tls - Invalid From
with tls - TLS handshake failed.
Do you want a supout sent to support?
 
User avatar
krisjanisj
MikroTik Support
MikroTik Support
Posts: 51
Joined: Wed Feb 20, 2019 2:53 pm
Contact:

Re: /tool e-mail

Wed Sep 11, 2019 10:35 am

Yes, please send us supout.rif file to support@mikrotik.com referencing this topic.
* Wager of "The Holy War" against users who don't paste their config/export/print into [code][/code] blocks
* Avid coffee consumer
* Provider of stupid solutions for simple problems
 
pe1chl
Forum Guru
Forum Guru
Posts: 5730
Joined: Mon Jun 08, 2015 12:09 pm

Re: /tool e-mail

Wed Sep 11, 2019 12:07 pm

If Youre using "from=" variable in /tool e-mail send , You need to also specify "user=" and "password=", i.e
Why would that be? Setting a sender address is completely unrelated to authentication when sending mail, isn't it?
 
cdemers
Member Candidate
Member Candidate
Posts: 184
Joined: Sun Feb 26, 2006 3:32 pm
Location: Canada
Contact:

Re: /tool e-mail

Wed Sep 11, 2019 2:57 pm

With most services these days, from addresses must match authentication to prevent address spoofing.

Sent from my SM-A520W using Tapatalk

 
pe1chl
Forum Guru
Forum Guru
Posts: 5730
Joined: Mon Jun 08, 2015 12:09 pm

Re: /tool e-mail

Wed Sep 11, 2019 4:47 pm

With most services these days, from addresses must match authentication to prevent address spoofing.
Well, not with my server. It requires proper from address but it allows unauthenticated SMTP from the local subnet.
(it does not even implement authentication so requiring that and enforcing it on connect would mean /tool e-mail would become unusable with this bog-standard server)

Who is online

Users browsing this forum: No registered users and 6 guests