Community discussions

MUM Europe 2020
 
Solaris
Member Candidate
Member Candidate
Topic Author
Posts: 107
Joined: Thu Apr 29, 2010 5:05 pm

terminating sessions: interface state changed

Thu Oct 17, 2019 1:14 am

  1. Version number (if the issue is upgrade related, specify which version was installed before as well); : ROS 7.0beta2
  2. Router's model; : RB4011iGS+
  3. Steps to reproduce the issue :
    1. Bridge a PPPOE client into a Huawei EchoLife EG8245H5 modem/ONT/GPON
    2. Wait for couple of minutes/hours, ether10 will flap/disconnect by itself
  4. Configuration export (use '/export hide-sensitive' command);
    # oct/17/2019 05:07:12 by RouterOS 7.0beta2
    #
    # model = RB4011iGS+
    /interface ethernet
    set [ find default-name=sfp-sfpplus1 ] auto-negotiation=no l2mtu=9014 mtu=\
        9014 name=NAS rx-flow-control=on tx-flow-control=on
    set [ find default-name=ether1 ] auto-negotiation=no
    set [ find default-name=ether2 ] advertise=1000M-full auto-negotiation=no
    set [ find default-name=ether3 ] speed=100Mbps
    set [ find default-name=ether4 ] speed=100Mbps
    set [ find default-name=ether5 ] speed=100Mbps
    set [ find default-name=ether6 ] speed=100Mbps
    set [ find default-name=ether7 ] speed=100Mbps
    set [ find default-name=ether8 ] speed=100Mbps
    set [ find default-name=ether9 ] speed=100Mbps
    set [ find default-name=ether10 ] auto-negotiation=no loop-protect=on mtu=\
        1492 poe-out=off rx-flow-control=auto tx-flow-control=auto
    /interface pppoe-client
    add add-default-route=yes disabled=no interface=ether10 keepalive-timeout=5 \
        name=Biznet user=redacted
    /interface ethernet switch port
    set 0 default-vlan-id=0
    set 1 default-vlan-id=0
    set 2 default-vlan-id=0
    set 3 default-vlan-id=0
    set 4 default-vlan-id=0
    set 5 default-vlan-id=0
    set 6 default-vlan-id=0
    set 7 default-vlan-id=0
    set 8 default-vlan-id=0
    set 9 default-vlan-id=0
    set 10 default-vlan-id=0
    set 11 default-vlan-id=0
    /interface wireless security-profiles
    set [ find default=yes ] supplicant-identity=MikroTik
    /ip pool
    add name=dhcp_hotspot ranges=10.8.8.2-10.8.8.254
    add name=dhcp_monster ranges=10.9.9.2-10.9.9.254
    add name=dhcp_nas ranges=10.10.10.2-10.10.10.254
    /ip dhcp-server
    add add-arp=yes address-pool=dhcp_hotspot always-broadcast=yes disabled=no \
        interface=ether1 name=Hotspot
    add add-arp=yes address-pool=dhcp_monster always-broadcast=yes disabled=no \
        interface=ether2 name=Monster
    add add-arp=yes address-pool=dhcp_nas always-broadcast=yes disabled=no \
        interface=NAS name=NAS
    /system logging action
    set 1 disk-file-name=log
    /interface bridge settings
    set allow-fast-path=no
    /ip firewall connection tracking
    set enabled=yes
    /ip settings
    set tcp-syncookies=yes
    /ip address
    add address=10.8.8.1/24 interface=ether1 network=10.8.8.0
    add address=10.9.9.1/24 interface=ether2 network=10.9.9.0
    add address=10.10.10.1/24 interface=NAS network=10.10.10.0
    /ip dhcp-server network
    add address=10.8.8.0/24 dns-server=10.8.8.1 gateway=10.8.8.1
    add address=10.9.9.0/24 dns-server=10.9.9.1 gateway=10.9.9.1
    add address=10.10.10.0/24 dns-server=10.10.10.1 gateway=10.10.10.1
    /ip dns
    set allow-remote-requests=yes cache-size=4096KiB max-concurrent-queries=10000 \
        max-concurrent-tcp-sessions=20000 servers=\
        203.142.82.222,203.142.84.222,8.8.8.8,8.8.4.4
    /ip firewall filter
    add action=fasttrack-connection chain=forward connection-state=\
        established,related
    add action=accept chain=forward connection-state=established,related
    /ip firewall mangle
    add action=change-mss chain=forward comment="Normalize MTU for IndiHome" \
        new-mss=1472 out-interface=Biznet passthrough=yes protocol=tcp tcp-flags=\
        syn tcp-mss=1493-65535
    add action=change-mss chain=forward in-interface=Biznet new-mss=1472 \
        passthrough=yes protocol=tcp tcp-flags=syn tcp-mss=1493-65535
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=Biznet src-address=\
        10.8.8.0/24
    add action=masquerade chain=srcnat out-interface=Biznet src-address=\
        10.9.9.0/24
    add action=masquerade chain=srcnat out-interface=Biznet src-address=\
        10.8.8.0/24
    add action=masquerade chain=srcnat out-interface=Biznet src-address=\
        10.9.9.0/24
    add action=masquerade chain=srcnat out-interface=Biznet src-address=\
        10.10.10.0/24
    /ip route
    add check-gateway=ping comment=NAS disabled=yes dst-address=10.10.10.0/24 \
        gateway=""
    add check-gateway=ping comment=NAS disabled=yes dst-address=10.10.10.0/24 \
        gateway=""
    /ip service
    set telnet disabled=yes
    set ftp disabled=yes
    set www disabled=yes
    set ssh disabled=yes
    set api disabled=yes
    set api-ssl disabled=yes
    /ip ssh
    set allow-none-crypto=yes forwarding-enabled=remote
    /ip torrent
    set download-directory=/flash/rw/disk
    /ip upnp
    set enabled=yes
    /ip upnp interfaces
    add interface=ether1 type=internal
    add interface=Biznet type=external
    add interface=NAS type=internal
    #error exporting /ipv6/route/rule
    #error exporting /routing/policy/selection
    /system clock
    set time-zone-name=Asia/Jakarta
    /system identity
    set name=Sentinel
    /system logging
    add topics=pppoe
    add topics=debug
    /system ntp client
    set enabled=yes
    /system ntp server
    set manycast=yes
    /system ntp client servers
    add address=211.233.40.78
    add address=202.156.0.34
    /system resource irq rps
    set NAS disabled=no
    
    
  5. Any additional information that would help troubleshoot the issue (screenshots, debug logs, etc.).
What i have done on my side is changing the UTP Cat6 cable to brand new cable & connector, the ether10/port flapping changing from every 20 Minutes into hours.
From past testing, this issue also happened with 6.45.6 or 6.46beta55
 
Solaris
Member Candidate
Member Candidate
Topic Author
Posts: 107
Joined: Thu Apr 29, 2010 5:05 pm

Re: terminating sessions: interface state changed

Sat Oct 26, 2019 1:17 pm

I have S+RJ10 attached into SFP+ port, before my power adapter is only 24 V 1.5 Ampere, after changing the power Adapter into 24 V 2.5 Ampere, the ether10 link is stable, now the link is up for more than 1d 06:14:00.

But the uptime only achievable by using ROS 6.45.6, using ROS 7.0beta3 is stuck with mentioned port flapping above, even it's on hours or minutes for port flapping to happened.

Image
 
Solaris
Member Candidate
Member Candidate
Topic Author
Posts: 107
Joined: Thu Apr 29, 2010 5:05 pm

Re: terminating sessions: interface state changed

Fri Feb 14, 2020 10:58 pm

Still not stable in v7.0beta5!, causing PPPOE-Client to disconnecting frequently, especially in high traffic.

Who is online

Users browsing this forum: No registered users and 14 guests