Page 1 of 1

[ROS 7.0beta4] multiple route tables, route rule not work

Posted: Mon Dec 09, 2019 5:31 pm
by kcarhc
I have read topic

"Cannot set routing-mark or table for routing rule" and
"how add multiple route tables, route rules in v7 beta"

and with following codes, I try to make multiple route work, but failed.

------------------------------
/interface/pppoe-client
add name=pppoe-out1 disabled=no \
add-default-route=yes default-route-distance=1 use-peer-dns=yes \
interface=ether1 max-mru=1492 max-mtu=1492 \
password=pass user=user

/interface/l2tp-client
add allow-fast-path=yes connect-to=123.45.67.89 disabled=no \
keepalive-timeout=10 name=l2tp-out1 \
password=pass user=user

/routing/table
add name=google vrf=main

/ip/route
add gateway="l2tp-out1@main" dst-address=0.0.0.0/0^google

/ip/route/rule
dst-address=8.8.8.8 action=lookup table=google

/tool/traceroute address=8.8.8.8
------------------------------

8.8.8.8 do not routing to l2tp-out1, always routing to pppoe-client

The following codes work well in 6.4x

------------------------------
/interface pppoe-client
add name=pppoe-out1 disabled=no \
add-default-route=yes default-route-distance=1 use-peer-dns=yes \
interface=ether1 max-mru=1492 max-mtu=1492 \
password=pass user=user

/interface l2tp-client
add allow-fast-path=yes connect-to=123.45.67.89 disabled=no \
keepalive-timeout=10 name=l2tp-out1 \
password=pass user=user

/ip route
add gateway=l2tp-out1 routing-mark=google

/ip route rule
add dst-address=8.8.8.8/32 table=google
------------------------------