Community discussions

MUM Europe 2020
 
iwikus
newbie
Topic Author
Posts: 25
Joined: Sat Jun 16, 2007 9:55 am

CHR 7.0 beta4 vrrp kernel panic

Sun Jan 12, 2020 2:21 pm

Hi,

I am playing with CHR 7.0 beta4 running in ESXi. Creating vrrp on bridge port cause router reboot when vrrp becomes master:
jan/12/2020 11:51:46 system,error,critical router was rebooted without proper shutdown
jan/12/2020 11:51:46 system,error,critical kernel failure in previous boot
Steps to reproduce
  • create bridge port and add ether1 into it
  • create vrrp interface on bridge port
  • add IP address to vrrp interface to enable it
When vrrp becomes master router will reboot. When you set vrrp priority to 255 you have endless reboot loop.

Configuration export (edited)
[admin@VRT] > /export hide-sensitive 
# jan/12/2020 11:54:21 by RouterOS 7.0beta4
# software id = 
#

/interface bridge
add igmp-snooping=yes name=bridge-lan protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
/interface vrrp
add disabled=yes interface=bridge-lan name=vrrp-lan
/interface bridge port
add bridge=bridge-lan interface=ether1
/ipv6 settings
set accept-router-advertisements=yes
/ip address
add address=10.0.0.200/24 interface=bridge-lan network=10.0.0.0
add address=10.0.0.202/24 interface=vrrp-lan network=10.0.0.0
 
sid5632
Member
Member
Posts: 375
Joined: Fri Feb 17, 2017 6:05 pm

Re: CHR 7.0 beta4 vrrp kernel panic

Sun Jan 12, 2020 5:24 pm

Address on VRRP interface should be a /32 not a /24.
 
iwikus
newbie
Topic Author
Posts: 25
Joined: Sat Jun 16, 2007 9:55 am

Re: CHR 7.0 beta4 vrrp kernel panic

Mon Jan 13, 2020 11:35 am

Address on VRRP interface should be a /32 not a /24.
Thanks, it seems work with /32. Anyway, other boxes with 6.46 does not crash with mask /24 on vrrp interface
 
sid5632
Member
Member
Posts: 375
Joined: Fri Feb 17, 2017 6:05 pm

Re: CHR 7.0 beta4 vrrp kernel panic

Mon Jan 13, 2020 5:17 pm

Anyway, other boxes with 6.46 does not crash with mask /24 on vrrp interface
Agreed, but you need to report it to MikroTik support.
 
ChrisCCC
just joined
Posts: 7
Joined: Thu Apr 07, 2016 7:28 pm

Re: CHR 7.0 beta4 vrrp kernel panic

Wed Jan 15, 2020 11:58 am

Why? This isn't really a support issue; it's a v7 beta bug, which is precisely the purpose of this forum section.
 
sid5632
Member
Member
Posts: 375
Joined: Fri Feb 17, 2017 6:05 pm

Re: CHR 7.0 beta4 vrrp kernel panic

Thu Jan 16, 2020 12:21 am

Because that's what it says here:
https://forum.mikrotik.com/viewtopic.php?f=1&t=152006

Send them an email referencing this thread. Not hard is it?
 
ChrisCCC
just joined
Posts: 7
Joined: Thu Apr 07, 2016 7:28 pm

Re: CHR 7.0 beta4 vrrp kernel panic

Fri Jan 17, 2020 6:37 pm

This is neither a v6 bug, nor a security vulnerability, though.

Who is online

Users browsing this forum: No registered users and 12 guests