Community discussions

MikroTik App
 
clueluzz
newbie
Topic Author
Posts: 27
Joined: Sun Feb 23, 2020 5:47 pm
Location: Jakarta, Indonesia
Contact:

Feature Request: Data usage

Tue Jun 02, 2020 6:39 am

Hi,

I know that there is an option to script the router to monitor traffic (DPI, etc), I found it a little complicated to setup. Also, it requires an external software to actually monitor the traffic like ntop. I think it would be very useful for people to have a very basic data usage graph for metered internet. I know I'm not the only one that has a limited Fair Usage Policy from their provider. Although the average bandwidth like the current one that we can set is useful to see how the network/internet is being used and what times the traffic peaks are, a how much data is being used (both up and download).

I have been able to monitor the usage from Queues based on Mangle rules, but when I reboot the router, the counters reset to 0. If somehow that doesn't reset on a reboot alone is already helpful, plus it keeps the data on a per day, per week, per month, and per year basis.

Just a thought.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1872
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: Feature Request: Data usage

Tue Jun 02, 2020 8:35 am

Problem is to store log data on the routers. Some routers does nearly have space free at all.
It simple and free (upp to 500MB log a day) to setup a Splunk server. Se link in my signature. (I do use 30 min)
 
Why do not use Splunk to monitor your MikroTik Router(s)? Look at this page in how to set it up.

MikroTik->Splunk
 
 
bd0g
just joined
Posts: 11
Joined: Tue May 23, 2017 11:54 am

Re: Feature Request: Data usage

Tue Jun 02, 2020 1:37 pm

Doesn't your provider track and provide you with your fair use usage?

Maybe it'll be easier to get the data from them? And even better, sometimes they don't count the same way : 1kB being 1000b and not 1024, sometime considering a minimum connection usage per query of 10kB, etc.
 
creatin
Frequent Visitor
Frequent Visitor
Posts: 93
Joined: Sat Nov 23, 2019 2:59 am

Re: Feature Request: Data usage

Tue Jun 16, 2020 2:24 am

Unfortunately I have similar case with my LTE provider which is covering internet connection in a remote location.
It provides decent speeds with a 100 gb traffic package limit after which speed is decreased to 2 mbps.
The 100 gb package is counted in period from 10:00 - 00:00, while period from 00:00 - 10:00 is outside of the 100 gb package, popularly called unlimited period :)

Again if all of 100 gb of traffic is spent speed decreases to 2 mbps, good thing is you still have full speed between 00:00 and 10:00 in the morning.

The problem are connections which are established at 23:59 and still connected after 00:00. For example, if established p2p connections are running before 00:00 and after 00:00 (into unlimited period),
LTE provider will decrease that traffic from 100 gb package, not in the unlimited period and thus you'll spend all your traffic from 100 gb package really quickly and get a speed of 2 mbps.

Their counters are faulty and only way to prove it is with an independent counter, preferably MIkroTik one :)
 
lilw
newbie
Posts: 36
Joined: Sun Jan 21, 2018 5:31 pm

Re: Feature Request: Data usage

Wed Aug 26, 2020 10:50 pm

Mikrotik should implement a simple data usage so it can monitor data traffic. The splunk is a very complicated one.
 
neutronlaser
Member
Member
Posts: 447
Joined: Thu Jan 18, 2018 5:18 pm

Re: Feature Request: Data usage

Wed Aug 26, 2020 11:41 pm

+1.
 
rplant
newbie
Posts: 32
Joined: Fri Sep 29, 2017 11:42 am

Re: Feature Request: Data usage

Fri Oct 09, 2020 7:10 am

Hi,
Simple Queues, Simple Queue Graphs, and Interface Graphs can do some of the basics.

Note: The following refers to V6, I haven't tested it much in V7, the script runs so I assume it is still good.

By setting up a bunch of simple Queues
I have 1 Parent, then 1 per internal IP address
as well as one catchall. (with limits on all perhaps of 500Mb/s) .
You can also add the to Tools/Graphing (Perhaps don't save to disk)

In winbox, add the Total Uploaded Bytes and Total Downloaded Bytes
Upload Avg Rate and Download Avg Rate to the Queue display.

You can periodically (Script) Save queue statistics to a file (on a USB Stick) then reset the current queue counters.

You can also create and add Queue Trees to the interfaces, to record traffic through them, which you can save periodically.
If keen you can also use these for Prioritizing traffic.

Script to create a bunch of simple queues

/queue simple add name=qparent max-limit=500M/500M target="192.168.0.0/16"

{
local name1
local len1

#Create 002 from numbers

:for x from 1 to 254 do={
:set name1 [("00" . $x)]; :set len1 [:len $name1];
:set name1 [:pick $name1 ($len1 - 3) 10]

:put $name1

/queue simple add name="q60-$name1" max-limit=500M/500M target="192.168.60.$x" \
parent="qparent"

}
}


/queue simple add name="qOver" parent=qparent max-limit=500M/500M target="192.168.0.0/16"

Sort them by name, or total downloaded, download rate, etc.
 
User avatar
kiler129
Member Candidate
Member Candidate
Posts: 266
Joined: Tue Mar 31, 2015 4:32 pm
Location: IL, USA
Contact:

Re: Feature Request: Data usage

Mon Oct 12, 2020 8:23 am

The huge issue with using queues for this is this will not count FT traffic.

Who is online

Users browsing this forum: No registered users and 14 guests