Page 1 of 1

v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 1:40 pm
by emils
RouterOS version 7.0beta8 has been released in public "development" channel!

What's new in 7.0beta8 (2020-Jun-4 15:04):

*) fixed CLI dependencies for routing menu;

What's new in 7.0beta7 (2020-Jun-3 16:31):

!) added Layer3 hardware offloading support for CRS317-1G-16S+RM more info here: https://wiki.mikrotik.com/wiki/Manual:C ... Offloading
!) enabled BGP support with multicore peer processing (CLI only);
!) enabled RPKI support (CLI only);
!) ported features and fixes introduced in v6.47;
!) routing updates, complete status report: https://help.mikrotik.com/docs/display/ ... col+Status
!) system kernel has been updated to version 5.6.3;
*) other minor fixes and improvements;

All released RouterOS v7 changelogs are available here:
https://mikrotik.com/download/changelog ... lease-tree

How to report RouterOS v7 bugs:
viewtopic.php?f=1&t=152006

Re: RouterOS v7 release discussion topic

Posted: Thu Jun 04, 2020 1:46 pm
by santyx32
I expected CAKE or fq-codel queue type since this new kernel already includes it.

Edit: Wireguard is also supported in kernel 5.6.x

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 1:55 pm
by strods
Please keep this topic related to the problems found in this RouterOS release. This topic is not made for feature requests. For that please create a new topic or contact support@mikrotik.com.

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 1:56 pm
by tjcomserv
I just wanted to say thank you very much for all your hard work.

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 2:07 pm
by anav
I am simply impressed that you can side stream in improvements from 6.47 into v7.0.

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 2:11 pm
by santyx32
DoH is no longer working in 7.0 beta 7, it worked in 6.47
Screenshot_20200604-061002_MikroTik.jpg

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 2:19 pm
by Jotne
DoH works fine for me.

Just added
https://1.1.1.1/dns-query
Did not select "Verify DoH Certificate" since this is just a test.

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 2:21 pm
by santyx32
DoH works fine for me.

Just added
https://1.1.1.1/dns-query
Did not select "Verify DoH Certificate" since this is just a test.
The verify certicate option used to work in 6.47, I have the root certicate imported into the router

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 2:23 pm
by Jotne
Does it work without certificates? Just to test the DoH to see what is wrong?

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 2:34 pm
by emils
Seems that the router is unable to resolve the DoH hostname. Post your DNS configuration and make sure you have at least one dynamic or static DNS server configured.

Re: v7.0beta7 [development] is released!

Posted: Thu Jun 04, 2020 2:53 pm
by santyx32
Seems that the router is unable to resolve the DoH hostname. Post your DNS configuration and make sure you have at least one dynamic or static DNS server configured.
I disabled the verify certificate option for testing but it still has resolving errors
/ip dns
set allow-remote-requests=yes servers=1.1.1.1 use-doh-server=\
    https://cloudflare-dns.com/dns-query
EDIT: I resetted the router and the problem with DoH persists, maybe this build requires a netinstall?
Device is hAP AC2

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 3:45 pm
by emils
What's new in 7.0beta8 (2020-Jun-4 15:04):

*) fixed CLI dependencies for routing menu;

Unfortunately, v7.0beta7 release did not have all the necessary routing changes for public release, here is a hotfix version of v7.0beta8.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 4:02 pm
by santyx32
DoH is still not working for me in beta8
Captura.PNG

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 4:24 pm
by Jotne
Test this instead:
/ip dns
set allow-remote-requests=yes use-doh-server=https://1.1.1.1/dns-query
Looks like your router does not resolve the name for cloudflare-dns.com

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 4:26 pm
by pe1chl
/export includes this line:
#error exporting /routing/policy/selection

/routing/policy/selection/print shows:
error - contact MikroTik support and send a supout file (3)

Is this already known?

In Winbox, there is no icon for "Routing" (this was true in previous versions as well)
Is there a manual for /routing/bgp ? It appears to be completely different from v6 so I need some directions to be able to test it.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 4:28 pm
by santyx32
Test this instead:
/ip dns
set allow-remote-requests=yes use-doh-server=https://1.1.1.1/dns-query
Looks like your router does not resolve the name for cloudflare-dns.com
It did in 6.47, I can even ping cloudflare-dns.com from the CLI but it's not working in DoH
AnotaciĆ³n 2020-06-04 082617.png
You updated directly from 6.47 or used Netinstall?

EDIT: Also tried Adguard and Quad9 without luck
EDIT 2: tried https://1.1.1.1/dns-query and it works, but if I want to use another server I can't do that, because they don't have a SSL certificate embedded into their IP address like Cloudflare has

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 4:28 pm
by hugues
A basic ibgp configuration :

/routing bgp template
add as=65534 name=lab
/routing bgp connection
add local.role=ibgp remote.address=10.X.X.X template=lab

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 4:44 pm
by kcarhc
router was rebooted without proper shutdown on RouterOS v7.0 beta 7

When it on RouterOS Beta 5, it's work well.

I have config some EoIP Tunnels and some IP Tunnels and Bonding Tunnels with EoIP Tunnels.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 4:51 pm
by kcarhc
IPsec Policies say no phase2 on PH2 no phase2

When Upgrade from RouterOS v7.0beta3 and v7.0beta5 to RouterOS v7.0beta7 or v7.0beta8

IPsec Policies say no phase2 on PH2 State
You need goto Identities and remove all and add the Identities for peers again
That's will make IPsec works again.

When Downgradepgrade from RouterOS v7.0beta7 or v7.0beta8 to RouterOS v7.0beta3 and v7.0beta5

IPsec Policies say no phase2 on PH2 State, too.
You need goto Identities and remove all and add the Identities for peers again
That's will make IPsec works again.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:00 pm
by patrick7
Good work, I just hope that you will do the same effort you're doing for IPv4 for IPv6 too.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:05 pm
by mrz
IPv6 works a lot better in v7, ipv6 policy routing and ECMP coming soon

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:08 pm
by pe1chl
IPv6 works a lot better in v7, ipv6 policy routing and ECMP coming soon
Great! I am looking forward to policy routing and hopefully the other mechanisms to do balancing/failover on IPv6 too.
(like NPT and connection-marking with per-connection-classifier)

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:09 pm
by kcarhc
router was rebooted without proper shutdown on RouterOS v7.0 Beta 7 and Beta 8

Every 10 minutes, router auto reboot.
I think maybe some scheduler Interval 10 minutes on RouterOS v7.0 Beta 7 and Beta 8 crash the kernel

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:14 pm
by patrick7
IPv6 works a lot better in v7, ipv6 policy routing and ECMP coming soon
Hardware offloading?

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:24 pm
by pe1chl
A basic ibgp configuration :

/routing bgp template
add as=65534 name=lab
/routing bgp connection
add local.role=ibgp remote.address=10.X.X.X template=lab
I tried setting it up this way, and it connects. That is, at first it connected and failed and then on the second attempt it connects and receives the routes.
Logged messages:
14:18:12 system,info  by admin 
14:18:48 system,info  by admin 
14:18:48 route,bgp,info Write to bgp failed (32) { #buf=1 max=64 sk=Socket{ 5[\00OUT] } } 
Those "system.info by admin" messages are logged whenever config is changed, I think it is missing some info about what was done (like "bgp added template").

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:27 pm
by rhaa01
I can't set the MTU on an ethernet interface to be larger than 1500. L2MTU is 1580 and I can't even set MTU to 1510.
Router: CCR1036-12G-4S

> int eth set 0 mtu=1510
failure: could not set mtu
> int set 0 mtu=1510
failure: could not set mtu

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:28 pm
by mrz
@pe1chl this message typically will appear when there is no local address set or not piicked automatically.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:31 pm
by msatter
I can't set the MTU on an ethernet interface to be larger than 1500. L2MTU is 1580 and I can't even set MTU to 1510.
Router: CCR1036-12G-4S

> int eth set 0 mtu=1510
failure: could not set mtu
> int set 0 mtu=1510
failure: could not set mtu
Is a know problem since the start of ROS 7. That is why did not start using this Beta yet.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 5:43 pm
by pe1chl
@pe1chl this message typically will appear when there is no local address set or not piicked automatically.
The router has only a single interface (ether1) and it has an address (172.22.16.252/21).
The first attempt DID come in to the other side but was disconnected immediately, then connected again and it worked.
Log on the other router:
Jun  4 16:18:48 MikroTik N0212 Connection opened by remote host
Jun  4 16:18:48 MikroTik N0212     RemoteAddress=172.22.16.252
Jun  4 16:18:48 MikroTik N0212 Connection closed
Jun  4 16:18:48 MikroTik N0212     RemoteAddress=172.22.16.252
Jun  4 16:18:58 MikroTik N0212 Connection opened by remote host
Jun  4 16:18:58 MikroTik N0212     RemoteAddress=172.22.16.252

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 8:18 pm
by pcdog
I am using a Chateau LTE12

v4 NAT seems a bit broken now.

- MTRs do not fully go through on some hosts with ipv4 only

on other hosts, if I run an mtr on my PC behind it, it will show the whole route, and then jump and cut out the whole icmp unreachables in between so I can see the mtr, until it's complete, then it only shows 2 hosts -that's with ipv6. weird.

- SSH works on ipv6 only, to the same hosts. reducing the MTU on my machine to mtu 1300 on the PC didn't fix it, so it's not an mtu issue. it's just frozen after SSH login

- disabling fasttrack didn't help

any ideas where I can troubleshoot more? it did work fine before, and a ssh connection using MOSH (UDP tunnel) works as well as SSH outbound over ipv6 now. it also works when I connect over an L2TPoverIPSEC tunnel


this only affects FORWARDED connections. it works fine originating from the chateau outbound!
happy to give remote access if MTIK staff wants to look at it more. It's an elisa 4g connection....

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 8:51 pm
by G2Dolphin
Can't believe my eyes. L3 HW offloading and Linux kernel v5.6.3, what a jump from v4.14. What's next, WireGuard and HW NAT? :)
You're amazing, guys! Gonna play around with spare RB3011 to test everything.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 8:58 pm
by floaty
.
and VRF ! that's rich !
.
[admin@chr] > ip vrf add list=vrf-if-list-red name=vrf-red 
03:52:05 echo: radvd,debug skip Router Advertisement sending on bridge2: no prefixes to send
[admin@chr] > ip vrf add list=vrf-if-list-red name=vrf-red 
[admin@chr] > 
03:52:11 echo: system,info vrf-red added by admin
03:52:11 echo: route,debug,calc 3 Main publish
[admin@chr] > 
[admin@chr] > 
.
dang !.PNG

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 8:59 pm
by Florian
Can't believe my eyes. L3 HW offloading and Linux kernel v5.6.3, what a jump from v4.14. What's next, WireGuard and HW NAT? :)
You're amazing, guys! Gonna play around with spare RB3011 to test everything.
IPv6 fasttrack/path (or any form of faster ipv6) would be nice :D

But it's already a big step to see V7.0 here... Congrats !

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 9:02 pm
by Paternot
Kernel 5.6.3, so little time after 4.x... Does it mean that RoS is using the official drivers, instead of Mikrotik's?

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 9:23 pm
by r00t
Anyone seeing same increased amount of flash writes as seen for v6.47? Or does that not affect ROS 7?
My test results are kind of inconclusive... not sure if it's higher than before or not.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 9:26 pm
by ErfanDL
new kernel mean better wifi performance?

Sent from my SM-A705FN using Tapatalk


Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 9:26 pm
by macgaiver
Anyone seeing same increased amount of flash writes as seen for v6.47? Or does that not affect ROS 7?
My test results are kind of inconclusive... not sure if it's higher than before or not.
it looks like it happens to a point, if i have to guess filesystem manages something and then it goes away, at least on my boards, maybe MT can comment, I have seen the same behaviur both in v6 and v7 now.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 9:36 pm
by santyx32
new kernel mean better wifi performance?

Sent from my SM-A705FN using Tapatalk
it feels a bit faster but maybe placebo

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 9:58 pm
by cfcnightmare
x86 version broken or its netinstall?
trying to install on usb flash and its error

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 10:00 pm
by santyx32
Kernel 5.6.3, so little time after 4.x... Does it mean that RoS is using the official drivers, instead of Mikrotik's?
AFAIK Mikrotik uses its own drivers to allow faster kernel upgrades

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 10:16 pm
by mafiosa
How do I get access to rosv7 documentation? Would be using on vultr vps for bgp. ROSv7 beta8 solves a lot of the issues that makes mikrotik usable.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 10:50 pm
by doush

!) routing updates, complete status report: https://help.mikrotik.com/docs/display/ ... col+Status
Great work.
It is very nice to see HW acceleration of routes and also surprised to see Flowspec.
Now we need HW Acceleration of "Traffic-Flow" to complement Flowspec.
Under D/DOS, if traffic flow is enabled, halts the router by consuming all the CPUs.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 11:15 pm
by Beone
x86 version broken or its netinstall?
trying to install on usb flash and its error
having the same issue, support did not reply

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 11:17 pm
by Paternot
Kernel 5.6.3, so little time after 4.x... Does it mean that RoS is using the official drivers, instead of Mikrotik's?
AFAIK Mikrotik uses its own drivers to allow faster kernel upgrades
Mikrotik does uses (used to?) its own drivers - one of the reasons for the slow upgrade turnaround - it is truly hell to debug this kind of thing.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 11:31 pm
by bpwl
What an update!!
There is more than in the release notes and so there is always hope: "*) other minor fixes and improvements;"
Is there anything changed in the New User Manager ? (that allows for WPA2/EAP and WPA/EAP authentication but did not work for Windows 10 client devices. (No problems with other clients))

viewtopic.php?f=1&t=154677#p775022

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 04, 2020 11:33 pm
by hel
After a clean ros7b8 netinstall on my hAP lite classic I couldn't access it via winbox or putty.
Winbox, after logging in and after "something (forgot what) descriptors" phase says "ERROR: cannot open source file".
In putty I can login, but after ROS logo there's nothing I can do, I could write anything and I do not receive any reply.
Reverted to a 6.47 using netinstall.
ros7b8.png

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 12:55 am
by tpedko
5G WiFi does not work on RB4011iGS+5HacQ2HnD

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 1:38 am
by osc86
Did someone already check if enabling igmp-snooping still breaks IPv6 connectivity like in V6?

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 2:15 am
by mducharme
After a clean ros7b8 netinstall on my hAP lite classic I couldn't access it via winbox or putty.
Winbox, after logging in and after "something (forgot what) descriptors" phase says "ERROR: cannot open source file".
In putty I can login, but after ROS logo there's nothing I can do, I could write anything and I do not receive any reply.
Reverted to a 6.47 using netinstall.

ros7b8.png
I upgraded my hAP mini from 7 beta 5 to 7 beta 8 and the same thing happened. I tried a factory reset on it and it did reset (I could see the name went back to MikroTik in the neighbor discovery packets) but no change to the behavior.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 2:47 am
by floaty
.
Winbox 3.24 crashes after setting up VRF and opening '/IP/routes' dialog ( ...and crashes immediately after trying to reopen)
.
[admin@chr-7-1] > ip route print                                                
Flags: D - DYNAMIC; A - ACTIVE; C - CONNECT, S - STATIC, m - MODEM
Columns: DST-ADDRESS, GATEWAY, DISTANCE
  #       DST-ADDRESS             GATEWAY                D
  0   AS  0.0.0.0/0               192.168.222.25         1
     DAC  10.1.1.0/24             ether2                 0
     DAC  192.168.222.0/24        bridge1                0
     DAC  172.16.30.0/24@vrf-red  71-e2-vlan100@vrf-red  0
[admin@chr-7-1] > 
[admin@chr-7-1] > 
[admin@chr-7-1] > 
[admin@chr-7-1] > routing/table/print 
Flags: D - dynamic; X - disabled, I - invalid; U - used 
 0 D   name="main" fib 

 1 D   name="vrf-red" fib 
[admin@chr-7-1] >                     
[admin@chr-7-1] > 
[admin@chr-7-1] > 
[admin@chr-7-1] > ping 172.16.30.2 arp-ping=yes interface=71-e2-vlan100
  SEQ HOST                                     SIZE TTL TIME  STATUS                                                                                         
    0 00:0C:29:CB:EC:F0                                 0ms  
    1 00:0C:29:CB:EC:F0                                 0ms  
    2 00:0C:29:CB:EC:F0                                 0ms  
    3 00:0C:29:CB:EC:F0                                 0ms  
    4 00:0C:29:CB:EC:F0                                 0ms  
    sent=5 received=5 packet-loss=0% min-rtt=0ms avg-rtt=0ms max-rtt=0ms 

[admin@chr-7-1] > 

#############################################################################

[admin@chr-7-2] > ip route print
Flags: D - DYNAMIC; A - ACTIVE; C - CONNECT, S - STATIC, m - MODEM
Columns: DST-ADDRESS, GATEWAY, DISTANCE
  #       DST-ADDRESS             GATEWAY                D
  0   AS  0.0.0.0                 192.168.222.254        1
     DAC  192.168.222.0/24        ether1                 0
     DAC  172.16.30.0/24@vrf-red  72-e2-vlan100@vrf-red  0
[admin@chr-7-2] > 
[admin@chr-7-2] > 
[admin@chr-7-2] > 
[admin@chr-7-2] > routing/table/print
Flags: D - dynamic; X - disabled, I - invalid; U - used 
 0 D   name="main" fib 

 1 D   name="vrf-red" fib 
[admin@chr-7-2] > 
[admin@chr-7-2] > 
[admin@chr-7-2] > 
[admin@chr-7-2] > ping 172.16.30.1 arp-ping=yes interface=72-e2-vlan100  
  SEQ HOST                                     SIZE TTL TIME  STATUS                                                                                            
    0 00:0C:29:BD:76:B9                                 0ms  
    1 00:0C:29:BD:76:B9                                 0ms  
    2 00:0C:29:BD:76:B9                                 0ms  
    3 00:0C:29:BD:76:B9                                 0ms  
[admin@chr-7-2] > 
[admin@chr-7-2] > 
.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 4:03 am
by sundalez
Im not sure what Mikrotik has done, but look at these numbers with latest ROS7 beta8 on the newly released ccr2004

Over 200 gig duplex against localhost ?

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 10:29 am
by zandhaas
Im not sure what Mikrotik has done, but look at these numbers with latest ROS7 beta8 on the newly released ccr2004

Over 200 gig duplex against localhost ?
Do you know what this was before you upgraded to ROS7b8?

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 10:41 am
by kamillo
Im not sure what Mikrotik has done, but look at these numbers with latest ROS7 beta8 on the newly released ccr2004

Over 200 gig duplex against localhost ?
They increased MTU size on the loopback interface in 6.47
*) interface - increased loopback interface MTU to 65536;
I would guess they did the same in v7

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 12:30 pm
by D13410N3
x86 version broken or its netinstall?
trying to install on usb flash and its error
Same issue for me

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 12:58 pm
by krisjanisj
cfcnightmare & D13410N3 - Does the same error pops-up if You try to install v6 x86 package with 7.0beta8 netinstall?

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 1:42 pm
by netzwerghh
Great to see BGP finally! Is there andy documentation of the new bgp config style yet? Seems the whole CLI logic changed for BGP. I was able to configure a basic setup but am wondering what all those options actually mean.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 1:43 pm
by mrz
Those parameters are subject to change, so no manual for now.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 2:17 pm
by cfcnightmare
cfcnightmare & D13410N3 - Does the same error pops-up if You try to install v6 x86 package with 7.0beta8 netinstall?
The package in download section is not even marked as x86

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 5:08 pm
by cfcnightmare
Those parameters are subject to change, so no manual for now.
Do you test it before upload to the downlod section?
Using test version we are beta testers (or alpha) so you need to exclude such primitive things like that

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 5:22 pm
by floaty
.
user-manager / radiusd:

chap-authentication works
eap works ! ( : [] )
no logging messages echoed to terminal-session for:
.
[admin@chr-7-1] > /system/logging/print                              
Flags: X - DISABLED, I - INVALID; * - DEFAULT
Columns: TOPICS, ACTION
   #      TOPICS    ACTION
### snip ###  
   4      radius    echo 
   

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 6:05 pm
by mafiosa
GRE tunnels don't seem to work!

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 6:09 pm
by mafiosa
GRE tunnels don't seem to work!
Sorry GRE works only the keepalive doesn't! After upgarding from v6.47 to v7beta 8 the tunnels stopped working. After reset same issue persists. WHen I turned off the keep alive it works fine. However the other end v6.47 works absolutely fine with keepalives on or off.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 6:46 pm
by pe1chl
Sorry GRE works only the keepalive doesn't! After upgarding from v6.47 to v7beta 8 the tunnels stopped working. After reset same issue persists. WHen I turned off the keep alive it works fine. However the other end v6.47 works absolutely fine with keepalives on or off.
Keepalives do not work in stock Linux either. Probably they had made a patch for it and it has not (yet) been applied to the kernel used with v7.
However, usually you do not need keepalives. I suggest that by default they are kept OFF and only enabled when the admin explicitly selects it.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 7:30 pm
by arm920t
x86 version broken or its netinstall?
trying to install on usb flash and its error
Netinstall is broken too.Use PXE to boot from lan.Device did not appear on the window.I got this error message:
Kernel panic - not syncing: VFS:Unable to mount root fs on unkown -block(0,0)
Kernel Offset: disabled
Rebooting in 5 seconds..

Also tried to upgrade from Beta 4 to Beta 8.The log said "Not enough memory".Same error as upgrade from Beta 4 to Beta 5.But the flash disk is totally empty.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 7:36 pm
by sundalez
Im not sure what Mikrotik has done, but look at these numbers with latest ROS7 beta8 on the newly released ccr2004

Over 200 gig duplex against localhost ?
They increased MTU size on the loopback interface in 6.47
*) interface - increased loopback interface MTU to 65536;
I would guess they did the same in v7
That makes sense, missed that :)

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 7:55 pm
by HzMeister
Where is CAKE?!?!?!?

Literally everyone expects it, yet there's nothing about it from mikrotik..

Kind of pathetic on their part tbh.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 7:57 pm
by bpwl
5G WiFi does not work on RB4011iGS+5HacQ2HnD
Simple test on "Omnitik 5 ac". Setting up WLAN2 failed !!!

- WLAN1 is "station bridge" (the way this Omnitik is part of my test setup)
- added virtual WLAN2 as "Ap bridge" (to test TXpower on "all rates fixed" with regulatory domain (as antenna gain is gone) . To see the power I need to capture it in "Wifi analyzer".)
... No luck, no signal (even after the longest DFS delay) so I cannot measure and cannot connect
- added virtual WLAN3 (just trying to get forward with different settings) as "bridge" . No problem it is immediatly visible. Smartphone connects.
- changed WLAN2 to "bridge" , no success
- changed WLAN3 to "AP bridge" , OK no problem
- removed WLAN2 as it had 02:00:00:AA:00:00 as MAC address !?
- entered new WLAN2 as "bridge" mode, it got a normal MAC address
- normal MAC address, but disconnected one minute later WLAN1 and after reconnection there was again that local MAC address on WLAN2. WLAN2 cannot be used.

Epilog: TX power follows "all rates fixed"settings , but that TX power cannot be seen on the Mikrotik (it always indicates "max power of the region - antenna gain") in the status/Channel but it transmits differently.

EDIT: tested some more .... WLAN2=bad, WLAN3=OK, WLAN4=bad, WLAN5=OK

EDIT2: the disconnects were reboots without proper shutdown, crashes ?

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 8:33 pm
by mada3k
WOW. Thats som heavy features and updates :shock:

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 9:05 pm
by bpwl
Strange screen refresh in WinBOX/terminal.
In 7.0beta8 if you scroll up/down the characters are incomplete. Not so for older ROS version.
Just pressing "shift" in that window already corrects the screen.
Klembord-2.jpg
EDIT : only happens when WinBOX is not full screen on the PC.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 9:11 pm
by mrz
Where is CAKE?!?!?!?

Literally everyone expects it, yet there's nothing about it from mikrotik..

Kind of pathetic on their part tbh.
You can find cakes here:
https://majaskukas.lv/
Even trendy gluten free ones, which probably you like the most.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 9:25 pm
by floaty
yepp: buttercream !
... my doc told me !

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 10:26 pm
by sstybel
I upgrade my wAP ac from ROS 6.47 to 7beta 8 by the Netinstall and now couldn't connect with them by the WinBox or SSH.
When I try ping default IP (192.168.88.1), some ICMP packet was lost.
Best regards,
Sebastian

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 10:44 pm
by Jotne
/ip accouning
is missing in latest beta.

This breaks my Splunk script.
:local AccuntData true
# Get traffic data (accounting data)
# ----------------------------------
if ($AccuntData) do={
# Test if fasttrack is enabled and give warning
	:if ([/ip firewall filter find where (action=fasttrack-connection && !disabled)] != "") do={
		:log info message=("script=traffic,fasttrack=1")
	} else={
		:log info message=("script=traffic,fasttrack=0")
	}
# Test if accounting is enabled and if yes, get data
	if ([/ip accounting get enabled]=yes) do={
		/ip accounting snapshot take
# Get uncounted data
		do {
			/ip accounting uncounted {
				:log info message=("script=uncounted,bytes=".[get bytes].",packets=".[get packets])
			}
		} on-error={}	
# Send data to loggin server
		foreach logline in=[/ip accounting snapshot find] do={
			:local output "$[/ip accounting snapshot print as-value from=$logline]"
			:set ( "$output"->"script" ) "traffic"
			:log info message="$output"
		}
	}
}

Even if I try the
do={
:my script
} on-error={}
it fails.

I though that I read some about better logging of script error in v7, but no trace of broken script in the log. And its a pain to see what parts fails. I need to cut an past part by part to the terminal and see what is giving eror.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 10:59 pm
by mrz
IP Acccounting is deprecated and removed from ROS v7.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 05, 2020 11:48 pm
by Jotne
IP Acccounting is deprecated and removed from ROS v7.
What do I use then to get traffic data from each client that I do use in Splunk for MikroTik?
SNMP is not an option.

Script will then fail 100% if some do an upgrade to 7.x, since on-error seem to not handle this situation.
.
Accounting.jpg

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 12:22 am
by andriys
What do I use then to get traffic data from each client that I do use in Splunk for MikroTik?
NetFlow is an obvious choice for that kind of data.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 12:32 am
by Jotne
Did forget about Netflow. Will have a look at it.
I do see that this needs an extra input to work on my server. Accounting do work with Syslog that I already uses.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 12:58 am
by floaty
sad ... evolution ... in fact ... there's in all times a child behind
I'm a sad mammal to say so ... :shock:
.
I'm great splunk fan !! ... but I'm doing graylog ... until I'm not !

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 4:23 am
by killersoft
LtAP mini VS v7.0beta 8

Well the wifi via a station & station bridge mode does not work. It connects briefly(10 seconds), then drops( no its not a signal, issue, 6.47 works a treat on the same unit)).

I have a Quectel EC25 LTE board in it. That works no problem !

Doing a WiFi SCAN produces random MAC & SSID's as per image below :
ltAP.png

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 4:32 am
by santyx32
Where is CAKE?!?!?!?

Literally everyone expects it, yet there's nothing about it from mikrotik..

Kind of pathetic on their part tbh.
You can find cakes here:
https://majaskukas.lv/
Even trendy gluten free ones, which probably you like the most.
We're talking about this šŸ° https://www.bufferbloat.net/projects/codel/wiki/Cake/ right?

Re: v7.0beta7 [development] is released!

Posted: Sat Jun 06, 2020 4:53 am
by killersoft
Please keep this topic related to the problems found in this RouterOS release. This topic is not made for feature requests. For that please create a new topic or contact support@mikrotik.com.
Where is CAKE?!?!?!?

Literally everyone expects it, yet there's nothing about it from mikrotik..

Kind of pathetic on their part tbh.
There is another thread for feature requests..
Also queuing has to be one of the lowest priority's right now.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 10:41 am
by idnawsi
routes nexthops unreachable, and sometimes it got disconnected without any reason.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 1:07 pm
by pe1chl
Did forget about Netflow. Will have a look at it.
I do see that this needs an extra input to work on my server. Accounting do work with Syslog that I already uses.
I used /ip accounting in the past but switched to netflow which has a lot more capability and can also do IPv6.
I wrote a simple Perl program (using Net::Flow library) to collect the netflow traffic and write it to a tab-separated file where I can run some other scripts to collect some statistic info.
Of course there are nice graphical netflow analyzers available but this was not required in my case (it is mainly for logging in case of complaints).

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 1:12 pm
by doush
As I mentioned earlier, Netflow/Traffic Flow also needs a rewrite or hardware acceleration on RouterOS.
Traffic flow consumes all the CPU resources in case of an ddos attack.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 2:25 pm
by nevolex
Amazing what a fresh kernel, hi wireguard!

Thanks guys

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 2:42 pm
by Linux1976
Upgrade from 6.47rc2 to 7beta8 on RB3011 changed Software ID and results in lost license. So no further testing for me.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 6:32 pm
by mrz
IP Acccounting is deprecated and removed from ROS v7.
What do I use then to get traffic data from each client that I do use in Splunk for MikroTik?
SNMP is not an option.

Script will then fail 100% if some do an upgrade to 7.x, since on-error seem to not handle this situation.
.
On-error catches only runtime errors. With syntax errors (which is what unknown keyword, remowed command is) script does not even start.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 7:44 pm
by brimfulnick
Where is CAKE?!?!?!?

Literally everyone expects it, yet there's nothing about it from mikrotik..

Kind of pathetic on their part tbh.
Not everyone is 'expecting' it. Whilst fq_codel / cake would be nice, I don't feel it should be implmented at the detriment of implementing other features

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 06, 2020 9:30 pm
by stucchimax
On a new RB4011 I am having issues running BGP for IPv6. I have a session for IPv4 that works perfectly, but IPv6 does not seem to announce and originate anything.

Here is the situation:
/routing bgp connection
add local.role=ebgp remote.address=x.x.x.x .as=xxxx template=net4
add local.address=2xxx:xxx:xxx::10 .role=ebgp remote.address=2xxx:xxx:xxx::1 .as=xxxxx template=\
    net6
add local.role=ebgp remote.address=2xxx:xxxx:1::36 .as=65000 template=net6
Here's the template
/routing bgp template
add address-families=ip as=xxxxx name=net4 output.filter=""
add address-families=ipv6 apply-changes=auto as=xxxxx instance=default name=net6 output.filter=""
And the static routes
/ip route
add dst-address=xxx.xxx.xxx.x/22 gateway="" type=unreachable
/ipv6 route
add dst-address=2xxx:xxxx::/29 gateway="" type=unreachable
The session gets set up, but no routes are exchanged over IPv6. Again, the same config with IPv4 works perfectly.

Am I missing something, or is this a bug ?

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 07, 2020 5:25 am
by hel
Not everyone is 'expecting' it. Whilst fq_codel / cake would be nice, I don't feel it should be implmented at the detriment of implementing other features
I agree. First priority is to get ROS7 at least as stable as ROS6. And then implement new features.
Personally I wait for SQM like fq_codel, CAKE too. We are trying to provide more comfortable service for our customers. This feature is one that we think improve it (but not 100% sure about it).

Devs, please check if smips version still have problems with ipsec.
On every 7beta I have problems with it. It (I think) maxing CPU to 100% when tunnel is working or looping through some phases of connecting. When this happens I lose connectivity to my router. Only way to restore my access in this situation is to unplug the cable from internet so ipsec will stop connecting. I had similar problem on ROS7b8 (just having problems with connecting winbox to confirm it), my router stopped responding until I have disconnected cable from internet. This is an only problem stopping me to test ros7, because I need an ipsec tunnel everyday.
ipsec config:
/ip ipsec policy group add name=Peak
/ip ipsec profile add dh-group=modp1024 enc-algorithm=aes-128 hash-algorithm=sha256 name=profile_1 nat-traversal=no
/ip ipsec peer add address=123.123.123.123/32 local-address=11.11.11.11 name=peak profile=profile_1
/ip ipsec proposal add auth-algorithms=sha256 enc-algorithms=aes-128-cbc name=peak
/ip ipsec identity add auth-method=digital-signature certificate=local-cert peer=peak policy-template-group=Peak remote-certificate=remote-cert
/ip ipsec policy add dst-address=123.123.123.123/32 peer=peak proposal=peak sa-dst-address=123.123.123.123 sa-src-address=11.11.11.11 src-address=11.11.11.11/32 tunnel=yes
Disabling ipsec peer and policy let me connect router to internet without problems.
On 6.47 I didn't see that ipsec could eat so much CPU, I could push ~20mbit/s of encrypted traffic between ipsec peers with only 80% of CPU load and it didn't break any other connectivity.

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 07, 2020 5:30 am
by pawelbien
Thank you for your hard work guys, really appreciate it. I'm happy with every v7 milestone, and this edition is certainly it.
MT should focus on releasing v7 asap after providing functionality similar to v6. Without looking at all the requests for the new features. There will be time for that later.

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 07, 2020 1:45 pm
by whatever
!) system kernel has been updated to version 5.6.3;
That is a really pleasant surprise. Never expected to see a 5.x kernel in ROS after TILE architecture has been removed from upstream Linux.

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 07, 2020 2:34 pm
by normis
TILE support in RouterOS never depended on the kernel

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 07, 2020 3:01 pm
by cfcnightmare
TILE support in RouterOS never depended on the kernel
How about x86 version? Did you checked it?
Even write to usb flash is not working....

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 08, 2020 4:29 am
by mducharme
5GHz interface on RB4011 wifi model is not working in 7.0beta8. It is in ap bridge mode. Scan shows nothing, devices do not see the SSID. I have 6.47 on another partition on the same device and rebooting to that makes it work again. The 2.4GHz interface works fine in either.

Strangely, my Audience wlan3, which uses the same chip (QCA9984), seems to work fine. I set it up as "ap bridge" and I can connect to it.

My RB4011 cannot even connect as "station bridge" to the Audience, but other devices can, like my iPhone.

When I try connecting the RB4011 wlan1 as either bridge or station bridge to the Audience wlan3 in "ap bridge" mode, it seems to see it at first and tries connecting, but I get "association timeout" in the log.

Whatever the the problem is, it seems specific to the RB4011 wifi model and not the QCA9984 chip. It does not work even if I reset to factory defaults, so it is not a config issue.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 08, 2020 6:29 am
by mducharme
my router stopped responding until I have disconnected cable from internet.
Thank you for this - I am having the same issue on my smips device (hAP mini). It is running 7.0beta8. I am not using it as a router so I had ether1 connected but it refused to connect via winbox or terminal (ssh/telnet). I plugged in ether2 instead and rebooted it, and now I can log into winbox and everything works, but terminal still does not (it freezes). The issue does not seem to involve the configuration of the port (on my device ether1 was not set up as an "internet" port in any way), but instead whether there is a cable plugged into ether1 or not.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 08, 2020 11:05 am
by bpwl
5GHz interface on RB4011 wifi model is not working in 7.0beta8. It is in ap bridge mode. Scan shows nothing, devices do not see the SSID. I have 6.47 on another partition on the same device and rebooting to that makes it work again. The 2.4GHz interface works fine in either.

Strangely, my Audience wlan3, which uses the same chip (QCA9984), seems to work fine. I set it up as "ap bridge" and I can connect to it.

My RB4011 cannot even connect as "station bridge" to the Audience, but other devices can, like my iPhone.

When I try connecting the RB4011 wlan1 as either bridge or station bridge to the Audience wlan3 in "ap bridge" mode, it seems to see it at first and tries connecting, but I get "association timeout" in the log.

Whatever the the problem is, it seems specific to the RB4011 wifi model and not the QCA9984 chip. It does not work even if I reset to factory defaults, so it is not a config issue.
My experience is that all even numbered WLAN do not work. Check the MAC address.
Add a virtual WLAN and use only the ODD interface numbers

viewtopic.php?f=1&t=161980#p798313

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 08, 2020 2:39 pm
by cfcnightmare
What about x86 version?
Can you solve the issue i wrote before?

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 08, 2020 2:48 pm
by pe1chl
What about x86 version?
Can you solve the issue i wrote before?
Please do not repeat the same thing over and over again!

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 08, 2020 8:44 pm
by slackR
Tried to load beta8 on a rb1200 and get a kernel panic


RouterBOOT booter 6.47

RouterBoard 1200

CPU frequency: 1000 MHz
Memory size: 512 MiB
NAND size: 64 MiB

Press <delete> key within 2 seconds to enter setup..

loading kernel... OK
setting up elf image... OK
jumping to kernel code
Starting...
Oops: Machine check, sig: 7 [#1]
BE PAGE_SIZE=4K RB1200
CPU: 0 PID: 41 Comm: sysinit Tainted: G M 5.6.3-440 #7
NIP: a10758ac LR: a1076f90 CTR: 00000000
REGS: 9ffeff08 TRAP: 0214 Tainted: G M (5.6.3-440)
MSR: 00029000 <CE,EE,ME> CR: 84000208 XER: 00000000

GPR00: a1076f3c 9e491cf8 9f734600 000000f8 00000000 00000000 000000fc 80499990
GPR08: 8047e1e4 a9015114 80480000 9e491cb8 24000208 10028298 a107d000 8038720d
GPR16: a107e094 00000039 803e52dc 00000124 8007297c 00000010 9f5f0a24 00000488
GPR24: a4f8b384 a107b448 9f5f0a24 a1080000 00015000 00000124 a107b284 a107b094
NIP [a10758ac] get_hcfg+0x118/0x124 [flash@0xa1075000]
LR [a1076f90] init_module+0x280/0x408 [flash@0xa1075000]
Call Trace:
[9e491cf8] [a1076f3c] init_module+0x22c/0x408 [flash@0xa1075000] (unreliable)
[9e491d28] [80002a54] do_one_initcall+0x7c/0x154
[9e491da8] [80074258] do_init_module+0x6c/0x1e0
[9e491dd8] [80075dc8] load_module+0x1974/0x1bb4
[9e491ea8] [80076174] sys_finit_module+0x8c/0x94
[9e491f38] [8000b168] ret_from_syscall+0x0/0x38
--- interrupt: c01 at 0x77edf204
LR = 0x77eb98c4
Instruction dump:
90010024 48003a79 80010024 80610008 38210020 7c0803a6 4e800020 3d20a108
8129b080 7d291a14 7c0004ac 80690000 <0c030000> 4c00012c 4e800020 3d20a108
---[ end trace 1e39f59b6d518d6a ]---

Kernel panic - not syncing: Fatal exception

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 08, 2020 10:22 pm
by Sob
Sorry for nagging, but can you please help me understand, why is there this combined dst-address parameter for other routing tables?
/ip route add ... dst-address=<destination>@<routing table>
I still can't wrap my head around it. Why not separate and intuitive:
/ip route add ... dst-address=<destination> table=<routing table>
like everywhere else? This is like if there was:
/interface bridge port add ... interface=<interface>@<bridge>
/ip firewall address-list add ... address=<address>@<list>
/ip firewall filter add ... action=<action>@<chain>
It would be weird. Or am I missing some deeper idea, why the combined parameter is better?

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 08, 2020 10:54 pm
by pe1chl
Maybe it is the direction that all parameters will be moving?
I see in BGP that there is things like "remote.address" too, apparently structuring several parameters under groups like "local" and "remote".
(such a parameter would have been called "remote-address" before)

Re: v7.0beta8 [development] is released!

Posted: Wed Jun 10, 2020 3:07 pm
by dbouwer
Sierra Wireless AirPrime MC7304 interface statistics are showing Gbps...
Screenshot_2020-06-10_11-13-43.png
.See attached.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 11, 2020 1:38 am
by joshfinlay
Unsure if this has been reported yet.

ROSv7b8 CHR on Proxmox

Configuration does not preserve across reboots, but log file does.

Expectation: Configuration preserves
Steps to reproduce:
Create VM in Proxmox
qm importdisk <VMID> chr-7.0beta8.img <storage>
Boot VM
Login. Make config changes. See working.
Reboot.
Result: Configuration restored to default after reboot

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 11, 2020 12:05 pm
by Chupaka
When in WinBox 3.24 I go to IP -> Routes, click "Add" and type "8.8.8.8@" in Dst. Address, WinBox hungs and, a few seconds later, disappears. Is it only me with Wine on MacOS, or the problem is repeatable everywhere?

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 11, 2020 8:30 pm
by octanenetworks
Appears to be broken on TILE (CCR1072).

Have pings, can't login to anything, via serial /system profile is suggesting that the system is at 100% utilization the entire time -

Hopefully better luck in 2021 for beta9.
[admin@MikroTik] /ip/dhcp-client> /tool/profile
Columns: NAME, USAGE
  NAME          USAGE
  console       0%
  networking    0%
  management    0%
  profiling     0%
  unclassified  99.9%
  total         99.9%
-- [Q quit|D dump|C-z pause]

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 8:51 am
by LetMeRepair
Is the any hardware requirements for ROS 7 (Beta 8 )? I have tried to test it on RB411UAHR (with Sierra MC8792V modem installed).

First did regular upgrade but it ends in a boot loop.
RouterBOOT booter 7.0beta8

RouterBoard 411UAHR

CPU frequency: 680 MHz
  Memory size:  64 MiB
    NAND size:  64 MiB

Press any key within 2 seconds to enter setup..
trying bootp protocol............... failed
kernel loading failed

loading kernel... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...
MikroTik 7.0beta8 (development)
MikroTik Login:

RouterBOOT booter 7.0beta8

RouterBoard 411UAHR

CPU frequency: 680 MHz
  Memory size:  64 MiB
    NAND size:  64 MiB
Did netinstall after this, it said it couldn't keep config so the box is back to defaults also. Still boot loop.

Downgrade to 6.47 (netinstall) works fine.

If I can provide any additional data to help debug let me know. If the box is just too old or something, oh well I would understand that. For me it's just a test router anyway, but have no big one free at the moment for testing.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 4:12 pm
by floaty
.
When in WinBox 3.24 I go to IP -> Routes, click "Add" and type "8.8.8.8@" in Dst. Address, WinBox hungs and, a few seconds later, disappears. Is it only me with Wine on MacOS, or the problem is repeatable everywhere?
.
it's general
.
Winbox 3.24 crashes after setting up VRF and opening '/IP/routes' dialog

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 4:57 pm
by dkenguru
2.4Ghz wireless don't work on hAP AC.
It's running, but any client's can't connect.
5Ghz works fine.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 8:01 pm
by ferarrese
What about x86 version?
Can you solve the issue i wrote before?
Hello, I see that you are a new colleague on the forum and you may not have learned to use the tool. Or don't learn to be pasciente yet.
Even though this is not the place to answer your question, here's your answer:
viewtopic.php?f=1&t=160929&p=799906#p799906

You can also use furum search which will also find a solution to your problem.

Be welcome

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 8:18 pm
by cfcnightmare
What about x86 version?
Can you solve the issue i wrote before?
Hello, I see that you are a new colleague on the forum and you may not have learned to use the tool. Or don't learn to be pasciente yet.
Even though this is not the place to answer your question, here's your answer:
viewtopic.php?f=1&t=160929&p=799906#p799906

You can also use furum search which will also find a solution to your problem.

Be welcome
Do you understand that you cannot even write it to a usb flash?
Why you give me that link?

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 8:33 pm
by jvanhambelgium
What do I use then to get traffic data from each client that I do use in Splunk for MikroTik?
NetFlow is an obvious choice for that kind of data.
So far I've not been able to find a free Netflow collector that actually works.
I've tried dozens...almost got it working with ElasticFlow (https://www.catapultsystems.com/blogs/i ... 04-part-1/)

Very sad IP-accounting will be gone in ROS7 , can't understand why. This "features" is not something cutting edge that needed works or was full of bugs to my understanding. It just basically works and is no rocket-science.

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 9:11 pm
by ferarrese
What about x86 version?
Can you solve the issue i wrote before?
Hello, I see that you are a new colleague on the forum and you may not have learned to use the tool. Or don't learn to be pasciente yet.
Even though this is not the place to answer your question, here's your answer:
viewtopic.php?f=1&t=160929&p=799906#p799906

You can also use furum search which will also find a solution to your problem.

Be welcome
Do you understand that you cannot even write it to a usb flash?
Why you give me that link?

Friend, if you just read the whole topic, you will see that this same problem has already been solved in another way
then the mikrotik support indicates to download an ISO of the installer and install directly on the flash.
I'll draw for you to understand:
https://box.mikrotik.com/f/092549ada5484eeab7bb/

Download the file, write to the flash drive with the Rufus utility (https://rufus.ie/)
and boot.

If you have any other specific problem, I would like to open a post on the forum to avoid polluting this POST, dedicated to the BUG of the new version of RouterOS.
Concluding this matter.
Thank you and good luck!

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 9:15 pm
by cfcnightmare
Did you see iso there?

Re: v7.0beta8 [development] is released!

Posted: Fri Jun 12, 2020 11:40 pm
by pe1chl
So far I've not been able to find a free Netflow collector that actually works.
I wrote my own in Perl, it uses Net::Flow and it writes tab-separated files (1 flow per line).
It is based on an example provided with Net::Flow. I could post it in a forum topic.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 13, 2020 1:28 pm
by arm920t
What about x86 version?
Can you solve the issue i wrote before?
Hello, I see that you are a new colleague on the forum and you may not have learned to use the tool. Or don't learn to be pasciente yet.
Even though this is not the place to answer your question, here's your answer:
viewtopic.php?f=1&t=160929&p=799906#p799906

You can also use furum search which will also find a solution to your problem.

Be welcome
Do you understand that you cannot even write it to a usb flash?
Why you give me that link?

Friend, if you just read the whole topic, you will see that this same problem has already been solved in another way
then the mikrotik support indicates to download an ISO of the installer and install directly on the flash.
I'll draw for you to understand:
https://box.mikrotik.com/f/092549ada5484eeab7bb/

Download the file, write to the flash drive with the Rufus utility (https://rufus.ie/)
and boot.

If you have any other specific problem, I would like to open a post on the forum to avoid polluting this POST, dedicated to the BUG of the new version of RouterOS.
Concluding this matter.
Thank you and good luck!
Not work! My system has two sata disk.I burned the iso into one and boot from it.Loading the linux kernel and report no disk found. I had changed the disk from sata to ide model. I does not work too.
I searched the comminuity and found this is a very old problem and did not solved till now.
error.JPG

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 13, 2020 4:37 pm
by mkx
Boot process (which is not the same as kernel) complained about CD-ROM not found. So the install package has to be started from a device which presents itself as CD-ROM, not as hard disk. Which is easy under VM, not so easy under barebone hardware.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 13, 2020 6:06 pm
by Paternot
Boot process (which is not the same as kernel) complained about CD-ROM not found. So the install package has to be started from a device which presents itself as CD-ROM, not as hard disk. Which is easy under VM, not so easy under barebone hardware.
But is it an ISO boot image? I never bothered with the x86 version.

If it is just an installation iso image, then one can just do a "cat file.iso > /dev/<flashdrive>; flush" and be done with the iso image. If the ISO is a normal one (Windows needs something more than a Distro ISO), it should boot as a CD.
WARNING: This will ERASE everything on the destination flashdrive - even the partition table. Be warned.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 13, 2020 6:53 pm
by mkx
Traditionally ISO images could only be used in CD and DVD physical media. And if software reading it wasn't too smart, it would choke if ISO image was "burned" on some other type of medium (such as HD). Quite a few linux installers were made so that they were looking for installation medium on CD-ROM type of devices.
Initially wasn't so, nowdays many USB sticks can present themselves either as HDD or CD-ROM to the host OS and modern linux distributions come as "hybrid ISOs" that can be simply written to USB stick ... probably not to more traditional HDD or SSD. Additionally modern installers scan all storage devices for installation medium.

Mind that all of this is pretty modern stuff, we all know Mikrotik is curently lagging behind in many aspects so one should not be too surprised if something which is otherwise usual fails in ROS. Good knowledge of computing history (at least last 15 years) helps to understand the shortcomings.

Re: v7.0beta8 [development] is released!

Posted: Sat Jun 13, 2020 10:59 pm
by Jotne
So far I've not been able to find a free Netflow collector that actually works.
Did try netflow for Splunk, but does not get it to work.
It also add a new port to listen to, not only Syslog. Not sure if nteflow work over long internet connection.

Why not just leave the working accounting that are in all Router OS up until 7.beta 6 (not in beta 8 )
Or MT can do a poll and ask if its ok to remove a function. Maybe its not only me and all the Splunk user who uses it... :(

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 14, 2020 12:05 am
by LetMeRepair
OMG why didn't anyone mention yet: UDP support on OpenVPN???

Feels like that was longer on the wishlist than anything else!

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 14, 2020 1:26 am
by Uxorious
Still issues with NTP server names.
UI gives an error when entering a server name.
Doing this: "/system/ntp/client/set enabled=yes servers=us.pool.ntp.org" will work, but the Address field will be blank and the resolved-address will be correct.
After that, "/export" does not include the server.

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 14, 2020 11:46 am
by pe1chl
OMG why didn't anyone mention yet: UDP support on OpenVPN???

Feels like that was longer on the wishlist than anything else!
Nobody appreciates that anymore, the whiners have moved on to requesting Wireguard....

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 14, 2020 11:56 am
by msatter
And we got a Linux version that supports Wireguard. So endless whining is avoided.

RouterOS eight would not be there in my lifetime.

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 14, 2020 12:06 pm
by mbovenka
Anyone else having problems with the CCR1036-8G-2S+ USB port under 7.0b8?

I upgraded my CCR from 6.46.1 to get my Huawei 3372h-320 working (tested on a hAP ac). But on my CCR, the stick isn't recognized. In fact, nothing is; nothing shows up in USB resources, whatever I connect to it (USB memory stick, Android phone, 4G stick). And nothing I connect to the USB port recognizes that there is anything at the other end (The Android phone doesn't go into USB tethering for instance, which works fine in 6.46.1, and gives me a working 'LTE' interface).

It looks like it just delivers power (it does do that: the phone charges), but nothing else. I have opened a ticket with support, we'll see what drops out.

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 14, 2020 12:43 pm
by pe1chl
And we got a Linux version that supports Wireguard. So endless whining is avoided.
RouterOS v6 runs on a Linux version that supports OpenVPN with UDP, and we all know what happened there...
"the Linux version supporting it" is amongst the many different points deciding if something is added to RouterOS.
That is why I think it is a good idea to allow for user code to run in a sandbox. So people can add what they need
even when MikroTik does not consider it to be worth it.
(of course this does not really work for every feature one can think of, but for some of them it would)

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 15, 2020 8:24 am
by normis
Boot process (which is not the same as kernel) complained about CD-ROM not found. So the install package has to be started from a device which presents itself as CD-ROM, not as hard disk. Which is easy under VM, not so easy under barebone hardware.
But is it an ISO boot image? I never bothered with the x86 version.

If it is just an installation iso image, then one can just do a "cat file.iso > /dev/<flashdrive>; flush" and be done with the iso image. If the ISO is a normal one (Windows needs something more than a Distro ISO), it should boot as a CD.
WARNING: This will ERASE everything on the destination flashdrive - even the partition table. Be warned.
BTW the IMG file is also available, just don't use the ISO for installation.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 15, 2020 11:24 am
by arm920t
Boot process (which is not the same as kernel) complained about CD-ROM not found. So the install package has to be started from a device which presents itself as CD-ROM, not as hard disk. Which is easy under VM, not so easy under barebone hardware.
Finally i installed ros V7 Beta5 under barebone hardware with the help of Vmware workstation.The boot partition is 35MB now which is bigger than previous(upgraded from V6).Thanks for your help.

Re: v7.0beta8 [development] is released!

Posted: Tue Jun 16, 2020 12:46 pm
by pe1chl
Can you please add the "rpfilter" matcher to the firewall matching rule options?
See viewtopic.php?f=2&t=120863 and viewtopic.php?f=14&t=56572

Re: v7.0beta8 [development] is released!

Posted: Tue Jun 16, 2020 1:16 pm
by wenasong
Just to check. I have my interfaces detected and running well on 7beta5, but after upgrading to 7beta8, all interfaces gone from the list,
also... somehow I have to wait about 2 minutes before I can use the CLI after login.

Any information to solve this issue?

-Wenas

Re: v7.0beta8 [development] is released!

Posted: Wed Jun 17, 2020 5:48 am
by arm920t
Just to check. I have my interfaces detected and running well on 7beta5, but after upgrading to 7beta8, all interfaces gone from the list,
also... somehow I have to wait about 2 minutes before I can use the CLI after login.

Any information to solve this issue?

-Wenas
Same hereļ¼ŒThe onboard nic works well in beta5 but can not detected in beta 8. I add a connectx-4 lx card and found the system working slowly with 80% cpu usage.Reset configuration or reboot didi not solve the problem. I reinstall beta8 and boot from another motherboard and this time everyting is ok.But after that i added a switch and system became slow again with very hight CPU usage

Re: v7.0beta8 [development] is released!

Posted: Wed Jun 17, 2020 10:59 am
by wenasong
Just to check. I have my interfaces detected and running well on 7beta5, but after upgrading to 7beta8, all interfaces gone from the list,
also... somehow I have to wait about 2 minutes before I can use the CLI after login.

Any information to solve this issue?

-Wenas
Same hereļ¼ŒThe onboard nic works well in beta5 but can not detected in beta 8. I add a connectx-4 lx card and found the system working slowly with 80% cpu usage.Reset configuration or reboot didi not solve the problem. I reinstall beta8 and boot from another motherboard and this time everyting is ok.But after that i added a switch and system became slow again with very hight CPU usage
Do you have any info on how to reinstall to Beta8, netinstall doesn't work for me. ISO only 7beta5 is available.

Re: v7.0beta8 [development] is released!

Posted: Wed Jun 17, 2020 11:12 am
by normis
What is not working with Netinstall? Any error?

Re: v7.0beta8 [development] is released!

Posted: Wed Jun 17, 2020 12:47 pm
by cfcnightmare
What is not working with Netinstall? Any error?
I posted screenshot above....

Re: v7.0beta8 [development] is released!

Posted: Wed Jun 17, 2020 1:33 pm
by arm920t
Just to check. I have my interfaces detected and running well on 7beta5, but after upgrading to 7beta8, all interfaces gone from the list,
also... somehow I have to wait about 2 minutes before I can use the CLI after login.

Any information to solve this issue?

-Wenas
Same hereļ¼ŒThe onboard nic works well in beta5 but can not detected in beta 8. I add a connectx-4 lx card and found the system working slowly with 80% cpu usage.Reset configuration or reboot didi not solve the problem. I reinstall beta8 and boot from another motherboard and this time everyting is ok.But after that i added a switch and system became slow again with very hight CPU usage
Do you have any info on how to reinstall to Beta8, netinstall doesn't work for me. ISO only 7beta5 is available.
Use Vmware Workstation to boot from 7beta5 iso. Mount the physical disk into vmware and install 7beta5 . Plug the disk to your x86 router and boot from it. Use the npk file to upgrade to 7beta8.
Vmware will solve the "can not find CD-ROM" error when you use the iso for installation
You can make your own 7beta8 ISO file , Just use the ULTRA ISO to edit the 7beta5 iso file and replace the routeros.npk in it with the routeros-x86-7.0beta8.npk (rename to routeros.npk)
replace.JPG

Re: v7.0beta8 [development] is released!

Posted: Wed Jun 17, 2020 7:06 pm
by telepro
On RB951G-2HnD running V7.0beta8, unable to successfully load a metarouter image.

Entered command response is as follows:
[admin@FasSat V3.05.03.U016] > /metarouter import-image file-name=openwrt-mr-mips-rootfs.v1.22.01.20200413.tar.gz
import failed: file in archive goes out of root directory: ./FasSat/
[admin@FasSat V3.05.03.U016] >

Should metarouter capability be available in V7, or is this error something unique to our metarouter image?
Is it Mikrotik's intention to have this available when V7 is released for production usage?
We use this feature on 1600+ 951G2HnD devices with ROS 6.45.8 and do strongly prefer it to remain available.

Re: v7.0beta8 [development] is released!

Posted: Wed Jun 24, 2020 12:37 am
by rushlife
hi, tried someone ros7.0b8 on CRS354 ?
possible fix for interfaces forwarding problem ?

viewtopic.php?t=160561

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 25, 2020 10:43 am
by angriukas
ROS 7.0beta8 contains problems with CAPsMAN (or with DHCP)!
Local WiFi interface (on same router) connected via CAPsMAN (in CAPsMAN forwarding mode) cannot deliver DHCP lease, error ocured:
03:01:08 dhcp,warning dhcp1-lan offering lease 192.168.101.253 for MAC-ADDRESS without success

There is no problems with same config on ROS 6.45.x
And because RBD53G-5HacD2HnD cannot be downgraded to 6.X - I am in really big trouble :(
Any suggestions are welcome: how to avoid "lease without success" issue in CAPsMAN forwarding mode?

Update:
In case of CAPsMAN forwarding mode, dynamic cap port in the bridge appears without "Forwarding". And probably this is the reason why DHCP are failing.
I try to set STP protocol to none, unfortunately same problem still exists - "Forwarding" not enabled, DHCP do not working.

Re: v7.0beta8 [development] is released!

Posted: Thu Jun 25, 2020 12:34 pm
by trungpro3105
Since RouterOS v6.43 it is possible to create a Private VLAN setup on CRS3xx series switches, example can be found in the Switch chip port isolation manual page.

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 28, 2020 11:09 am
by bluecrow76
Did some testing with BGP this evening. BGP does not work when a TCP MD5 key is specified. Removing the TCP MD5 key requirement from the remote peer allows BGP to connect.

When the TCP MD5 key is specified, there are no error messages on either end regarding an invalid key as would be expected.

This test was done on a hEX S router running ROS 7.0beta8 connecting to a production RB1200 running ROS 6.47.

Example config:
/routing bgp template
set default as=4274700001
/routing bgp connection
add connect=yes listen=yes local.role=ibgp remote.address=10.23.1.37 template=default tcp-md5-key=abc123

Re: v7.0beta8 [development] is released!

Posted: Sun Jun 28, 2020 10:48 pm
by Lupin
Mikrotik, with the new kernel do you think to make MPTCP available?

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 11:25 am
by pe1chl
Mikrotik, with the new kernel do you think to make MPTCP available?
MPTCP runs on end-systems, not on routers. It would be like asking MikroTik to make QUIC available. It is already available.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 12:15 pm
by eworm
It would be like asking MikroTik to make QUIC available. It is already available.
Well, RouterOS can be client as well, so for example fetch command could benefit. It's not a big win there, though.

But DoH over QUIC or HTTPS/3 could be worth adding one day... No idea if there are endpoints supporting it already.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 3:01 pm
by bpwl
It would be like asking MikroTik to make QUIC available. It is already available.
Well, RouterOS can be client as well, so for example fetch command could benefit. It's not a big win there, though.

It's probably not only the RouterOS traffic alone that would benefit from MPTCP. If one uses a WAN uplink as client (with NAT etc) then all internet traffic is handled as RouterOS-client on that WAN interface. I have no idea if LAN based TCP could be converted to "aggregated WAN MPTCP", it could just be wishful thinking. I only see improved connectivity with the web-proxy, which is using slightly different HTTP protocols than the clients. (Over satellite it makes quite a difference).

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 3:25 pm
by nithinkumar2000
Can anyone please confirm wheather IPv6 accounting is added to ROS v7?

Waiting for that from a long time.

ISP need Delegation Prefix for IPDR and since ROS is not having IPv6 Accounting we are unable to fetch the Delegated IPv6 Prefix details...

Hope Mikrotik Team will take this in priority.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 3:42 pm
by pe1chl
Can anyone please confirm wheather IPv6 accounting is added to ROS v7?
IP(v4) Accounting has been removed in RouterOS v7. So certainly there has been no IPv6 Accounting added.
Accounting should now be done using Netflow (IP->Traffic Flow) which already supports IPv6 in RouterOS v6.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 4:24 pm
by mrz
It would be like asking MikroTik to make QUIC available. It is already available.
Well, RouterOS can be client as well, so for example fetch command could benefit. It's not a big win there, though.

It's probably not only the RouterOS traffic alone that would benefit from MPTCP. If one uses a WAN uplink as client (with NAT etc) then all internet traffic is handled as RouterOS-client on that WAN interface. I have no idea if LAN based TCP could be converted to "aggregated WAN MPTCP", it could just be wishful thinking. I only see improved connectivity with the web-proxy, which is using slightly different HTTP protocols than the clients. (Over satellite it makes quite a difference).
In case of NAT router is only changing SRC or DST address of the packet, it does not make a connection. So it is still end-to-end system feature.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 4:54 pm
by nithinkumar2000
Can anyone please confirm wheather IPv6 accounting is added to ROS v7?
IP(v4) Accounting has been removed in RouterOS v7. So certainly there has been no IPv6 Accounting added.
Accounting should now be done using Netflow (IP->Traffic Flow) which already supports IPv6 in RouterOS v6.
Thank You for the reply. But i was asking about radius accounting for IPv6.
Currently we are unable to get the information about DHCPv6 PD information in radius session log.

We are ISP and it is mandatory for us to log the following Parameters in our IPDR:

1. Session Start Date & Time -> Working
2. Session End Date & Time -> Working
3. IPv4 Address Assigned -> Working
4. IPv6 Prefix Assigned -> Working
5. IPv6 Delegation Assigned -> NOT WORKING
6. MAC Address -> Working
7. User ID -> Working

Because of this issue we are unable to implement IPv6 in our Network.

I Hope all major ISP in INDIA using Mikroitk Router is facing this issue and still we have received no Updates of improvements from the team.

It would be really great if anyone who is having some update/solutions regarding this problem may share here which will be very useful to everyone.

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 6:09 pm
by pe1chl
It's probably not only the RouterOS traffic alone that would benefit from MPTCP. If one uses a WAN uplink as client (with NAT etc) then all internet traffic is handled as RouterOS-client on that WAN interface. I have no idea if LAN based TCP could be converted to "aggregated WAN MPTCP", it could just be wishful thinking. I only see improved connectivity with the web-proxy, which is using slightly different HTTP protocols than the clients. (Over satellite it makes quite a difference).
Of course it would be possible to use a socks proxy to make a bad TCP implementation work better over a difficult connection (e.g. one that delays or re-orders packets).
A web proxy is another case where that would work.
However, I'm not so sure if it is a good idea to cover up the problems this way, it will likely work better when the end-system TCP is improved.
(I know that some popular operating system has a terrible TCP implementation, but is it everyone-else's problem to fix that?)

Re: v7.0beta8 [development] is released!

Posted: Mon Jun 29, 2020 10:47 pm
by Lupin
I see MPTCP implemented using OpenWRT on end Router, and a debian/ubuntu on datacenter vps
Creating some tunnel make real aggregation of multiple ISP with different bandwidth, latency instantly

See this example:
https://www.youtube.com/watch?v=YYDZ_8wc5HA

Re: v7.0beta8 [development] is released!

Posted: Tue Jun 30, 2020 5:33 am
by nithinkumar2000
Can anyone please confirm wheather IPv6 accounting is added to ROS v7?
IP(v4) Accounting has been removed in RouterOS v7. So certainly there has been no IPv6 Accounting added.
Accounting should now be done using Netflow (IP->Traffic Flow) which already supports IPv6 in RouterOS v6.
Thank You for the reply. But i was asking about radius accounting for IPv6.
Currently we are unable to get the information about DHCPv6 PD information in radius session log.

We are ISP and it is mandatory for us to log the following Parameters in our IPDR:

1. Session Start Date & Time -> Working
2. Session End Date & Time -> Working
3. IPv4 Address Assigned -> Working
4. IPv6 Prefix Assigned -> Working
5. IPv6 Delegation Assigned -> NOT WORKING
6. MAC Address -> Working
7. User ID -> Working

Because of this issue we are unable to implement IPv6 in our Network.

I Hope all major ISP in INDIA using Mikroitk Router is facing this issue and still we have received no Updates of improvements from the team.

It would be really great if anyone who is having some update/solutions regarding this problem may share here which will be very useful to everyone.
Anyone?????

Re: v7.0beta8 [development] is released!

Posted: Tue Jun 30, 2020 6:56 am
by mducharme
Anyone?????
What we do is run a script every 5 minutes that converts all DHCPv6 dynamic bindings (leases) to static bindings. We backup the config of our PPPoE concentrator every hour, and keep the backups for a very long time period. So, every customer gets the same prefix lease the next time, and if we need to find which customer had a lease, we just need to check the backups of our concentrator. It is not as nice as having this info reported in the RADIUS accounting packets, but in the meantime, it works very well.

Re: v7.0beta8 [development] is released!

Posted: Thu Jul 02, 2020 5:15 pm
by DarkNate
Can anyone please confirm wheather IPv6 accounting is added to ROS v7?
IP(v4) Accounting has been removed in RouterOS v7. So certainly there has been no IPv6 Accounting added.
Accounting should now be done using Netflow (IP->Traffic Flow) which already supports IPv6 in RouterOS v6.
Thank You for the reply. But i was asking about radius accounting for IPv6.
Currently we are unable to get the information about DHCPv6 PD information in radius session log.

We are ISP and it is mandatory for us to log the following Parameters in our IPDR:

1. Session Start Date & Time -> Working
2. Session End Date & Time -> Working
3. IPv4 Address Assigned -> Working
4. IPv6 Prefix Assigned -> Working
5. IPv6 Delegation Assigned -> NOT WORKING
6. MAC Address -> Working
7. User ID -> Working

Because of this issue we are unable to implement IPv6 in our Network.

I Hope all major ISP in INDIA using Mikroitk Router is facing this issue and still we have received no Updates of improvements from the team.

It would be really great if anyone who is having some update/solutions regarding this problem may share here which will be very useful to everyone.
Hi, I'm a home user using MikroTik as my router. With BSNL FTTH as my ISP. I too have IPv6 problems on MikroTik. I found a hack, it's probably violating some IPv6 specifications, but it works.
Link: viewtopic.php?f=13&t=162930#p802934

However it's not just MikroTik, I've seen the exact same problems even with consumer brands like TP-Link, Netgear, D-Link and even some reports on pfSense.

Re: v7.0beta8 [development] is released!

Posted: Fri Jul 03, 2020 9:42 pm
by nithinkumar2000
Anyone?????
What we do is run a script every 5 minutes that converts all DHCPv6 dynamic bindings (leases) to static bindings. We backup the config of our PPPoE concentrator every hour, and keep the backups for a very long time period. So, every customer gets the same prefix lease the next time, and if we need to find which customer had a lease, we just need to check the backups of our concentrator. It is not as nice as having this info reported in the RADIUS accounting packets, but in the meantime, it works very well.
Thank You so much for the reply @mducharme

It would be really helpful if you can share the script.

Thanks in Advance

Re: v7.0beta8 [development] is released!

Posted: Sat Jul 04, 2020 11:48 pm
by mafiosa
OSPF doesn't work. All routes learnt by ospf on v7 router is marked as invalid while other v6 routers are learning ospf networks via v7 but traffic is being dropped by v7 router.

Re: v7.0beta8 [development] is released!

Posted: Sun Jul 05, 2020 5:07 pm
by nithinkumar2000
I Really Appriciate MIKROTIK Team for their wonderful hardwork with ROS v7 :)

But Please add the IPv6 Radius accounting as all ISP are looking for the same from very long time.

ISP's are unable to deploy the IPv6 due to No Radius Accounting for IPv6 and it is really SAD :( that Mikrotik team is not taking any actions towards this issue.

Expecting the Feature at the earliest.

Re: v7.0beta8 [development] is released!

Posted: Mon Jul 06, 2020 3:37 pm
by normis
nithin kumar

What's new in 6.45.1 (2019-Jun-27 10:23):
*) dhcpv6-server - added RADIUS accounting support with queue based statistics;

It's already in RouterOS.

Re: v7.0beta8 [development] is released!

Posted: Mon Jul 06, 2020 5:00 pm
by nithinkumar2000
nithin kumar

What's new in 6.45.1 (2019-Jun-27 10:23):
*) dhcpv6-server - added RADIUS accounting support with queue based statistics;

It's already in RouterOS.
It is Still Not Working Normis.

We are getting only Remote Prefix but Not the Delegated IPv6 Prefix

Re: v7.0beta8 [development] is released!

Posted: Mon Jul 06, 2020 8:09 pm
by mducharme
Thank You so much for the reply @mducharme

It would be really helpful if you can share the script.

Thanks in Advance
Schedule this to run every 5 minutes:
/ipv6 dhcp-server binding;
:foreach i in=[find server~"pppoe"] do={
  make-static $i;
  set $i comment=[get $i server];
  set $i server=all;
}

Re: v7.0beta8 [development] is released!

Posted: Mon Jul 06, 2020 8:11 pm
by mducharme

It is Still Not Working Normis.

We are getting only Remote Prefix but Not the Delegated IPv6 Prefix
This is because they only added support for DHCPv6 RADIUS accounting in that version where PPPoE is not used. If PPPoE is used, it is still not supported.