Community discussions

MikroTik App
 
mafiosa
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Fri Dec 09, 2016 8:10 pm

ROSv7 documentation/ config guides

Thu Jun 04, 2020 11:26 pm

Where can I find ROSv7 documentation and configuration guide? Need to get bgp up in beta 8. Looking for documentation.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6142
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROSv7 documentation/ config guides

Fri Jun 05, 2020 12:28 am

At the moment there is none because configuration can and probably will change.

What exactly you were not able to set up?
 
mafiosa
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Fri Dec 09, 2016 8:10 pm

Re: ROSv7 documentation/ config guides

Fri Jun 05, 2020 12:36 am

An example of eBGP multihop configuration would do.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1895
Joined: Mon Jan 14, 2008 1:53 pm
Location: Over the Rainbow
Contact:

Re: ROSv7 documentation/ config guides

Fri Jun 05, 2020 7:42 am

@mafiosa
/routing bgp template
add address-families=ip as=65533 instance=default multihop=yes name=as65533-ipv4 routing-table=main

/routing bgp connection
add connect=yes listen=yes local.role=ebgp remote.address=10.69.1.254 .as=65001 template=as65533-ipv4

http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet NSE7 | Extreme Networks ENA
 
mducharme
Trainer
Trainer
Posts: 1034
Joined: Tue Jul 19, 2016 6:45 pm

Re: ROSv7 documentation/ config guides

Fri Jun 05, 2020 7:52 pm

I have peering up, but I can't seem to figure out how to advertise things. What is the equivalent of v6's "/routing bgp network" on v7?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6142
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROSv7 documentation/ config guides

Fri Jun 05, 2020 9:03 pm

There is no equivalent. If you did not specify output filter chain in the templae, then all routes from the routing table is being advertised.
If you specify output chain then by default chain blocks everything. You need to configure filters to accept prefixes you want to advertise from routing table.
 
dmayan
newbie
Posts: 26
Joined: Sun Nov 10, 2013 9:28 pm

Re: ROSv7 documentation/ config guides

Fri Jun 05, 2020 11:21 pm

At the moment there is none because configuration can and probably will change.

What exactly you were not able to set up?
Well, why not calling it ROS v7 ALFA... Beta is a bug squashing and polishment stage... New features and configurations are implemented in alfa.
 
mducharme
Trainer
Trainer
Posts: 1034
Joined: Tue Jul 19, 2016 6:45 pm

Re: ROSv7 documentation/ config guides

Sun Jun 07, 2020 1:24 am

There is no equivalent. If you did not specify output filter chain in the templae, then all routes from the routing table is being advertised.
If you specify output chain then by default chain blocks everything. You need to configure filters to accept prefixes you want to advertise from routing table.
Hello,

When I have address-families set in the template to ipv6, it looks like I am receiving IPv6 routes but not sending them. I did a packet capture and it looks like I am sending NLRI to the peer for the IPv4 routes I have in my routing table instead of the IPv6 ones. I do not have BGP enabled for address family ip, so I'm not sure why I would be sending IPv4 prefix info to the peer. It seems like a bug.

Also I am receiving default routes from the v6 peer but gateway is blank so they are marked invalid.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6142
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROSv7 documentation/ config guides

Mon Jun 08, 2020 4:36 pm

Some basic stuff to start with ROSv7 routing config:
https://help.mikrotik.com/docs/display/ ... g+Examples
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1895
Joined: Mon Jan 14, 2008 1:53 pm
Location: Over the Rainbow
Contact:

Re: ROSv7 documentation/ config guides

Tue Jun 09, 2020 3:28 am

Some basic stuff to start with ROSv7 routing config:
https://help.mikrotik.com/docs/display/ ... g+Examples
Thank you Maris
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet NSE7 | Extreme Networks ENA
 
mducharme
Trainer
Trainer
Posts: 1034
Joined: Tue Jul 19, 2016 6:45 pm

Re: ROSv7 documentation/ config guides

Tue Jun 09, 2020 4:02 am

Some basic stuff to start with ROSv7 routing config:
https://help.mikrotik.com/docs/display/ ... g+Examples
So with OSPF how does this work now? Redistribution used to create external type 5 LSAs, and if you added the network to advertise to the networks list as passive you would get a regular type 2 or 3 LSA. The article says that now we set up filters otherwise everything is advertised, but what LSA type is it advertised as? Does it advertise connected as type 2 or 3, but redistributed from OSPF as type 5? I'm not sure in the new version how to distinguish redistribution (type 5) from advertisements (type 2/3).

Also how do you do passive interface as the default? It used to be possible to add interface=all and set passive=yes. Does that still work to make passive the default?

Also where is OSPFv2 authentication - is it being removed from ROS 7? Since OSPFv3 does not have authentication, it doesn't bother me if you are removing it, but then we should plan on removing OSPFv2 authentication from our networks to prepare things for ROS 7.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1895
Joined: Mon Jan 14, 2008 1:53 pm
Location: Over the Rainbow
Contact:

Re: ROSv7 documentation/ config guides

Tue Jun 09, 2020 7:59 am


Also how do you do passive interface as the default? It used to be possible to add interface=all and set passive=yes. Does that still work to make passive the default?
I too want to know this. At first glance the new implementation seems like a step backwards from v6.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet NSE7 | Extreme Networks ENA
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6142
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: ROSv7 documentation/ config guides

Tue Jun 09, 2020 8:42 am

and if you added the network to advertise to the networks list as passive you would get a regular type 2 or 3 LSA
V7 is the same, if you add network it is advertised as type2 or 3 LSA

Passive and authentication parameters are there but not working at te moment, so it will not be a step back.

BTW we are open to suggestions on how to improve configuration while it is still possible.
 
mducharme
Trainer
Trainer
Posts: 1034
Joined: Tue Jul 19, 2016 6:45 pm

Re: ROSv7 documentation/ config guides

Tue Jun 09, 2020 8:53 pm

Passive and authentication parameters are there but not working at te moment, so it will not be a step back.
OK, but I'm not just talking about those - I am asking about the "all" option that we have in RouterOS 6. I use this all the time in OSPFv2 and OSPFv3 to make interfaces passive by default. Adding "all" as passive is much safer on certain routers, where there could be a big security issue if somebody forgets to do so for an interface and you could suddenly have an adjacency forming with a customer's network. It seems to me with this new method that there will be no "all" option and we will have to remember for each network or interface added into the "interfaces" tab to check the "passive" box, and this is very dangerous because you end up trusting people to always remember to do that and never make a mistake. There has to be a "passive default" option somewhere to reverse the behavior so that you have to check something to make an interface not passive. I also want basically everything to be type 2/3 LSAs and not type 5, so simply not adding interfaces in cases where I don't want adjacency to be formed is not a good solution because I will be stuck with many unwanted type 5 LSAs.

Can I suggest that instead of making passive a check box you make it a drop down with three options: "Use instance default", "Yes" or "No". "Use instance default" would be the default setting obviously. Then in the OSPF instance, add a new check box for "passive default". That should remove any security holes.

Secondarily it would also be nice to still have the ability somehow to advertise all interfaces in OSPFv3 by default like we can right now in RouterOS v6 with the "all" option, but losing this capability will not bother me as much as the "passive" setting. Perhaps you can add a checkbox into the instance "advertise all interfaces (OSPFv3 only)"? You might be able to do the same "advertise all interfaces" thing with OSPFv2 to add a dynamic 0.0.0.0/0, then it would not have to be OSPFv3 only.
 
mafiosa
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Fri Dec 09, 2016 8:10 pm

Re: ROSv7 documentation/ config guides

Fri Jul 03, 2020 9:22 pm

I cannot get ospf working! Routes learnt on v7 beta8 router is marked as invalid. Is there any solution?

Who is online

Users browsing this forum: No registered users and 14 guests