Community discussions

MikroTik App
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 664
Joined: Thu Dec 11, 2014 8:53 am

v7.1beta1 [development] is released!

Tue Jul 21, 2020 2:52 pm

RouterOS version 7.1beta1 has been released in public "development" channel!

What's new in 7.1beta1 (2020-Jul-21 08:58):

!) added FastTrack and NAT hardware offloading support for CRS317-1G-16S+RM;
!) ported features and fixes introduced in v6.47.1;
*) route - added rpki-check;
*) route - bgp improvements;
*) route - do not allow modifying/deleting "main" table;
*) route - fixed incorrectly interpreted prefix states received from RTR;
*) route - fixed IPv6 ECMP connected routes;
*) route - fixed IPv6 policy routing;
*) route - routing rules improvements;
*) wireless - fixed wireless performance for 802.11b/g/n and 802.11a/n interfaces on non-ARM architecture devices;
*) other minor fixes and improvements;

P.S: version numbering has been updated to v7.1beta due to internal workflow modifications. This is just the next beta version after 7.0beta8

All released RouterOS v7 changelogs are available here:
https://mikrotik.com/download/changelog ... lease-tree

How to report RouterOS v7 bugs:
viewtopic.php?f=1&t=152006
 
mbovenka
Member Candidate
Member Candidate
Posts: 215
Joined: Mon Oct 14, 2019 10:14 am

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 3:18 pm

!) added FastTrack and NAT hardware offloading support for CRS317-1G-16S+RM;

Holy...<beep>. When is this coming to other CRS3xx switches? The CRS305 in particular? Please pretty please?
 
mkx
Forum Guru
Forum Guru
Posts: 4976
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 3:28 pm

When is this coming to other CRS3xx switches? The CRS305 in particular?

I hope ... but won't hold my breath. CRS317 is built around 98DX8216 SoC while most of the rest are built around 98DX32xx ... not sure if 98DX32xx can do the same magic as 98DX82xx ... CRS309 and CRS312 might support it soon (they both have 98DX82xx as well).
BR,
Metod
 
User avatar
floaty
Member Candidate
Member Candidate
Posts: 253
Joined: Sat Oct 20, 2018 1:24 am
Location: 52°08'32.34"N 14°39'05.0"E

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 3:32 pm

.
"ip route" context is still a CLI-only domain
.
bumms.PNG
You do not have the required permissions to view the files attached to this post.
~~
We know what happens to people who stay in the middle of the road. They get run over.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 3:44 pm

"ip route" context is still a CLI-only domain
For me it is possible to manage routes from winbox, however:
- whenever I change something in a route table entry it disappears from view
- when I go to another TAB on the window and back to the overview, the modified route again appears
- when a status changes on a route, e.g. a route with ping check goes to available/not it is not updated on an open route overview.

It looks like there is some difficulty with the access from the dynamic contents of the route table from winbox.
(this was the same in earlier v7 betas that I tried!)
 
notToNew
Member Candidate
Member Candidate
Posts: 168
Joined: Fri Feb 19, 2016 3:15 pm

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 4:01 pm

Updated HAP AC lite, great wireless performance. Hope for fast progress!
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
 
User avatar
floaty
Member Candidate
Member Candidate
Posts: 253
Joined: Sat Oct 20, 2018 1:24 am
Location: 52°08'32.34"N 14°39'05.0"E

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 4:08 pm

.
a ball plus : ) vrf-menu has joined ip-context in winbox
.
vrf-menu.png
You do not have the required permissions to view the files attached to this post.
~~
We know what happens to people who stay in the middle of the road. They get run over.
 
doush
Long time Member
Long time Member
Posts: 640
Joined: Thu Jun 04, 2009 3:11 pm

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 4:46 pm

NAT Hardware Offloading !
Great news. When is this coming to the actual router products like CCR series or new router products ?
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Posts: 101
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 5:09 pm

NAT Hardware Offloading !
Great news. When is this coming to the actual router products like CCR series or new router products ?
Same Question from my side!
MTCNA | MTCRE | MTCINE | MTCTCE

Mikrotik Consultant - Specialized in ISP OPERATIONS | ROUTING | QOS | FIREWALL | MPLS | SCRIPTING | IPv6
 
mbovenka
Member Candidate
Member Candidate
Posts: 215
Joined: Mon Oct 14, 2019 10:14 am

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 5:18 pm

NAT Hardware Offloading !
Great news. When is this coming to the actual router products like CCR series or new router products ?

Not going to happen. They don't have the hardware for it, up to and including the CCR2004. Maybe, just maybe, the CCR2016 will be an ARM64/PresteraDX combo, but I wouldn't count on it (would be great, though...).
 
mbovenka
Member Candidate
Member Candidate
Posts: 215
Joined: Mon Oct 14, 2019 10:14 am

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 5:25 pm

The USB port of my CCR1036-8G-2S+ now works again 👍
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Posts: 101
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 5:30 pm

The USB port of my CCR1036-8G-2S+ now works again
Great to Hear That :) :) :) :)
MTCNA | MTCRE | MTCINE | MTCTCE

Mikrotik Consultant - Specialized in ISP OPERATIONS | ROUTING | QOS | FIREWALL | MPLS | SCRIPTING | IPv6
 
sfrode
just joined
Posts: 8
Joined: Thu Apr 16, 2020 12:12 am
Location: Oslo, Norway
Contact:

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 5:58 pm

ROS v7.1beta1 still have trouble with IPv6 BGP as described here: viewtopic.php?f=1&t=162424&p=800209 :(
 
rpingar
Long time Member
Long time Member
Posts: 556
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 6:12 pm

bgp keep alive not sent or broken to the second bgp session estabilished.
on both essions we check rpki.
On 7b8 the two session were working fine, now the second goes down each 180s for hold time expire on remote (ccr with 6.47.1).

Also when we clear the session the main routing rable is not able to clean, or it is not able to clean in a reasonable time.

regards
Ros
 
Paternot
Forum Veteran
Forum Veteran
Posts: 779
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 8:27 pm

Great news! Can't wait to see RoS 7.X stable. Maybe 7.5? :D
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 224
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 8:28 pm

Let GPT3 write the rest of the code to reach 7.1 production, and the day after UltimateROS.
 
csalcedo
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Fri Jan 22, 2016 8:09 pm
Location: Santiago Chile

missing routeros-smips-7.1beta1.npk

Tue Jul 21, 2020 10:36 pm

tried to install from packages menu to update but I get the following error:
missing routeros-smips-7.1beta1.npk
Unit is hap lite (for testing)
not sufficient space to download and move to files (manual mode)
 
EKSEISIA
just joined
Posts: 2
Joined: Tue Jul 21, 2020 11:00 pm

Re: v7.1beta1 [development] is released!

Tue Jul 21, 2020 11:15 pm

Hi.
After upgrading RBD53G-5HacD2HnD-TC&EG12-EA to new v7.1 beta, router shut down many times, because for no apparent reason CPU nominal frequency automatically set to = auto.
When change it to normal frequency = 716, all start work correctly after several restarts. I had to flash netinstall, so that the router would come to life. But in winbox still trying upgrade to 6.47.1 version. LTE modem also work not correctly. wAP ac LTE6 kit working on the same project with the same sim card give more speed with only 2 bands.
After the firmware v7.1beta1 it shows all the time - internet limited access.

We use sim card Bite operator - Latvia.
Thank you,
Alex
 
notToNew
Member Candidate
Member Candidate
Posts: 168
Joined: Fri Feb 19, 2016 3:15 pm

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 3:28 am

Reboot loop on RBSXTR with LTE6 modem.
Reproducible, also tried netinstall.
Could not generate supout, did not find an autosupout.
Log told me: Device rebootet after kernel panic.
Uptime 33seconds, then the device rebooted.

Edit: I tried to overcome the boot loop by disabling the lte device (which was just a guess) , which did not work. It rebooted anyway and after reboot, the lte device was active again.
I upgraded an other device earlier (hap ap lite) which still works very good!
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
 
rpingar
Long time Member
Long time Member
Posts: 556
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 9:46 am

found a main routing table bgp related bug:
- if you have a static invalid route about a prefix
- then you learn the same prefix from a bgp peer
- then the bgp session goes down
- routeros don't clear the bgp route learned, leaving it as invalid

regards
Ros
 
mafiosa
Frequent Visitor
Frequent Visitor
Posts: 88
Joined: Fri Dec 09, 2016 8:10 pm

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 9:47 am

is ospf working properly now? can anyone confirm?
 
hturkan
just joined
Posts: 10
Joined: Mon Dec 19, 2016 9:38 am

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 10:53 am

hi, how many nat rules can we add with hardware offload? Is there a limitation?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6142
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 10:58 am

CRS317 supports up to 4096 NAT entries. To clarify it is not about how many rules you have, but how many connections can be offloaded.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: missing routeros-smips-7.1beta1.npk

Wed Jul 22, 2020 11:47 am

tried to install from packages menu to update but I get the following error:
missing routeros-smips-7.1beta1.npk
Unit is hap lite (for testing)
not sufficient space to download and move to files (manual mode)
These devices already have problems updating RouterOS v6 from the device itself... There is simply not enough space on the flash and not enough RAM to upload a second version so it can update it in-place.
(other devices with 16MB flash but with 256MB RAM usually have no problem because they can upload the new version in RAM for installation)

Given that v7 will of course grow, and that it now is all in a single package so you can no longer trim down the size by using separate packages and installing only what you need, I guess these devices in the long run will not be able to run v7 realistically...
For now of course you can use netinstall to install a v7 beta, but likely when the next beta appears you again face the same issue and have to use netinstall every time you want to update.
 
krisjanisj
MikroTik Support
MikroTik Support
Posts: 75
Joined: Wed Feb 20, 2019 2:53 pm
Contact:

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 12:06 pm

@notToNew - Please create a support ticket at support@mikrotik.com with all the information about this issue so we can troubleshoot it.
 
sup5
Member
Member
Posts: 340
Joined: Sat Jul 10, 2010 12:37 am

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 1:26 pm

How is HW-offloaded NAT configured?
Does it kick in automatically?
How do I notice that the 4096 connection limit is reached?
Is it shown, which connections aren't HW-offloaded anymore?
 
mafiosa
Frequent Visitor
Frequent Visitor
Posts: 88
Joined: Fri Dec 09, 2016 8:10 pm

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 4:37 pm

routes learnt from ibgp becomes invalid.
[admin@MikroTik] /routing/bgp/connection> add remote.address=2a0f:9400:8017:32::2 local.address=2a0f:9400:8017:32::1 local.role=ibgp-rr template=ipv6-ibg connect=yes listen=yes
[admin@MikroTik] /routing/bgp/connection> add remote.address=2a0f:9400:8017:20::2 local.address=2a0f:9400:8017:20::1 local.role=ibgp-rr template=ipv6-ibg connect=yes listen=yes
[admin@MikroTik] /routing/bgp/connection> ..
[admin@MikroTik] /routing/bgp> peer-cache/
[admin@MikroTik] /routing/bgp/peer-cache> print
Flags: E - established
0 E remote.address=192.168.168.46 .as=213196 .id=192.168.40.2 .refused-cap-opt=no .capabilities=mp,rr,as4 .messages=161 .bytes=3179 .eor=""
local.address=192.168.168.45 .as=213326 .id=10.28.115.18 .capabilities=mp,rr,gr,as4 .messages=148 .bytes=3106 .eor=""
output.procid=22
input.procid=22 ebgp
hold-time=3m keepalive-time=1m

1 E remote.address=192.168.168.2 .as=213326 .id=192.168.254.2 .refused-cap-opt=no .capabilities=mp,rr,as4 .messages=23 .bytes=467 .eor=""
local.role=ibgp-rr .address=192.168.168.1 .as=213326 .id=10.28.115.18 .capabilities=mp,rr,gr,as4 .messages=24 .bytes=638 .eor=""
output.procid=24
input.procid=24 ibgp
multihop=yes hold-time=3m keepalive-time=1m

2 E remote.address=192.168.168.22 .as=213326 .id=192.168.254.10 .refused-cap-opt=no .capabilities=mp,rr,as4 .messages=22 .bytes=476 .eor=""
local.role=ibgp-rr .address=192.168.168.21 .as=213326 .id=10.28.115.18 .capabilities=mp,rr,gr,as4 .messages=22 .bytes=600 .eor=""
output.procid=25
input.procid=25 ibgp
multihop=yes hold-time=3m keepalive-time=1m

3 E remote.address=2a0f:9400:8017:69::2 .as=213326 .id=115.187.62.14 .refused-cap-opt=no .capabilities=mp,rr,as4 .afi=ipv6 .messages=16 .bytes=390 .eor=""
local.role=ibgp-rr .address=2a0f:9400:8017:69::1 .as=213326 .id=10.28.115.18 .capabilities=mp,rr,gr,as4 .afi=ipv6 .messages=16 .bytes=550 .eor=""
output.procid=26
input.procid=26 ibgp
multihop=yes hold-time=3m keepalive-time=1m

4 E remote.address=2a0f:9400:8017:32::2 .as=213326 .id=192.168.254.2 .refused-cap-opt=no .capabilities=mp,rr,as4 .afi=ipv6 .messages=11 .bytes=288 .eor=""
local.role=ibgp-rr .address=2a0f:9400:8017:32::1 .as=213326 .id=10.28.115.18 .capabilities=mp,rr,gr,as4 .afi=ipv6 .messages=11 .bytes=411 .eor=""
output.procid=27
input.procid=27 ibgp
multihop=yes hold-time=3m keepalive-time=1m
Routes learnt from ibgp are getting marked as invalid.
You do not have the required permissions to view the files attached to this post.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6142
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 4:51 pm

Show output of
/routing/route/print detail
 
mafiosa
Frequent Visitor
Frequent Visitor
Posts: 88
Joined: Fri Dec 09, 2016 8:10 pm

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 5:07 pm

Show output of
/routing/route/print detail
[admin@MikroTik] > /routing/route/print detail
Flags: X - disabled, I - inactive, F - filtered, U - unreachable, A - active; c - connect, s - static, r - rip, b - bgp, o - ospf, d - dhcp, v - vpn, m - modem, a - ldp-address, l - ldp-mapping; + - ecmp
As afi=ip4 contribution=active dst-address=0.0.0.0/0 routing-table=main pref-src="" gateway=10.28.115.17 immediate-gw=10.28.115.17%WAN check-gateway=ping distance=1 scope=30 target-scope=10 belongs-to="Static route"
debug.fwp-ptr=0x20202190

Ac afi=ip4 contribution=active dst-address=10.28.115.16/30 routing-table=main gateway=WAN immediate-gw=WAN distance=0 scope=10 belongs-to="Connected route" local-address=10.28.115.18%WAN
debug.fwp-ptr=0x202020C8

Ab afi=ip4 contribution=active dst-address=172.22.146.0/25 routing-table=main gateway=192.168.168.2 immediate-gw=192.168.168.2%ether10 distance=200 scope=40 target-scope=30 belongs-to="BGP IP routes from 192.168.168.2"
bgp.peer-cache-id=*B000005 .local-pref=100 .atomic-aggregate=yes .origin=igp
debug.fwp-ptr=0x202024B0

Ac afi=ip4 contribution=active dst-address=172.22.146.0/27 routing-table=main gateway=ether9 immediate-gw=ether9 distance=0 scope=10 belongs-to="Connected route" local-address=172.22.146.1%ether9
debug.fwp-ptr=0x2020212C

Ac afi=ip4 contribution=active dst-address=172.22.146.32/27 routing-table=main gateway=LAN immediate-gw=LAN distance=0 scope=10 belongs-to="Connected route" local-address=172.22.146.33%LAN
debug.fwp-ptr=0x202021F4

As afi=ip4 contribution=active dst-address=172.22.146.64/26 routing-table=main pref-src="" gateway=192.168.168.2 immediate-gw=192.168.168.2%ether10 distance=1 scope=30 target-scope=10 belongs-to="Static route"
debug.fwp-ptr=0x202025DC

Ab afi=ip4 contribution=active dst-address=192.168.30.0/24 routing-table=main gateway=192.168.168.46 immediate-gw=Peer-Burdwan distance=20 scope=40 target-scope=10 belongs-to="BGP IP routes from 192.168.168.46"
bgp.peer-cache-id=*B000003 .as-path="213196" .atomic-aggregate=yes .origin=igp
debug.fwp-ptr=0x20202640

Ab afi=ip4 contribution=active dst-address=192.168.50.0/24 routing-table=main gateway=192.168.168.46 immediate-gw=Peer-Burdwan distance=20 scope=40 target-scope=10 belongs-to="BGP IP routes from 192.168.168.46"
bgp.peer-cache-id=*B000003 .as-path="213196" .atomic-aggregate=yes .origin=igp
debug.fwp-ptr=0x20202640

Ab afi=ip4 contribution=active dst-address=192.168.108.0/24 routing-table=main gateway=192.168.168.22 immediate-gw=Dumdum-PoP distance=200 scope=40 target-scope=30 belongs-to="BGP IP routes from 192.168.168.22"
bgp.peer-cache-id=*B000009 .local-pref=100 .atomic-aggregate=yes .origin=igp
debug.fwp-ptr=0x20202514

Ac afi=ip4 contribution=active dst-address=192.168.168.0/30 routing-table=main gateway=ether10 immediate-gw=ether10 distance=0 scope=10 belongs-to="Connected route" local-address=192.168.168.1%ether10
debug.fwp-ptr=0x20202064

Ac afi=ip4 contribution=active dst-address=192.168.168.4/30 routing-table=main gateway=Madhyamgram-PoP immediate-gw=Madhyamgram-PoP distance=0 scope=10 belongs-to="Connected route" local-address=192.168.168.5%Madhyamgram-PoP
debug.fwp-ptr=0x202023E8

Ac afi=ip4 contribution=active dst-address=192.168.168.20/30 routing-table=main gateway=Dumdum-PoP immediate-gw=Dumdum-PoP distance=0 scope=10 belongs-to="Connected route" local-address=192.168.168.21%Dumdum-PoP
debug.fwp-ptr=0x20202384

Ac afi=ip4 contribution=active dst-address=192.168.168.44/30 routing-table=main gateway=Peer-Burdwan immediate-gw=Peer-Burdwan distance=0 scope=10 belongs-to="Connected route" local-address=192.168.168.45%Peer-Burdwan
debug.fwp-ptr=0x2020244C

Ac afi=ip4 contribution=active dst-address=192.168.254.1 routing-table=main gateway=loopback immediate-gw=loopback distance=0 scope=10 belongs-to="Connected route" local-address=192.168.254.1%loopback
debug.fwp-ptr=0x20202000

Ac afi=ip6 contribution=active dst-address=2af:9400:8017:20::/64 routing-table=main gateway=Dumdum-PoP immediate-gw=Dumdum-PoP distance=0 scope=10 belongs-to="Connected route" local-address=2af:9400:8017:20::1%Dumdum-PoP
debug.fwp-ptr=0x20202384

Ac afi=ip6 contribution=active dst-address=2af:9400:8017:44::/64 routing-table=main gateway=Peer-Burdwan immediate-gw=Peer-Burdwan distance=0 scope=10 belongs-to="Connected route" local-address=2af:9400:8017:44::1%Peer-Burdwan
debug.fwp-ptr=0x2020244C

Ac afi=ip6 contribution=active dst-address=2a0e:46c5:f012::/64 routing-table=main gateway=UL-Redpanda immediate-gw=UL-Redpanda distance=0 scope=10 belongs-to="Connected route" local-address=2a0e:46c5:f012::2%UL-Redpanda
debug.fwp-ptr=0x202026A4

Ib afi=ip6 contribution=unreachable dst-address=2a0e:b107:9e4::/46 routing-table=main gateway=:: distance=200 scope=40 target-scope=30 belongs-to="BGP IP6 routes from 2a0f:9400:8017:32::2"
bgp.peer-cache-id=*B00000C .aggregator="213326:192.168.254.2" .local-pref=100 .atomic-aggregate=yes .origin=incomplete
debug.fwp-ptr=0x20202578

As afi=ip6 contribution=active dst-address=2a0e:b107:9ec::/46 routing-table=main pref-src="" gateway=blackhole immediate-gw="" distance=1 scope=250 target-scope=10 belongs-to="Static route"
debug.fwp-ptr=0x20202708

Ib afi=ip6 contribution=unreachable dst-address=2a0e:b107:b00::/46 routing-table=main gateway=:: distance=200 scope=40 target-scope=30 belongs-to="BGP IP6 routes from 2a0f:9400:8017:69::2"
bgp.peer-cache-id=*B00000A .local-pref=100 .atomic-aggregate=yes .origin=igp
debug.fwp-ptr=0x20202578

Ib afi=ip6 contribution=unreachable dst-address=2a0e:b107:b04::/46 routing-table=main gateway=:: distance=200 scope=40 target-scope=30 belongs-to="BGP IP6 routes from 2a0f:9400:8017:69::2"
bgp.peer-cache-id=*B00000A .local-pref=100 .atomic-aggregate=yes .origin=igp
debug.fwp-ptr=0x20202578

Ib afi=ip6 contribution=unreachable dst-address=2a0e:b107:b08::/46 routing-table=main gateway=:: distance=200 scope=40 target-scope=30 belongs-to="BGP IP6 routes from 2a0f:9400:8017:69::2"
bgp.peer-cache-id=*B00000A .local-pref=100 .atomic-aggregate=yes .origin=igp
debug.fwp-ptr=0x20202578

Ib afi=ip6 contribution=unreachable dst-address=2a0e:b107:b0c::/46 routing-table=main gateway=:: distance=200 scope=40 target-scope=30 belongs-to="BGP IP6 routes from 2a0f:9400:8017:69::2"
bgp.peer-cache-id=*B00000A .local-pref=100 .atomic-aggregate=yes .origin=igp
debug.fwp-ptr=0x20202578

As afi=ip6 contribution=active dst-address=2a0f:9400:8017::/48 routing-table=main pref-src="" gateway=blackhole immediate-gw="" distance=1 scope=250 target-scope=10 belongs-to="Static route"
debug.fwp-ptr=0x20202708

Ac afi=ip6 contribution=active dst-address=2a0f:9400:8017::/64 routing-table=main gateway=loopback immediate-gw=loopback distance=0 scope=10 belongs-to="Connected route" local-address=2a0f:9400:8017::1%loopback
debug.fwp-ptr=0x20202000

Ac afi=ip6 contribution=active dst-address=2a0f:9400:8017:32::/64 routing-table=main gateway=ether10 immediate-gw=ether10 distance=0 scope=10 belongs-to="Connected route" local-address=2a0f:9400:8017:32::1%ether10
debug.fwp-ptr=0x20202064

Ac afi=ip6 contribution=active dst-address=2a0f:9400:8017:69::/64 routing-table=main gateway=Madhyamgram-PoP immediate-gw=Madhyamgram-PoP distance=0 scope=10 belongs-to="Connected route" local-address=2a0f:9400:8017:69::1%Madhyamgram-PoP
debug.fwp-ptr=0x202023E8

Ac afi=ip6 contribution=active dst-address=fe80::%ether1/64 routing-table=main gateway=ether1 immediate-gw=ether1 distance=0 scope=10 belongs-to="Connected route" local-address=fe80::6e3b:6bff:fe93:b153%ether1
debug.fwp-ptr=0x20202320

Ac afi=ip6 contribution=active dst-address=fe80::%sfp1/64 routing-table=main gateway=sfp1 immediate-gw=sfp1 distance=0 scope=10 belongs-to="Connected route" local-address=fe80::6e3b:6bff:fe93:b158%sfp1
debug.fwp-ptr=0x202022BC

Ac afi=ip6 contribution=active dst-address=fe80::%ether8/64 routing-table=main gateway=ether8 immediate-gw=ether8 distance=0 scope=10 belongs-to="Connected route" local-address=fe80::6e3b:6bff:fe93:b15b%ether8
debug.fwp-ptr=0x20202258

Ac afi=ip6 contribution=active dst-address=fe80::%ether9/64 routing-table=main gateway=ether9 immediate-gw=ether9 distance=0 scope=10 belongs-to="Connected route" local-address=fe80::6e3b:6bff:fe93:b15c%ether9
debug.fwp-ptr=0x2020212C

Ac afi=ip6 contribution=active dst-address=fe80::%ether10/64 routing-table=main gateway=ether10 immediate-gw=ether10 distance=0 scope=10 belongs-to="Connected route" local-address=fe80::6e3b:6bff:fe93:b15d%ether10
debug.fwp-ptr=0x20202064

Ac afi=ip6 contribution=active dst-address=fe80::%WAN/64 routing-table=main gateway=WAN immediate-gw=WAN distance=0 scope=10 belongs-to="Connected route" local-address=fe80::6e3b:6bff:fe69:6969%WAN
debug.fwp-ptr=0x202020C8

Ac afi=ip6 contribution=active dst-address=fe80::%loopback/64 routing-table=main gateway=loopback immediate-gw=loopback distance=0 scope=10 belongs-to="Connected route" local-address=fe80::28bc:deff:fe69:55ec%loopback
debug.fwp-ptr=0x20202000

Ac afi=ip6 contribution=active dst-address=fe80::%LAN/64 routing-table=main gateway=LAN immediate-gw=LAN distance=0 scope=10 belongs-to="Connected route" local-address=fe80::6e3b:6bff:fe93:b155%LAN
debug.fwp-ptr=0x202021F4

Ac+ afi=ip6 contribution=active dst-address=fe80::%Dumdum-PoP/64 routing-table=main gateway=Dumdum-PoP immediate-gw=Dumdum-PoP distance=0 scope=10 belongs-to="Connected route" local-address=fe80::5efe:a1c:7312%Dumdum-PoP
debug.fwp-ptr=0x20202384

Ac+ afi=ip6 contribution=active dst-address=fe80::%Dumdum-PoP/64 routing-table=main gateway=Dumdum-PoP immediate-gw=Dumdum-PoP distance=0 scope=10 belongs-to="Connected route" local-address=fe80::2:a0e:5ee8%Dumdum-PoP
debug.fwp-ptr=0x20202384

Ac+ afi=ip6 contribution=active dst-address=fe80::%Madhyamgram-PoP/64 routing-table=main gateway=Madhyamgram-PoP immediate-gw=Madhyamgram-PoP distance=0 scope=10 belongs-to="Connected route" local-address=fe80::5efe:a1c:7312%Madhyamgram-PoP
debug.fwp-ptr=0x202023E8

Ac+ afi=ip6 contribution=active dst-address=fe80::%Madhyamgram-PoP/64 routing-table=main gateway=Madhyamgram-PoP immediate-gw=Madhyamgram-PoP distance=0 scope=10 belongs-to="Connected route" local-address=fe80::2:a0e:606d%Madhyamgram-PoP
debug.fwp-ptr=0x202023E8

Ac+ afi=ip6 contribution=active dst-address=fe80::%Peer-Burdwan/64 routing-table=main gateway=Peer-Burdwan immediate-gw=Peer-Burdwan distance=0 scope=10 belongs-to="Connected route" local-address=fe80::5efe:a1c:7312%Peer-Burdwan
debug.fwp-ptr=0x2020244C

Ac+ afi=ip6 contribution=active dst-address=fe80::%Peer-Burdwan/64 routing-table=main gateway=Peer-Burdwan immediate-gw=Peer-Burdwan distance=0 scope=10 belongs-to="Connected route" local-address=fe80::2:6702:8462%Peer-Burdwan
debug.fwp-ptr=0x2020244C

Ac+ afi=ip6 contribution=active dst-address=fe80::%UL-Redpanda/64 routing-table=main gateway=UL-Redpanda immediate-gw=UL-Redpanda distance=0 scope=10 belongs-to="Connected route" local-address=fe80::5efe:a1c:7312%UL-Redpanda
debug.fwp-ptr=0x202026A4

Ac+ afi=ip6 contribution=active dst-address=fe80::%UL-Redpanda/64 routing-table=main gateway=UL-Redpanda immediate-gw=UL-Redpanda distance=0 scope=10 belongs-to="Connected route" local-address=fe80::3:a1c:7312%UL-Redpanda
debug.fwp-ptr=0x202026A4

A afi=link contribution=active dst-address=ether1 routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=sfp1 routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=ether8 routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=ether9 routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=ether10 routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=WAN routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=loopback routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=LAN routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=Dumdum-PoP routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=Madhyamgram-PoP routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=Peer-Burdwan routing-table=main distance=0 belongs-to="Interface"

A afi=link contribution=active dst-address=UL-Redpanda routing-table=main distance=0 belongs-to="Interface"
 
buset1974
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Wed Sep 13, 2006 12:12 pm
Location: Jakarta

Re: v7.1beta1 [development] is released!

Wed Jul 22, 2020 5:20 pm

hgh cpu show in profile.(CCR1009)
so many unclassified 100% cpu

[admin@MikroTik-Lab-01] > /tool/profile freeze-frame-interval=1 cpu=all
Columns: NAME, CPU, USAGE
NAME C USAGE
unclassified 0 100%
cpu0 100%
console 1 0%
networking 1 0.5%
winbox 1 0%
management 1 1%
telnet 1 0%
unclassified 1 98.5%
cpu1 100%
management 2 0%
unclassified 2 100%
cpu2 100%
winbox 3 0%
management 3 0%
unclassified 3 100%
cpu3 100%
networking 4 0%
unclassified 4 100%
cpu4 100%
console 5 0.5%
management 5 0.5%
unclassified 5 99%
cpu5 100%
management 6 0%
unclassified 6 100%
cpu6 100%
networking 7 0%
profiling 7 0%
unclassified 7 100%
cpu7 100%
networking 8 0%
unclassified 8 100%
cpu8 100%
 
santyx32
Member Candidate
Member Candidate
Posts: 150
Joined: Fri Oct 25, 2019 2:17 am

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 7:26 am

IDK why Mikrotik haven't implemented fq_codel or CAKE qdiscs since they're already present in Linux 5.6, leave the classic mangle based traffic classification and prioritization for the enterprise but home users just need a simpler way to get rid of the bufferbloat caused by ISP misconfiguration. Even if you get to create lots of mangle rules for each kind of traffic you have inside your home network and create queue trees, PCQ/SFQ is a dumb shaper (round robbin algorithm as a fancier term) that adds extra latency + packet loss during load.
[https://drive.google.com/drive/folders/ ... sp=sharing] 11/10/2020 OpenWRT build download for hAP ac2[/url], don't forget to backup ROS license

I'm the guy known as geminis3
 
sdroy
just joined
Posts: 6
Joined: Tue Dec 13, 2016 5:40 am
Location: Dhaka, Bangladesh
Contact:

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 8:57 am

Can not able to call /routing/filter/rule as output.filter in bgp template...
Note: In attachment image it is manually written not auto-complete by pressing "Tab"
You do not have the required permissions to view the files attached to this post.
Last edited by sdroy on Thu Jul 23, 2020 9:25 am, edited 2 times in total.
Thanks & Regards,
Shuvodip Roy
Email: sdroy@live.com
 
sdroy
just joined
Posts: 6
Joined: Tue Dec 13, 2016 5:40 am
Location: Dhaka, Bangladesh
Contact:

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 9:11 am

RPKI check is working fine but while filtering it block valid Routes also..
You do not have the required permissions to view the files attached to this post.
Thanks & Regards,
Shuvodip Roy
Email: sdroy@live.com
 
rpingar
Long time Member
Long time Member
Posts: 556
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 9:40 am

Can not able to call /routing/filter/rule as output.filter in bgp template...
Note: In attachment image it is manually written not auto-complete by pressing "Tab"
Hello,
Output requires selection rules:

/routing filter rule
add action=accept chain=xx

/routing filter select-rule
add chain=xx-select do-where=xx

/routing bgp template
set 0 output.filter=xx-select

regards
Ros
 
nostromog
Member Candidate
Member Candidate
Posts: 202
Joined: Wed Jul 18, 2018 3:39 pm

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 9:50 am

Is the problem about ignoring MTU settings still happening in 7.1beta? ( viewtopic.php?t=158457 )
 
rpingar
Long time Member
Long time Member
Posts: 556
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 9:58 am

Is the problem about ignoring MTU settings still happening in 7.1beta? ( viewtopic.php?t=158457 )
no, jumbo frame is working fine at least on mellanox board.

refards
ros
 
sdroy
just joined
Posts: 6
Joined: Tue Dec 13, 2016 5:40 am
Location: Dhaka, Bangladesh
Contact:

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 10:13 am

Can not able to call /routing/filter/rule as output.filter in bgp template...
Note: In attachment image it is manually written not auto-complete by pressing "Tab"
Hello,
Output requires selection rules:

/routing filter rule
add action=accept chain=xx

/routing filter select-rule
add chain=xx-select do-where=xx

/routing bgp template
set 0 output.filter=xx-select

regards
Ros
Thanks for sharing the information. Now RPKI filtering remains....
Thanks & Regards,
Shuvodip Roy
Email: sdroy@live.com
 
anuser
Member
Member
Posts: 489
Joined: Sat Nov 29, 2014 7:27 pm

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 1:37 pm

*) wireless - fixed wireless performance for 802.11b/g/n and 802.11a/n interfaces on non-ARM architecture devices;
1. Will this be backported to RouterOS 6.x?
2. Only b/g/n and a/n, but not ac?
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 664
Joined: Thu Dec 11, 2014 8:53 am

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 1:58 pm

The specific issue was with version 7 only. If you have issues with v6, please feel free to open a ticket in support system.
 
JanZorz
just joined
Posts: 16
Joined: Fri Jan 07, 2011 1:42 pm

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 6:32 pm

Tried to install .iso image into KVM on Proxmox, but after install it reboots and is stuck at "Booting from hard disk..."

Same procedure works fine on the same KVM setup with 6.47.1... any idea?

Cheers, Jan
 
User avatar
Anastasia
newbie
Posts: 45
Joined: Wed Oct 28, 2015 7:12 pm

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 8:12 pm

I can install version 7 on my device or it cannot be done because low-level license?
Device Model: 951Ui-2HnD
Architecture: mipsbe
License level: 4
 
gangster123
just joined
Posts: 3
Joined: Sat Jun 13, 2020 5:05 am

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 8:34 pm

ERROR: missing lora-7.1beta1-arm.npk

attempting on hAP ac2 from 6.48b12 to 7.1b1 yields above error msg.

edit:

i can go back to 6.47.1 but still can't go to 7.1. returned to 6.48 no problem, but 7.1 still won't download beyond the error msg. everything else is working normally/great! any ideas on what prevents the upgrade? thanks in advance for any help.
Last edited by gangster123 on Thu Jul 23, 2020 10:05 pm, edited 1 time in total.
 
RyperX
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Thu May 21, 2015 11:14 am

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 9:05 pm

Short question, anybody tested it on an rb2011?
I would like the openvpn udp feature but my router is my main device at home. I dont use anything on special features
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 9:18 pm

The RB2011 still supports partitioning. So partition it into 2 partitions, copy your current config to second partition, and update it.
When you are not happy, activate the 2nd partition and reboot and you will have the old version.
When it fails to boot or you powercycle it halfway through the boot, it will switch partitions automatically.
 
RyperX
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Thu May 21, 2015 11:14 am

Re: v7.1beta1 [development] is released!

Thu Jul 23, 2020 11:35 pm

The RB2011 still supports partitioning. So partition it into 2 partitions, copy your current config to second partition, and update it.
When you are not happy, activate the 2nd partition and reboot and you will have the old version.
When it fails to boot or you powercycle it halfway through the boot, it will switch partitions automatically.
Thanks for tipp. At the moment it runs fine without any error.
UDP with OpenVPN works also.
 
npeca75
newbie
Posts: 29
Joined: Thu Aug 03, 2017 3:12 pm

Re: v7.1beta1 [development] is released!

Fri Jul 24, 2020 2:37 am

RB760igs
tried to upgrade from 6.47.1

wooow, RB is dead
only Netinstall could help

shame
 
User avatar
cbrown
Trainer
Trainer
Posts: 1842
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

Re: v7.1beta1 [development] is released!

Fri Jul 24, 2020 2:47 am

RB760igs
tried to upgrade from 6.47.1

wooow, RB is dead
only Netinstall could help

shame
Same here with a 3011. I thought maybe it was because I had two partitions so I netinstalled back to 6.47.1 repartitioned back to a single partition, upgraded my firmware to be sure then tried the upgrade to 7.1beta1 again. Still stuck on “starting services”. Tried netinstalling straight to 7.1beta1 and still stuck on “starting services”.
C.Brown

cbrown[at]cbrown.co
Telegram: @chris4brown
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179
 
KOK
just joined
Posts: 14
Joined: Fri Oct 31, 2014 9:40 pm

Re: v7.1beta1 [development] is released!

Fri Jul 24, 2020 6:18 am

Tried to install .iso image into KVM on Proxmox, but after install it reboots and is stuck at "Booting from hard disk..."

Same procedure works fine on the same KVM setup with 6.47.1... any idea?

Cheers, Jan
I just upgraded from 7.0beta8 to 7.1beta1 from system/packages/update without any issue in a Proxmox KVM
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24747
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v7.1beta1 [development] is released!

Fri Jul 24, 2020 9:43 am

word of advice, don't use ISO for VM. use CHR image.
No answer to your question? How to write posts
 
raceboy
newbie
Posts: 48
Joined: Fri Mar 23, 2018 7:23 pm

Re: v7.1beta1 [development] is released!

Fri Jul 24, 2020 8:35 pm

just a question. when ros 7 will be stable release. could i just update chr or i will have to create new vm ? thanks
 
User avatar
zajadacz
just joined
Posts: 20
Joined: Fri Jul 29, 2016 12:30 pm

Re: v7.1beta1 [development] is released!

Fri Jul 24, 2020 9:19 pm

RB951G-2HnD not working. Tried to upgrade from 6.46.6 by uploading .npk but it crashes entirely (no communication through LAN, no wi-fi). Fortunately after power reset it has switched to a second partition with 6.46.6, so no netinstall needed.
 
mducharme
Trainer
Trainer
Posts: 1031
Joined: Tue Jul 19, 2016 6:45 pm

Re: v7.1beta1 [development] is released!

Sat Jul 25, 2020 3:02 am

RB951G-2HnD not working. Tried to upgrade from 6.46.6 by uploading .npk but it crashes entirely (no communication through LAN, no wi-fi). Fortunately after power reset it has switched to a second partition with 6.46.6, so no netinstall needed.
You probably can't upgrade from 6.46.6. Only latest stable RouterOS 6.x release usually works to upgrade to RouterOS 7.
 
jonah1810
newbie
Posts: 25
Joined: Tue Jul 30, 2019 10:19 pm

Re: v7.1beta1 [development] is released!

Sat Jul 25, 2020 4:54 am

Any word on what the wireless performance upgrade actually does?
has anybody tried any side by side testing?
 
onnoossendrijver
Member
Member
Posts: 430
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: v7.1beta1 [development] is released!

Sat Jul 25, 2020 10:51 am

I tried (net)installing ROS7 on a spare RB600A. It didn't work. The board didn't boot with the new software.
@Mikrotik: Will the RB600A be supported in a future release? Or am I doing something wrong?
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
nostromog
Member Candidate
Member Candidate
Posts: 202
Joined: Wed Jul 18, 2018 3:39 pm

Re: v7.1beta1 [development] is released!

Sat Jul 25, 2020 2:49 pm

Is the problem about ignoring MTU settings still happening in 7.1beta? ( viewtopic.php?t=158457 )
no, jumbo frame is working fine at least on mellanox board.

refards
ros
Confirmed, I tried and it worked. In 7.0beta5 the VLAN setup was only working with ICMP and UDP, but TCP was broken.

So I'm giving it serious testing.
 
User avatar
hknet
Member Candidate
Member Candidate
Posts: 105
Joined: Sun Jul 17, 2016 6:05 pm
Location: Vienna, Austria
Contact:

Re: v7.1beta1 [development] is released!

Sat Jul 25, 2020 4:42 pm

NAT Hardware Offloading !
Great news. When is this coming to the actual router products like CCR series or new router products ?
Same Question from my side!
word of advice: if you're on 1036 oder 1072 your box can usually handle any 10G nat traffic, of course depending on your setup you could also overload those CPUs with lots of firewall-rules, but we haven't seen this happening at our bigger customer-setups using those boxes.
also the nat table on CRS seems a bit limited (4k), therefore if you need 1M+ or more connections you might have to look for some other gear as 1036 and 1072 are limited to 1M connections (at least in the stable releases, don't know about v7).
at the usual customer setups on 10G we see 100k+ connections and this is just fine, but could not be offloaded on CRS317.

so basically if you see 4k+ connections in your firewalltable you probably should not go for a crs317 nat-offloading (but we haven't tested this new feature in our lab, therefore reality might be different)

maybe someone from MT can clarify how 4k+ sessions would be handled on the CRS317 - like would those be dropped or handled in cpu or would simply all sessions go to cpu once the hardwaretable is full or whatever :)

thx
hk
 
blazej44800
newbie
Posts: 45
Joined: Thu Feb 20, 2014 6:16 pm

Re: v7.1beta1 [development] is released!

Sat Jul 25, 2020 10:04 pm

@hknet please, don't mess up count of NAT rules with conntrack table size limit.
CCNA R&S
 
User avatar
xvo
Forum Guru
Forum Guru
Posts: 1088
Joined: Sat Mar 03, 2018 1:12 am
Location: Moscow, Russia

Re: v7.1beta1 [development] is released!

Sun Jul 26, 2020 12:29 am

@hknet please, don't mess up count of NAT rules with conntrack table size limit.
The 4k number for NAT offloading is not the number of rules, but the number of connections:
viewtopic.php?f=1&t=163957#p807204
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta1 [development] is released!

Sun Jul 26, 2020 1:40 am

Having a 4K limit would be lowish, but it depends on how the acceleration table is managed.
I understand that connections over thr 4K limit will not be accelerated, but maybe there could be some effort (now or in the future) to keep useful connections in the hardware table, i.e. connections that make a lot of traffic.
When nothing is done, and there is a simple "use hw table when there is space in it" method, of course after a while there will be only long-lived connections with maybe very little traffic in the hw table (SIP registrations, ssh sessions, etc), and all new shortlived connections like web traffic will be handled in software only.
 
thadrumr
just joined
Posts: 24
Joined: Sat Dec 23, 2017 2:02 am

Re: v7.1beta1 [development] is released!

Sun Jul 26, 2020 3:48 pm

This version and 7.0 beta8 still has problems with the IPSec connection to my Avaya 1140 IP phone. This phone worked on version 7.0 beta 6 but since the upgrade to beta 8 and 7.1 beta 1 it does not work. I have verified the vpn works with my Vyos router virtual machine. I also verified it was not the firewall on my Mikrotik as I disabled the deny all at the bottom of the firewall rule set.
 
GamePad64
just joined
Posts: 1
Joined: Mon Jul 27, 2020 2:51 pm

Re: v7.1beta1 [development] is released!

Mon Jul 27, 2020 3:01 pm

Tried installing 7.1beta1 on my hap ac^2. First, it didn't want to download from Packages, "not found".
After downloading manually, install didn't go well. I got a bootloop. Okay, netinstall. After netinstalling 7.1beta1, it lanunched successfully. Tried to restore an old binary backup -- got a bootloop.
Netinstalled 7.1beta1 again. Tried to /import an old .rsc config, got a syntax error. Okay, tried to import it manually, line by line. The router decided to reboot unexpectedly, and I got a bootloop again :)
So, I've netinstalled 6.47.1, restored my backup and decided to wait for a more stable version.
 
stalkersam
just joined
Posts: 2
Joined: Mon Jul 27, 2020 9:59 pm

Re: v7.1beta1 [development] is released!

Mon Jul 27, 2020 10:13 pm

Hi my big problem RBD53G-5HacD2HnD (arm) v7.1beta firmware. I have 2 devices Yealink SIP-T19_E2 MAC address firstly 00:15:65:ХХ:ХХ:ХХ DHCP status offered
`but the devices Yealink SIP-T19_E2 MAC address firstly 80:5E:C0:ХХ:ХХ:ХХ status bound
I used default configuration & I'm not understand why you did this buggg????
please change firmware this not funy. I cannot fix this bug.
Please please

My log full 2000 messages & not stop

Please fix it as soon as possible not possible to work
Last edited by stalkersam on Mon Jul 27, 2020 10:17 pm, edited 1 time in total.
 
nje431
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Tue Sep 10, 2013 5:17 pm

Re: v7.1beta1 [development] is released!

Tue Jul 28, 2020 2:18 am

Cosmetic error on a RB1100AHx4 in Winbox under System>Health. It's showing 49.5 amps. Terminal is showing 495 ma.
 
atakacs
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Mon Mar 07, 2016 5:39 pm

Re: v7.1beta1 [development] is released!

Tue Jul 28, 2020 10:57 am

Cosmetic error on a RB1100AHx4 in Winbox under System>Health. It's showing 49.5 amps. Terminal is showing 495 ma.
Oh- was about to ask for an upgrade from our electric provider :)
 
nevolex
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Mon Apr 20, 2020 1:09 pm

Re: v7.1beta1 [development] is released!

Tue Jul 28, 2020 1:56 pm

I hope the release will be end of this year?
 
User avatar
hknet
Member Candidate
Member Candidate
Posts: 105
Joined: Sun Jul 17, 2016 6:05 pm
Location: Vienna, Austria
Contact:

Re: v7.1beta1 [development] is released!

Wed Jul 29, 2020 5:33 am

@hknet please, don't mess up count of NAT rules with conntrack table size limit.
not me :)
 
anuser
Member
Member
Posts: 489
Joined: Sat Nov 29, 2014 7:27 pm

Re: v7.1beta1 [development] is released!

Wed Jul 29, 2020 11:15 pm

*) wireless -[...]
Comparing v7 with v6 are there any improvements or enhancements with regerads to wireless?
 
erlinden
Long time Member
Long time Member
Posts: 557
Joined: Wed Jun 12, 2013 1:59 pm

Re: v7.1beta1 [development] is released!

Wed Jul 29, 2020 11:50 pm

Comparing v7 with v6 are there any improvements or enhancements with regerads to wireless?
viewtopic.php?f=1&t=163957#p807036
First the problem, then the solution
 
cihancan
just joined
Posts: 17
Joined: Thu May 14, 2020 7:51 pm

Re: v7.1beta1 [development] is released!

Thu Jul 30, 2020 12:14 pm

How stable is v7beta? im having ping timeout problems with 6.4x, but i dont wanna brick my device
 
User avatar
skylark
MikroTik Support
MikroTik Support
Posts: 138
Joined: Wed Feb 10, 2016 3:55 pm

Re: v7.1beta1 [development] is released!

Thu Jul 30, 2020 12:23 pm

Cosmetic error on a RB1100AHx4 in Winbox under System>Health. It's showing 49.5 amps. Terminal is showing 495 ma.
Scheduled for fixing.

How stable is v7beta? im having ping timeout problems with 6.4x, but i dont wanna brick my device
I do not think ICMP timeout problems are related to the version the device has.
V7 is a beta version, but still, the latest version should not brick any device.
 
cihancan
just joined
Posts: 17
Joined: Thu May 14, 2020 7:51 pm

Re: v7.1beta1 [development] is released!

Thu Jul 30, 2020 12:41 pm

Cosmetic error on a RB1100AHx4 in Winbox under System>Health. It's showing 49.5 amps. Terminal is showing 495 ma.
Scheduled for fixing.

How stable is v7beta? im having ping timeout problems with 6.4x, but i dont wanna brick my device
I do not think ICMP timeout problems are related to the version the device has.
V7 is a beta version, but still, the latest version should not brick any device.
Ok then but i have another problem, even tho it says beta7 downloaded rebooting... it's still older version boots up.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8486
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v7.1beta1 [development] is released!

Thu Jul 30, 2020 2:17 pm

Check what's in Log

Plus, you should not be able to upgrade from v6 to v7 via Packages -> Check for upgrade, you need to do that manually
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
anuser
Member
Member
Posts: 489
Joined: Sat Nov 29, 2014 7:27 pm

Re: v7.1beta1 [development] is released!

Thu Jul 30, 2020 4:16 pm

After updating from /system packages on a cap ac:
  • "can not install system-7.1beta1: it is not made for arm, but for i386"
    Image
  • TX shows 0dBm for wlan1 radio on cAP ac
    Image
 
morf
Member Candidate
Member Candidate
Posts: 178
Joined: Tue Jun 21, 2011 5:31 pm
Location: Saint-Petersburg

Re: v7.1beta1 [development] is released!

Thu Jul 30, 2020 8:21 pm

Updated CCR1036 to version 7.1. Configured a BGP session with BIRD on Ubuntu, where Fullview is located. All routes (818 thousand) were loaded for about 15 minutes. 1-3 CPUs are constantly loaded. And all these 15 minutes I waited for the response to the command "routing/route/print count-only". After the entire FV has loaded, 1 CPU is constantly loaded. How it should work multi-cpu ?
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Posts: 101
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: v7.1beta1 [development] is released!

Thu Jul 30, 2020 9:14 pm

Updated CCR1036 to version 7.1. Configured a BGP session with BIRD on Ubuntu, where Fullview is located. All routes (818 thousand) were loaded for about 15 minutes. 1-3 CPUs are constantly loaded. And all these 15 minutes I waited for the response to the command "routing/route/print count-only". After the entire FV has loaded, 1 CPU is constantly loaded. How it should work multi-cpu ?
I think mikrotik team is still working on this issue. BGP Load is still not properly using Multiple cores.

Hope these issues will fix soon and expecting a Stable release for mikrotik team asap... :D
MTCNA | MTCRE | MTCINE | MTCTCE

Mikrotik Consultant - Specialized in ISP OPERATIONS | ROUTING | QOS | FIREWALL | MPLS | SCRIPTING | IPv6
 
rpress
Member Candidate
Member Candidate
Posts: 110
Joined: Thu May 07, 2009 5:13 am

Re: v7.1beta1 [development] is released!

Sat Aug 01, 2020 3:13 am

Does anyone see a problem with per client queues? When I try to use pcq-upload-default it reboots. I have had trouble with QEMU, I am not sure if it is my settings there.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta1 [development] is released!

Sat Aug 01, 2020 11:20 am

Does anyone see a problem with per client queues? When I try to use pcq-upload-default it reboots. I have had trouble with QEMU, I am not sure if it is my settings there.
I am using that on a CCR-1009 without issues.
 
2mail
just joined
Posts: 2
Joined: Sun May 20, 2018 10:58 pm

Re: v7.1beta1 [development] is released!

Sun Aug 02, 2020 12:37 pm

When can we expect update on the wireless performance on the Netmetal 5 and LHG 5
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 144
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: v7.1beta1 [development] is released!

Mon Aug 03, 2020 12:02 am

FYI : little unstable for CRS354, sometimes this unit won't boot with this version ROS
 
User avatar
raimondsp
MikroTik Support
MikroTik Support
Posts: 35
Joined: Mon Apr 27, 2020 10:14 am

Re: v7.1beta1 [development] is released!

Mon Aug 03, 2020 10:29 am

How is HW-offloaded NAT configured?
Does it kick in automatically?
How do I notice that the 4096 connection limit is reached?
Is it shown, which connections aren't HW-offloaded anymore?
/interface/ethernet/switch/set switch1 l3hw=fw
, where:
L3hw ::= fw | no | yes
  yes -- All traffic gets processed by the Hardware. Incompatible with Firewall.
  no -- All traffic goes through the CPU
  fw -- Uses CPU Firewall while offloading Fasttrack connections to the HW
FastTrack connections that are HW-offloaded have H flag in
/ip/firewall/connection/print
 
User avatar
raimondsp
MikroTik Support
MikroTik Support
Posts: 35
Joined: Mon Apr 27, 2020 10:14 am

Re: v7.1beta1 [development] is released!

Mon Aug 03, 2020 10:48 am

Having a 4K limit would be lowish, but it depends on how the acceleration table is managed.
I understand that connections over thr 4K limit will not be accelerated, but maybe there could be some effort (now or in the future) to keep useful connections in the hardware table, i.e. connections that make a lot of traffic.
When nothing is done, and there is a simple "use hw table when there is space in it" method, of course after a while there will be only long-lived connections with maybe very little traffic in the hw table (SIP registrations, ssh sessions, etc), and all new shortlived connections like web traffic will be handled in software only.
There is a smart connection pickup algorithm for the HW offload implemented already. It is nothing like the first 4k long-lasting connections occupy the entire HW table and sit there forever. If the connection has no traffic, or the amount of data is low, the connection gets removed from the HW table and replaced by another one with more traffic.

Without going deep into details, the more traffic the connection has, the higher chance for it to be HW-offloaded.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta1 [development] is released!

Mon Aug 03, 2020 11:25 am

Ok, that sounds good!
 
rpress
Member Candidate
Member Candidate
Posts: 110
Joined: Thu May 07, 2009 5:13 am

Re: v7.1beta1 [development] is released!

Mon Aug 03, 2020 1:53 pm

Does anyone see a problem with per client queues? When I try to use pcq-upload-default it reboots. I have had trouble with QEMU, I am not sure if it is my settings there.
I am using that on a CCR-1009 without issues.
Thanks for your reply. I have played around some more, knowing that you have it working. I'm not sure exactly why, but I can use pcq-upload-default on some of my Queue Tree entries, but on others it causes the router to reboot. I don't think it's a problem with my QEMU settings.


On another topic, does anyone know if v7.1 has a working i40e driver? I was thinking of buying an Intel card for use with SR-IOV.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta1 [development] is released!

Mon Aug 03, 2020 3:27 pm

Ok I was not aware that it was in a v7 topic (my phpBB skin does not clearly show that anymore), I am running 6.47.1 on the CCR1009 and it works OK there.
Maybe it is a v7 specific issue.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1895
Joined: Mon Jan 14, 2008 1:53 pm
Location: Over the Rainbow
Contact:

Re: v7.1beta1 [development] is released!

Mon Aug 03, 2020 5:06 pm

.


On another topic, does anyone know if v7.1 has a working i40e driver? I was thinking of buying an Intel card for use with SR-IOV.
Yes, it does.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet NSE7 | Extreme Networks ENA
 
anuser
Member
Member
Posts: 489
Joined: Sat Nov 29, 2014 7:27 pm

Re: v7.1beta1 [development] is released!

Thu Aug 06, 2020 8:42 am

Upgrading wAP ac devices from 6.47.1 to v7.1beta1 results in dead devices. Had to netinstall them with to make them working running again with ROS 6.
 
anuser
Member
Member
Posts: 489
Joined: Sat Nov 29, 2014 7:27 pm

Re: v7.1beta1 [development] is released!

Thu Aug 06, 2020 8:45 am

Updated HAP AC lite, great wireless performance. Hope for fast progress!
Well, let´s post some iperf3 results comparing ROS6 and thise ROS7 firmware, please.
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1875
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: v7.1beta1 [development] is released!

Fri Aug 07, 2020 9:43 pm

RB1100AHx4 does not upgrade.
RB1100AHx4b7.1.PNG
You do not have the required permissions to view the files attached to this post.
Real admins use real keyboards.
To quote or not to quote, there is the topic: viewtopic.php?f=2&t=168474
 
csalcedo
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Fri Jan 22, 2016 8:09 pm
Location: Santiago Chile

Port LEDs don't turn on rb2011

Sat Aug 08, 2020 2:18 am

Just installed v7.1beta1 on an RB2011 and found that if I plug in on ports ETH6-ETH10 the port LED does not turn on but if I plug into ETH1 both port 1 and 6 Leds turn on. This happens the same for ETH2 (turns on 2 and 7 and so forth) 3, 4 and 5
Otherwise looks ok
 
User avatar
rooted
Member Candidate
Member Candidate
Posts: 122
Joined: Tue Feb 04, 2020 5:58 pm

Re: v7.1beta1 [development] is released!

Sat Aug 08, 2020 10:49 am

Subbing
 
Weafyr
just joined
Posts: 2
Joined: Wed Aug 29, 2018 4:14 pm

Re: v7.1beta1 [development] is released!

Mon Aug 10, 2020 7:01 pm

Tried to install v7.1b1 on RB3011 ended up badly.
I did update from packages menu from v7.0b8 and the router stayed stuck on "Starting services..."
Tried netinstall, both 7.0b8 and 7.1b1 version of netinstall did not find the router.
Then with netinstall v6.45.9 ether boot finally worked. So I tried to install v7.1b1 again using netinstall, and router went into "Starting services..." again with small change - after short time, about 15s, the device reboot itself.
Finally reflash to 7.0b8 bringed my device back to life.

The whole time I had been connected to the router with console to watch what is going on, but there is no any information at all..
Formatting disk......

installed system-7.1beta1
Writing configuration...

Software installed.
Press ENTER to reboot

Rebooting...
Restarting system.


RouterBOOT booter 7.0beta8

RouterBOARD 3011UiAS

CPU frequency: 1400 MHz
  Memory size: 1024 MiB
    NAND size: 128 MiB

Press any key within 2 seconds to enter setup..

loading kernel... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...


RouterBOOT booter 7.0beta8

RouterBOARD 3011UiAS

CPU frequency: 1400 MHz
  Memory size: 1024 MiB
    NAND size: 128 MiB

Press any key within 2 seconds to enter setup..

loading kernel... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...
 
rpress
Member Candidate
Member Candidate
Posts: 110
Joined: Thu May 07, 2009 5:13 am

Re: v7.1beta1 [development] is released!

Tue Aug 11, 2020 12:13 pm

On another topic, does anyone know if v7.1 has a working i40e driver? I was thinking of buying an Intel card for use with SR-IOV.
Yes, it does.
Thanks for your reply. I have installed the card, and indeed i40e driver is working, I can passthrough the PF.

What I did not realize is that Intel uses a different driver for VF (SR-IOV), and this is not working. For now I can use macvtap but if Mikrotik could add the iavf driver that would be great.
 
msatter
Forum Guru
Forum Guru
Posts: 1960
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v7.1beta1 [development] is released!

Tue Aug 11, 2020 5:51 pm

RB1100AHx4 does not upgrade.

RB1100AHx4b7.1.PNG
See: viewtopic.php?f=1&t=163957#p808620
One RB4011 (cooled) and a RB760iGS (hEX S) in series. The 4011 Does PPPoE/IKEv2.
The cooler: viewtopic.php?f=3&t=138613&start=300#p799879
Running:
RouterOS 6.48beta48 / Winbox 3.27 64bits / MikroTik APP 1.3.15
 
mrshark
just joined
Posts: 11
Joined: Sun Aug 16, 2020 2:42 pm

Re: v7.1beta1 [development] is released!

Sun Aug 16, 2020 2:49 pm

hi, i just bought a brand new HAP MINI, and was trying to update it directly to 7.x beta, but it says the free space is not enough to be able to complete the request... is beta firmware bigger because of debug info, or will it always be such big, and as such these cheaper devices would not ever receive v7? Thanks in advance...
 
Widmo
just joined
Posts: 4
Joined: Thu Sep 14, 2017 2:02 am

Re: v7.1beta1 [development] is released!

Mon Aug 17, 2020 9:29 pm

HI, I have HEX-S,
after upgrade to devleopment firmware i have error:
20:23:54 system,error can not install system-7.1beta1: it is not made for mmips, but for i686
I'm trying System->Packages->Download
and
manual install from: https://download.mikrotik.com/routeros/ ... -mmips.npk

Both are the same effect.
 
ipcsolutions
just joined
Posts: 3
Joined: Fri Aug 07, 2015 1:58 am

Re: v7.1beta1 [development] is released!

Tue Aug 18, 2020 1:06 am

Hi Group

I upgraded from 7.0b5 to 7.1b1 on ARM device and this broke my UDP OpenVPN tunnel (as client). When I downgraded to 7.0b5 all good again.
Anyone have any ideas why?

Thanks
Mike
 
Widmo
just joined
Posts: 4
Joined: Thu Sep 14, 2017 2:02 am

Re: v7.1beta1 [development] is released!

Tue Aug 18, 2020 1:24 am

I upgraded from 7.0b5 to 7.1b1 on ARM device and this broke my UDP OpenVPN tunnel (as client). When I downgraded to 7.0b5 all good again.
Anyone have any ideas why?
Because it is still beta ;)

If You want to have working openvpn, report a bug! :)
 
User avatar
herger
just joined
Posts: 14
Joined: Tue Aug 18, 2020 2:48 pm

Re: v7.1beta1 [development] is released!

Wed Aug 19, 2020 9:24 pm

VLAN tagging seems to be broken:
  • Version number (if the issue is upgrade related, specify which version was installed before as well);
    v7.1beta1 before v6.74.1
  • Router's model;
    RB951G-2HnD
  • Steps to reproduce the issue;
    create a bridge and add ports; create vlan interface on top; add dhcp client to interface; packets are sent tagged in the beginning, untagged afterwards.
  • Configuration export (use '/export hide-sensitive' command);
    # jan/02/1970 21:08:09 by RouterOS 7.1beta1
    # software id = MZ2W-H1WJ
    #
    # model = 951G-2HnD
    # serial number = 46990201AD6A
    /interface bridge
    add name=bridge1
    /interface wireless
    # managed by CAPsMAN
    set [ find default-name=wlan1 ] ssid=MikroTik
    /interface vlan
    add interface=bridge1 name=CAPS vlan-id=98
    /interface lte apn
    set [ find default=yes ] ip-type=ipv4
    /interface wireless security-profiles
    set [ find default=yes ] supplicant-identity=MikroTik
    /ip vrf
    add list=all name=main
    /interface bridge port
    add bridge=bridge1 interface=ether2
    add bridge=bridge1 interface=ether3
    add bridge=bridge1 interface=ether4
    add bridge=bridge1 interface=ether5
    /ipv6 settings
    set disable-ipv6=yes
    /interface wireless cap
    # 
    set certificate=request discovery-interfaces=CAPS enabled=yes interfaces=wlan1
    /ip dhcp-client
    add disabled=no interface=CAPS
    /system logging
    add action=echo disabled=yes topics=debug,!packet
    
  • Any additional information that would help troubleshoot the issue (screenshots, debug logs, etc.).
    Exact same setup is working on v6.74.1. did try to enable vlan switching with same result, packets are sent tagged the first few seconds, untagged afterwards.
    2020-08-19 20_14_31-admin@172.17.99.254 (MikroTik) - WinBox (64bit) v6.47.1 on RB1100AHx2 (powerpc).png
    2020-08-19 20_15_18-admin@D4_CA_6D_06_97_91 (MikroTik) - WinBox (64bit) v7.1beta1 on RB951G-2HnD (mi.png
You do not have the required permissions to view the files attached to this post.
Last edited by herger on Wed Aug 19, 2020 11:57 pm, edited 2 times in total.
 
nevolex
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Mon Apr 20, 2020 1:09 pm

Re: v7.1beta1 [development] is released!

Thu Aug 20, 2020 12:41 pm

do you guys know if band steering will be awalible in ros 7?


Thanks
 
santyx32
Member Candidate
Member Candidate
Posts: 150
Joined: Fri Oct 25, 2019 2:17 am

Re: v7.1beta1 [development] is released!

Thu Aug 20, 2020 10:03 pm

do you guys know if band steering will be awalible in ros 7?


Thanks
Band steering is more complex than making SSIDs the same, the AP needs to gather information from the environment and the client capabilities/signal to redirect clients to each band.
[https://drive.google.com/drive/folders/ ... sp=sharing] 11/10/2020 OpenWRT build download for hAP ac2[/url], don't forget to backup ROS license

I'm the guy known as geminis3
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta1 [development] is released!

Thu Aug 20, 2020 11:43 pm

And actually, clients should (and will) do that themselves, with less issues than trying to control it from the access point.
It has been a long time since I saw a client that by default preferred 2.4 over 5 GHz connection.
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 107
Joined: Wed Aug 09, 2017 1:15 pm

Re: v7.1beta1 [development] is released!

Fri Aug 21, 2020 12:08 pm

It has been a long time since I saw a client that by default preferred 2.4 over 5 GHz connection.
Amazon Echo devices do this all the time.. At least 1.Gen ones that I have.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7038
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta1 [development] is released!

Fri Aug 21, 2020 12:31 pm

It has been a long time since I saw a client that by default preferred 2.4 over 5 GHz connection.
Amazon Echo devices do this all the time.. At least 1.Gen ones that I have.
The comparable Google devices do it OK. Your device may be too old, it will probably get confused big time by 802.1r/v/k and maybe even by bandsteering.
It is better to just ignore this, it is not that important for that kind of device anyway.
I don't think it is still an issue for more powerful devices like laptops, phones, tablets etc.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 664
Joined: Thu Dec 11, 2014 8:53 am

Re: v7.1beta1 [development] is released!

Fri Aug 21, 2020 2:01 pm

New version 7.1beta2 has been released in development RouterOS channel:

viewtopic.php?f=1&t=165248

Who is online

Users browsing this forum: eworm, MAHMOKOOO and 10 guests