Community discussions

MikroTik App
 
npeca75
newbie
Topic Author
Posts: 32
Joined: Thu Aug 03, 2017 3:12 pm

v7.2 beta & mt7621

Sat Oct 10, 2020 9:25 pm

Hi to all
after many hours testing i found out that kernel v5 and mt7621 simlpy does not work with integrated switch chip

same setup with HW offload was working in ROS v6.x

Does Mkirotik have in plan to fix HW issues with mt7621?
or we are doomed to use SW switching?
 
msatter
Forum Guru
Forum Guru
Posts: 2013
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v7.2 beta & mt7621

Sun Oct 11, 2020 1:11 am

Those devices are released to be used with new bridge setup, that replaced the Master-Slave default, in RouterOS 6.xx and higher. Hardware switching (HW) is only active on the first bridge in ROS 6.xx+
Loving my freedom and so, no Twitter, no Facebook/Instagram/WhatsApp, no Apple and no Google/Alphabet.

Running:
RouterOS 6.48 / Winbox 3.27 64bits
 
npeca75
newbie
Topic Author
Posts: 32
Joined: Thu Aug 03, 2017 3:12 pm

Re: v7.2 beta & mt7621

Sun Oct 11, 2020 5:29 am

Hi @msatter

as i said, HW offloading working well in v6.xx (without rstp)
so, i know what is the difference between old master-slave and new /interface ethernet switch

i am talking about ROS v7.x and kernel v5
very simple config
# model = RouterBOARD 750G r3
# serial number = 6F38085A9ED2
/interface bridge add name=BR-Switch protocol-mode=none
/interface vlan add interface=BR-Switch name=vlan2 vlan-id=2
/interface ethernet switch port set 5 vlan-mode=secure
/ip vrf add list=all name=main
/interface bridge port add bridge=BR-Switch interface=ether1
/interface bridge port add bridge=BR-Switch interface=ether2
/interface ethernet switch vlan add independent-learning=no ports=switch1-cpu,ether1,ether2 switch=switch1 vlan-id=2
/interface ethernet switch vlan add independent-learning=no ports=switch1-cpu,ether1,ether2 switch=switch1 vlan-id=1
/ip dhcp-client add disabled=no interface=vlan2
...does not work

same setup, ROS v6, working

Who is online

Users browsing this forum: Bing [Bot] and 7 guests