Community discussions

MikroTik App
 
cadillackid
just joined
Topic Author
Posts: 21
Joined: Wed Oct 17, 2007 5:20 pm

how to understand routi9ng in v7

Mon Oct 12, 2020 2:36 am

I really am confused by routing in V7.. in v6 going to /ip route. was easy I could add static routes and either select an IP or an interface as a gateway and they would work.. what I find with V7. is /ip route is confusing with percent symbols and such..

I have 2 L2TP client VPN s that auto establish when ROS is booted and LTE comes on line.. I have VLANs for IP phones and for the laptop wifi user..

this means I apply various static routes some go to the VPN some go out to the internet via firewall masqueruede.. what im finding is roputing often "stuck" when doing a traceroute at my local router.. when I run V6 this doesnt happen..

I can only believe it has to do with the mew routing module.. is there a way to get rid of routing route table and go back to standard / ip route scenerio in V7?

I dont do any marking, everything is static route using either an IP or interface as gateway depending on where its going..

I tried doing an ipv6 disable in settings via command line to see if that would help. no dice..

when I take my config and drop it back into an ROS v6 unit identical (and then re-enable PPP on my LTE since MBIM wont work or I use an R11 card) then everything eworks as expected..

I know my VPN tunnel,s are workjing as i can access the hosts behind then from the ROSv7 device itself fine.. I can ping the hosts from a laptop just no access.. it seems something in this wierd routin g method is causing me issues.. my /ip route i nthe gUI changes all the time..

ive read the short little blurb in the online doc. but doesnt seem to make much sense.. seems like all the routes should still be added to the main table. but they work when they want..

anyone else have routing issues with v71beta ?
 
cadillackid
just joined
Topic Author
Posts: 21
Joined: Wed Oct 17, 2007 5:20 pm

Re: how to understand routi9ng in v7

Mon Oct 12, 2020 2:06 pm

the more I go through this the more I figure out that its an SSH issue through this router..

I cant SSH anywhere from a WLAN client connected to this LTAP mini. (except into the mikrotik itself). I can HTTP, Telnet, etc but cannot SSH.. I get to thje point of being authenticated and trying to eastablish session, then timeout (broken pipe) occurs.. doesnt matter if im trying to reach a server behind one of my tunnel or SSH to a server on the internet.. Port doesnt seem to affect it either..

I CAN ssh to the mikrotik then use /sys ssh. to access a server on the internet or behind one of my tunnels just fine..

my firewall rules dont trigger.. is there some sort of DPI going on that would shut down SSH connections?, is it a TTL issue? I had thought the fact my main WAN is LTE was the issue however I can connect and stay in a session for long periods of time easily by using /sys ssh.

-Christopher
 
DarkNate
Member Candidate
Member Candidate
Posts: 273
Joined: Fri Jun 26, 2020 4:37 pm

Re: how to understand routi9ng in v7

Mon Oct 12, 2020 4:27 pm

"How to understand"?

You start by reading before posting here, you start by searching:

https://help.mikrotik.com/docs/display/ ... col+Status

https://help.mikrotik.com/docs/display/ ... g+Examples
 
cadillackid
just joined
Topic Author
Posts: 21
Joined: Wed Oct 17, 2007 5:20 pm

Re: how to understand routi9ng in v7

Mon Oct 12, 2020 10:20 pm

well arent you just a great ball of cheer.. why bother to answer if just gonnaspread negativity

in fact I did read those articles.. and in fact I didnt find an answer to totally understanding why /routing route and /ip route. considering my static routes seem to chow up in both.. I also didnt find an explanation to percent symbols in ip route for interface names..

Oh and there appears to be an actual Bug in ros7.1beta2 regarding disabling fasttrack and the SSH protocol..

-Christopher
 
User avatar
vecernik87
Forum Veteran
Forum Veteran
Posts: 772
Joined: Fri Nov 10, 2017 8:19 am

Re: how to understand routi9ng in v7

Tue Oct 13, 2020 5:04 am

Cmon, he tried to help you and there is not a single negative point in his reply. The least you can do is not insult him.
Since you did not bother to say, that you went through these pages (calling it "short little blurb" didn't help), it was safe to assume you didn't read it and you might benefit from the information. Was it really so bad, that he provided you link for current v7 routing manual?

I can't help you with all your questions but I can at least confirm that the "%" syntax is already in v6, where valid gateway values are IP | interface | IP%interface | IP@table
In V7, you can still enter all these values (I tested it just now) and it seems to work. However, whole routing engine is still unfinished and buggy. There is clear list of things which are not finished yet, so do not expect it to work.

re. /routing/route and /ip/route difference - this is purely my personal guess - I assume Mikrotik wants to separate the routing menu from "ip" and "ipv6". That way they can keep all routing related things in the "routing" menu.

any other questions - sorry, can't help with that. If you find a feature which is marked as "working" yet it does not work, you may report it to mikrotik directly using email/helpdesk portal, so they are aware of it.

ps: your original post sounds like you are using the v7 in real environment, not in lab. If that is the true, then your troubles are kinda self inflicted.
 
cadillackid
just joined
Topic Author
Posts: 21
Joined: Wed Oct 17, 2007 5:20 pm

Re: how to understand routi9ng in v7

Tue Oct 13, 2020 3:29 pm

v7 is being used in my Mobile DEV lab. so not on a real customer site.. so now dont insult me i nthat way to assume i am just going to toss it out there.. its a test environment..

I had never seen percent symbols in the routing table in my V6 before. is why i asked about them..

I have no issues with someone providing links but when you slam someone essentially by saying "RTFM" yes thats an insult to me so yes i came back strong.. gonna happen.

anyway the last post was MUCH more helpful than the first..
peoiple just need to quit with that crap.. so i ask questions.. isnt that what a forum is for? im new to v7beta, im new to using LTE in my environments, im learning.. got it?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6179
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: how to understand routi9ng in v7

Tue Oct 13, 2020 3:53 pm

I know my VPN tunnel,s are workjing as i can access the hosts behind then from the ROSv7 device itself fine.. I can ping the hosts from a laptop just no access.. it seems something in this wierd routin g method is causing me issues.. my /ip route i nthe gUI changes all the time..
If ping works and some other protocol does not, it usually indicates that problem is not related with routes or routing protocols. If it were routes, then ping would not work either.
You mentioned routes with interface gateways, those can be used only on p2p interfaces. On broadcast interfaces it will not work and you may get unexpected behavior.

ip%interface is the same as it was in ROSv6. interface after % indicates that gateway will be resolved to specific interface only.
 
cadillackid
just joined
Topic Author
Posts: 21
Joined: Wed Oct 17, 2007 5:20 pm

Re: how to understand routi9ng in v7

Wed Oct 14, 2020 1:34 am

perfect thanks! I had just never inserted percent symbols in ROS6. I had chosen interfaces in the dropdowns for gateways on P2P.. makes sense now..

it looks like there is a logged bug against ROS71beta2 with others experiencing failing SSH as well.. I realized what you said after I had written it, that route would fail with all protocols.. I had even disabled all of my firewall filters...

a workaround is re-enable fasttrack which is fine for my Lab environment as i dont need to firewall between LAN ports in the Mobile Lab.

im getting more used to /routing route and /ip route differences..
-Christopher

Who is online

Users browsing this forum: realtime and 10 guests