Page 1 of 1

L2TP "Rate" = 0 on "Mikrotik Chateau"

Posted: Mon Oct 12, 2020 5:39 pm
by florentleg
Hello,

I've been running performance tests to establish diagrams with the Mikrotik - Chateau.
I've been using iPerf with a serverside and clientside.
The issue i'm facing is :

Whenever I try to execute a speedtest with a speed <100 Mbits/sec, everything looks fine, the "Tx" column for L2TP interface is approximately at the speed I programmed.
But when I try go above, I sometimes read "140 Kb/s" or just "0".
I also ran speedtests through lan bridges (No L2TP, with and without mangle rules) at 1000 Mbits/s and it worked fine aswell.

Am I missing something ?

Please note that I also tested the configuration below on HAPac, HAPac2 and CCR1009 and it worked like a charm.

Here is my configuration (Hidden adresses):
/interface bridge
add name=LAN_BRIDGE priority=0x1000
add name=WAN_BRIDGE
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
set [ find default-name=wlan2 ] ssid=MikroTik
/interface l2tp-client
add add-default-route=yes allow=chap allow-fast-path=yes connect-to=\
    XXXX disabled=no name=l2tp-out1 password=XXXX user=\
    XXXXX
/interface lte
# SIM not present
set [ find ] allow-roaming=no name=lte1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=pool_dhcp1 ranges=XXXX-XXXX
/ip dhcp-server
add address-pool=pool_dhcp1 disabled=no interface=LAN_BRIDGE lease-time=1d \
    name=dhcp1
/ip vrf
add list=all name=main
/interface bridge port
add bridge=WAN_BRIDGE interface=ether1
add bridge=LAN_BRIDGE interface=ether2
add bridge=LAN_BRIDGE interface=ether3
add bridge=LAN_BRIDGE interface=ether4
add bridge=LAN_BRIDGE interface=ether5
/ip address
add address=XXXX interface=LAN_BRIDGE network=XXXX
/ip dhcp-client
add default-route-distance=10 disabled=no interface=WAN_BRIDGE
/ip dhcp-server network
add address=XXXX dns-server=XXXX gateway=\
    XXXX netmask=24 ntp-server=XXXX

/ip firewall mangle
add action=fasttrack-connection chain=forward disabled=yes in-interface=\
    l2tp-out1 out-interface=LAN_BRIDGE
add action=fasttrack-connection chain=forward disabled=yes in-interface=\
    LAN_BRIDGE out-interface=l2tp-out1
add action=fasttrack-connection chain=output disabled=yes out-interface=\
    WAN_BRIDGE
add action=fasttrack-connection chain=input disabled=yes in-interface=\
    WAN_BRIDGE
add action=fasttrack-connection chain=forward disabled=yes in-interface=\
    WAN_BRIDGE out-interface=LAN_BRIDGE
add action=fasttrack-connection chain=forward disabled=yes in-interface=\
    LAN_BRIDGE out-interface=WAN_BRIDGE
/ip firewall nat
add action=masquerade chain=srcnat comment=masquerade out-interface=l2tp-out1
/ip firewall service-port
set sip disabled=yes
/ip service
set telnet disabled=yes
/system clock
set time-zone-name=Europe/Paris
/system routerboard settings
set cpu-frequency=auto