Community discussions

MikroTik App
 
erkexzcx
Member Candidate
Member Candidate
Topic Author
Posts: 146
Joined: Mon Oct 07, 2019 11:42 pm

Chateau 12 - WiFi no longer connects for a random device

Sat Nov 28, 2020 5:54 pm

Description

I have Chateau 12 Mikrotik router with latest ROS 7.1 beta2, which I am using as access point. I setup 2 WiFis - one for 2.4Ghz and the other one for 5Ghz. Since I have no point to use 2.4Ghz for now, I only use 5Ghz WiFi only. I don't know if this issue happens with 2.4Ghz. Main router is Mikrotik RB4011iGS+RM running latest stable version of routerOS 6.*.*.

Devices like laptops or smartphones are constantly being moved, therefore they disconnect and reconnect as they get away from Wi-Fi and get close again, but at some point some random device is no longer connecting to the Wi-Fi anymore. Android devices show "Obtaining IP address" and then "Configuration failed". Not sure about laptops, but most importantly - it happens to randomly "selected" device which no longer able to connect to Wi-Fi. All other devices work as expected without any issues. It's just happens to a random device.

Workaround/Temporary Fix

In order to fix it, one can:
  • Reboot router (it does not fix itself at all). Didn't try experimenting with wireless interface resets or similar kind of thing.
  • Temporarily switch to 2.4Ghz until router is rebooted.

What I suspect

Something is wrong with Mikrotik WiFi drivers on "Chateau 12" or the way devices get configuration via WiFi. Something directly related to WiFi...

At home I have "Mikrotik RB4011iGS+RM" router and Netgear R7800 with OpenWRT acting as access point only. This setup is rock stable.
Now I have "Mikrotik RB4011iGS+RM" working as router and "Mikrotik Chateau 12" as access point only. And this setup is causing this issue...

Logs

Logs look like this:
Image

[admin@Mikrotik Chateau 12] > /interface wireless export hide-sensitive 
# nov/28/2020 17:47:48 by RouterOS 7.1beta2
# software id = FHFK-T2KF
#
# model = RBD53G-5HacD2HnD
# serial number = C8CA0C1B7905
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm mode=dynamic-keys name="my home" supplicant-identity="" unicast-ciphers=tkip,aes-ccm
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-XXXX country="united states" disabled=no frequency=auto mode=ap-bridge name=wlan-corona security-profile="my home" ssid=Corona wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX country="united states" disabled=no frequency=auto mode=ap-bridge name=wlan-ebola security-profile="my home" ssid=Ebola wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
I am reporting this issue here since chateau 12 has only RouterOS7, and I suspect it's something to do with a firmware.
 
erkexzcx
Member Candidate
Member Candidate
Topic Author
Posts: 146
Joined: Mon Oct 07, 2019 11:42 pm

Re: Chateau 12 - WiFi no longer connects for a random device

Sun Nov 29, 2020 12:29 pm

Disabling and re-enabling Wireless interface temporarily fixes the issue...
 
kivi
just joined
Posts: 1
Joined: Sun Nov 29, 2020 5:15 pm

Re: Chateau 12 - WiFi no longer connects for a random device

Sun Nov 29, 2020 5:16 pm

Hi!
Exaclty the same issue here.
 
pbx81
just joined
Posts: 4
Joined: Mon Nov 30, 2020 11:46 am

Re: Chateau 12 - WiFi no longer connects for a random device

Mon Nov 30, 2020 11:48 am

I have same problem with Chateau 12, and as written above, the solution is to disable and enable wifi again. I already wrote to support, so hope, they will provide new release soon.
 
redhatperl
just joined
Posts: 4
Joined: Wed Oct 28, 2020 1:40 pm

Re: Chateau 12 - WiFi no longer connects for a random device

Tue Dec 01, 2020 9:04 pm

Disabling and re-enabling Wireless interface temporarily fixes the issue...
I have had the similar issue with Chateau, please try the latest beta3 which worked for me.

Link: https://box.mikrotik.com/f/7eb38dc0726f ... a3-arm.npk
 
User avatar
Larsa
Member Candidate
Member Candidate
Posts: 237
Joined: Sat Aug 29, 2015 7:40 pm

Re: Chateau 12 - WiFi no longer connects for a random device

Tue Dec 01, 2020 10:23 pm

I have had the similar issue with Chateau, please try the latest beta3 which worked for me.

You wouldn't happen to have the release notes as well?
 
infabo
newbie
Posts: 30
Joined: Thu Nov 12, 2020 12:07 pm

Re: Chateau 12 - WiFi no longer connects for a random device

Wed Dec 02, 2020 2:07 am

Disabling and re-enabling Wireless interface temporarily fixes the issue...
I have had the similar issue with Chateau, please try the latest beta3 which worked for me.

Link: https://box.mikrotik.com/f/7eb38dc0726f ... a3-arm.npk
Thanks for sharing!

Happened to me, that I had no known DHCP-issues the last few days. Just one complete hang-up, where the Chateau wasn't responding (neither wifi, nor LAN and even with static IP I could not connect to it). So I wasn't able to create a support.rif the support asked me for.
 
WeWiNet
Member
Member
Posts: 488
Joined: Thu Sep 27, 2018 4:11 pm

Re: Chateau 12 - WiFi no longer connects for a random device

Wed Dec 02, 2020 10:55 am

erkexzcx:
At home I have "Mikrotik RB4011iGS+RM" router and Netgear R7800 with OpenWRT acting as access point only. This setup is rock stable.
Now I have "Mikrotik RB4011iGS+RM" working as router and "Mikrotik Chateau 12" as access point only. And this setup is causing this issue...
RB4011 has 4x4 5Ghz Wifi, whereas Chateau has 2x2 only. In your case I would use RB4011 as router and AP, and then Chatau as LTE modem only...

redhatperl:
I have had the similar issue with Chateau, please try the latest beta3 which worked for me.
Please can you advice beta 3 build time ? (look for build time under "system/packages") and share this.
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? or maybe I am just crazy :lol: !!!
 
User avatar
memelchenkov
just joined
Posts: 23
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Re: Chateau 12 - WiFi no longer connects for a random device

Wed Dec 02, 2020 12:05 pm

Please can you advice beta 3 build time ? (look for build time under "system/packages") and share this.
Thanks to @redhatperl for sharing the firmware. It solves my different problems. Build time: Nov/13/2020 11:05:49.
 
erkexzcx
Member Candidate
Member Candidate
Topic Author
Posts: 146
Joined: Mon Oct 07, 2019 11:42 pm

Re: Chateau 12 - WiFi no longer connects for a random device

Wed Dec 02, 2020 8:30 pm

erkexzcx:
At home I have "Mikrotik RB4011iGS+RM" router and Netgear R7800 with OpenWRT acting as access point only. This setup is rock stable.
Now I have "Mikrotik RB4011iGS+RM" working as router and "Mikrotik Chateau 12" as access point only. And this setup is causing this issue...
RB4011 has 4x4 5Ghz Wifi, whereas Chateau has 2x2 only. In your case I would use RB4011 as router and AP, and then Chatau as LTE modem only...
I have RB4011 without WiFi. At home I have Mikrotik RB4011 as main router, and Netgear R7800 (OpenWRT) as Access point. My laptop achieves 750mbps speed on 5Ghz internet (I have gigabit internet). Rock stable connection.

Now I moved temporarily to different location, but here I brought Chateau 12 router with me. I am currently using it as access point only. In order to "feel like home" I connected Chateau 12 router with RB4011 router at my home via IPSEC/IKE2 tunnel and mounted EoIP tunnel on top of that. I bridged EoIP on both ends and now I have home internet at different location. When I connect to Chateau 12 access point (wifi), I get IP address from my home, not from Chateau router. I even wrote tutorial how to set it up.

I wanted to avoid explaining this, because you would suspect this configuration rather than Chateau 12 router, but with some additional testing it just boils down to Wireless drivers/software of Mikrotik. I installed beta3 (see upper comments) and so far everything is stable, but it's been only few hours, so I will be looking how it will perform tomorrow.
 
erkexzcx
Member Candidate
Member Candidate
Topic Author
Posts: 146
Joined: Mon Oct 07, 2019 11:42 pm

Re: Chateau 12 - WiFi no longer connects for a random device  [SOLVED]

Fri Dec 04, 2020 8:45 pm

I confirm that beta3 fixes this issue.

Who is online

Users browsing this forum: No registered users and 10 guests