Community discussions

MikroTik App
 
ofirule
just joined
Topic Author
Posts: 23
Joined: Tue Mar 26, 2019 6:19 pm

Sierra MC7455 with RouterOS 7.1b3 on RB922UAGS

Sun Dec 20, 2020 7:27 pm

Hi,
I have a Sierra MC7455 , when connecting to the RB922UAGS routerboard it does get recognized but not as an LTE interface but rather as a serial device using PPP.

The modem has the USB 3.0 pins taped out, it is running in usbcomp mode 8( verified using swi_switchmode.pl script used on a laptop with a USB/mini-pci adapter) :
*  8 - DM   NMEA  AT    MBIM                            SUPPORTED
Only other modes supported are MBIM only (9) and QMI (6) tried both but didn't got something else.

Device info:
> system resource print  
                   uptime: 2m14s
                  version: 7.1beta3 (development)
               build-time: Dec/02/2020 15:59:47
         factory-software: 6.28
              free-memory: 89.7MiB
             total-memory: 128.0MiB
                      cpu: MIPS 74Kc V5.0
                cpu-count: 1
            cpu-frequency: 720MHz
                 cpu-load: 0%
           free-hdd-space: 111.4MiB
          total-hdd-space: 128.0MiB
  write-sect-since-reboot: 92
         write-sect-total: 7115
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: RB922UAGS-5HPacD
                 platform: MikroTik
USB info:
> system resource usb print  
Columns: DEVICE, VENDOR, NAME, SPEED
  #  DEV  VENDOR                         NAME                                                           SPE
  0  2-1  Sierra Wireless, Incorporated  Sierra Wireless MC7455 QualcommC2AE SnapdragonE284A2 X7 LTE-A  480
  1  1-0  Linux 5.6.3 ehci_hcd           RB400 EHCI                                                     480
  2  2-0  Linux 5.6.3 ehci_hcd           RB400 EHCI                                                     480
Config export (getting stuck in the middle):

 > export 
# dec/20/2020 19:21:36 by RouterOS 7.1beta3
# software id = PZZI-24MA
#
# model = 922UAGS-5HPacD
# serial number = 9F880996E072
/interface bridge
add admin-mac=B8:69:F4:21:50:4F auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-XXXX disabled=no frequency=auto installation=outdoor mode=ap-bridge ssid=MikroTik-215051
/interface lte apn
set [ find default=yes ] ip-type=ipv4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip vrf
add list=all name=main
/port
set 0 name=usb1
/interface ppp-client
add apn=internet name=ppp-out1 port=usb1
/routing table
add fib name=""
/interface bridge port
add bridge=bridge comment=defconf interface=ether1
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=*2000003
/ipv6 settings
set disable-ipv6=yes
/ip dhcp-client
add comment=defconf disabled=no interface=bridge
....
 
leopardus2
Member Candidate
Member Candidate
Posts: 104
Joined: Thu Oct 13, 2016 5:12 pm

Re: Sierra MC7455 with RouterOS 7.1b3 on RB922UAGS

Wed Dec 30, 2020 1:35 pm

Your modem should be supported in MBIM mode. But you will not be able to talk to it using at-chat.

Rick
 
ofirule
just joined
Topic Author
Posts: 23
Joined: Tue Mar 26, 2019 6:19 pm

Re: Sierra MC7455 with RouterOS 7.1b3 on RB922UAGS

Mon Jan 04, 2021 7:04 pm

Downgrading to  7.1beta2 fixed the issue
 
Moebius
just joined
Posts: 10
Joined: Mon Jun 29, 2020 10:32 pm

Re: Sierra MC7455 with RouterOS 7.1b3 on RB922UAGS

Sat May 01, 2021 7:25 am

Confirming same issue, 7.1b2 MC7455 works in MBIM, under 7.1b5 it no longer is recognized.
 
dlhitmhcx6i
just joined
Posts: 3
Joined: Sat May 01, 2021 10:06 pm

Re: Sierra MC7455 with RouterOS 7.1b3 on RB922UAGS

Sat May 01, 2021 10:13 pm

The same issue on 7.1b3-7.1b5. The error I see in the log is:
lte1: reply timeout for: AT E0 V1
There's no lte1 interface in the interface list.
 
dlhitmhcx6i
just joined
Posts: 3
Joined: Sat May 01, 2021 10:06 pm

Re: Sierra MC7455 with RouterOS 7.1b3 on RB922UAGS

Thu May 20, 2021 7:07 pm

7.1beta6, the bug hasn't been resolved. I still have to run 7.1beta2.
 
ofirule
just joined
Topic Author
Posts: 23
Joined: Tue Mar 26, 2019 6:19 pm

Re: Sierra MC7455 with RouterOS 7.1b3 on RB922UAGS

Tue Aug 31, 2021 1:06 pm

Fixed and working in 7.1-rc1 and 7.1-rc2
 
gvm
just joined
Posts: 1
Joined: Sat Aug 08, 2020 9:50 pm

Re: Sierra MC7455 with RouterOS 7.1b3 on RB922UAGS

Tue Sep 28, 2021 6:05 pm

Hello,

Actually EM7455B still doesn't work with continuous "lte1: reply timeout for: AT E0 V1" message on 7.1rc1-4 (tested on MIPSBE, ARM, MMIPS) so have to downgrade back to 7.1b2 (the latest firmware it works with).
Could you please check and fix it?
EM7455B - FW: SWI9X30C_02.33.03.00 / MBIM

Thanks in advance,
Gleb

Who is online

Users browsing this forum: borr, ech1965, jmszuch1, ultratoto14 and 5 guests