Community discussions

MikroTik App
 
rplant
newbie
Topic Author
Posts: 30
Joined: Fri Sep 29, 2017 11:42 am

updated bridge MTU (Caused OpenVPN problem)

Wed Jan 06, 2021 5:13 am

FYI,

HapAC2 ros V7.1Beta3

I was initially having some issues with openvpn trying to send longish packets.

While troubleshooting found that generally pinging things
(normal, no openvpn) with slightly long packets (behind NAT) was broken.

ping -l 1500 192.168.1.1 wouldn't work.
But ping -l 1800 192.168.1.1 worked fine...

I discovered that with slightly over length frames, they weren't being fragmented.

I eventually found the bridge on the router I was using with 7.1Beta3 had a MTU of
1598 bytes (rather than previously the minimum MTU of the attached interfaces)

This is good (I think)

However it did mean that in this case I needed to manually set the MTU of the bridge to 1500,
when the longish pings got fragmented correctly and started working again.
And the longish packets in OpenVPN worked properly again.

Who is online

Users browsing this forum: No registered users and 9 guests