Community discussions

MikroTik App
 
kcarhc
just joined
Topic Author
Posts: 21
Joined: Thu Feb 01, 2018 9:54 am

Anyone with TCP staus issue like fin wait/last ack/mtu , use this magic code will fix

Thu Jan 21, 2021 2:48 am

Anyone with TCP staus issue like fin wait/last ack/mtu , use this magic code will fix

on RouterOS 7.1beta 3 in firewall mangle set mss = interface mtu - 40 not working well.
so pppoe-client on RouterOS 7.1beta 3 maybe have tcp fin wait/last ack/ mtu issue,
in /ip firewall connctions, it show tcp connection status fin wait, last ack for long time.

works well on RouterOS 7.1beta 3

I think this issue will fix in RouterOS 7.1beta 4 soon.

#########################################

:if ([/tool sniffer get running] = false) do={
/tool sniffer set filter-interface=all filter-ip-address=1.2.3.4 only-headers=yes
/tool sniffer start
}

#########################################
add a scheduler for auto start when RouterOS reboot or packet sniffer crash.

/system scheduler
add interval=10s name=Fix_TCP_FIN_WAIT on-event=":if ([/tool sniffer get running] = false) do={\r\
\n /tool sniffer set filter-interface=all filter-ip-address=1.2.3.4 only-headers=yes\r\
\n /tool sniffer start\r\
\n}" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=\
jan/01/2000 start-time=00:00:00
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6195
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Anyone with TCP staus issue like fin wait/last ack/mtu , use this magic code will fix

Thu Jan 21, 2021 10:12 am

Disabling fast-path in ip settings is a lot easier.

Who is online

Users browsing this forum: No registered users and 11 guests