Community discussions

MikroTik App
 
User avatar
memelchenkov
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 55
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Issue with low-level traffic handling

Thu Jan 28, 2021 12:47 pm

Does anybody experienced the issue, when traffic goes by wrong path? I have IPSEC channel instantiated by Mikrotik. I mangle some traffic by connmarks and mangled traffic should pass this IPSEC channel. It works well until PPPoE connection re-initiates. After this, mystic things happens: by Mikrotik firewall logs everything is OK, but in reality part of unmangled traffic starts going via IPSEC channel (to be more specific -- traffic of IPSEC connection establishing from computer fails to establish due this issue). Only reboot helps. I trying to resolve this issue with support with no success for a long time, I am very tired making it work properly. Please, if you experienced the same behaviour, open Support requests to speed things up. My case # is SUP-37062.
Last edited by memelchenkov on Sat Feb 06, 2021 11:12 pm, edited 1 time in total.
 
User avatar
memelchenkov
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 55
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Re: Issue with low-level traffic handling

Fri Feb 05, 2021 12:29 pm

With 7.1b4 now a strange behavior: udp connection mangled as no-mark works for some time, then just stalled, no incoming traffic. Pressing "Remove" button in firewall helps, traffic starts going. It differs from previous beta, there were no such bug. However, it's only early hours, will see later.
Sorry not to add this to ticket, I just see adding info to ticket is ineffective at the moment.
Last edited by memelchenkov on Fri Feb 05, 2021 1:43 pm, edited 2 times in total.
 
User avatar
memelchenkov
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 55
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Re: Issue with low-level traffic handling

Fri Feb 05, 2021 1:23 pm

After PPPoE reconnects no-marked traffic funny passes to IPSEC mangled channel. The bug still exists, I really appreciate if you'll fix it in short time, because it completely breaks my whole work process. I believe, bugs in core components should be killed at the first place, and only after cleaning core from bugs you may add different new features to 7.x branch.
 
User avatar
memelchenkov
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 55
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Re: Issue with low-level traffic handling

Sat Feb 06, 2021 11:02 pm

I simplified Firewall rules and even completely disabled Fasttrack. I can say "yes", PPPoE reconnects brings mess to mangling and IPSEC processing, traffic starts going wrong way. I updated the ticket, please Mikrotik supporters who read the forum please take an eye on my ticket.

Who is online

Users browsing this forum: netvisionip and 14 guests