Community discussions

MikroTik App
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 687
Joined: Thu Dec 11, 2014 8:53 am

v7.1beta4 [development] is released!

Thu Feb 04, 2021 10:52 am

RouterOS version 7.1beta4 has been released in public "development" channel!

What's new in 7.1beta4 (2021-Feb-03 09:39):

*) api - added support for REST API;
*) crs3xx - fixed Layer3 hardware offloading;
*) route - routing rules improvements;
*) winbox - added support for wifiwave2;
*) winbox - updated User Manager, OSPF and BGP menus;
*) wifiwave2 - authentication and functionality improvements;
*) other fixes and improvements;

All released RouterOS v7 changelogs are available here:
https://mikrotik.com/download/changelog ... lease-tree

How to report RouterOS v7 bugs:
viewtopic.php?f=1&t=152006
 
tpedko
just joined
Posts: 10
Joined: Wed May 22, 2019 9:58 am

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 11:41 am

simple queues fixed on the router RB4011iGS+5HacQ2HnD-IN?
 
User avatar
ErfanDL
Member
Member
Posts: 334
Joined: Thu Sep 29, 2016 9:13 am
Location: IRAN
Contact:

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 11:58 am

RouterOS version 7.1beta4 has been released in public "development" channel!

*) api - added support for REST API;
that's mean HTTP REST API with GET PUT ?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24824
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 11:59 am

No answer to your question? How to write posts
 
User avatar
eworm
Forum Veteran
Forum Veteran
Posts: 755
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 12:01 pm

Looks like export still hangs...
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
ErfanDL
Member
Member
Posts: 334
Joined: Thu Sep 29, 2016 9:13 am
Location: IRAN
Contact:

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 12:04 pm

One of the best features I've ever expected. Thanks to Mikrotik
 
buvarbeno
just joined
Posts: 4
Joined: Thu Mar 07, 2019 12:11 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 12:08 pm

I use an RB951g-2hnd for testing. With minimal firewall, NAT and fasttrack. The WAN side of the router is connected to a LAN (DHCP client), and behind the router I can reach an RDS server from original LAN. With 6 series ROS (many versions and latest beta from yesterday too) it is working, but with ROS7 beta3 and beta 4 too, the RDP link is unstable, it disconnects in every minutes.
Last edited by buvarbeno on Thu Feb 04, 2021 12:26 pm, edited 3 times in total.
 
SLNetworks
just joined
Posts: 7
Joined: Tue Dec 10, 2019 11:02 am

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 12:14 pm

Is SwOS hidden by chance in this release for the CRS354? 🤞
 
velk1001
just joined
Posts: 19
Joined: Wed Sep 23, 2020 4:01 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 12:20 pm

I have just upgrade to v7.1beta4 from v6.48 on an Nray and the bandwidth speed test is not working any more.

Regards
Paul
You do not have the required permissions to view the files attached to this post.
 
hecatae
just joined
Posts: 6
Joined: Thu May 21, 2020 2:34 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 12:22 pm

I have just upgrade to v7.1beta4 from v6.48 on an Nray and the bandwidth speed test is not working any more.

Regards
Paul
Please follow this thread for bug reporting: viewtopic.php?f=1&t=152006
 
kamillo
Member Candidate
Member Candidate
Posts: 167
Joined: Tue Jul 15, 2014 5:44 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 12:26 pm

@normis, can the https://help.mikrotik.com/docs/display/ ... col+Status be updated to reflect any changes in beta4?
 
Manfred
just joined
Posts: 9
Joined: Wed Feb 06, 2013 3:45 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 12:52 pm

Updated a RB2011 and a Chateau LTE12 from Beta3 to Beta4.
A small Bug is introduced in Beta4::
If anything in "ip/routes" is changed ( modify, add, ... ), only a "by admin" appears in the Log - Window in the Message - Tab.
Missing what has been done !
 
User avatar
eworm
Forum Veteran
Forum Veteran
Posts: 755
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 1:04 pm

*) api - added support for REST API;
With this being added... How about a JSON parser within RouterOS? This would allow one device to call another device's REST API.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 1:05 pm

Looks like export still hangs...
Indeed. Downloaded the .ova for CHR, installed on VMware ESXi 6.7u3, start the VM, type /export, instaneous hangup.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 1:06 pm

Updated a RB2011 and a Chateau LTE12 from Beta3 to Beta4.
A small Bug is introduced in Beta4::
If anything in "ip/routes" is changed ( modify, add, ... ), only a "by admin" appears in the Log - Window in the Message - Tab.
Missing what has been done !
That is not introduced in beta4, this bug has been in v7 from the beginning.
 
User avatar
GreySer
just joined
Posts: 20
Joined: Thu Apr 21, 2016 9:38 am
Location: Cheboksary

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 2:15 pm

Updated RB3011 from ROS7 beta3 to beta 4. Circle reboot...
loading kernel... OK
setting up elf image... OK
jumping to kernel code
opendir: No such file or directory
ERROR: no system package found!
Kernel panic - not syncing: Attempted to kill init! exitcode=0x000000CPU: 1 PID: 1 Comm: init Not tainted 5.6.3 #35
Hardware name: RB3011
{bf05ff2c} _stext+0x97a4/0x432b28
{bf05ff34} _stext+0x41f2a0/0x432b28
{bf05ff44} _stext+0x19a98/0x432b28
{bf05ff6c} _stext+0x1b8c8/0x432b28
{bf05ff84} _stext+0x1c9dc/0x432b28
{bf05ff9c} _stext+0x1ca4c/0x432b28
CPU0: stopping
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.6.3 #35
Hardware name: RB3011
{80901f04} _stext+0x97a4/0x432b28
{80901f0c} _stext+0x41f2a0/0x432b28
{80901f1c} _stext+0xbef0/0x432b28
{80901f34} _stext+0x1b2af4/0x432b28
{80901f4c} _stext+0x1acc/0x432b28
Exception stack(0x80901f50 to 0x80901f98)
1f40:                                     000cea30 00000000 000cea30 801142a0
1f60: 80900000 00000001 80903e24 80903e60 80824a38 512f04d0 10c5387d 00000000
1f80: 00000000 80901fa0 80106f60 80106f50 60000013 ffffffff
{80901f9c} _stext+0x6f50/0x432b28
{80901fa4} _stext+0x3a038/0x432b28
{80901fbc} _stext+0x3a2c8/0x432b28
{80901fc4} _sinittext+0x934/0x20d2c
Rebooting in 5 seconds..
Last edited by GreySer on Thu Feb 04, 2021 6:27 pm, edited 1 time in total.
 
bruins0437
just joined
Posts: 21
Joined: Thu Jul 13, 2017 4:30 am
Location: New Hampshire

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 3:01 pm

RB4011iGS+ updated from 7.1beta3 to 7.1beta4 with no problems.
 
tpedko
just joined
Posts: 10
Joined: Wed May 22, 2019 9:58 am

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 3:24 pm

RB4011iGS+ updated from 7.1beta3 to 7.1beta4 with no problems.
are simple queues set up?
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1326
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 3:46 pm

Really excited to see a REST API in this release. Thanks MT!
Global - MikroTik Support & Consulting - English | Español | Serbian | Danish +1 855-645-7684
https://iparchitechs.com/ecosystem/mikr ... consulting mikrotiksupport@iparchitechs.com
 
bruins0437
just joined
Posts: 21
Joined: Thu Jul 13, 2017 4:30 am
Location: New Hampshire

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 5:12 pm

RB4011iGS+ updated from 7.1beta3 to 7.1beta4 with no problems.
are simple queues set up?
I don't have simple queues setup, but I can try it.
 
ectoplasmosis
just joined
Posts: 11
Joined: Thu Nov 08, 2018 3:41 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 5:33 pm

Anyone upgraded their CRS317 yet?

Mine is working happily on 7.1beta2 with L3 hardware offloading enabled... Afraid to break things with this new beta!
 
mafiosa
Member Candidate
Member Candidate
Posts: 117
Joined: Fri Dec 09, 2016 8:10 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 5:43 pm

So we can now finally use winbox to configure BGP and OSPF?
 
Paternot
Forum Veteran
Forum Veteran
Posts: 802
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 5:50 pm

Finally a beta4! :D
No time to test it now: how is wireguard and BGP going?
 
WeWiNet
Long time Member
Long time Member
Posts: 522
Joined: Thu Sep 27, 2018 4:11 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 5:53 pm

Tried an upgrade on Chateau LTE12 (from 7beta3).
Device in boot loop and not possible to reset the device.
Will need to do a netinstall...
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? no way, finally I stay with 6.48! I am NOT crazy :lol: !!!
 
mafiosa
Member Candidate
Member Candidate
Posts: 117
Joined: Fri Dec 09, 2016 8:10 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 7:58 pm

Creating filters via winbox not working. Certain options in bgp crashes winbox. The AFI option in bgp templates in particular.
 
gtj0
just joined
Posts: 7
Joined: Wed Sep 23, 2020 8:08 pm

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 8:04 pm

NetMetal 5 922UAGS-5HPacT with an add-on R11e-2Hnd .. The 2.4 GHz radio isn't detected at all. This was an earlier issue that was fixed in Beta3 but now seems to be broken again. Supout sent.
 
User avatar
doneware
Trainer
Trainer
Posts: 599
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 8:41 pm

with REST API finally here a lot of possibilities are open at once. thank you!
(let me try one more thing)
#TR0359
 
User avatar
doneware
Trainer
Trainer
Posts: 599
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 8:46 pm

Normis, will it pe possible somehow to decouple REST from www-ssl in the future?
i definitely don't want to expose the web ui to everyone. and maybe a way to change the base URI for the REST API.
#TR0359
 
lcohen999
just joined
Posts: 12
Joined: Fri Oct 18, 2019 3:34 am

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 10:38 pm

Has anyone with an Audience tried this yet.

Beta3 always gave me a bootloop with a simple wireless access point only config (and the new wifiwave2)?


edit: Decided to jump in.

Upgrade went fine
added wave2, bootloop.
Factory reset by reset button to recover

Setup a bridge for all NIC/Wifi, thats it (audience is just my AC, I have a Hap AC in the basement)

So, compared to 6 brach, my 2x2 Surface 7+...

6.48, fast.com = 200mbps
7.1beta4..... 400mbps !

speedtest.net is about the same.

So I would say, great job on the wifi team. That is a MASSIVE improvement.

Lets see if the unit bootloops like beta3 did. If not....this Audience will stay happily on 7.1b4

Anyone also notice the size of the wave module is 1/2 the size?


edit: options for 5G AX are showing up too. I tried to select it but says no supported channels
Last edited by lcohen999 on Thu Feb 04, 2021 11:24 pm, edited 2 times in total.
 
User avatar
memelchenkov
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Re: v7.1beta4 [development] is released!

Thu Feb 04, 2021 11:22 pm

Tried an upgrade on Chateau LTE12 (from 7beta3).
Device in boot loop and not possible to reset the device.
Will need to do a netinstall...
Upgraded just fine from 7.1 pre-beta4. Did not tried to upgrade from beta3.
 
thadrumr
newbie
Posts: 31
Joined: Sat Dec 23, 2017 2:02 am

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 12:43 am

I tried an upgrade to my CHR version 7.1 beta 3 running on Hyper-V 2016 and it completely failed. I had to download a new CHR vhdx and boot from it. Luckily I was able to mount my old CHR VHDX as a secondary drive and I had an old backup file in there. Stupid me didn't forgot to take a snapshot. After the upgrade it said missing system upon boot.
 
krzysztof
newbie
Posts: 26
Joined: Sat Apr 25, 2015 7:46 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 2:37 am

In X86 v7.1 beta 3 the system doesn't boot,
In X86 v7.1 beta 4 the system doesn't boot,

In X86 v7.1beta2 system boot very well,
 
lcohen999
just joined
Posts: 12
Joined: Fri Oct 18, 2019 3:34 am

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 3:25 am

Kernel Panic on Audience

error while running customized default configuration script: expected end of command (line 1320 column 53)

Lets see how we do, seemed to recover this time...
 
thadrumr
newbie
Posts: 31
Joined: Sat Dec 23, 2017 2:02 am

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 4:25 am

Looks like CAKE is still causing a random reboot. The device remains stable when I disable CAKE. I setup a simple queue using cake and a target of my lan subnets like below.


/queue simple/pri
Flags: X - disabled, I - invalid; D - dynamic
0 X name="queue1" target=10.22.87.0/24,192.168.2.0/24 parent=none
packet-marks="" priority=1/1 queue=cake/cake limit-at=0/0
max-limit=12M/225M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
bucket-size=0.1/0.005 total-queue=hotspot-default

Here is how my Cake queue type is setup.

name="cake" kind=cake cake-bandwidth=0bps cake-overhead=0
cake-overhead-scheme="" cake-rtt=100ms cake-diffserv=diffserv4
cake-flowmode=triple-isolate cake-nat=no cake-wash=no cake-ack-filter=none
 
SrConfluente
just joined
Posts: 1
Joined: Wed Jan 27, 2021 2:47 am

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 5:05 am

Looks like CAKE is still causing a random reboot. The device remains stable when I disable CAKE. I setup a simple queue using cake and a target of my lan subnets like below.


/queue simple/pri
Flags: X - disabled, I - invalid; D - dynamic
0 X name="queue1" target=10.22.87.0/24,192.168.2.0/24 parent=none
packet-marks="" priority=1/1 queue=cake/cake limit-at=0/0
max-limit=12M/225M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
bucket-size=0.1/0.005 total-queue=hotspot-default

Here is how my Cake queue type is setup.

name="cake" kind=cake cake-bandwidth=0bps cake-overhead=0
cake-overhead-scheme="" cake-rtt=100ms cake-diffserv=diffserv4
cake-flowmode=triple-isolate cake-nat=no cake-wash=no cake-ack-filter=none
Can confirm. Had two kernel panics in HAP AC2, cake was the reason I updated but since sfq works I reverted to stable.
 
chubbs596
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Fri Dec 06, 2013 6:07 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 8:03 am

Creating filters via winbox not working. Certain options in bgp crashes winbox. The AFI option in bgp templates in particular.
I have seen the same issue with winbox crashing on some BGP menus
 
User avatar
FToms
MikroTik Support
MikroTik Support
Posts: 10
Joined: Fri Jul 24, 2020 3:28 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 8:20 am

edit: options for 5G AX are showing up too. I tried to select it but says no supported channels
Wireless standard support is limited by the capabilities of the hardware. You can find out, which bands an interface supports, by checking the 'Radios' section in WinBox, or running '/interface/wifiwave2/radio/print detail' in the CLI.
 
haedertowfeq
just joined
Posts: 3
Joined: Thu Nov 19, 2020 5:58 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 9:09 am

Looks like CAKE is still causing a random reboot. The device remains stable when I disable CAKE. I setup a simple queue using cake and a target of my lan subnets like below.


/queue simple/pri
Flags: X - disabled, I - invalid; D - dynamic
0 X name="queue1" target=10.22.87.0/24,192.168.2.0/24 parent=none
packet-marks="" priority=1/1 queue=cake/cake limit-at=0/0
max-limit=12M/225M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
bucket-size=0.1/0.005 total-queue=hotspot-default

Here is how my Cake queue type is setup.

name="cake" kind=cake cake-bandwidth=0bps cake-overhead=0
cake-overhead-scheme="" cake-rtt=100ms cake-diffserv=diffserv4
cake-flowmode=triple-isolate cake-nat=no cake-wash=no cake-ack-filter=none
My Hex S: CAKE random reboot
I setup queue tree with FQ_CoDel


تم الإرسال من Redmi Note 8 Pro باستخدام Tapatalk

 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1917
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 10:52 am

Looks like export still hangs...
Can confirm, tested on hAP ac^2 with clean and minimal configuration (around 20 lines)
# feb/05/2021 09:48:31 by RouterOS 7.1beta4
# software id = C38F-6NNH
#
# model = RBD52G-5HacD2HnD
# serial number = BEED0Bxxxxxx
/interface bridge
add name=bridge1 vlan-filtering=yes
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
set [ find default-name=wlan2 ] ssid=MikroTik
/interface list
add name=WAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/interface list member
add interface=ether1 list=WAN
/ip address
add address=172.16.0.1 interface=bridge1 network=255.255.255.0
/ip dhcp-client
add disabled=no interface=ether1
<--HANGS here-->
 
Why do not use Splunk to monitor your MikroTik Router(s)? Look at this page in how to set it up.

MikroTik->Splunk
 
 
User avatar
skylark
MikroTik Support
MikroTik Support
Posts: 139
Joined: Wed Feb 10, 2016 3:55 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 11:08 am

Please issues with unit reboot while using cake/codel/fq_codel queue types report to support@mikrotik.com with attaching supout.rif file right after the reboot.
 
User avatar
dreamind
just joined
Posts: 10
Joined: Thu Apr 18, 2013 9:15 pm
Location: Germany
Contact:

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 11:32 am

I still can't get routing filters to work, so that OSPF would pick up the default route. I tried the same under beta3, but there OSPF didn't seem to consider the filters at all.

Now with beta4, there is only:
/routing/filter/rule add chain=ospf_out rule=
.
There is no match-prfx-value or similar, as mentioned in the preliminary documentation: https://help.mikrotik.com/docs/display/ ... g+Examples
 
mafiosa
Member Candidate
Member Candidate
Posts: 117
Joined: Fri Dec 09, 2016 8:10 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 11:54 am

I still can't get routing filters to work, so that OSPF would pick up the default route. I tried the same under beta3, but there OSPF didn't seem to consider the filters at all.

Now with beta4, there is only:
/routing/filter/rule add chain=ospf_out rule=
.
There is no match-prfx-value or similar, as mentioned in the preliminary documentation: https://help.mikrotik.com/docs/display/ ... g+Examples
Yes exactly the reason why I stopped testing it yesterday.
 
User avatar
memelchenkov
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 12:17 pm

Chateau LTE12, /export works just fine. Please report to support everyone who has issues, that means the bug depends on your specific configuration, so Mikrotik should detect which config lines/firmware problems causes export failing.
 
WeWiNet
Long time Member
Long time Member
Posts: 522
Joined: Thu Sep 27, 2018 4:11 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 12:25 pm

Chateau LTE12, /export works just fine. Please report to support everyone who has issues, that means the bug depends on your specific configuration, so Mikrotik should detect which config lines/firmware problems causes export failing.
Chateau LTE12 : I had to do netinstall. Then again a rests to default to get "default". Then after did export, and stuck at the end of firewall export!!!
So not working on my box with default profile!!!
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? no way, finally I stay with 6.48! I am NOT crazy :lol: !!!
 
mafiosa
Member Candidate
Member Candidate
Posts: 117
Joined: Fri Dec 09, 2016 8:10 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 12:49 pm

Yes exactly the reason why I stopped testing it yesterday.
Just received reply from support that filters are being reworked and do not work as of now. Will never test betas again unless they don't mention what's know to be not working.
 
haedertowfeq
just joined
Posts: 3
Joined: Thu Nov 19, 2020 5:58 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 1:44 pm

Please issues with unit reboot while using cake/codel/fq_codel queue types report to support@mikrotik.com with attaching supout.rif file right after the reboot.
OK Image

تم الإرسال من Redmi Note 8 Pro باستخدام Tapatalk

 
mkx
Forum Guru
Forum Guru
Posts: 5414
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 2:54 pm

Will never test betas again ...

If you can't accept random things broken, then beta testing is not for you. No need to publicly announce that, we'll accept your decision regardless.
BR,
Metod
 
WeWiNet
Long time Member
Long time Member
Posts: 522
Joined: Thu Sep 27, 2018 4:11 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 2:59 pm

Mikrotik support: Now that Wifiwave2 package is usable within winbox, its adaptation will raise quickly and questions as well as feedback on the forum as well!

I heavily recommend you split out wifiwave2 package as a new forum topic so the feedback is not diluted in ROS7 generic thread.
Also ROS 7 users not using Wifiwave 2 have no benefit of wifiwav2 package discussion and bug reports!

Please do it, now.... I said now ;-). Please!
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? no way, finally I stay with 6.48! I am NOT crazy :lol: !!!
 
lcohen999
just joined
Posts: 12
Joined: Fri Oct 18, 2019 3:34 am

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 3:25 pm

edit: options for 5G AX are showing up too. I tried to select it but says no supported channels
Wireless standard support is limited by the capabilities of the hardware. You can find out, which bands an interface supports, by checking the 'Radios' section in WinBox, or running '/interface/wifiwave2/radio/print detail' in the CLI.
I know...I was somehow hoping the Audience supported it unmarket'ed

Thay said winbox shows it supports 80/160 and 80/+80 but selecting those game me the same error

Also, it says I am locked on United States 3...I have my country setup as Canada
 
thadrumr
newbie
Posts: 31
Joined: Sat Dec 23, 2017 2:02 am

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 3:38 pm

I sent support an e-mail with my attached rif just after a crash which seems to be relate to CAKE. Hopefully support can decode the rif file and see what happened.
 
MarcSN
just joined
Posts: 8
Joined: Wed Jul 01, 2020 7:18 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 4:57 pm

Anyone also notice the size of the wave module is 1/2 the size?
Sadly still too big.. I have 2 WAP R acs, they report having 256MB of RAM and an IPQ4019 WIFI interface ( which doesn't conform to the specifications from the mikrotik website?! ) but only 16 MB of storage :(
The Package includes 6 diffrent firmwares and the IPQ4019 firmware is only 1,3 MB. The others amount to 15,4 MB, so a packege specific to the IPQ4019 without the other stuff would probably fit.
 
gtj0
just joined
Posts: 7
Joined: Wed Sep 23, 2020 8:08 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 5:08 pm

Chateau LTE12, /export works just fine. Please report to support everyone who has issues, that means the bug depends on your specific configuration, so Mikrotik should detect which config lines/firmware problems causes export failing.
Chateau LTE12 : I had to do netinstall. Then again a rests to default to get "default". Then after did export, and stuck at the end of firewall export!!!
So not working on my box with default profile!!!
Indeed. It now hangs at "/routing table" which would come just after ipv6
[admin@sw04] > /routing export        
# feb/05/2021 08:03:23 by RouterOS 7.1beta4
# software id = NSGG-UDD1
#
# model = RouterBOARD 750G r2
# serial number = 64FC05EEE051
/routing table
add fib name=""
#interrupted
[admin@sw04] > 
Supout sent
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 5:45 pm

Chateau LTE12, /export works just fine. Please report to support everyone who has issues, that means the bug depends on your specific configuration, so Mikrotik should detect which config lines/firmware problems causes export failing.
That is why I mentioned: I loaded it on a CHR, starting with default configuration (which is almost nothing on a CHR!) and then it already hangs.
Just like Jotne showed with a much larger configuration: after the IP dhcp-client line.
Without working /export there is little incentive for me to test further, as I cannot backup configuration to the repository I use for that, so I cannot track my changes.
(which would help when finding problems during testing)
 
lcohen999
just joined
Posts: 12
Joined: Fri Oct 18, 2019 3:34 am

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 5:59 pm

...and 24 hours from install, (2 random reboots later) 5GHz antenna just stopped working.

Disabling and re-enabling didn't fix it. Nothing noted in the log. Had to reboot
 
nemoforum
newbie
Posts: 44
Joined: Thu Jan 05, 2017 11:08 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 9:34 pm

Got bootloop after upgrade 7.1b3 ->7.1b4 on my hAP ac2.
Had to netinstall 7.1b4 with configuration reset, then applied the backup (from 7.1b3).
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 113
Joined: Wed Aug 09, 2017 1:15 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 10:13 pm

I can't get more than one peer per wireguard instance working at the time.
After a reboot the first client connecting "wins", all other don't receive traffic.
Multiple instances with just one peer each seem to work simultaneously.
 
mducharme
Trainer
Trainer
Posts: 1144
Joined: Tue Jul 19, 2016 6:45 pm

Re: v7.1beta4 [development] is released!

Fri Feb 05, 2021 10:50 pm

EoIP is still not working with keepalive enabled.
 
User avatar
rooted
Member Candidate
Member Candidate
Posts: 125
Joined: Tue Feb 04, 2020 5:58 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 3:35 am


so a packege specific to the IPQ4019 without the other stuff would probably fit.
I'm hoping to see this as well, it makes sense.
 
nevolex
Member Candidate
Member Candidate
Posts: 108
Joined: Mon Apr 20, 2020 1:09 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 3:46 am

winbox - added support for wifiwave2;

do we still need an external driver for that, or is it now integrated into the ros?
 
nannou9
newbie
Posts: 33
Joined: Tue Nov 10, 2020 9:56 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 9:33 am

Audience ros 7.1b4 wifiwave2, factory reset after upgrade to b4 from b3.
Tested Wifi3- QCA9984

Wifi reconnection problem is fixed in b4- thanks!
However now after less than 1h all my devices disconnect and can’t connect anymore and reboot is needed.
There is absolutely nothing in logs which would indicate any problem. Even no unsuccessful authentication or anything. WiFi however is still advertised by the ap, just can’t join.
This seems to be happening regardless of amount of devices connected to WiFi (tested 2-15).
Using mostly apple devices.

/interface bridge
add name=bridge-vlan1000 vlan-filtering=yes
/interface wifiwave2
add disabled=yes mac-address=74:4D:28:F4:F1:B3 name=wifi1
add disabled=yes mac-address=74:4D:28:F4:F1:B4 name=wifi2
add band=5ghz-ac channel-width=20/40/80mhz disabled=no mac-address=\
    74:4D:28:F4:F1:B5 mode=ap name=wifi3 security.authentication-types=wpa3-psk \
    ssid="Mikro"
/interface vlan
add interface=bridge-vlan1000 name=vlan1000 vlan-id=1000
/interface bridge port
add bridge=bridge-vlan1000 frame-types=admit-only-vlan-tagged interface=ether1
add bridge=bridge-vlan1000 interface=ether2 pvid=1000
add bridge=bridge-vlan1000 interface=wifi3 pvid=1000
/interface bridge vlan
add bridge=bridge-vlan1000 tagged=bridge-vlan1000,ether1 untagged=ether2,wifi3 \
    vlan-ids=1000
add bridge=bridge-vlan1000 tagged=ether2,ether1 vlan-ids=1003
/ip dhcp-client
add disabled=no interface=vlan1000
Edit
When My clients can’t connect I have notice that winbox is showing the wifivave interface status (in status tab, not on the interface list) as state disabled and channel empty.
However the interface itself is showing as enabled.
Also disabling and reenabling makes no difference. Only restart works.
Last edited by nannou9 on Sat Feb 06, 2021 10:41 pm, edited 4 times in total.
 
notToNew
Member Candidate
Member Candidate
Posts: 173
Joined: Fri Feb 19, 2016 3:15 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 10:12 am

hm, my Wireguard config stopped working after Update from beta3 to beta4.
didn't find a reason, the Log is empty.
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
 
nannou9
newbie
Posts: 33
Joined: Tue Nov 10, 2020 9:56 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 11:27 am

Has anybody managed to actually ever save any config change for wifivawe in web ui ? I am getting error saying that exactly one must be set: Mac or master. But I have mac only set through cli, but UI tries to set master each time as there is no disabled/blank option.
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 2:53 pm

update works so good
You do not have the required permissions to view the files attached to this post.
 
Quasar
just joined
Posts: 23
Joined: Sun Oct 05, 2014 1:11 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 3:20 pm

*) api - added support for REST API;
Nice! For anyone giving it a spin: do note that it's on the www-ssl service - I spent some time wondering why api-ssl wasn't responding to my HTTP requests..
 
lcohen999
just joined
Posts: 12
Joined: Fri Oct 18, 2019 3:34 am

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 4:39 pm

Audience ros 7.1b4 wifiwave2, factory reset after upgrade to b4 from b3.
Tested Wifi3- QCA9984

Wifi reconnection problem is fixed in b4- thanks!
However now after less than 1h all my devices disconnect and can’t connect anymore and reboot is needed.
There is absolutely nothing in logs which would indicate any problem. Even no unsuccessful authentication or anything. WiFi hover is still advertised by the ap, just can’t join.
This seems to be happening regardless of amount of devices connected to WiFi (tested 2-15).
Using mostly apple devices.

/interface bridge
add name=bridge-vlan1000 vlan-filtering=yes
/interface wifiwave2
add disabled=yes mac-address=74:4D:28:F4:F1:B3 name=wifi1
add disabled=yes mac-address=74:4D:28:F4:F1:B4 name=wifi2
add band=5ghz-ac channel-width=20/40/80mhz disabled=no mac-address=\
    74:4D:28:F4:F1:B5 mode=ap name=wifi3 security.authentication-types=wpa3-psk \
    ssid="Mikro"
/interface vlan
add interface=bridge-vlan1000 name=vlan1000 vlan-id=1000
/interface bridge port
add bridge=bridge-vlan1000 frame-types=admit-only-vlan-tagged interface=ether1
add bridge=bridge-vlan1000 interface=ether2 pvid=1000
add bridge=bridge-vlan1000 interface=wifi3 pvid=1000
/interface bridge vlan
add bridge=bridge-vlan1000 tagged=bridge-vlan1000,ether1 untagged=ether2,wifi3 \
    vlan-ids=1000
add bridge=bridge-vlan1000 tagged=ether2,ether1 vlan-ids=1003
/ip dhcp-client
add disabled=no interface=vlan1000
Try using the mesh 5g antenna. It seems to stable for me and not have the regular one just die (I had the same thing happen)
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 8:49 pm

seems like cake does not work as good as in beta3.
 
mducharme
Trainer
Trainer
Posts: 1144
Joined: Tue Jul 19, 2016 6:45 pm

Re: v7.1beta4 [development] is released!

Sat Feb 06, 2021 10:15 pm

Does wifiwave2 have bridging support yet? I tried it on my audience in beta3 a few months ago and it seemed to work, but the issue was that I need to use the 5GHz uplink radio on the audience to get back to my main router and this bridging did not work (no equivalent of station bridge or wds).
 
User avatar
FToms
MikroTik Support
MikroTik Support
Posts: 10
Joined: Fri Jul 24, 2020 3:28 pm

Re: v7.1beta4 [development] is released!

Mon Feb 08, 2021 8:49 am

Does wifiwave2 have bridging support yet? I tried it on my audience in beta3 a few months ago and it seemed to work, but the issue was that I need to use the 5GHz uplink radio on the audience to get back to my main router and this bridging did not work (no equivalent of station bridge or wds).
4-address operation mode required for station bridging is not currently supported with wifiwave2.
 
User avatar
FToms
MikroTik Support
MikroTik Support
Posts: 10
Joined: Fri Jul 24, 2020 3:28 pm

Re: v7.1beta4 [development] is released!

Mon Feb 08, 2021 10:23 am

Has anybody managed to actually ever save any config change for wifivawe in web ui ? I am getting error saying that exactly one must be set: Mac or master. But I have mac only set through cli, but UI tries to set master each time as there is no disabled/blank option.
The WebFig interface for wifiwave2 is not yet usable. Hence why it was omitted from the changelog. It is only accessible because WebFig and WinBox share the same back end.
 
User avatar
genesispro
Member Candidate
Member Candidate
Posts: 156
Joined: Fri Mar 14, 2014 12:33 pm

Re: v7.1beta4 [development] is released!

Mon Feb 08, 2021 10:26 am

any plan for dude v7?
Mikrotik Rulez
 
nemoforum
newbie
Posts: 44
Joined: Thu Jan 05, 2017 11:08 pm

Re: v7.1beta4 [development] is released!

Mon Feb 08, 2021 12:33 pm

Will wave2 driver support features like no_country_set, superchannel and so on? Or the new wave2 driver is provided by the vendor and there are no customisation options?
 
WeWiNet
Long time Member
Long time Member
Posts: 522
Joined: Thu Sep 27, 2018 4:11 pm

Re: v7.1beta4 [development] is released!

Mon Feb 08, 2021 12:59 pm

WifiWave2 on RB4011:
What is the performance one should see/expect with it?
test set up with no other 5Ghz AP (running iperf3 on 1G ethernet connected computer), distance 2-3 meter between AP and Client:
(using 160Mhz as well as 80Mhz)

- Macbook Pro, 3x3 11ac 80Mhz: ~480mbps
- laptop Intel 11ac 6200 160Mhz: ~480mbps (showing 160Mhz usage and phy rate of 1700mbps!!! in UL/DL)
- Samsung S20 2x2 11ac: ~480mbps

This is almost less than what I get with the normal wifi package. And 80Mhz client sees same speed as 160Mhz client.
Fully cabled iperf3 test peaks at 970mbps as expected so not a setup problem.

Is this throughput what you should expect with this package?
Please those using wifiwave2, can you share data?

Positive: WPA3 is well working!
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? no way, finally I stay with 6.48! I am NOT crazy :lol: !!!
 
McShadow
just joined
Posts: 1
Joined: Mon Feb 08, 2021 3:19 pm

Re: v7.1beta4 [development] is released!

Mon Feb 08, 2021 3:25 pm

Looks like export still hangs...
It sadly does.
I tried it with Chateau LTE12 7.1beta4 (ARM).

Export now stops on /routing/pimsm.

- McShadow
 
nemoforum
newbie
Posts: 44
Joined: Thu Jan 05, 2017 11:08 pm

Re: v7.1beta4 [development] is released!

Mon Feb 08, 2021 10:39 pm

Regarding /routing/export :
2021-02-08_22-38.png
You do not have the required permissions to view the files attached to this post.
 
TimurA
Member Candidate
Member Candidate
Posts: 199
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: v7.1beta4 [development] is released!

Mon Feb 08, 2021 10:50 pm

Positive: WPA3 is well working!
no him there :), but the problem is in ipv6, the connection state does not work, it will need to remove the check for the established and relayed to the forward.
ImageImage
 
User avatar
EnverS
just joined
Posts: 11
Joined: Wed Feb 13, 2019 11:19 pm

Re: v7.1beta4 [development] is released!

Tue Feb 09, 2021 2:24 am

Looks like export still hangs...
Yep, can not see the full config still..
 
User avatar
EnverS
just joined
Posts: 11
Joined: Wed Feb 13, 2019 11:19 pm

Re: v7.1beta4 [development] is released!

Tue Feb 09, 2021 2:31 am

RouterOS version 7.1beta4 has been released in public "development" channel!

What's new in 7.1beta4 (2021-Feb-03 09:39):

*) api - added support for REST API;
*) crs3xx - fixed Layer3 hardware offloading;
*) route - routing rules improvements;
*) winbox - added support for wifiwave2;
*) winbox - updated User Manager, OSPF and BGP menus;
*) wifiwave2 - authentication and functionality improvements;
*) other fixes and improvements;

All released RouterOS v7 changelogs are available here:
https://mikrotik.com/download/changelog ... lease-tree

How to report RouterOS v7 bugs:
viewtopic.php?f=1&t=152006
Hello,
are there any plans to add some examples of EAP authentication for wireless with certificates TLS/TTLS and 802.1X port based authentication with new user-manager?
Winbox already shows new user-manager.
Can we get wiki update on these features with some initial examples of usage?
We want to see and use new MT radius server in action.

Regards.
Enver.
 
User avatar
genesispro
Member Candidate
Member Candidate
Posts: 156
Joined: Fri Mar 14, 2014 12:33 pm

Re: v7.1beta4 [development] is released!

Tue Feb 09, 2021 10:57 am

I get
L2TP connection rejected no IPsec encryption while it was required
towards 1/5 vpn servers that I need to connect.
It is connecting to the other 4/5 servers also l2tp/ipsec based.
It has been working before.
I also tried to update the vpn server that doesn't accept it to latest beta (6.49beta11) but still it will throw this error.
If I change ipsec from required to yes it connects immediately.
Other clients (v6) connect to this server fine.
If I enter a wrong ipsec password to the client it throws wrong password error. The moment the password is correct it fails with
L2TP connection rejected no IPsec encryption while it was required

Did anyone else had it/resolved it?
Mikrotik Rulez
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Tue Feb 09, 2021 11:22 am

L2TP/IPsec often has a timing problem because when the IPsec association has not yet been established, an unencrypted L2TP packet may leak out and establish the connection, which is then rejected.
You can avoid such problems using a firewall rule, e.g. on the server:
/ip firewall filter
add action=accept chain=input comment=Established/Related connection-state=\
    established,related
add action=accept chain=input comment=L2TP/IPsec dst-port=1701 \
    ipsec-policy=in,ipsec protocol=udp
add action=reject chain=input comment="L2TP no IPsec" dst-port=1701 log=\
    yes log-prefix=l2tp protocol=udp reject-with=icmp-port-unreachable
(of course you will have more rules than that)
 
notToNew
Member Candidate
Member Candidate
Posts: 173
Joined: Fri Feb 19, 2016 3:15 pm

Re: v7.1beta4 [development] is released!

Tue Feb 09, 2021 12:51 pm

after Upgrade, vrrp between 6.48.1 and 7.1b4 does not work. Both Devices are always Master. downgrading solved it.
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
 
tpedko
just joined
Posts: 10
Joined: Wed May 22, 2019 9:58 am

Re: v7.1beta4 [development] is released!

Tue Feb 09, 2021 2:02 pm

Audiense+LTE show in interface new FW version.
fw_version.png
but install latest version
fw_version2.png
And log show error
reset_conf.png
You do not have the required permissions to view the files attached to this post.
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Tue Feb 09, 2021 3:55 pm

/export hangs.

Copyright needs 2021 update too
You do not have the required permissions to view the files attached to this post.
 
User avatar
Nevon
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Thu Sep 05, 2013 6:06 pm
Location: Sweden
Contact:

Re: v7.1beta4 [development] is released!

Tue Feb 09, 2021 10:19 pm

Hi wonder if someone can help me.
Trying to setup a iBGP IPV6 between a ROS6.46.8 to ROS7b4 router. ROS6 router has full table but I dont get it to share the routes. I have already IPv4 workin..
----------------------------------------------------------------------------
PEMA Kommunikationer AB
Vårgårda - Sweden
AS207448
----------------------------------------------------------------------------
 
User avatar
miguelangelfelix
Trainer
Trainer
Posts: 17
Joined: Tue May 19, 2009 7:32 am
Location: Los Mochis Sinaloa
Contact:

Re: v7.1beta4 [development] is released!

Wed Feb 10, 2021 10:43 am

So... Where can i set rpki filter ROAs validation??? I can't find "match-rpki" filter option i could use on v7.1beta3 RouterOS Version




[admin@MikroTik] > routing/filter/rule/

.. -- go up to filter
add -- Create a new item
disable -- Disable items
edit --
enable -- Enable items
export -- Print or save an export script that can be used to restore configuration
find -- Find items by value
get -- Gets value of item's property
move -- Change order of items
print -- Print values of item properties
remove -- Remove item
reset --
set -- Change item properties


[admin@MikroTik] > routing/filter/rule/add
Creates new item with specified property values.

chain --
copy-from -- Item number
disabled -- Defines whether item is ignored or used
place-before -- Item number
rule --


[admin@MikroTik] > routing/filter/rule/add rule=

Rule -- string value


[admin@MikroTik] > routing/filter/rule/add rule=
 
rpingar
Long time Member
Long time Member
Posts: 563
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.1beta4 [development] is released!

Wed Feb 10, 2021 11:04 am

So... Where can i set rpki filter ROAs validation??? I can't find "match-rpki" filter option i could use on v7.1beta3 RouterOS Version




[admin@MikroTik] > routing/filter/rule/

.. -- go up to filter
add -- Create a new item
disable -- Disable items
edit --
enable -- Enable items
export -- Print or save an export script that can be used to restore configuration
find -- Find items by value
get -- Gets value of item's property
move -- Change order of items
print -- Print values of item properties
remove -- Remove item
reset --
set -- Change item properties


[admin@MikroTik] > routing/filter/rule/add
Creates new item with specified property values.

chain --
copy-from -- Item number
disabled -- Defines whether item is ignored or used
place-before -- Item number
rule --


[admin@MikroTik] > routing/filter/rule/add rule=

Rule -- string value


[admin@MikroTik] > routing/filter/rule/add rule=
+1
 
mafiosa
Member Candidate
Member Candidate
Posts: 117
Joined: Fri Dec 09, 2016 8:10 pm

Re: v7.1beta4 [development] is released!

Wed Feb 10, 2021 12:44 pm

So... Where can i set rpki filter ROAs validation??? I can't find "match-rpki" filter option i could use on v7.1beta3 RouterOS Version




[admin@MikroTik] > routing/filter/rule/

.. -- go up to filter
add -- Create a new item
disable -- Disable items
edit --
enable -- Enable items
export -- Print or save an export script that can be used to restore configuration
find -- Find items by value
get -- Gets value of item's property
move -- Change order of items
print -- Print values of item properties
remove -- Remove item
reset --
set -- Change item properties


[admin@MikroTik] > routing/filter/rule/add
Creates new item with specified property values.

chain --
copy-from -- Item number
disabled -- Defines whether item is ignored or used
place-before -- Item number
rule --


[admin@MikroTik] > routing/filter/rule/add rule=

Rule -- string value


[admin@MikroTik] > routing/filter/rule/add rule=
Bgp filters don't work as per support email reply.
 
OlofL
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Mon Oct 12, 2015 2:37 pm

Re: v7.1beta4 [development] is released!

Wed Feb 10, 2021 8:40 pm

BUG Report:

When reporting an issue, please follow this template:
Version number (if the issue is upgrade related, specify which version was installed before as well);
Has the /system routerboard command changed name or been removed btw?
[admin@MikroTik] > /system/package/update/print
            channel: stable
  installed-version: 7.1beta4
Router's model;
"Cloud hosted router" using the .IMG file, in GNS3 with default settings.

Steps to reproduce the issue;
Boot router, login, and then type
/export
....

[admin@MikroTik] > /export
# feb/10/2021 18:36:27 by RouterOS 7.1beta4
# software id =
#
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-client
add disabled=no interface=ether1
#interrupted <----- (ctrl+c was pressed here)

in console, and it will hang until ctrl+c
 
OlofL
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Mon Oct 12, 2015 2:37 pm

Re: v7.1beta4 [development] is released!

Wed Feb 10, 2021 8:45 pm

BUG report:

v7.1beta4, using GNS3 with CHR IMG file. Same setup as post above. These bugs are probably related.


The export command does not exist under.
/routing ospf
or
/routing bgp
They where available in RouterOS v6.

However, /routing export exists, but it hangs.
[admin@MikroTik] /routing/ospf> export
bad command name export (line 1 column 1)
[admin@MikroTik] /routing/ospf>
area  instance  interface  interface-template  lsa  neighbor  static-neighbor
[admin@MikroTik] /routing/ospf> ..export
# feb/10/2021 18:43:11 by RouterOS 7.1beta4
# software id =
#
#interrupted <--- press ctrl+c because it hangs.
 
rpress
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 07, 2009 5:13 am

Re: v7.1beta4 [development] is released!

Thu Feb 11, 2021 1:17 pm

Upgraded from CHR v7.1beta2 to beta4. Pings to the router are taking 500-1500ms, lots of packet loss. If I try to disable an interface the router reboots.

Still has the same problem I had before: viewtopic.php?f=1&t=165022
 
User avatar
FToms
MikroTik Support
MikroTik Support
Posts: 10
Joined: Fri Jul 24, 2020 3:28 pm

Re: v7.1beta4 [development] is released!

Fri Feb 12, 2021 11:08 am


However now after less than 1h all my devices disconnect and can’t connect anymore and reboot is needed.
There is absolutely nothing in logs which would indicate any problem. Even no unsuccessful authentication or anything. WiFi however is still advertised by the ap, just can’t join.
This seems to be happening regardless of amount of devices connected to WiFi (tested 2-15).
Thank you for this report. The cause of this issue has been identified and will be fixed in the next release.
In the meantime, a workaround for it would be connecting no more than 1 WPA3 authenticated client device per interface (you can create additional virtual APs to connect more than 1 WPA3 client to the same radio).
 
nannou9
newbie
Posts: 33
Joined: Tue Nov 10, 2020 9:56 pm

Re: v7.1beta4 [development] is released!

Fri Feb 12, 2021 4:13 pm


However now after less than 1h all my devices disconnect and can’t connect anymore and reboot is needed.
There is absolutely nothing in logs which would indicate any problem. Even no unsuccessful authentication or anything. WiFi however is still advertised by the ap, just can’t join.
This seems to be happening regardless of amount of devices connected to WiFi (tested 2-15).
Thank you for this report. The cause of this issue has been identified and will be fixed in the next release.
In the meantime, a workaround for it would be connecting no more than 1 WPA3 authenticated client device per interface (you can create additional virtual APs to connect more than 1 WPA3 client to the same radio).
Great! Thanks for the workaround. This is exactly what I was hoping for. I am running multiple clients with wpa2 only and no problems for 2 hours now.
 
nannou9
newbie
Posts: 33
Joined: Tue Nov 10, 2020 9:56 pm

Re: v7.1beta4 [development] is released!

Fri Feb 12, 2021 10:07 pm

Wifiwave2 frequencies for UK are incomplete.
According to Ofcom (UK regulator), frequencies between 5725-5850 MHz do not require DFS and are available for indoor WiFi.
Currently they are not available for UK in MikroTik devices.
More details: https://www.ofcom.org.uk/consultations- ... -for-wi-fi
 
bozko
just joined
Posts: 7
Joined: Wed Nov 13, 2019 3:06 pm

Re: v7.1beta4 [development] is released!

Fri Feb 12, 2021 10:47 pm

export hanging is a huge problem to evaluate 7.xy beta

IMHO first priority should be fixing export issue
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Fri Feb 12, 2021 11:46 pm

The chicken egg problem: they request a /export for reporting bugs - but /export hangs....
 
User avatar
eworm
Forum Veteran
Forum Veteran
Posts: 755
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v7.1beta4 [development] is released!

Sat Feb 13, 2021 1:09 am

export hanging is a huge problem to evaluate 7.xy beta

IMHO first priority should be fixing export issue
Full ACK! I do not even consider testing before this is fixed.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
nannou9
newbie
Posts: 33
Joined: Tue Nov 10, 2020 9:56 pm

Re: v7.1beta4 [development] is released!

Sat Feb 13, 2021 1:30 am

In previous betas it was actually completing but after very long time, like 20m. Assuming it is simply still the case.
I have been doing exports myself too and I do not consider this a blocker as others are suggesting.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Sat Feb 13, 2021 12:37 pm

How do you want to run a test scenario, document the configuration used during testing, and report problems to MikroTik when you cannot do a /export ???
I have started a /export command now to see if it will ever complete.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8526
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v7.1beta4 [development] is released!

Sat Feb 13, 2021 2:13 pm

I have started a /export command now to see if it will ever complete.
Is it still exporting?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Sat Feb 13, 2021 2:46 pm

No, indeed it terminated after some time and completed the export, and also generated an autosuport.old.rif and autosupout.rif (spaced 10 minutes in time)
I guess indeed it first did some part of the export, then hang for ~10 minutes, dumped an autosupout.rif and continued, hang again for ~10 minutes, dumped another autosupout.rif (renaming the first to autosupout.old.rif) and then completed.
The resulting export looks OK.

But it is a bit of a tedious way to do exports...
 
wiresnarg
just joined
Posts: 3
Joined: Sun Feb 14, 2021 12:37 am

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 12:56 am

No, indeed it terminated after some time and completed the export,
I guess indeed it first did some part of the export, then hang for ~10 minutes,
The resulting export looks OK.
This matches my exact experience on 2011UiAS-2HnD.

routerboard: yes
model: 2011UiAS-2HnD
serial-number:
firmware-type: ar9344
factory-firmware: 3.24
current-firmware: 7.1beta4
upgrade-firmware: 7.1beta4

That said, thank you for working on RouterOS 7 !
 
wiresnarg
just joined
Posts: 3
Joined: Sun Feb 14, 2021 12:37 am

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 12:09 pm

No, indeed it terminated after some time and completed the export,
I guess indeed it first did some part of the export, then hang for ~10 minutes,
The resulting export looks OK.
This matches my exact experience on 2011UiAS-2HnD.

routerboard: yes
model: 2011UiAS-2HnD
serial-number:
firmware-type: ar9344
factory-firmware: 3.24
current-firmware: 7.1beta4
upgrade-firmware: 7.1beta4

That said, thank you for working on RouterOS 7 !
Follow up:
I noticed that verbose exports are considerably faster. Can someone else confirm that?
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 12:48 pm

Follow up:
I noticed that verbose exports are considerably faster. Can someone else confirm that?
You are right! /export verbose works correctly, only when verbose is omitted it is slow and generates crashdumps.
 
mkx
Forum Guru
Forum Guru
Posts: 5414
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 12:57 pm

I wish MT acknowledged the problem so that not everybody (and their dog) reports it as some great discovery.
It would be even better if the problem was fixed ASAP even though this problem probably doesn't affect normal device operation.
BR,
Metod
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 2:40 pm

I wish MT acknowledged the problem so that not everybody (and their dog) reports it as some great discovery.
Did you know that /export verbose works when /export doesn't? For me that was a great discovery!
 
User avatar
CTassisF
just joined
Posts: 2
Joined: Thu Jun 11, 2020 10:26 pm
Location: São Paulo, Brazil
Contact:

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 4:39 pm

If you disable watchdog automatic-supout will /export work faster? I guess that might work because the autosupout.rif file won't be generated, but I'm not on v7 right now to be able to test it myself.
 
mkx
Forum Guru
Forum Guru
Posts: 5414
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 5:41 pm

Did you know that /export verbose works when /export doesn't? For me that was a great discovery!
No, I did not and I agree it's worth mentioning. However, issue with running export (without any options) had been reported many times so far it's really stale by now and because it did not get fixed it's still reported over and over again. Surely it's not the only issue with current beta release but reports of other issues seem to be almost non-existent right now compared to the amount of complaints about export bug ...

BTW, I'm not running beta ... when I tried a year ago I found out 7.0beta did not work with VLANs configured directly on AR8327 switch chip (configuration went without any error message), I reported the issue on this forum which apparently received zero attention (both by devs and forum members). I'm following betas, however release notes so far did not mention anything about the issue I had (and unlike some others I'm not constantly bitching about it). Some time I'll install then-current beta to see myself if something changed with respect to my issue but I don't know when that'll be. I can see there are bigger and more important issues open in v7 beta, but for me "my" issue is a show stopper.
BR,
Metod
 
krzysztof
newbie
Posts: 26
Joined: Sat Apr 25, 2015 7:46 pm

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 6:31 pm

In X86 v7.1 beta 4 doesn't boot. I tried many times on different platforms and always the same. The system freezes while booting.
In X86 v7.1 beta 3 also does not start.
Starts Well In X86 v7.1 beta 2

When will you correct this mistake?
I am waiting impatiently when it boots to x86.
Last edited by krzysztof on Sun Feb 14, 2021 8:56 pm, edited 1 time in total.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8526
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 7:15 pm

I run CHR v7.1 beta 4 in Oracle Cloud. It's x86 and it does work.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 9:15 pm

No, I did not and I agree it's worth mentioning. However, issue with running export (without any options) had been reported many times so far it's really stale by now and because it did not get fixed it's still reported over and over again.
Yes it is a blocking issue for many. However I agree that people should read the release topic before adding their comment. It helps avoiding such duplicate reports.
BTW, I'm not running beta ...
I am not running it on router hardware but only in a CHR to experiment and see which new features appear that could be useful.
By testing early I hope the most obvious bugs will be resolved and missing features are added before I test it on a real router.
 
ib254254
just joined
Posts: 13
Joined: Sat Nov 21, 2020 10:15 pm

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 9:31 pm

1350 Mbps Wireless Performance. very stable. It is the highest Wireless Test results Best with MikroTik.

RouterOS v7.1beta4 and wifiwave2 performance test result;
You do not have the required permissions to view the files attached to this post.
 
bozko
just joined
Posts: 7
Joined: Wed Nov 13, 2019 3:06 pm

Re: v7.1beta4 [development] is released!

Sun Feb 14, 2021 11:02 pm

/export verbose 
just works!

Why don't you (mods/admins) add this very valuable info in first post?
 
nehmefadi
just joined
Posts: 1
Joined: Mon Feb 15, 2021 2:29 am

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 2:39 am

I have just upgrade to v7.1beta4
my rb 1009 reboot every 8 min when i put 100 pppoe users
i have tried the setup on different hardware same issue
thank you
 
cxcool
just joined
Posts: 2
Joined: Sun May 12, 2019 5:13 am

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 7:51 am

gre tunnel are borken ...down grade to 6.xx works immediately
 
rpingar
Long time Member
Long time Member
Posts: 563
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 9:13 am

In X86 v7.1 beta 4 doesn't boot. I tried many times on different platforms and always the same. The system freezes while booting.
In X86 v7.1 beta 3 also does not start.
Starts Well In X86 v7.1 beta 2

When will you correct this mistake?
I am waiting impatiently when it boots to x86.
use cd-iso 7.0beta5 (the last one that works) choosing legacy bios (and setup legacy boot in bios).
Then upgrade using the packages to 7.1beta4.
It was the only way it worked for me.
regards
Ros
 
User avatar
karlisi
Member
Member
Posts: 351
Joined: Mon May 31, 2004 8:09 am
Location: Latvia

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 11:07 am

In previous betas it was actually completing but after very long time, like 20m.
Actually without 'verbose' it takes exactly 20min. Very interesting.
---
Karlis
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 11:36 am

gre tunnel are borken ...down grade to 6.xx works immediately
This is known. Disable keepalive at both ends.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 11:38 am

In previous betas it was actually completing but after very long time, like 20m.
Actually without 'verbose' it takes exactly 20min. Very interesting.
This was already explained. It hangs twice, and apparently there is some form of software watchdog that fires after 10 minutes, generates a crashdump, and then the execution of the export continues at the next statement. So after 20 minutes you have your export (probably missing two items, but you won't notice that when they are at default settings) and two crashdumps.
 
mikegleasonjr
just joined
Posts: 12
Joined: Tue Aug 07, 2018 3:14 am

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 7:50 pm

Will never test betas again ...

If you can't accept random things broken, then beta testing is not for you. No need to publicly announce that, we'll accept your decision regardless.
From a high level perspective, I think betas are more like alphas. He's kind of right that, while you would expect some things to break in betas, you should still be able to go far and have a relatively stable beta to be able to properly test it. When a big proportion of users can't even run the devices to test them and give constructive feedback, it wastes everyone's time.

I too will never install a beta again for this reason.

Again, it is a matter of opinions. But as a software engineer, I think the betas are too unstable top be properly tested.
 
mkx
Forum Guru
Forum Guru
Posts: 5414
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 8:23 pm

I can uderstand everybody who decide not to install beta version, it's their gear, their time, their life. But why bitching about quality of betas (or lack of it)? Either accept the lack of quality of betas and proceed to test (reporting issues etc.) or stop testing and shut up about it.
BR,
Metod
 
r00t
Member
Member
Posts: 423
Joined: Tue Nov 28, 2017 2:14 am

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 10:02 pm

I think main problem is branch naming Mikrotik is using. Anyone who doesn't know how things go with Mikrotik expect beta to be something that's like 90% stable and in most cases can be used to get cool new features without risking much. That's how it usually is when it comes to testing beta releases of software. So they install it on their router and then get burned by finding half of the things doesn't even work, router crashes, there are inconsistencies with winbox vs. console and all other stuff "we" already know about.

Long time ago I proposed changing naming to something like this:
Beta branch should be called Unstable
Stable should be called Stable candidate
Actual Stable release where stable candidate version would get promoted after a week. Or not... depending on stable candidate version feedback. If problematic, new candidate version would be released and stable would skip the problematic release.

Most admins already use this "wait a week" strategy when it comes to "Stable" versions, but again new Mikrotik users often get burned.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 10:40 pm

I think "stable" should not be used in any release name, because of the confusion between "stability of the system" and "stability of the version".
Stable version can mean "it does not change often" or "it does not crash a lot".
(just like "free" can mean "it does not cost money" or "there is freedom to use it in your own developments")
 
mikegleasonjr
just joined
Posts: 12
Joined: Tue Aug 07, 2018 3:14 am

Re: v7.1beta4 [development] is released!

Mon Feb 15, 2021 10:57 pm

I can uderstand everybody who decide not to install beta version, it's their gear, their time, their life. But why bitching about quality of betas (or lack of it)? Either accept the lack of quality of betas and proceed to test (reporting issues etc.) or stop testing and shut up about it.
I was respectful and verbose in explaining why some users like me feel that way. I will continue in that vein. The reason we're vocal about it is that we want to test the device and help Mikrotik find bugs earlier while enjoying new functionalities.

But you get bit once since you loose a lot of time since it is barely usable. Not even for home use, or lab use. As I said, it is helping no one, and first and foremost it is not helping Mikrotik.

They advertise their beta as a beta, since it has "beta" in the name. A beta is...
Beta software refers to computer software that is undergoing testing and has not yet been officially released. The beta phase follows the alpha phase, but precedes the final version. Some beta software is only made available to a select number of users, while other beta programs are released to the general public.
- https://techterms.com/definition/beta_s ... l%20public.

But in its state, it is more like pre-alpha: https://en.wikipedia.org/wiki/Software_ ... life_cycle

So I am not mad Mikrotik made this early preview code available to us, I feel cheated when there's a beta out for more than a year with dozens of new versions that is not functioning at its minimum. I lost time. I wouldn't have installed a pre-alpha version. I felt mislead.

Thank you for reading my point of view
 
r00t
Member
Member
Posts: 423
Joined: Tue Nov 28, 2017 2:14 am

Re: v7.1beta4 [development] is released!

Tue Feb 16, 2021 3:49 am

I think "stable" should not be used in any release name, because of the confusion between "stability of the system" and "stability of the version".
This is a good point. Maybe "Testing/Preview" (currently beta) -> "Release candidate" (for a week) -> "Current/Latest" (stable) would be better naming...
 
gdanov
newbie
Posts: 28
Joined: Thu Jan 17, 2019 1:10 pm

Re: v7.1beta4 [development] is released!

Tue Feb 16, 2021 2:29 pm

I can uderstand everybody who decide not to install beta version, it's their gear, their time, their life. But why bitching about quality of betas (or lack of it)? Either accept the lack of quality of betas and proceed to test (reporting issues etc.) or stop testing and shut up about it.
Because MT's betas are not betas, but alphas. In the software world there's long practice of naming releases that is not exactly formal, but the definitions are understood & used pretty uniformly by the industry.

Additionally there is pretty well accepted release process that MT don't seem to be following. For example there are no branch-level release candidates. For this reason even on the stable channel we have to wait for a week to see if the more enthusiastic members got burned and then install based on the feedback.

While I have adapted without "bitchin'" about it, it's fact that MT's release process is ... inaccurate and incomplete to put it politely.
 
Paternot
Forum Veteran
Forum Veteran
Posts: 802
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v7.1beta4 [development] is released!

Tue Feb 16, 2021 2:50 pm

Although I agree that the Mikrotik's betas are alphas, they are labelled "development". Both at the web page and at the system upgrade on the routers. It isn't even marked "testing".

So, we could argue that the v7 should be 7.1alpha4, instead of 7.1beta4 - and it would be a reasonable argument. But complaining that something put into the "development" branch is broken? That's a little too much.
 
gtj0
just joined
Posts: 7
Joined: Wed Sep 23, 2020 8:08 pm

Re: v7.1beta4 [development] is released!

Tue Feb 16, 2021 6:46 pm

I'm going to wait for RouterOS 7.8675309Beta42 before trying another one. Maybe it'll be out before the universe collapses but I'm not holding out hope.
 
onnoossendrijver
Member
Member
Posts: 442
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: v7.1beta4 [development] is released!

Tue Feb 16, 2021 7:34 pm

But complaining that something put into the "development" branch is broken? That's a little too much.
I totally agree!
I have devices where 7 is working great, and other devices where I can't even get 7 to boot. I accept that for its a development release.
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Tue Feb 16, 2021 10:58 pm

v7.42 will be the most stable release ever.
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Tue Feb 16, 2021 11:20 pm

Although I agree that the Mikrotik's betas are alphas, they are labelled "development". Both at the web page and at the system upgrade on the routers. It isn't even marked "testing".

So, we could argue that the v7 should be 7.1alpha4, instead of 7.1beta4 - and it would be a reasonable argument. But complaining that something put into the "development" branch is broken? That's a little too much.
What if someone sells devices running development software. Mind blown.
 
Paternot
Forum Veteran
Forum Veteran
Posts: 802
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 2:46 am

Although I agree that the Mikrotik's betas are alphas, they are labelled "development". Both at the web page and at the system upgrade on the routers. It isn't even marked "testing".

So, we could argue that the v7 should be 7.1alpha4, instead of 7.1beta4 - and it would be a reasonable argument. But complaining that something put into the "development" branch is broken? That's a little too much.
What if someone sells devices running development software. Mind blown.
Ah, yes. THAT was a very good question. They shouldn't have done it, period.
 
onnoossendrijver
Member
Member
Posts: 442
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 9:47 am

What if someone sells devices running development software. Mind blown.
That is not winning prizes... But the big boys do the same. They even don't call it beta or development..
First Cisco Nexus switches: Total crap. First Juniper SRX: the same. Checkpoint modular firewalls: after all these years still major bugs.
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
gdanov
newbie
Posts: 28
Joined: Thu Jan 17, 2019 1:10 pm

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 11:34 am

Although I agree that the Mikrotik's betas are alphas, they are labelled "development". Both at the web page and at the system upgrade on the routers. It isn't even marked "testing".

So, we could argue that the v7 should be 7.1alpha4, instead of 7.1beta4 - and it would be a reasonable argument. But complaining that something put into the "development" branch is broken? That's a little too much.
I'd speculate they shared the "beta" out of desperation — to demonstrate progress and to get some testing out in the wild for free. Just outsourcing the testing to their users is worth enough for them to tolerate much more bitchin' than you see in this thread.

Apart from the typical entitled whining there's also build-up of frustration in the long-term users. You see it often. I think MT is doing very poor job socializing their users with the new release. There's one moderator trying to cover all bases (respect to him) but this can't solve all problems.

Judging from my experience in the SW industry and the clues around this "beta" MT are in trouble w.r.t. software delivery and playing catch-up. While complaining about one's pet feature won't solve this and are annoying, complaints about overall software quality and delivery process should be encouraged.
 
gdanov
newbie
Posts: 28
Joined: Thu Jan 17, 2019 1:10 pm

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 11:36 am

What if someone sells devices running development software. Mind blown.
That is not winning prizes... But the big boys do the same. They even don't call it beta or development..
First Cisco Nexus switches: Total crap. First Juniper SRX: the same. Checkpoint modular firewalls: after all these years still major bugs.
MT is not big boy and this is why I love it. The business model of the big players puts a cushion of consultants or IT support that have to eat their s**t.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1917
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 12:57 pm

Maybe this discussion should be in another thread?
 
Why do not use Splunk to monitor your MikroTik Router(s)? Look at this page in how to set it up.

MikroTik->Splunk
 
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 12:58 pm

I'd speculate they shared the "beta" out of desperation — to demonstrate progress and to get some testing out in the wild for free.
Well, we have been promised the version 7 that would solve all our problems for many years.
Many feature additions and bugfixes were made to version 6 in the meantime, but version 7 would bring the holy grail of an entire new routing engine and better implementation of BGP (mainly interesting for those that do BGP to internet, for me on a closed network BGP works OK).

Version 6 has made a lot of patches in the Linux kernel and that made them effectively locked to the same kernel version over time.
At some point, the new version 7 became tied to the use of a new version of the Linux kernel. There could be no kernel update within version 6.

That, at some point, made it necessary to force version 7 into the user community because the hardware department had designed new hardware that really required a new kernel.
As this meant the new version had to be shared anyway, it also was the start of the "beta" testing of version 7's other features.

But it looks like the porting of the previous Linux kernel patches is not complete yet. Likely a lot of work.
(e.g. MPLS is not yet present in v7, and some things that required kernel patches, like GRE tunnel keepalives, no longer work)

The rate at which v7 betas now appear (and their release notes) does not really seem to indicate that e.g. a team of 2-3 developers is now working fulltime on this.
Maybe they try to, but are constantly distracted by important bugfixes for the users of the new hardware, or in the old version 6.
 
User avatar
memelchenkov
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 1:06 pm

As an experienced software developer, I confirm that there is definitely lack of developers who are working on it! QA team is also understaffed. Hardly the owners read this forum, so it's just a cry in the blank.
 
Paternot
Forum Veteran
Forum Veteran
Posts: 802
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 1:46 pm

As an experienced software developer, I confirm that there is definitely lack of developers who are working on it! QA team is also understaffed. Hardly the owners read this forum, so it's just a cry in the blank.
The idea is to present the community feelings and suggestions. With a little bit of luck, the developers want to solve this internally, but lack the clout to make it happen. As time passes, and as complaints get pile up on this forum, it may come a time when this body of messages could be presented as evidence of "customers are complaining".

Yes, yes, I know: fat chance. One can always dream. :D
 
User avatar
memelchenkov
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Sun Oct 11, 2020 12:00 pm
Contact:

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 1:55 pm

Unfortunately, developers in medium/large companies do not decide anything. Even Project Manager can't do much. Only Product Owner / Sales Managers / General Managers decide. They already decided to sell product with alpha-quality firmware, telling everyone it's a release. What do you expect from them? It's not 70's - 80's, when developers were kings. Now developers are "human resources".
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Wed Feb 17, 2021 3:00 pm

Juding by the changelog length I would say that they put by far more effort into the 6.x than into 7.x. That's okay as 7.x is just in development and nobody should use it for production purposes anyway. People with devices like Chateau12 are just trapped. At least they made Chateau12 useable for simple home-usage again with 7.1 beta3. But the uncertain feeling remains: what will be broken in the next beta? :D
 
fflo
newbie
Posts: 33
Joined: Wed Jan 02, 2019 7:59 am

Re: v7.1beta4 [development] is released!

Thu Feb 18, 2021 6:23 am

Looks like export still hangs...
Is there a reason why this bug has not been fixed?
Working with the Terminal regularly this keeps me from testing the latest v7.1 betas. Does there exist a workaround?
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Thu Feb 18, 2021 9:17 am

Looks like export still hangs...
Is there a reason why this bug has not been fixed?
Working with the Terminal regularly this keeps me from testing the latest v7.1 betas. Does there exist a workaround?
Yes, there is. As mentioned before in this thread, "/export verbose" works. Without verbose argument it hangs and you can see a suppout.rif appearing in the files list.
 
andyc829
just joined
Posts: 1
Joined: Sat Feb 20, 2021 11:05 am

Re: v7.1beta4 [development] is released!

Sat Feb 20, 2021 11:14 am

I am trying to get wireguard set up but the router does not even attempt to handshake with the server. I've not had any experience of anything in the development channel prior to Beta 4.
 
angboontiong
Forum Guru
Forum Guru
Posts: 1131
Joined: Fri Jan 16, 2009 9:59 am

Re: v7.1beta4 [development] is released!

Sun Feb 21, 2021 7:01 pm

This version gmail got issue when i use it to send my backup file.
 
lcohen999
just joined
Posts: 12
Joined: Fri Oct 18, 2019 3:34 am

Re: v7.1beta4 [development] is released!

Mon Feb 22, 2021 9:25 pm


However now after less than 1h all my devices disconnect and can’t connect anymore and reboot is needed.
There is absolutely nothing in logs which would indicate any problem. Even no unsuccessful authentication or anything. WiFi however is still advertised by the ap, just can’t join.
This seems to be happening regardless of amount of devices connected to WiFi (tested 2-15).
Thank you for this report. The cause of this issue has been identified and will be fixed in the next release.
In the meantime, a workaround for it would be connecting no more than 1 WPA3 authenticated client device per interface (you can create additional virtual APs to connect more than 1 WPA3 client to the same radio).
I seem to have worked around this on my Audience by using the back-haul wifi as the 5GHz. Given most of my stuff is 5GHz anyway, this seems to have worked around the issue (plus a nightly reboot for good measure).
 
updog
just joined
Posts: 1
Joined: Mon May 13, 2019 4:36 am

Re: v7.1beta4 [development] is released!

Mon Feb 22, 2021 11:49 pm

I'm running the beta on my RB493G and the queue tree stats are not logging total packets, only total bytes and packets dropped. I've tried with queue types cake, fq_codel, and pfifo.
 6   name="HOME_UPLOAD" parent=STANDARD_UPLOAD packet-mark=HOME_UPLOAD_MARK rate=0 packet-rate=0 queued-bytes=0 
     queued-packets=0 bytes=2475679 packets=0 dropped=0 

 7   name="HOME_DOWNLOAD" parent=STANDARD_DOWNLOAD packet-mark=HOME_DOWNLOAD_MARK rate=320 packet-rate=0 
     queued-bytes=0 queued-packets=0 bytes=71284787 packets=0 dropped=0
 
infabo
newbie
Posts: 40
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 12:28 am

is it possible to get logs before the kernel panic reboot?
You do not have the required permissions to view the files attached to this post.
 
mkx
Forum Guru
Forum Guru
Posts: 5414
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 11:05 am

Only if logs are sent elsewhere (not to memory), such as disk or network syslog server.
BR,
Metod
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 11:20 am

It can also help to connect the serial port (if there is any) to another system and run a terminal program there to capture what is sent to serial.
 
User avatar
Uqbar
Member Candidate
Member Candidate
Posts: 118
Joined: Tue May 05, 2015 11:56 am
Contact:

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 7:08 pm

Will we then have "HTTPS by default" web UI as well?
There's never a stupid question. But often stupid answers.
And, yes I do used search engines. This is why I am here.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8526
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 7:13 pm

You have to provide a certificate, so looks like it won't be default.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
Uqbar
Member Candidate
Member Candidate
Posts: 118
Joined: Tue May 05, 2015 11:56 am
Contact:

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 7:23 pm

You have to provide a certificate, so looks like it won't be default.
Why not using the same for REST-API?
If the customer wants to use her own, then they will install and use it.
There's never a stupid question. But often stupid answers.
And, yes I do used search engines. This is why I am here.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7234
Joined: Mon Jun 08, 2015 12:09 pm

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 7:32 pm

There is no such thing as a "default certificate" that will be usable with modern browsers.
You need to provide a certificate or it will be marked as unsafe. Nothing you can do about that.
 
User avatar
Uqbar
Member Candidate
Member Candidate
Posts: 118
Joined: Tue May 05, 2015 11:56 am
Contact:

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 7:49 pm

There is no such thing as a "default certificate" that will be usable with modern browsers.
You need to provide a certificate or it will be marked as unsafe. Nothing you can do about that.
So rest api are HTTP by default?
I understood from previous posts that is was HTTPS...
There's never a stupid question. But often stupid answers.
And, yes I do used search engines. This is why I am here.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8526
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v7.1beta4 [development] is released!

Wed Feb 24, 2021 11:33 pm

REST API works only over https. You need to install a certificate to use https (and REST API).
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
mducharme
Trainer
Trainer
Posts: 1144
Joined: Tue Jul 19, 2016 6:45 pm

Re: v7.1beta4 [development] is released!

Thu Feb 25, 2021 9:18 am

Some of the new features from 6.48.x are not yet present in 7.1beta4 (ex. LLDP-MED Voice VLAN) - any idea when those will be available?
Last edited by mducharme on Fri Feb 26, 2021 9:22 am, edited 1 time in total.
 
User avatar
Uqbar
Member Candidate
Member Candidate
Posts: 118
Joined: Tue May 05, 2015 11:56 am
Contact:

Re: v7.1beta4 [development] is released!

Thu Feb 25, 2021 9:32 am

Some of the new features from 6.48.x are not yet present in 6.47beta4 (ex. LLDP-MED Voice VLAN) - any idea when those will be available?
This thread is for v7betas, not v6!
There's never a stupid question. But often stupid answers.
And, yes I do used search engines. This is why I am here.
 
mducharme
Trainer
Trainer
Posts: 1144
Joined: Tue Jul 19, 2016 6:45 pm

Re: v7.1beta4 [development] is released!

Fri Feb 26, 2021 9:24 am

This thread is for v7betas, not v6!
Yes, sorry, I meant the following:

Some of the new features from 6.48.x are not yet present in 7.1beta4 (ex. LLDP-MED Voice VLAN) - any idea when those will be available?
 
mkx
Forum Guru
Forum Guru
Posts: 5414
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1beta4 [development] is released!

Fri Feb 26, 2021 8:32 pm

Betas in v7 line come out quite infrequently. I expect most of new functionality in v6 to land in v7 betas soon. However in v7 quite a few old functions from v6 are missing and I guess development in v6 and in v7 is not parallel at the moment.
BR,
Metod
 
G00dm4n
newbie
Posts: 32
Joined: Sat Oct 20, 2018 1:07 am

Re: v7.1beta4 [development] is released!

Sun Feb 28, 2021 3:31 am

Hi Guys,

I do not know if I do something wrong but I cant get to graphs & webfig (even this) on my CCR1009 after upgraded to 7.1b4.
Does any one have similar issues?

Who is online

Users browsing this forum: No registered users and 10 guests