Community discussions

MikroTik App
 
rpingar
Long time Member
Long time Member
Topic Author
Posts: 563
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

rpki verify in new routing firewall rule

Tue Feb 09, 2021 4:13 pm

I need to now how to configure the rpki verify, filter rule, in new (scripts) format present in 7.1beta4.

something like this doesn't work:
add chain=bgp_in rule={if match={rpki invalid } then= {action reject } }
failure: invalid match at if

may someone of you help me?

regards
Ros
 
User avatar
netravnen
just joined
Posts: 14
Joined: Sun Dec 31, 2017 2:48 am
Location: DE
Contact:

Re: rpki verify in new routing firewall rule

Tue Feb 09, 2021 7:14 pm

https://help.mikrotik.com/docs/display/ROS/ROSv7+Basic+Routing+Examples
/routing/bgp/rpki
add group=myRpkiGroup address=192.168.1.1 port=8282 refresh-interval=20

/routing/filter/rule
add chain=bgp_in rpki-verify=myRpkiGroup
add chain=bgp_in match-rpki=invalid action=reject
add action=accept
?
have you, also, remembered to enable IPv6 on something recently...? ;)
 
rpingar
Long time Member
Long time Member
Topic Author
Posts: 563
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: rpki verify in new routing firewall rule

Wed Feb 10, 2021 11:02 am

https://help.mikrotik.com/docs/display/ ... g+Examples
/routing/bgp/rpki
add group=myRpkiGroup address=192.168.1.1 port=8282 refresh-interval=20

/routing/filter/rule
add chain=bgp_in rpki-verify=myRpkiGroup
add chain=bgp_in match-rpki=invalid action=reject
add action=accept
?
no they are not working on new beta4 because the rule are changed following the script languace
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6195
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: rpki verify in new routing firewall rule

Wed Feb 10, 2021 2:38 pm

In currently released beta (v7.1beta4) it is not possible to add rpki validation. We will finish routing filters release and then update documentation with new syntax.
 
rpingar
Long time Member
Long time Member
Topic Author
Posts: 563
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: rpki verify in new routing firewall rule

Wed Feb 10, 2021 3:41 pm

In currently released beta (v7.1beta4) it is not possible to add rpki validation. We will finish routing filters release and then update documentation with new syntax.
when may we espect the new beta about routing filters working?

regards

Who is online

Users browsing this forum: No registered users and 2 guests