Community discussions

MikroTik App
 
wiresnarg
just joined
Topic Author
Posts: 3
Joined: Sun Feb 14, 2021 12:37 am

v7.1beta4 [bug] export hangs / slow

Sun Feb 14, 2021 12:23 pm

Hi,

I thought I'd break out the bug reports from the v71beta4 release announcement [1] to a separate topic.
Please leave a comment if this topic is a duplicate and accept my apologies.

Several users have reported in [1] that export hangs or is slow. I can confirm this behaviour.
At the same time, I noticed that a verbose export does not suffer from this performance issue.

Since the default export is compact [2] I assume that the filtering for non-default configurations may be the culprit.

The flag terse has no performance impact.

I also noticed that
/system/backup/save dont-encrypt=yes name=foo
is even faster than any export.

Can anyone reproduce my experience?

Kind regards

[1] viewtopic.php?p=843702
[2] https://wiki.mikrotik.com/wiki/Manual:C ... act_Export
 
mkx
Forum Guru
Forum Guru
Posts: 5409
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1beta4 [bug] export hangs / slow

Sun Feb 14, 2021 12:53 pm

I also noticed that
/system/backup/save dont-encrypt=yes name=foo
is even faster than any export.

ROS v6 is like this as well and it's easy to explain: backup file is a mere a collection of binary configuration, I guess a combination of memory dumps (or may be not) and pre-existing binary configuration files and backup process simply collects them and packs them into single file. Export OTOH has to covert it to ASCII format and reorder stanzas so that they can be imported line-by-line to a empty-config device.
What is new in v7 is that exporter seemingly chokes on comparison of running config versus default config (verbose and terse don't do it) in certain sections. I'm pretty sure MT devs are aware of the problem given how simply it's replicated but solving it is probably not at the top of To-Do list.
BR,
Metod

Who is online

Users browsing this forum: No registered users and 13 guests