Community discussions

MikroTik App
 
mafiosa
Member Candidate
Member Candidate
Topic Author
Posts: 189
Joined: Fri Dec 09, 2016 8:10 pm
Location: Kolkata, India
Contact:

BGP route filters not working in beta 5

Wed Mar 24, 2021 11:40 am

I have the following networks:
2a0e:b107:xx0::/46
2a0e:b107:xx4::/46
2a0e:b107:xx8::/46
2a0e:b107:xxc::/46
I have added these as blackhole using ipv6 route add dst=2a0e:b107:xx0::/46 blackhole.
I have also created an address list with the following networks called bgp-network
For route filter as of now I have configured:
chain=securebit-out rule= if ([protocol static ]) then={action accept }
I am also using output.network=bgp-network in the bgp connection.

1 name="osixp"
remote.address=2602:feda:afe::1 .as=65515
local.address=2602:feda:afe::3 .role=ebgp
tx-ttl=1 rx-min-ttl=1 connect=yes listen=yes routing-table=main
router-id=192.168.254.1 as=213326 address-families=ipv6
output.affinity=main .filter=securebit-out .network=bgp-network
input.affinity=main
However, I find that no network is being advertised to the bgp neighbor.
Running Bugtik v7.1 RC4 on RB3011-UiAS-RM HAP AC^2, VyOS 1.3 RC6 on Proxmox VE.
 
fbl
just joined
Posts: 17
Joined: Fri Jul 20, 2018 5:39 pm

Re: BGP route filters not working in beta 5

Sat Apr 03, 2021 2:28 am

I'm having the same issue.
I can't get RouterOS 7.1beta5 to announce anything to its neighbours, not even when using an accept-all filter chain as output.filter.

My configuration:
/routing id
add disabled=no id=192.0.2.1 name=rid select-dynamic-id=""
/routing bgp template
add address-families=ip as=12345 input.filter=allow_all name=templ output.filter=allow_all router-id=rid
/ip route
add blackhole disabled=no dst-address=192.0.2.0/24
/routing bgp connection
add connect=yes listen=yes local.address=198.51.100.1 .role=ebgp name=peer remote.address=198.51.100.2 .as=12346 templates=templ
/routing filter rule
add chain=allow_all rule="action accept"
 
fbl
just joined
Posts: 17
Joined: Fri Jul 20, 2018 5:39 pm

Re: BGP route filters not working in beta 5

Tue May 25, 2021 3:02 am

Seems to be working again in beta 6. Remember to set the redistribute attribute for /routing/bgp/template or /routing/bgp/connection.

Who is online

Users browsing this forum: DevTek, mike7 and 12 guests