Community discussions

 
darencrew
just joined
Topic Author
Posts: 24
Joined: Thu Nov 23, 2006 6:12 pm

SSH problems on 5.0rc1

Thu Oct 07, 2010 7:07 pm

Hello,

I found a bug on ssh.

Before upgrade i use specific port for ssh, after upgrade i succeed in connecting but password is always rejected....

After a downgrade to 4.11 without any other change, i succeed in both connecting and logging....

So according to other posts, ssh seems to have a real problem.

Regards
 
ditonet
Forum Veteran
Forum Veteran
Posts: 837
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: SSH problems on 5.0rc1

Thu Oct 07, 2010 11:04 pm

Hi,

For me SSH on specific port works fine, on x86 platform.

Regards, Grzegorz.
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: SSH problems on 5.0rc1

Fri Oct 08, 2010 4:03 pm

check if you have set ssh-key for that account. If you are using ssh-key you cannot login using password anymore. That is as intended with RouterOS 5
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: SSH problems on 5.0rc1

Sat Oct 09, 2010 6:42 am

check if you have set ssh-key for that account. If you are using ssh-key you cannot login using password anymore. That is as intended with RouterOS 5
I just wanted say, nice feature addition. :-)
Doug
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: SSH problems on 5.0rc1

Mon Oct 18, 2010 4:27 pm

What's new in 5.0beta5 (2010-Jul-23 14:50):

*) ssh - password authentication is disabled for users with public keys;
well...
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: SSH problems on 5.0rc1

Tue Oct 19, 2010 12:03 am

janisk,
I saw that in the changelog. I think this feature is a good feature for security, as it prevents brute-forcing a password if you use ssh-key for a user account.

Nice work :-)
Doug
 
User avatar
femur
just joined
Posts: 12
Joined: Wed Mar 15, 2006 6:00 pm
Location: Poland, Sieradz

Re: SSH problems on 5.0rc1

Thu Jun 16, 2011 9:16 am

What's new in 5.0beta5 (2010-Jul-23 14:50):
*) ssh - password authentication is disabled for users with public keys;
I do approve of good default settings for security. But give me a chance to think by myself, please. :)
First case. I use public-keys from more than one place, and setting key from one place generates problem from another. I need to take roundabout route with key.
The second case. I use public-keys from central admin server. If I go to a customer for service, and can not use internet from there I can not login into machine, because have no access to central admin server.

There is a simple suggestion to patch this up. Let me disable this default environment. For instance:
/user set admin password-login=yes
or something similar.

Who is online

Users browsing this forum: No registered users and 7 guests