Community discussions

 
p2systems
just joined
Topic Author
Posts: 8
Joined: Sun Aug 28, 2011 10:27 pm

RouterOS 6.10 beta

Wed Feb 05, 2014 4:28 pm

As title says, RouterOS 6.10 has been released for development testing. No changelog so far.
I will keep this thread updated, as a changelog appears.

Update:

What's new in 6.10 (2014-Feb-06 12:44):

*) ipv6 pool - fix dynamic prefix disappearing which may influence large VPNs with IPv6;
*) ssh client - fix key agreement when sometimes wrong DH algorithm was selected;
*) bgp - multipath eBGP now does not propagate BGP nexthop unless
forced in configuration;
Last edited by p2systems on Thu Feb 06, 2014 1:56 pm, edited 2 times in total.
 
Diamond
newbie
Posts: 26
Joined: Tue Mar 19, 2013 7:11 pm
Location: RU

Re: RouterOS 6.10 beta

Wed Feb 05, 2014 9:11 pm

When the cell copying feature (http://forum.mikrotik.com/viewtopic.php?f=1&t=79209) will?
 
cursixx
just joined
Posts: 5
Joined: Tue Jan 29, 2013 6:21 pm

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 6:19 am

any known problems with eoip? 6.9 was working fine but after the switch to 6.10 it isn't passing traffic.

this is over a pptp connection, eoip is building and keeping a connection but no packets passed "other then keep alive"
 
derliang
just joined
Posts: 6
Joined: Thu Oct 03, 2013 5:52 pm

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 11:30 am

What's new in 6.10 (2014-Feb-06 10:57):

*) ssh client - fix key agreement when sometimes wrong DH algorithm was selected;
*) bgp - multipath eBGP now does not propagate BGP nexthop unless
forced in configuration;
 
23q
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Thu Sep 02, 2010 2:54 pm
Location: Ukraine

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 12:29 pm

where download 6.10?
 
p2systems
just joined
Topic Author
Posts: 8
Joined: Sun Aug 28, 2011 10:27 pm

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 12:33 pm

Write MikroTik support for development access to RouterOS.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 2:08 pm

any known problems with eoip? 6.9 was working fine but after the switch to 6.10 it isn't passing traffic.

this is over a pptp connection, eoip is building and keeping a connection but no packets passed "other then keep alive"
Well all is working for me just fine in EOIP over PPTP that is bridged on both sides with Ethernet.
Just check if EOIP mac addresses are different on both tunnel end also - check what MAC addresses bridge is using.
If no write to support with supout.rif files from both ends.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
cursixx
just joined
Posts: 5
Joined: Tue Jan 29, 2013 6:21 pm

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 4:49 pm

the 6.10 build 2.6.2014 fixed eoip
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2279
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 7:05 pm

Why name is 6.10 ?
It is pre-release for testing. It should be 6.10rc1 :!:
LAN, FTTx, Wireless. ISP operator
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1210
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 9:08 pm

Anything about fixing routing marks in 6.10 (broken in 6.9, works in 6.7)?
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
wispwest
Member
Member
Posts: 477
Joined: Tue May 19, 2009 3:48 am

Re: RouterOS 6.10 beta

Thu Feb 06, 2014 11:14 pm

Is anyone seeing any better throughput with Nv2 PtP's with this?
 
sdv
just joined
Posts: 13
Joined: Tue Oct 01, 2013 9:30 am

Re: RouterOS 6.10 beta

Fri Feb 07, 2014 9:25 am

 
efaden
Forum Guru
Forum Guru
Posts: 1711
Joined: Sat Mar 30, 2013 1:55 am
Location: New York, USA

Re: RouterOS 6.10 beta

Fri Feb 07, 2014 2:52 pm

Why name is 6.10 ?
It is pre-release for testing. It should be 6.10rc1 :!:

Because their naming makes no sense.

Sent from my SCH-I545 using Tapatalk
 
p2systems
just joined
Topic Author
Posts: 8
Joined: Sun Aug 28, 2011 10:27 pm

Re: RouterOS 6.10 beta

Fri Feb 07, 2014 3:05 pm

Anything about fixing routing marks in 6.10 (broken in 6.9, works in 6.7)?
Works fine here
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1210
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: RouterOS 6.10 beta

Fri Feb 07, 2014 8:21 pm

I upgraded again to 6.9 to check again:
- connection mark works ok
- routing mark in firewall works (at least rule counts packets, doing 2 different marks, based on connection mark and mangle rules)
- route shows up inactive and does not work, even if gateway says reachable, as if the interface is visible only from the main table, but not from other routing tables (outgoing interfaces are PPPoE and sstp server binding).
So it doesn't work.

A simple downgrade to 6.7 fixes everything.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
lcitech
just joined
Posts: 6
Joined: Thu Jun 06, 2013 8:48 pm

Re: RouterOS 6.10 beta

Sat Feb 08, 2014 1:45 am

6.7 to 6.9 broke pptp connections on several of our systems in production. It actually works fine, however after upgrade security profiles were not working/applied ... showing <unknown> instead of the configured profile (we always set new profiles rather than "default-profile")
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 6.10 beta

Mon Feb 10, 2014 10:02 am

6.7 to 6.9 broke pptp connections on several of our systems in production. It actually works fine, however after upgrade security profiles were not working/applied ... showing <unknown> instead of the configured profile (we always set new profiles rather than "default-profile")
could you please clarify where exactly you saw "unknown"? I just upgraded a PPTP server running 6.7 to 6.9 and my 'pofile1' still says 'profile1'
Screenshot 2014-02-10 10.01.55.png
You do not have the required permissions to view the files attached to this post.
No answer to your question? How to write posts
 
shiny
just joined
Posts: 14
Joined: Tue Feb 19, 2013 3:19 pm

Re: RouterOS 6.10 beta

Mon Feb 10, 2014 4:13 pm

6.7 to 6.9 broke pptp connections on several of our systems in production. It actually works fine, however after upgrade security profiles were not working/applied ... showing <unknown> instead of the configured profile (we always set new profiles rather than "default-profile")
could you please clarify where exactly you saw "unknown"? I just upgraded a PPTP server running 6.7 to 6.9 and my 'pofile1' still says 'profile1'
Screenshot 2014-02-10 10.01.55.png
It happens when the 6.7 version was running the experimental PPP package. At least everywhere i got this problem, the 6.7 experimental PPP package was installed and after upgrade all PPP settings/profiles/interfaces were gone.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2279
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RouterOS 6.10 beta

Mon Feb 10, 2014 8:32 pm

What's new in 6.10 (2014-Feb-10 15:11):

*) ovpn client - remove cipher=any & auth=any options, protocol does not support them;
*) pptp - fixed where Windows & MacOS clients were disconnecting all the time;
*) sstp - make it work with Windows client with AES encryption;
*) ipv6 pool - fix dynamic prefix disappearing which may influence large VPNs with IPv6;
*) ssh client - fix key agreement when sometimes wrong DH algorithm was selected;
*) bgp - multipath eBGP now does not propagate BGP nexthop unless forced in configuration;
LAN, FTTx, Wireless. ISP operator
 
lcitech
just joined
Posts: 6
Joined: Thu Jun 06, 2013 8:48 pm

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 3:48 am

could you please clarify where exactly you saw "unknown"? I just upgraded a PPTP server running 6.7 to 6.9 and my 'pofile1' still says 'profile1'
What shiny said, although we were not running "ppp experimental' package.
All profiles were missing in Winbox and webfig, present in the cli, but not recognized in the PPTP interface .
Re-entering the security profiles fixed the issue. Sorry I can't seem to replicate the issue downgrading to 6.7 then upgrading to 6.9.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 10:29 am

you should remove the ppp test package before upgrading to v6.9 or later. there is nothing else that can be done, unfortunately
No answer to your question? How to write posts
 
dodgerz
just joined
Posts: 4
Joined: Tue Feb 11, 2014 11:03 am

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 11:22 am

What's new in 6.10 (2014-Feb-10 15:11):
*) ovpn client - remove cipher=any & auth=any options, protocol does not support them;
When OVPN start working on UDP?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 11:25 am

we have released a new pre-release build for v6.10, please test for remaining issues. most of the reported things in v6.9 have been fixed already

What's new in 6.10 (2014-Feb-11 11:05):

*) fix autosupout.rif generation after kernel panic;
*) ovpn - make it work again;
*) ovpn client - remove cipher=any & auth=any options,
protocol does not support them;
*) pptp - fixed where Windows & MacOS clients were disconnecting all the time;
*) sstp - make it work with Windows client with AES encryption;
*) ipv6 pool - fix dynamic prefix disappearing which may influence large
VPNs with IPv6;
*) ssh client - fix key agreement when sometimes wrong DH algorithm was selected;
*) bgp - multipath eBGP now does not propagate BGP nexthop unless
forced in configuration;

If using the ppp-v6 package, remove it first, then upgrade
No answer to your question? How to write posts
 
mietus
Member Candidate
Member Candidate
Posts: 122
Joined: Mon Jan 30, 2006 11:14 pm
Location: Poland

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 1:02 pm

And what about Ticket#2014020366000387, is it fixed or will be?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 1:07 pm

And what about Ticket#2014020366000387, is it fixed or will be?
it is fixed already
No answer to your question? How to write posts
 
mietus
Member Candidate
Member Candidate
Posts: 122
Joined: Mon Jan 30, 2006 11:14 pm
Location: Poland

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 2:13 pm

And what about Ticket#2014020366000387, is it fixed or will be?
it is fixed already
I asked beacuse there is no info in changelog ;)

Any other improvements in ppp?
 
makstex
newbie
Posts: 46
Joined: Fri Mar 27, 2009 6:31 am

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 3:18 pm

Fixed.
Last edited by makstex on Wed Feb 12, 2014 1:20 pm, edited 1 time in total.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5913
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: RouterOS 6.10 beta

Tue Feb 11, 2014 3:22 pm

Send a supout to support and also specify what client you are using and what client config.
 
sdv
just joined
Posts: 13
Joined: Tue Oct 01, 2013 9:30 am

Re: RouterOS 6.10 beta

Wed Feb 12, 2014 8:49 am

What about using MRRU parameter in ppp-server (l2tp/pptp) configuration on RB 1100AHx2? Any fixes?
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: RouterOS 6.10 beta

Wed Feb 12, 2014 12:58 pm

What about using MRRU parameter in ppp-server (l2tp/pptp) configuration on RB 1100AHx2? Any fixes?
I love these! :) Like everyone here should knows what you are talking about... What about it, exactly?
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
skibi82
newbie
Posts: 42
Joined: Fri Mar 22, 2013 7:09 pm

Re: RouterOS 6.10 beta

Wed Feb 12, 2014 1:17 pm

Woof in 6.10 build Feb/12/2014 10:52:34

/ip ipsec peer> set local-address=

The first step in the right direction :)
Now I was left to wait for the rest of the VPN :)

I'll arrange a test thank you

Regards
J>S
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1810
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: RouterOS 6.10 beta

Wed Feb 12, 2014 1:21 pm

/ip ipsec peer> set local-address=

The first step in the right direction :)
Now I was left to wait for the rest of the VPN :)
Very exciting!

Hopefully /ipsec peer set address becomes /ipsec peer set remote-address to keep things consistent and logical.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: RouterOS 6.10 beta

Wed Feb 12, 2014 1:53 pm

/ip ipsec peer> set local-address=

The first step in the right direction :)
Now I was left to wait for the rest of the VPN :)
Very exciting!

Hopefully /ipsec peer set address becomes /ipsec peer set remote-address to keep things consistent and logical.
Holy crap!

Awesome change!

Please please please MORE IPSec updates!
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
sdv
just joined
Posts: 13
Joined: Tue Oct 01, 2013 9:30 am

Re: RouterOS 6.10 beta

Wed Feb 12, 2014 2:28 pm

What about using MRRU parameter in ppp-server (l2tp/pptp) configuration on RB 1100AHx2? Any fixes?
I love these! :) Like everyone here should knows what you are talking about... What about it, exactly?
Problem is described in two or more post above, but I do it again:
Upgrade: 6.6 -> 6.9
RouterBOARD: RB 1100AHx2
Tested bugs:
а. [L2TP-Server]:
After upgrade router reboots while first l2tp-session established with watchdog exeption message on serial console.
L2tp-server (and router) crash caused by the use of MRRU (value doesn't matter) parameter in /interface l2tp-server server configuration, so multilink-PPP over single link seems to be broken.
b. [Update]:
Client Mikrotik RB 750G with MRRU option enabled.
Ticket#2014021266000146

I'll try to get support.rif (it constantly reboots, so this bit difficult) from router later.
 
twingman
just joined
Posts: 6
Joined: Mon Oct 07, 2013 11:10 am
Location: Žilina, Slovakia
Contact:

Re: RouterOS 6.10 beta

Fri Feb 14, 2014 4:28 pm

I have same issue as user sdv.

I am worry about upgrading, I don't have time to go to the datacenter when it goes to constantly rebooting again :(
2x CCR1009-7G-1C-1S+
1x CRS328-24P-4S+
many (cca 200) RB951`s, some 2011, 4011, wAPs, ...
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2279
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RouterOS 6.10 beta

Fri Feb 14, 2014 4:51 pm

LAN, FTTx, Wireless. ISP operator

Who is online

Users browsing this forum: No registered users and 6 guests