Community discussions

 
User avatar
ThiagoLimah
just joined
Posts: 1
Joined: Wed May 23, 2018 4:11 pm
Location: Alegrete/RS
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed May 23, 2018 4:16 pm

+1 !!
 
fredyz
just joined
Posts: 6
Joined: Wed Jun 13, 2018 7:07 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Jun 13, 2018 7:19 pm

I've read the full thread and this show the total lack of touch from the guys from Latvia. They are completely stubborn and it seems as much as people show the need for that feature they seem to play a kids' game and say "I am not doing it".

We are in middle-2018 and IPv4 has ran out for a long time ago and there is not even a clue about this issue. They don`t give a damn. They are concerned about other totally different things.

It shows also a complete lack of management skills from the people in charge for bringing the necessary features in time and from those who have to develop it. Show general mess from top to bottom. Worst is: people in charge must believe they are doing a fantastic job by prioritizing "who knows what".

This is yet another example of this total mess and huge ego from these guys.

This post probably will be censored as soon as they read it and they will probably find it "unfair".

Stop fooling yourselves asking repetitively for them to do this as a beggar does. They are probably laughing of it.
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Aug 16, 2018 8:39 pm

Hi, I see some hint that MikroTik has quietly added partial support for Delegated-IPv6-Prefix, look here

https://wiki.mikrotik.com/wiki/Manual:I ... US_Support

They don't mention it but look at radreply. Maybe it isn't fully there yet but it looks like they are working on it.
 
User avatar
marlow
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Mar 16, 2006 6:59 pm
Location: Ireland

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Aug 16, 2018 8:43 pm

Oh .. interesting. Time to play with rc releases.

/M
Communication is the beginning of understanding
-- AT&T
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Aug 19, 2018 5:43 pm

Apparently now is supported this attribute after some years... according to the wiki.
Which says it was added the Delegated-IPv6-Prefix to radius client on 6.43rc.

https://wiki.mikrotik.com/wiki/Manual:R ... ess-Accept

Edit:

This appears on the changelog of 6.43rc51.
*) dhcpv6-server - added additional RADIUS parameters for Prefix delegation, "rate-limit" and "life-time";
Last edited by null31 on Sun Aug 19, 2018 6:08 pm, edited 1 time in total.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Aug 19, 2018 5:47 pm

Good news!!! It remains to wait for 6.43 and test, test and test.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Sep 14, 2018 2:20 pm

Has anyone managed to work with radius delivering the prefix-delegation to the client router, using the Delegated-IPv6-Prefix attribute? It still does not work here.
 
User avatar
marlow
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Mar 16, 2006 6:59 pm
Location: Ireland

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Sep 15, 2018 1:13 pm

Has anyone managed to work with radius delivering the prefix-delegation to the client router, using the Delegated-IPv6-Prefix attribute? It still does not work here.
Which client router are you testing with ?

/M
Communication is the beginning of understanding
-- AT&T
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Sep 17, 2018 3:51 pm

I used a
DLink DIR-615 Hardware version .: T1 Firmware .: 20.11
and a ONU Fiberhome AN5506-04-F Hardware Version .: WKE2.134.285F2G Software Version .: RP2599 (00.00)
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 4:31 am

RADIUS should not "deliver the delegation to the client router", instead it should somehow configure the DHCPv6 server on the router to hand out a specified prefix to the client instead of just any available prefix. Do you see any visible indication that it has done this when the client router connects? Are you testing this with PPPoE or just plain IPv6/DHCP?

They now officially list support: https://wiki.mikrotik.com/wiki/Manual:R ... ess-Accept

"Delegated-IPv6-Prefix - IPv6 Prefix. Added in v6.43"
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 1:49 pm

CCR1016-12G 6.43.1 - "Delegated-IPv6-Prefix" attribute for PPPoE not work.
Billing gives radius attributes, but the router does not create a dynamic DHCP IPV6 server
You do not have the required permissions to view the files attached to this post.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 2:00 pm

RADIUS should not "deliver the delegation to the client router", instead it should somehow configure the DHCPv6 server on the router to hand out a specified prefix to the client instead of just any available prefix. Do you see any visible indication that it has done this when the client router connects? Are you testing this with PPPoE or just plain IPv6/DHCP?

They now officially list support: https://wiki.mikrotik.com/wiki/Manual:R ... ess-Accept

"Delegated-IPv6-Prefix - IPv6 Prefix. Added in v6.43"
We are testing through pppoe.
Using the framed ipv6 addres attribute for the ppp connection and the delegated-ipv6-prefix attribute to create the Dynamic DHCP server in Mikortik and assign the prefix delegation to the client router.
In the Mikrotik radius settings, we set ppp and dhcp.

In case it establishes the ppp connection, it creates the dynamic server in the mikrotik dhchpv6 server, but does not dynamically binding, and the client router does not receive the PD prefix.

I noticed that in this version, even if you let Mikrotik deliver the pool, setting the DHCP POOL-PD profile or using the Prefix-Delagation-Pool attribute and pointing to the pool created in Mikrotik, it does not work, while in version 6.42 .7 works.
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 6:03 pm

CCR1016-12G 6.43.1 - "Delegated-IPv6-Prefix" attribute for PPPoE not work.
Billing gives radius attributes, but the router does not create a dynamic DHCP IPV6 server
Verify that under IPv6->Addresses the PPPoE client is getting an IPv6 link local address assigned. If not, it is because IPv6CP negotiation is not happening, this happens if IPv6 was set to "no" in the profile on the client side, and in this case a DHCPv6 server will not be created.

Since it is a new option, I'm also not sure if in the concentrator's PPP profile you perhaps need to choose the DHCPv6 PD pool option along with a "default" pool that it should assign from if the customer has no Delegated-IPv6-Prefix?
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 6:45 pm

CCR1016-12G 6.43.1 - "Delegated-IPv6-Prefix" attribute for PPPoE not work.
Billing gives radius attributes, but the router does not create a dynamic DHCP IPV6 server
Verify that under IPv6->Addresses the PPPoE client is getting an IPv6 link local address assigned. If not, it is because IPv6CP negotiation is not happening, this happens if IPv6 was set to "no" in the profile on the client side, and in this case a DHCPv6 server will not be created.

Since it is a new option, I'm also not sure if in the concentrator's PPP profile you perhaps need to choose the DHCPv6 PD pool option along with a "default" pool that it should assign from if the customer has no Delegated-IPv6-Prefix?
In my case, in version 6.42.7 with the same configuration on cliente router , when i set only ipv6-framed to be delivery by radius and use Mikrotik-Delagated-IPv6-Pool to use a pool created on Mikrotik, works fine.

I hoped with this option, I could deliver both the prefix for the ppp connection and the prefix-delagation through the radius.
But this does not happen, and the attribute that worked in version 6.42.7, stopped working in version 6.43. That is the question.

In case the IPV6 CP negotiation occurs normally, because it receives the block / 64 set in the radius, create the dynamic dhcp server in the Mikrotik, but the client router (the same used in test with 6.42.7 version) does not receive the pool.

In addition to not solving this management question all allocation of ip by radius, it stopped working what already worked in the previous version.
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 6:54 pm

I hoped with this option, I could deliver both the prefix for the ppp connection and the prefix-delagation through the radius.
But this does not happen, and the attribute that worked in version 6.42.7, stopped working in version 6.43. That is the question.
I wonder if the reason it stopped working is because they added the new attribute: Delegated-IPv6-Prefix-Pool

The old attribute Mikrotik-Delegated-IPv6-Pool may no longer be needed (since it is the same thing as Delegated-IPv6-Prefix-Pool) and they have removed it? Or maybe they didn't mean to remove it, but adding the new attribute Delegated-IPv6-Prefix-Pool that does the same thing somehow unintentionally broke the old one.

Try using Delegated-IPv6-Prefix-Pool instead of Mikrotik-Delegated-IPv6-Pool
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 7:20 pm

I hoped with this option, I could deliver both the prefix for the ppp connection and the prefix-delagation through the radius.
But this does not happen, and the attribute that worked in version 6.42.7, stopped working in version 6.43. That is the question.
I wonder if the reason it stopped working is because they added the new attribute: Delegated-IPv6-Prefix-Pool

The old attribute Mikrotik-Delegated-IPv6-Pool may no longer be needed (since it is the same thing as Delegated-IPv6-Prefix-Pool) and they have removed it? Or maybe they didn't mean to remove it, but adding the new attribute Delegated-IPv6-Prefix-Pool that does the same thing somehow unintentionally broke the old one.

Try using Delegated-IPv6-Prefix-Pool instead of Mikrotik-Delegated-IPv6-Pool
I try Delegated-IPv6-Prefix-Pool and have the same situation.
Dynamic DHCP server is created, but binding is not done and the router does not receive the PD.
 
whaiser
just joined
Posts: 1
Joined: Tue Sep 18, 2018 7:57 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 8:14 pm

+1
Same issue here!
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 8:29 pm

Verify that under IPv6->Addresses the PPPoE client is getting an IPv6 link local address assigned. If not, it is because IPv6CP negotiation is not happening, this happens if IPv6 was set to "no" in the profile on the client side, and in this case a DHCPv6 server will not be created.

Since it is a new option, I'm also not sure if in the concentrator's PPP profile you perhaps need to choose the DHCPv6 PD pool option along with a "default" pool that it should assign from if the customer has no Delegated-IPv6-Prefix?
On client side PPPoE client is getting an IPv6 link local address assigned - fe80::f/64 and nothing Global IPV6
Why would I assign a DHCPv6 PD pool manually in PPP-profile? I think it should be assigned automatically.

Ok, I set manually in the DHCPv6 PD pool name in profile. After reconnecting the PPP client, the DHCP server was dynamically created, but the ipv6 is not assigned to the client. Is there any instruction from a Mikrotik-developers how to do it correctly?
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
gondim
just joined
Posts: 6
Joined: Fri Feb 08, 2008 6:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 18, 2018 8:41 pm

Same problem here. Even though upgrading to version 6.43.1, the problem still continues.
On the same routerboard if I return to version 6.40.9, the DHCPv6 PD Pool returns to normal operation. Without changing any configuration on the routeros.
A problem exists, you can be sure of that.
 
fredyz
just joined
Posts: 6
Joined: Wed Jun 13, 2018 7:07 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Sep 19, 2018 8:53 am

Same problem here as reported by thg3x

In version 6.43 in both DHCP Server or PPPoE the Dynamic DHCP server is created, but binding is not done and the CPE does not receive the PD.
Downgrading to version 6.42.7 makes it work again.

If radius parameters wasn't working as expected it would not even create the dynamic DHCP Server upon connection. Also this has been tested with all parameters local with and without PPPoE and none worked.
 
minelli
newbie
Posts: 41
Joined: Tue Feb 26, 2008 2:36 am

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Sep 20, 2018 2:21 am

Same problem here.
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Sep 20, 2018 4:43 am

Confirmed, I did a bit of debugging and I see what is happening - the client requests a prefix from the DHCPv6 server, the server says "binding not found" and gives a zero second lease of prefix ::/0 to the client, so the MikroTik client successfully gets a "lease" of ::/0, which expires after one second, and so the client follows up one second later to renew the lease, and every second thereafter continuously.

If I manually create the DHCPv6 binding and associate the prefix, client DUID and IAID, it gets the prefix.

Certainly a major bug - I wonder how this got through testing?
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Sep 20, 2018 3:46 pm

Another thing I realized was that in version 6.42.7, mikrotik creates the dynamic dhcp-server without the use-radius option, while version 6.43, it creates the dynamic dhcp-server with the use-radius=no option.
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Sep 20, 2018 8:43 pm

Another thing I realized was that in version 6.42.7, mikrotik creates the dynamic dhcp-server without the use-radius option, while version 6.43, it creates the dynamic dhcp-server with the use-radius=no option.
That's because the use-radius option was only added in 6.43, it did not exist in 6.42.7. This difference is not a mistake, it is only different because the setting did not exist before.
 
radekmacek
just joined
Posts: 6
Joined: Fri Oct 02, 2015 8:55 am

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Sep 21, 2018 3:50 pm

Hi, we have PPPoE customers and we want to assign IPv6 prefix /56 using Delegated-IPv6-Prefix as well. After some debugging there seems to be same issue in current version 6.43.2.

Radius server sends Delegated-IPv6-Prefix /56 to our router, but no DHCPv6 server is created for the OE tunnel.

If we create IPv6 pool: "OE_pool_v6" /40, prefix /56 , then put it to profile DHCPv6 PD pool. After that, upon connection, DHCPv6 server is created but prefix that it delegates does not match Delegated-IPv6-Prefix /56 sent by Raidus server. It takes first /56 from OE_pool_v6.
Tried the same with Delegated-IPv6-Prefix-pool set. But the result was the same.

I guess mikrotik just ignores received Delegated-IPv6-Prefix and takes the local one. Same behavior for version 6.42.7, 6.43., 6.43.1 and between tile and powerpc. Hope it will be fixed soon. Don't want to create /56 for each customer...
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Sep 28, 2018 2:27 pm

6.43 version introduces this feature for DHCP service. You are trying to use it with PPP service. Currently such feature is not supported.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Sep 28, 2018 3:50 pm

You are trying to use it with PPP service. Currently such feature is not supported.
In which version will be support the "Delegated-IPv6-Prefix" attribute for PPPoE ? Very much needed.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Sep 28, 2018 10:22 pm

6.43 version introduces this feature for DHCP service. You are trying to use it with PPP service. Currently such feature is not supported.
I dont understand why the Mikrotik-IPv6-Delagated-Pool stop to working in this version while workinkg in previous version, if Mikrotik only introduces the new features for dhcp.
Sounds weird to me!
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Sep 28, 2018 11:21 pm

6.43 version introduces this feature for DHCP service. You are trying to use it with PPP service. Currently such feature is not supported.
I dont understand why the Mikrotik-IPv6-Delagated-Pool stop to working in this version while workinkg in previous version, if Mikrotik only introduces the new features for dhcp.
Sounds weird to me!
It is not only Mikrotik-Delegated-IPv6-Pool that doesn't work. DHCPv6 prefix delegation over PPP tunnels is completely broken and doesn't work even if you don't use any IPv6 RADIUS attributes. The simple standard configuration of setting the "DHCPV6 PD Pool" in the PPP profile does not work, the client cannot get a DHCPv6 prefix. I do not understand why this is not fixed yet. It is not even possible currently to use this new version for the MikroTik IPv6 engineer training because the config for the training would not work.
 
gondim
just joined
Posts: 6
Joined: Fri Feb 08, 2008 6:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Oct 01, 2018 4:02 pm

Hi all,

What stopped working was the DHCPv6 PD Pool that is in the attached image.
You do not have the required permissions to view the files attached to this post.
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Oct 01, 2018 6:35 pm

Good afternoon everyone,

In fact, in my tests, the DHCPv6 PD pool no longer works. Either by mikrotik in the ppp profile or via radius the way I used it here.
I have done all the tests in this version, this option is not functional, the DUAL-STACK clients do not receive the prefix via DHCPv6 via DP pool.Pv6 via DP pool
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Oct 02, 2018 3:15 am

Good afternoon everyone,

In fact, in my tests, the DHCPv6 PD pool no longer works. Either by mikrotik in the ppp profile or via radius the way I used it here.
I have done all the tests in this version, this option is not functional, the DUAL-STACK clients do not receive the prefix via DHCPv6 via DP pool.Pv6 via DP pool
Yes, the same thing is happening to all of us. It has been broken for three weeks now, since 6.43 was released. It essentially breaks IPv6 services for clients.
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Oct 02, 2018 5:20 pm

Looks like it is fixed in the 6.44 beta:

viewtopic.php?f=21&t=139057&start=50#p689985
*) dhcpv6-server - recreate DHCPv6 server binding if it is no longer within prefix pool when rebinding/renewing;
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Oct 02, 2018 8:36 pm

I'm going to test today.
 
thg3x
just joined
Posts: 11
Joined: Sat Apr 15, 2017 1:40 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 03, 2018 9:23 pm

Looks like it is fixed in the 6.44 beta:

viewtopic.php?f=21&t=139057&start=50#p689985
*) dhcpv6-server - recreate DHCPv6 server binding if it is no longer within prefix pool when rebinding/renewing;
I did a test yesterday, it worked again as it worked in version 6.42.7, but I still can not get radius to assign the pools, it is still necessary to create the pools in mikrotik. In my understanding nothing new, since the interests us is the full integration with the radius, not to create several pools in Mikrotik and only point these pools in radius.
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Oct 04, 2018 1:45 pm

Truth. What else is to do the log report prefix in delegation, for security reasons to identify the user for future action. You do not have to run v6 without this dhcpv6 log.
 
marekm
Member Candidate
Member Candidate
Posts: 208
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Oct 08, 2018 7:41 pm

Looks like it is fixed in the 6.44 beta:

viewtopic.php?f=21&t=139057&start=50#p689985
*) dhcpv6-server - recreate DHCPv6 server binding if it is no longer within prefix pool when rebinding/renewing;
Does this mean 6.44 will finally support running a dual-stack PPPoE server with RADIUS auth? Or are these fixes still only for DHCP?
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Oct 08, 2018 8:46 pm

Does this mean 6.44 will finally support running a dual-stack PPPoE server with RADIUS auth? Or are these fixes still only for DHCP?
That fix is for everything, but 6.44 only currently supports the attribute over DHCPv6, not PPP tunnels

I would hope that they are adding support for the attribute to PPP tunnels as well, but haven't heard anything on this yet.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 10, 2018 1:59 pm

While implementing new features in DHCP RADIUS services we did make some changes in a way how DhCPv6 server works and as a result starting from v6.43 some of the DHCPv6 clients could not get prefix. For example, RouterOS DHCPv6 client did work just fine with our server.

Next 6.43 release and 6.44beta21 will contain fix for this problem. So PPPoE with DHCPv6 PD should work exactly the same as it did before v6.43.
 
marekm
Member Candidate
Member Candidate
Posts: 208
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 10, 2018 2:16 pm

Next 6.43 release and 6.44beta21 will contain fix for this problem. So PPPoE with DHCPv6 PD should work exactly the same as it did before v6.43.
So PPPoE *client* will work as it did, but how about PPPoE *server* with DHCPv6 PD and Delegated-IPv6-Prefix attribute (which didn't work without workarounds like manually creating many pools)?
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 10, 2018 2:20 pm

So PPPoE with DHCPv6 PD should work exactly the same as it did before v6.43.
manually create pools again? We need to create pools automatically with Radius for PPPoE.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
omidkosari
Trainer
Trainer
Posts: 616
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 10, 2018 2:55 pm

So PPPoE with DHCPv6 PD should work exactly the same as it did before v6.43.
manually create pools again? We need to create pools automatically with Radius for PPPoE.
+1

Without that ipv6 for pppoe clients is nightmare .
MTCNA , MTCRE, MTCWE, Mikrotik Certified Trainer
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 10, 2018 3:35 pm

Changes regarding pools are not reverted. Fix changes how "solicit" packet is processed received from DHCPv6 clients that didn't have "Rapid Commit" enabled.
 
marekm
Member Candidate
Member Candidate
Posts: 208
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 10, 2018 7:28 pm

Changes regarding pools are not reverted. Fix changes how "solicit" packet is processed received from DHCPv6 clients that didn't have "Rapid Commit" enabled.
Could you give a clear answer about Delegated-IPv6-Prefix support in PPPoE server? Will it work in 6.44 / 6.45 / 7.x ?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Oct 11, 2018 11:55 am

I will try to clear things up since sees that there has been a huge misunderstanding about RouterOS v6.43 changelog.

RouterOS before v6.43 did not support "Delegated-IPv6-Prefix" in any situations.

Then we added this feature in RouterOS:

*) dhcpv6-server - added additional RADIUS parameters for Prefix delegation, "rate-limit" and "life-time";

As topic of changelog entry states - change is made for DHCP service. We have not made any changes for PPP service.

v6.43, v6.43.1 and v6.43.2 did break communication between RouterOS DHCPv6 server and some DHCPv6 clients and in most cases it was noticeable on PPPoE configurations. Now it is fixed and version with fix will be released soon.

In short, if under "/radius" menu you have selected service "DHCP", then "Delegated-IPv6-Prefix" is supported. If under "/radius" menu you have selected "PPP" service, then "Delegated-IPv6-Prefix" is not supported at the moment.
FF0000
One step at the time - we added "Delegated-IPv6-Prefix" suport for DHCP in v6.43, we will see what we can do about PPP service in future RouterOS releases.
 
User avatar
omidkosari
Trainer
Trainer
Posts: 616
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Oct 11, 2018 3:20 pm

Thanks for clarification and hope for implement same feature for ppp in near time
MTCNA , MTCRE, MTCWE, Mikrotik Certified Trainer
 
littlecake
just joined
Posts: 21
Joined: Sun Jun 04, 2006 8:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Oct 11, 2018 4:45 pm

I hope also that they will do it, we are doing this think wery dirty way with scripts on AP and client side now.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Oct 11, 2018 5:52 pm

While feature is not implemented, you may use such workaround:

1) Add new pool with prefix that you want to assign to your PPPoE client;
2) Add new PPP profile and select this pool;
3) Send from RADIUS "Mikrotik-Group" parameter which is equal with this profile name.

This option is present in RouterOS starting from v6.42:
*) ppp - allow to override remote user PPP profile via "Mikrotik-Group"
 
marekm
Member Candidate
Member Candidate
Posts: 208
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Oct 11, 2018 7:51 pm

1) Add new pool with prefix that you want to assign to your PPPoE client;
2) Add new PPP profile and select this pool;
3) Send from RADIUS "Mikrotik-Group" parameter which is equal with this profile name.
The workaround may be fine when testing IPv6 on just a few customers, but doesn't scale well to hundreds/thousands of them.
The confusion is probably a result of IPv6 PPPoE also using DHCPv6 over link-local addresses configured by IPv6CP (unlike IPv4 PPPoE which configures global IPv4 addresses using IPCP, without DHCP). So when you say you fixed DHCPv6 with RADIUS attributes, it wasn't clear that PPPoE is a special case which is not yet supported.
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Oct 20, 2018 2:37 am

I did a test yesterday, it worked again as it worked in version 6.42.7, but I still can not get radius to assign the pools, it is still necessary to create the pools in mikrotik. In my understanding nothing new, since the interests us is the full integration with the radius, not to create several pools in Mikrotik and only point these pools in radius.
This fix from 6.44beta is now supposedly in 6.43.4 but I am still having the same problem, whereas 6.42.7 worked fine. I'm wondering if they somehow accidentally left the fix out of 6.43.4 even though it is in the changelog. Can you test the behavior on your side with 6.43.4?
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Oct 29, 2018 7:05 pm

6.44beta28

DHCPv6 running by lightning. Still looking forward to the PD log by Radius.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Nov 14, 2018 3:41 pm

Any news?
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
fredyz
just joined
Posts: 6
Joined: Wed Jun 13, 2018 7:07 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Nov 27, 2018 6:14 pm

Well, a couple of weeks has passed and not signal of Delegated-IPv6-Prefix being implemented to PPP as well. It took so long for this to happen for DHCP so I hope it doesn't take the same time for PPP as well.

Seems the same people responsible to handle this are in charge for quiet a while with the same practises regardless if people using are satisfied or not.

On the top of that seems there is no understand how many ISPs are affected by the lack of this feature and how this is holding IPv6 adoption in many places as the lack of this features stops ISPs from getting the radius log of which prefix was given to a customer. And we are not asking for something "nice to have" or cosmetic.

How long more !
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Nov 27, 2018 10:19 pm

Good afternoon,
I do not know how you talk about ipv6 with routerOS for years with this pending. We are all affected by this question.
 
littlecake
just joined
Posts: 21
Joined: Sun Jun 04, 2006 8:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Nov 27, 2018 10:37 pm

i do not understand Mikrotik in this case.
I hope before that mikrotik wil implement this feature, now i am looking for alternative.
Our network was running completely with mikrotik.
After comes 802.11n the mikrotik radios was bad , we implement UBNT.
Now we are running routers from mikrotik... after few years it seems that mikrotik will go completely out from our network.
I am sad, that the change will take lot of work, but i cannot accept that we will not implement IPv6 only because the mikrotik is not able to do IPv6 PD.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Nov 27, 2018 10:41 pm

I fully agree with the message littlecake. We have a similar situation.
In the radio, we already changed Mikrotik to another vendor.
MPLS - we are looking for an alternative vendor.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
omidkosari
Trainer
Trainer
Posts: 616
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Nov 28, 2018 9:41 am

Mikrotik is expected to be more agile than the other companies but unfortunately it's the opposite
MTCNA , MTCRE, MTCWE, Mikrotik Certified Trainer
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Dec 21, 2018 11:34 am

6.43.8 (2018-Dec-21 07:10) no news and changes. Does anyone in MikroTik deal with this problem?
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Dec 22, 2018 4:30 am

when we will have a novelty about a smooth operation, report prefix delegation. An alternative was presented in the GTER for PD logging
ftp://ftp.registro.br/pub/gter/gter46/
slide number 7
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Dec 23, 2018 1:18 pm

I have hope that they are still working on this and on IPv6 RADIUS accounting. They seem to have prioritized IPv6-related enhancements in the past year or so, judging by the change logs.
 
marekm
Member Candidate
Member Candidate
Posts: 208
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Dec 24, 2018 4:44 pm

+1
Mikrotik, please tell us some estimated timeframe when this feature will be finished, so we can decide: wait longer, or go with accel-ppp on Linux instead (it's a lot of work, so it would not be fun to do all this work only to find out it was unnecessary because you finally implemented this feature).
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Dec 24, 2018 8:31 pm

We have been using a workaround for now, although I'm not sure whether it will work for everybody, if it does help someone I can post the script. We have a script that runs that turns any dynamic DHCPv6 PPPoE bindings into static bindings, so that if the customer disconnects and reconnects, they get the same lease. It also copies the pppoe interface name to the comment so that we know which user the binding is for.
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Dec 24, 2018 11:24 pm

We have been using a workaround for now, although I'm not sure whether it will work for everybody, if it does help someone I can post the script. We have a script that runs that turns any dynamic DHCPv6 PPPoE bindings into static bindings, so that if the customer disconnects and reconnects, they get the same lease. It also copies the pppoe interface name to the comment so that we know which user the binding is for.


Dear friend, I could post the script.
 
mducharme
Trainer
Trainer
Posts: 874
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Dec 25, 2018 1:40 am

Dear friend, I could post the script.
Here it is - we run this every 5 minutes using the scheduler:
/ipv6 dhcp-server binding;
:foreach i in=[find server~"pppoe"] do={
  make-static $i;
  set $i comment=[get $i server];
  set $i server=all;
}
It works well and users always get the same prefix after disconnecting and reconnecting. It is really just a temporary solution for us until the better solution of Delegated-IPv6-Prefix becomes available.

Because static bindings will be backed up with the router configuration backup by Oxidized, we can look in there to see what user has what binding.

I was also toying with the idea of writing a parser that would look through the backed up config from RouterOS and update RADIUS mysql accounting table with the Delegated-IPv6-Prefix, as though it were being given by RouterOS itself, as a workaround for the lack of accounting. However it wasn't a big deal for us because we only have a few PPPoE concentrators and we tunnel all customers back to these concentrators.

@saaremaa and @marekm is this workaround useful for you at all?
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Dec 25, 2018 6:21 am

Dear friend, I could post the script.
Here it is - we run this every 5 minutes using the scheduler:
/ipv6 dhcp-server binding;
:foreach i in=[find server~"pppoe"] do={
  make-static $i;
  set $i comment=[get $i server];
  set $i server=all;
}
It works well and users always get the same prefix after disconnecting and reconnecting. It is really just a temporary solution for us until the better solution of Delegated-IPv6-Prefix becomes available.

Because static bindings will be backed up with the router configuration backup by Oxidized, we can look in there to see what user has what binding.

I was also toying with the idea of writing a parser that would look through the backed up config from RouterOS and update RADIUS mysql accounting table with the Delegated-IPv6-Prefix, as though it were being given by RouterOS itself, as a workaround for the lack of accounting. However it wasn't a big deal for us because we only have a few PPPoE concentrators and we tunnel all customers back to these concentrators.

@saaremaa and @marekm is this workaround useful for you at all?
Okay, thanks for the tip.

I can aggregate to a separate log server for better control of the delegate prefix.

Hello good afternoon,
I also made this scritp to make a copy of the daily static PD for future analysis, sending to a technical email.

Code: Select all

/ipv6 dhcp-server export verbose file=IPv6LOG-PD
:log info message="enviando LOGIPV6PD por email"
:delay 5s
:global data [/system clock get date]
:global hora [/system clock get time]
:global nome [/system identity get name]
/tool e-mail send to="noc@empresa.com.br" subject="IPV6LOGPD $nome - $data às $hora" body="IPV6LGPD $nome realizado às $hora de $data." file=IPv6LOG-PD.rsc start-tls=yes
:log info message="backup do log PD enviado!"
Last edited by DuhBatista on Sun Dec 30, 2018 6:33 pm, edited 1 time in total.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Dec 25, 2018 3:32 pm

@saaremaa and @marekm is this workaround useful for you at all?
In my case, this method will not help. It is required that the binding of the prefix to the client's account be in the billing and issued by the Radius attribute. This is a requirement of Roskomnadzor (Russia).
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 05, 2019 11:20 pm

Any news? It seems to me - again, no.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Feb 08, 2019 3:27 pm

Until now, no one on the team gives anything. Terrible.
 
remontti
just joined
Posts: 4
Joined: Mon Aug 31, 2015 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 19, 2019 7:04 pm

Unfortunately the team has not yet deployed the Delegated-IPv6-Prefix.

It is by these and others that people have been abandoning mikrotik.

I hope you're ashamed in the face.

We have been expecting this since 2014.
5 years waiting.
it's ridiculous!
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 19, 2019 10:44 pm

Good afternoon

Inevitably stay that way, a matter of extreme complexity, and mikrotik has not done anything yet so we can move forward.

Wrong
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 26, 2019 10:26 pm

CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
marlow
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Mar 16, 2006 6:59 pm
Location: Ireland

Re: Report

Wed Feb 27, 2019 12:15 am

Unfortunately the team has not yet deployed the Delegated-IPv6-Prefix.

It is by these and others that people have been abandoning mikrotik.

I hope you're ashamed in the face.

We have been expecting this since 2014.
5 years waiting.
it's ridiculous!
Hang on. .. 2014 ?

What sort of dreamland do you live in ? I have been asking for these kind of features, when 2.9 was stable.. and that is a long time before that.

Anyhow ...since before 2008 anyhow ..

I have tickets to prove it. Yet ignored.

/M
Communication is the beginning of understanding
-- AT&T
 
ft897d
just joined
Posts: 3
Joined: Sun Feb 19, 2017 2:29 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Feb 27, 2019 1:00 pm

Dear support, please tell me when the company MikroTik plans to implement the support of "Delegated-IPv6-Prefix" radius attribute for PPP services?
 
ft897d
just joined
Posts: 3
Joined: Sun Feb 19, 2017 2:29 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Feb 28, 2019 1:15 pm

Dear support, please tell me when the company MikroTik plans to implement the support of "Delegated-IPv6-Prefix" radius attribute for PPP services?
Hello,

It is in our plans to implement such functioality, however, I can not provide any ETA.

Best regards,
Martins S.

:((((((
 
User avatar
omidkosari
Trainer
Trainer
Posts: 616
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Mar 03, 2019 12:23 pm

viewtopic.php?f=21&t=145793&p=717609#p717667
saaremaa - What is the question here actually? Delegated-IPv6-Prefix is already working for DHCP service (RADIUS). Such parameter is not available yet for PPP service. If you make PPPoE server which then distributes addresses by using DHCP service, then this will not work since users are authenticated by using PPP service, not DHCP;
MTCNA , MTCRE, MTCWE, Mikrotik Certified Trainer
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Mar 03, 2019 12:27 pm

viewtopic.php?f=21&t=145793&p=717609#p717900
saaremaa - Sorry about that. I mixed both services together. We do support Delegated-IPv6-Prefix for DHCP service but not for PPP yet. It is in our plans to add support for this in the future;
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
littlecake
just joined
Posts: 21
Joined: Sun Jun 04, 2006 8:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Mar 03, 2019 12:28 pm

But nobody knows how far is the "future" :)
 
remontti
just joined
Posts: 4
Joined: Mon Aug 31, 2015 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Mar 20, 2019 9:56 pm

viewtopic.php?f=21&t=145793&p=717609#p717667
saaremaa - What is the question here actually? Delegated-IPv6-Prefix is already working for DHCP service (RADIUS). Such parameter is not available yet for PPP service. If you make PPPoE server which then distributes addresses by using DHCP service, then this will not work since users are authenticated by using PPP service, not DHCP;
Everyone coming out of RouterOS exactly because they have not yet deployed Delegated-IPv6-Prefix with PPPoE. This update of you is useless to the vast majority.
We have been clamoring for this functionality for years. It is a disregard for users.
Hope to see this working on an update.

All other companies competing with mikrotik are already compatible with Delegated-IPv6-Prefix + PPPoE.
is being charged to do
IPv6 is being charged to be implanted.
When a large company (example google) deactivate their IPv4, is Mikrotik will lose many customers
Sorry for my English.
 
DuhBatista
just joined
Posts: 11
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Mar 24, 2019 8:21 pm

inadmissible
 
marekm
Member Candidate
Member Candidate
Posts: 208
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Mar 28, 2019 10:30 pm

On a positive side, lack of this feature may have kept many people safe from this soon to be disclosed vulnerability:
viewtopic.php?f=2&t=147048
viewtopic.php?f=2&p=723809

Stop IPv6 deployment, or move from MT to something else (Cisco, Linux + BIRD + accel-ppp, ...) so you can deploy IPv6 anyway = not vulnerable :)
Since it was known internally for about a year, perhaps it was the real reason support was not telling anyone why it takes so long to implement Delegated-IPv6-Prefix.
 
User avatar
marlow
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Mar 16, 2006 6:59 pm
Location: Ireland

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 01, 2019 12:39 pm

Nah. Requests for Delegated-IPv6-Prefix on PPPoE go back to ROS 3.x

And thats a decade ago.

It is just disregard of Mikrotiks customers.

/M
Communication is the beginning of understanding
-- AT&T
 
fredyz
just joined
Posts: 6
Joined: Wed Jun 13, 2018 7:07 pm

Re: Report

Mon Apr 08, 2019 6:56 pm

That's a cultural thing within Mikrotik it seems. Looks like the development and the organization of the priorities is messed up and the same person (or similar people) are in charge for a long time and refuses even to acknowledge there are serious issues regarding organization.They probably feel better believing that keeping the same way of doing things and dismissing everything else they may not like to hear is the right way to go.
Nah. Requests for Delegated-IPv6-Prefix on PPPoE go back to ROS 3.x

And thats a decade ago.

It is just disregard of Mikrotiks customers.

/M
 
User avatar
petrb
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jan 26, 2017 4:17 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Apr 11, 2019 12:14 pm

I want to deploy a combination of the VPLS+PPPoE+Delegated-IPv6-Prefix. Most of the cheap devices cannot do this at the once :( . Basic linux distribution have poor implementation of the VPLS. MK please implement "Delegated-IPv6-Prefix" attribute for PPPoE. Thanks
Did you read manual? .... What? .... Read the manual.
 
CoMMyz
just joined
Posts: 23
Joined: Fri Dec 04, 2015 10:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 22, 2019 3:01 am

We need this please done - the need for IPv6 over Radios with PPPoE is a use case for most ISP's out there.
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Apr 27, 2019 5:03 pm

+1
Testing Latest ROS 6.44.3, same situation!
 
marekm
Member Candidate
Member Candidate
Posts: 208
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 29, 2019 1:09 pm

For anyone looking for alternatives (on x86 hardware), VyOS now includes accel-ppp which supports Delegated-IPv6-Prefix.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 29, 2019 1:22 pm

We gradually abandon Mikrotik as BRAS and migrate to VAS Experts DPI BRAS There are many more MPLS from Mikrotik in the network, but because of the absence of FRR, I also want to leave
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
petrb
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jan 26, 2017 4:17 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 29, 2019 2:23 pm

For anyone looking for alternatives (on x86 hardware), VyOS now includes accel-ppp which supports Delegated-IPv6-Prefix.
vyos not support VPLS :( .... or documentation is poor
Did you read manual? .... What? .... Read the manual.
 
User avatar
marlow
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Mar 16, 2006 6:59 pm
Location: Ireland

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon May 06, 2019 9:51 pm

For anyone looking for alternatives (on x86 hardware), VyOS now includes accel-ppp which supports Delegated-IPv6-Prefix.

Jup. I'm already testing accel-ppp on Edgerouter Infinity and also looking at cross-compiling the package for Edgerouter X. Mikrotik seem to have no interest in the need of their customers.

/M
Communication is the beginning of understanding
-- AT&T
 
User avatar
petrb
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jan 26, 2017 4:17 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Jun 29, 2019 7:45 pm

I gave up the idea of implementing PPPoE delegated-ipv6-prefix and use DHCP and 802.1x for network configuration.

How it works:
1. I have a freeradius with 802.1x authentification, store Calling-Station-Id after successful EAP.
2. DHCPv4 and DHCPv6 server at the MK is connected to the radius.
3. At the freeradius rewrite policy to pair DHCP"username" attribute and "Calling-Station-Id" to find EAP"username".
4. Freeradius send correct framed-ip-address, framed-route, delegated-ipv6-prefix, Mikrotik-Rate-Limit, Mikrotik-address-list

Results:
- Works perfect for IPv4.
- IPv6 not work for MK CPE (DHCP username attribute for IPv4 and IPv6 are different - mac vs duid ......... long story)
- IPv6 works perfect for UBNT CPE (same username attribute for IPv4 and IPv6 DHCP client)

Until DHCP option 79 will be implemented, you can use Kea as dhcp server instead Mikrotik.

Next sollution for the future will be DHCPv6 op 79 - Client Link-Layer Address Option
viewtopic.php?f=2&t=149399

Until DHCP option 79 will be implemented, you can use Kea as dhcp server instead Mikrotik.
Did you read manual? .... What? .... Read the manual.
 
ricardobrock
just joined
Posts: 2
Joined: Tue Mar 26, 2019 1:58 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Jul 16, 2019 9:21 am

+1
Any update about this from Mikrotik??? We have multiple CCR1072-1G-8S+ running only for PPPoE and my customers would like to use IPv6.
@Mikrotik, this post is from 2014, should I start buying other routers for PPPoE? If there would be any information about this FR, just to give people (network engineers) headsup when they can expect something?
 
interprime
just joined
Posts: 15
Joined: Wed Jun 08, 2011 1:08 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Jul 16, 2019 10:18 pm

+1 since 2014
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Jul 17, 2019 6:47 pm

+1 again!
But what about latest version?
"dhcpv6-server - override prefix pool and/or DNS server settings by values received from RADIUS;"
Could it be related?
 
ricardobrock
just joined
Posts: 2
Joined: Tue Mar 26, 2019 1:58 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Aug 29, 2019 9:40 pm

@Mikrotik Amy response?

Ripe says IPv4 is done by then end of this year.
 
tdamas
just joined
Posts: 1
Joined: Wed Sep 04, 2019 9:34 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Sep 04, 2019 9:39 pm

WORKING since 6.45.1:
*) dhcpv6-server - added additional RADIUS parameters for Prefix delegation, "rate-limit" and "life-time";

For now, it need to activate the "dhcp" option under RADIUS configuration to log accounting packets.
 
User avatar
petrb
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jan 26, 2017 4:17 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Sep 11, 2019 10:41 am

dhcpv6 PD is not PPPoE PD
Did you read manual? .... What? .... Read the manual.
 
User avatar
dibatech
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Tue Apr 04, 2006 10:14 am

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Sep 19, 2019 5:07 pm

@Mikrotik: This must be really difficult to impliment....
 
User avatar
pietroscherer
Trainer
Trainer
Posts: 170
Joined: Thu Mar 05, 2015 3:05 pm
Location: RS, Brazil
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Sep 19, 2019 5:45 pm

Anyone tested on 6.45.x ?
Pietro Scherer
http://www.tchesolutions.com.br [ISPs Consulting and Training]
http://www.routermage.com [Backup and Automation System]
:D
 
User avatar
edurosso
just joined
Posts: 1
Joined: Tue Sep 24, 2019 3:25 am
Location: Santa Maria - RS - Brasil

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 24, 2019 3:50 am

Anyone tested on 6.45.x ?
Hi Pietro, glad to see you.
I just tested on 6.45.6. For PPPoE, sending "Delegated-IPv6-Prefix" attribute did not work. I found that enabling "dhcp" option in RADIUS Client resulted on RouterOS sending "Delegated-IPv6-Prefix" to RADIUS Server, but not for PPPoE connections, only for DHCPv6.
So, until MikroTik releases full support for "Delegated-IPv6-Prefix" for PPPoE, I am using "Mikrotik-Delegated-IPv6-Pool" instead. But this is not a solution, it is a workaround because this way I need to create the pools, and therefore, RADIUS Server don't receive PD information from RouterOS via accounting or access/accept requests. RADIUS receives back only the "Framed-IPv6-Prefix" (WAN).
__
Eduardo Cargnelutti
 
jindranix
just joined
Posts: 6
Joined: Mon Jun 09, 2014 11:41 am

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 02, 2019 12:51 pm

Yes, it is really annoying. this small thing is missing to full dual-stack support on PPPoE.
 
User avatar
danunjaya123
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Thu Oct 03, 2019 7:36 am
Location: India

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Oct 04, 2019 12:56 pm

I have configured PPPoE on IPv6 for my customers on different Vlan's, Now i have got issue in this when i did PPPoE Dail at customer end getting IPv6 IP and showing IPv6 for my PC but not able to get browsing on IPv6 traffic, For this i have found that it was IPv6 DNS issue.

When i dail On PPPoE getting IP only not getting DNS of IPv6.

Let us we know how DNS will reach the customer when dailup.


Is IPv6 Support Hotspot?, I need to give for some of my customers on DHCP mode so they are getting IP but not able to redirect to Radius.

I have CCR-1036

Who is online

Users browsing this forum: No registered users and 112 guests