Community discussions

MUM Europe 2020
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Oct 29, 2018 7:05 pm

6.44beta28

DHCPv6 running by lightning. Still looking forward to the PD log by Radius.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Nov 14, 2018 3:41 pm

Any news?
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
fredyz
just joined
Posts: 6
Joined: Wed Jun 13, 2018 7:07 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Nov 27, 2018 6:14 pm

Well, a couple of weeks has passed and not signal of Delegated-IPv6-Prefix being implemented to PPP as well. It took so long for this to happen for DHCP so I hope it doesn't take the same time for PPP as well.

Seems the same people responsible to handle this are in charge for quiet a while with the same practises regardless if people using are satisfied or not.

On the top of that seems there is no understand how many ISPs are affected by the lack of this feature and how this is holding IPv6 adoption in many places as the lack of this features stops ISPs from getting the radius log of which prefix was given to a customer. And we are not asking for something "nice to have" or cosmetic.

How long more !
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Nov 27, 2018 10:19 pm

Good afternoon,
I do not know how you talk about ipv6 with routerOS for years with this pending. We are all affected by this question.
 
littlecake
just joined
Posts: 21
Joined: Sun Jun 04, 2006 8:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Nov 27, 2018 10:37 pm

i do not understand Mikrotik in this case.
I hope before that mikrotik wil implement this feature, now i am looking for alternative.
Our network was running completely with mikrotik.
After comes 802.11n the mikrotik radios was bad , we implement UBNT.
Now we are running routers from mikrotik... after few years it seems that mikrotik will go completely out from our network.
I am sad, that the change will take lot of work, but i cannot accept that we will not implement IPv6 only because the mikrotik is not able to do IPv6 PD.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Nov 27, 2018 10:41 pm

I fully agree with the message littlecake. We have a similar situation.
In the radio, we already changed Mikrotik to another vendor.
MPLS - we are looking for an alternative vendor.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
omidkosari
Trainer
Trainer
Posts: 628
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Nov 28, 2018 9:41 am

Mikrotik is expected to be more agile than the other companies but unfortunately it's the opposite
MTCNA , MTCRE, MTCWE, Mikrotik Certified Trainer
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Dec 21, 2018 11:34 am

6.43.8 (2018-Dec-21 07:10) no news and changes. Does anyone in MikroTik deal with this problem?
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Dec 22, 2018 4:30 am

when we will have a novelty about a smooth operation, report prefix delegation. An alternative was presented in the GTER for PD logging
ftp://ftp.registro.br/pub/gter/gter46/
slide number 7
 
mducharme
Trainer
Trainer
Posts: 890
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Dec 23, 2018 1:18 pm

I have hope that they are still working on this and on IPv6 RADIUS accounting. They seem to have prioritized IPv6-related enhancements in the past year or so, judging by the change logs.
 
marekm
Member Candidate
Member Candidate
Posts: 220
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Dec 24, 2018 4:44 pm

+1
Mikrotik, please tell us some estimated timeframe when this feature will be finished, so we can decide: wait longer, or go with accel-ppp on Linux instead (it's a lot of work, so it would not be fun to do all this work only to find out it was unnecessary because you finally implemented this feature).
 
mducharme
Trainer
Trainer
Posts: 890
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Dec 24, 2018 8:31 pm

We have been using a workaround for now, although I'm not sure whether it will work for everybody, if it does help someone I can post the script. We have a script that runs that turns any dynamic DHCPv6 PPPoE bindings into static bindings, so that if the customer disconnects and reconnects, they get the same lease. It also copies the pppoe interface name to the comment so that we know which user the binding is for.
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Dec 24, 2018 11:24 pm

We have been using a workaround for now, although I'm not sure whether it will work for everybody, if it does help someone I can post the script. We have a script that runs that turns any dynamic DHCPv6 PPPoE bindings into static bindings, so that if the customer disconnects and reconnects, they get the same lease. It also copies the pppoe interface name to the comment so that we know which user the binding is for.


Dear friend, I could post the script.
 
mducharme
Trainer
Trainer
Posts: 890
Joined: Tue Jul 19, 2016 6:45 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Dec 25, 2018 1:40 am

Dear friend, I could post the script.
Here it is - we run this every 5 minutes using the scheduler:
/ipv6 dhcp-server binding;
:foreach i in=[find server~"pppoe"] do={
  make-static $i;
  set $i comment=[get $i server];
  set $i server=all;
}
It works well and users always get the same prefix after disconnecting and reconnecting. It is really just a temporary solution for us until the better solution of Delegated-IPv6-Prefix becomes available.

Because static bindings will be backed up with the router configuration backup by Oxidized, we can look in there to see what user has what binding.

I was also toying with the idea of writing a parser that would look through the backed up config from RouterOS and update RADIUS mysql accounting table with the Delegated-IPv6-Prefix, as though it were being given by RouterOS itself, as a workaround for the lack of accounting. However it wasn't a big deal for us because we only have a few PPPoE concentrators and we tunnel all customers back to these concentrators.

@saaremaa and @marekm is this workaround useful for you at all?
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Dec 25, 2018 6:21 am

Dear friend, I could post the script.
Here it is - we run this every 5 minutes using the scheduler:
/ipv6 dhcp-server binding;
:foreach i in=[find server~"pppoe"] do={
  make-static $i;
  set $i comment=[get $i server];
  set $i server=all;
}
It works well and users always get the same prefix after disconnecting and reconnecting. It is really just a temporary solution for us until the better solution of Delegated-IPv6-Prefix becomes available.

Because static bindings will be backed up with the router configuration backup by Oxidized, we can look in there to see what user has what binding.

I was also toying with the idea of writing a parser that would look through the backed up config from RouterOS and update RADIUS mysql accounting table with the Delegated-IPv6-Prefix, as though it were being given by RouterOS itself, as a workaround for the lack of accounting. However it wasn't a big deal for us because we only have a few PPPoE concentrators and we tunnel all customers back to these concentrators.

@saaremaa and @marekm is this workaround useful for you at all?
Okay, thanks for the tip.

I can aggregate to a separate log server for better control of the delegate prefix.

Hello good afternoon,
I also made this scritp to make a copy of the daily static PD for future analysis, sending to a technical email.

Code: Select all

/ipv6 dhcp-server export verbose file=IPv6LOG-PD
:log info message="enviando LOGIPV6PD por email"
:delay 5s
:global data [/system clock get date]
:global hora [/system clock get time]
:global nome [/system identity get name]
/tool e-mail send to="noc@empresa.com.br" subject="IPV6LOGPD $nome - $data às $hora" body="IPV6LGPD $nome realizado às $hora de $data." file=IPv6LOG-PD.rsc start-tls=yes
:log info message="backup do log PD enviado!"
Last edited by DuhBatista on Sun Dec 30, 2018 6:33 pm, edited 1 time in total.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Dec 25, 2018 3:32 pm

@saaremaa and @marekm is this workaround useful for you at all?
In my case, this method will not help. It is required that the binding of the prefix to the client's account be in the billing and issued by the Radius attribute. This is a requirement of Roskomnadzor (Russia).
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 05, 2019 11:20 pm

Any news? It seems to me - again, no.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Feb 08, 2019 3:27 pm

Until now, no one on the team gives anything. Terrible.
 
remontti
just joined
Posts: 5
Joined: Mon Aug 31, 2015 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 19, 2019 7:04 pm

Unfortunately the team has not yet deployed the Delegated-IPv6-Prefix.

It is by these and others that people have been abandoning mikrotik.

I hope you're ashamed in the face.

We have been expecting this since 2014.
5 years waiting.
it's ridiculous!
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 19, 2019 10:44 pm

Good afternoon

Inevitably stay that way, a matter of extreme complexity, and mikrotik has not done anything yet so we can move forward.

Wrong
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 26, 2019 10:26 pm

CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
marlow
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Mar 16, 2006 6:59 pm
Location: Ireland

Re: Report

Wed Feb 27, 2019 12:15 am

Unfortunately the team has not yet deployed the Delegated-IPv6-Prefix.

It is by these and others that people have been abandoning mikrotik.

I hope you're ashamed in the face.

We have been expecting this since 2014.
5 years waiting.
it's ridiculous!
Hang on. .. 2014 ?

What sort of dreamland do you live in ? I have been asking for these kind of features, when 2.9 was stable.. and that is a long time before that.

Anyhow ...since before 2008 anyhow ..

I have tickets to prove it. Yet ignored.

/M
Communication is the beginning of understanding
-- AT&T
 
ft897d
just joined
Posts: 3
Joined: Sun Feb 19, 2017 2:29 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Feb 27, 2019 1:00 pm

Dear support, please tell me when the company MikroTik plans to implement the support of "Delegated-IPv6-Prefix" radius attribute for PPP services?
 
ft897d
just joined
Posts: 3
Joined: Sun Feb 19, 2017 2:29 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Feb 28, 2019 1:15 pm

Dear support, please tell me when the company MikroTik plans to implement the support of "Delegated-IPv6-Prefix" radius attribute for PPP services?
Hello,

It is in our plans to implement such functioality, however, I can not provide any ETA.

Best regards,
Martins S.

:((((((
 
User avatar
omidkosari
Trainer
Trainer
Posts: 628
Joined: Fri Sep 01, 2006 4:18 pm
Location: Iran , Karaj
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Mar 03, 2019 12:23 pm

viewtopic.php?f=21&t=145793&p=717609#p717667
saaremaa - What is the question here actually? Delegated-IPv6-Prefix is already working for DHCP service (RADIUS). Such parameter is not available yet for PPP service. If you make PPPoE server which then distributes addresses by using DHCP service, then this will not work since users are authenticated by using PPP service, not DHCP;
MTCNA , MTCRE, MTCWE, Mikrotik Certified Trainer
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Mar 03, 2019 12:27 pm

viewtopic.php?f=21&t=145793&p=717609#p717900
saaremaa - Sorry about that. I mixed both services together. We do support Delegated-IPv6-Prefix for DHCP service but not for PPP yet. It is in our plans to add support for this in the future;
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
littlecake
just joined
Posts: 21
Joined: Sun Jun 04, 2006 8:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Mar 03, 2019 12:28 pm

But nobody knows how far is the "future" :)
 
remontti
just joined
Posts: 5
Joined: Mon Aug 31, 2015 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Mar 20, 2019 9:56 pm

viewtopic.php?f=21&t=145793&p=717609#p717667
saaremaa - What is the question here actually? Delegated-IPv6-Prefix is already working for DHCP service (RADIUS). Such parameter is not available yet for PPP service. If you make PPPoE server which then distributes addresses by using DHCP service, then this will not work since users are authenticated by using PPP service, not DHCP;
Everyone coming out of RouterOS exactly because they have not yet deployed Delegated-IPv6-Prefix with PPPoE. This update of you is useless to the vast majority.
We have been clamoring for this functionality for years. It is a disregard for users.
Hope to see this working on an update.

All other companies competing with mikrotik are already compatible with Delegated-IPv6-Prefix + PPPoE.
is being charged to do
IPv6 is being charged to be implanted.
When a large company (example google) deactivate their IPv4, is Mikrotik will lose many customers
Sorry for my English.
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sun Mar 24, 2019 8:21 pm

inadmissible
 
marekm
Member Candidate
Member Candidate
Posts: 220
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Mar 28, 2019 10:30 pm

On a positive side, lack of this feature may have kept many people safe from this soon to be disclosed vulnerability:
viewtopic.php?f=2&t=147048
viewtopic.php?f=2&p=723809

Stop IPv6 deployment, or move from MT to something else (Cisco, Linux + BIRD + accel-ppp, ...) so you can deploy IPv6 anyway = not vulnerable :)
Since it was known internally for about a year, perhaps it was the real reason support was not telling anyone why it takes so long to implement Delegated-IPv6-Prefix.
 
User avatar
marlow
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Mar 16, 2006 6:59 pm
Location: Ireland

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 01, 2019 12:39 pm

Nah. Requests for Delegated-IPv6-Prefix on PPPoE go back to ROS 3.x

And thats a decade ago.

It is just disregard of Mikrotiks customers.

/M
Communication is the beginning of understanding
-- AT&T
 
fredyz
just joined
Posts: 6
Joined: Wed Jun 13, 2018 7:07 pm

Re: Report

Mon Apr 08, 2019 6:56 pm

That's a cultural thing within Mikrotik it seems. Looks like the development and the organization of the priorities is messed up and the same person (or similar people) are in charge for a long time and refuses even to acknowledge there are serious issues regarding organization.They probably feel better believing that keeping the same way of doing things and dismissing everything else they may not like to hear is the right way to go.
Nah. Requests for Delegated-IPv6-Prefix on PPPoE go back to ROS 3.x

And thats a decade ago.

It is just disregard of Mikrotiks customers.

/M
 
User avatar
petrb
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jan 26, 2017 4:17 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Apr 11, 2019 12:14 pm

I want to deploy a combination of the VPLS+PPPoE+Delegated-IPv6-Prefix. Most of the cheap devices cannot do this at the once :( . Basic linux distribution have poor implementation of the VPLS. MK please implement "Delegated-IPv6-Prefix" attribute for PPPoE. Thanks
Did you read manual? .... What? .... Read the manual.
 
CoMMyz
newbie
Posts: 26
Joined: Fri Dec 04, 2015 10:56 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 22, 2019 3:01 am

We need this please done - the need for IPv6 over Radios with PPPoE is a use case for most ISP's out there.
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Apr 27, 2019 5:03 pm

+1
Testing Latest ROS 6.44.3, same situation!
 
marekm
Member Candidate
Member Candidate
Posts: 220
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 29, 2019 1:09 pm

For anyone looking for alternatives (on x86 hardware), VyOS now includes accel-ppp which supports Delegated-IPv6-Prefix.
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 156
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 29, 2019 1:22 pm

We gradually abandon Mikrotik as BRAS and migrate to VAS Experts DPI BRAS There are many more MPLS from Mikrotik in the network, but because of the absence of FRR, I also want to leave
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
petrb
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jan 26, 2017 4:17 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Apr 29, 2019 2:23 pm

For anyone looking for alternatives (on x86 hardware), VyOS now includes accel-ppp which supports Delegated-IPv6-Prefix.
vyos not support VPLS :( .... or documentation is poor
Did you read manual? .... What? .... Read the manual.
 
User avatar
marlow
Member Candidate
Member Candidate
Posts: 159
Joined: Thu Mar 16, 2006 6:59 pm
Location: Ireland

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon May 06, 2019 9:51 pm

For anyone looking for alternatives (on x86 hardware), VyOS now includes accel-ppp which supports Delegated-IPv6-Prefix.

Jup. I'm already testing accel-ppp on Edgerouter Infinity and also looking at cross-compiling the package for Edgerouter X. Mikrotik seem to have no interest in the need of their customers.

/M
Communication is the beginning of understanding
-- AT&T
 
User avatar
petrb
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jan 26, 2017 4:17 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Jun 29, 2019 7:45 pm

I gave up the idea of implementing PPPoE delegated-ipv6-prefix and use DHCP and 802.1x for network configuration.

How it works:
1. I have a freeradius with 802.1x authentification, store Calling-Station-Id after successful EAP.
2. DHCPv4 and DHCPv6 server at the MK is connected to the radius.
3. At the freeradius rewrite policy to pair DHCP"username" attribute and "Calling-Station-Id" to find EAP"username".
4. Freeradius send correct framed-ip-address, framed-route, delegated-ipv6-prefix, Mikrotik-Rate-Limit, Mikrotik-address-list

Results:
- Works perfect for IPv4.
- IPv6 not work for MK CPE (DHCP username attribute for IPv4 and IPv6 are different - mac vs duid ......... long story)
- IPv6 works perfect for UBNT CPE (same username attribute for IPv4 and IPv6 DHCP client)

Until DHCP option 79 will be implemented, you can use Kea as dhcp server instead Mikrotik.

Next sollution for the future will be DHCPv6 op 79 - Client Link-Layer Address Option
viewtopic.php?f=2&t=149399

Until DHCP option 79 will be implemented, you can use Kea as dhcp server instead Mikrotik.
Did you read manual? .... What? .... Read the manual.
 
ricardobrock
just joined
Posts: 4
Joined: Tue Mar 26, 2019 1:58 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Jul 16, 2019 9:21 am

+1
Any update about this from Mikrotik??? We have multiple CCR1072-1G-8S+ running only for PPPoE and my customers would like to use IPv6.
@Mikrotik, this post is from 2014, should I start buying other routers for PPPoE? If there would be any information about this FR, just to give people (network engineers) headsup when they can expect something?
 
interprime
just joined
Posts: 15
Joined: Wed Jun 08, 2011 1:08 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Jul 16, 2019 10:18 pm

+1 since 2014
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Jul 17, 2019 6:47 pm

+1 again!
But what about latest version?
"dhcpv6-server - override prefix pool and/or DNS server settings by values received from RADIUS;"
Could it be related?
 
ricardobrock
just joined
Posts: 4
Joined: Tue Mar 26, 2019 1:58 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Aug 29, 2019 9:40 pm

@Mikrotik Amy response?

Ripe says IPv4 is done by then end of this year.
 
tdamas
just joined
Posts: 1
Joined: Wed Sep 04, 2019 9:34 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Sep 04, 2019 9:39 pm

WORKING since 6.45.1:
*) dhcpv6-server - added additional RADIUS parameters for Prefix delegation, "rate-limit" and "life-time";

For now, it need to activate the "dhcp" option under RADIUS configuration to log accounting packets.
 
User avatar
petrb
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Thu Jan 26, 2017 4:17 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Sep 11, 2019 10:41 am

dhcpv6 PD is not PPPoE PD
Did you read manual? .... What? .... Read the manual.
 
User avatar
dibatech
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Tue Apr 04, 2006 10:14 am

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Sep 19, 2019 5:07 pm

@Mikrotik: This must be really difficult to impliment....
 
User avatar
pietroscherer
Trainer
Trainer
Posts: 170
Joined: Thu Mar 05, 2015 3:05 pm
Location: RS, Brazil
Contact:

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Thu Sep 19, 2019 5:45 pm

Anyone tested on 6.45.x ?
Pietro Scherer
http://www.tchesolutions.com.br [ISPs Consulting and Training]
http://www.routermage.com [Backup and Automation System]
:D
 
User avatar
edurosso
just joined
Posts: 1
Joined: Tue Sep 24, 2019 3:25 am
Location: Santa Maria - RS - Brasil

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Sep 24, 2019 3:50 am

Anyone tested on 6.45.x ?
Hi Pietro, glad to see you.
I just tested on 6.45.6. For PPPoE, sending "Delegated-IPv6-Prefix" attribute did not work. I found that enabling "dhcp" option in RADIUS Client resulted on RouterOS sending "Delegated-IPv6-Prefix" to RADIUS Server, but not for PPPoE connections, only for DHCPv6.
So, until MikroTik releases full support for "Delegated-IPv6-Prefix" for PPPoE, I am using "Mikrotik-Delegated-IPv6-Pool" instead. But this is not a solution, it is a workaround because this way I need to create the pools, and therefore, RADIUS Server don't receive PD information from RouterOS via accounting or access/accept requests. RADIUS receives back only the "Framed-IPv6-Prefix" (WAN).
__
Eduardo Cargnelutti
 
jindranix
just joined
Posts: 7
Joined: Mon Jun 09, 2014 11:41 am

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Wed Oct 02, 2019 12:51 pm

Yes, it is really annoying. this small thing is missing to full dual-stack support on PPPoE.
 
User avatar
danunjaya123
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Thu Oct 03, 2019 7:36 am
Location: India

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Oct 04, 2019 12:56 pm

I have configured PPPoE on IPv6 for my customers on different Vlan's, Now i have got issue in this when i did PPPoE Dail at customer end getting IPv6 IP and showing IPv6 for my PC but not able to get browsing on IPv6 traffic, For this i have found that it was IPv6 DNS issue.

When i dail On PPPoE getting IP only not getting DNS of IPv6.

Let us we know how DNS will reach the customer when dailup.


Is IPv6 Support Hotspot?, I need to give for some of my customers on DHCP mode so they are getting IP but not able to redirect to Radius.

I have CCR-1036
 
marekm
Member Candidate
Member Candidate
Posts: 220
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Mon Nov 18, 2019 12:30 am

Any update on this long requested feature?
Will it ever appear in v6, or only in v7?
 
jimkim5934
just joined
Posts: 1
Joined: Fri Dec 13, 2019 9:08 am

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Dec 13, 2019 9:21 am

In 6.46, I have IA PD issue. There is no IA PD value in the packet.


Frame 4098: 171 bytes on wire (1368 bits), 171 bytes captured (1368 bits) on interface 0
Ethernet II, Src: Routerbo_e2:3f:6e (6c:3b:6b:e2:3f:6e), Dst: HWTC_98:21:70 (8c:44:4f:98:21:70)
PPP-over-Ethernet Session
0001 .... = Version: 1
.... 0001 = Type: 1
Code: Session Data (0x00)
Session ID: 0x000b
Payload Length: 151
Point-to-Point Protocol
Protocol: Internet Protocol version 6 (0x0057)
Internet Protocol Version 6, Src: fe80::f0:c, Dst: fe80::68a4:b5e:4a59:5a46
0110 .... = Version: 6
.... 0000 0000 .... .... .... .... .... = Traffic Class: 0x00 (DSCP: CS0, ECN: Not-ECT)
.... .... .... 0000 0000 0000 0000 0000 = Flow Label: 0x00000
Payload Length: 109
Next Header: UDP (17)
Hop Limit: 64
Source: fe80::f0:c
Destination: fe80::68a4:b5e:4a59:5a46
User Datagram Protocol, Src Port: 547, Dst Port: 546
Source Port: 547
Destination Port: 546
Length: 109
Checksum: 0x6001 [unverified]
[Checksum Status: Unverified]
[Stream index: 159]
[Timestamps]
DHCPv6
Message type: Reply (7)
Transaction ID: 0xb53f80
Client Identifier
Option: Client Identifier (1)
Length: 10
Value: 000300018c444f982170
DUID: 000300018c444f982170
DUID Type: link-layer address (3)
Hardware type: Ethernet (1)
Link-layer address: 8c:44:4f:98:21:70
Server Identifier
Option: Server Identifier (2)
Length: 10
Value: 000300016c3b6be23f6e
DUID: 000300016c3b6be23f6e
DUID Type: link-layer address (3)
Hardware type: Ethernet (1)
Link-layer address: 6c:3b:6b:e2:3f:6e
Rapid Commit
Option: Rapid Commit (14)
Length: 0
DNS recursive name server
Option: DNS recursive name server (23)
Length: 16
Value: 200102b80054e0010000000000000003
1 DNS server address: 2001:2b8:54:e001::3
Identity Association for Prefix Delegation
Option: Identity Association for Prefix Delegation (25)
Length: 41
Value: 000000000001fa4000032a00001a00190000000000000000…
IAID: 00000000
T1: 129600
T2: 207360
IA Prefix
Option: IA Prefix (26)
Length: 25
Value: 000000000000000000000000000000000000000000000000…
Preferred lifetime: 0
Valid lifetime: 0
Prefix length: 0
Prefix address: ::
 
ricardobrock
just joined
Posts: 4
Joined: Tue Mar 26, 2019 1:58 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Sat Dec 14, 2019 12:07 am

Does anyone understand why this has been added to 6.46?

dhcpv6-server - include "User-Name" parameter in accounting requests;

so, something todo with IPv6-PD or what?

@Mikrotik, can you guys please tell us how long it will take. All other ISP are even going to native IPv6, and were still on ony IPv4!!!!!!!!!!!!!
 
DuhBatista
just joined
Posts: 13
Joined: Mon Oct 01, 2018 6:24 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Dec 17, 2019 10:17 pm

Contribution, adapt to your Radius for prefix-PD logging
https://wiki.brasilpeeringforum.org/w/G ... o_Mikrotik
 
ricardobrock
just joined
Posts: 4
Joined: Tue Mar 26, 2019 1:58 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Jan 03, 2020 12:16 am

Ok, anyone who wants this!!!! Managed to make it work, very easy!!!!!!!!

https://www.vyos.io/

lookalike Juniper / Brocade, new to this, tested over the last few months with several PPP clients. Awesome product.

MT can really learn from these guys. IPv6-PD over PPP incl. Radius is a pré to have as ISP. anything other is not a solution but working a way around :-).
 
marekm
Member Candidate
Member Candidate
Posts: 220
Joined: Tue Feb 01, 2011 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Fri Jan 03, 2020 1:10 pm

This feature was requested since 2014, and still not implemented in 2020.
MT, please at least tell us how much longer it will take - so we can make informed decision (wait for MT or switch our PPPoE servers to VyOS - more work, but may be worth it if we have to wait for MT too long; the problem is we still don't know how long) to proceed with IPv6 deployment.
Similar pattern as with CRS318 netPower reverse-PoE switches - still vapourware 10 months after first announced. Again, need to decide - wait for MT, or roll our own?
 
remontti
just joined
Posts: 5
Joined: Mon Aug 31, 2015 11:27 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Jan 28, 2020 2:17 am

This was the only solution I found.
How to deliver IPv6+IPv4 to RouterOS through DHCPv6 PD and save logs in a database
https://blog.remontti.com.br/3931

Esta foi a única solução que encontrei
Como entregar IPv6+IPv4 no Mikrotik/RouterOS através de PPPoE/DHCPv6 PD e registrando os logs em um banco de dados
https://blog.remontti.com.br/3931
 
jindranix
just joined
Posts: 7
Joined: Mon Jun 09, 2014 11:41 am

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Jan 28, 2020 12:22 pm

Is it really hard to do this feature? But the choice there is only gray...
 
User avatar
alexcherry
just joined
Posts: 21
Joined: Tue Jan 11, 2011 5:01 pm

Re: Report "Delegated-IPv6-Prefix" attribute for PPPoE

Tue Feb 18, 2020 2:23 pm

Hi guys, I was fighting with IPv6 deployment for few weeks. The authentication is PPPoE as in many other networks.
The main issue is that when customer got IPv6 delegated prefix from Mikrotik, we don't have control and information about the prefix that is assigned to end user. This is because Mikrotik doesn't support Radius based IPv6 assignment on PPPoE. In IPv4 it's fine, because there are Framed-IP-Address and Framed-Route attributes.
But in PPPoE with Radius, Delegated-Ipv6-Prefix is not accepted by Mikrotik, even if we send it from Radius. In accounting messages Mikrotik sends back to Radius Delegated-IPv6-Prefix attribute, so, we have extended our Radius and grab and save this information. But it's a sort of "hack" and regular FreeRadius doesn't support it.

I've created a petition, please vote for a proper Delegated-IPv6-Prefix support in Radius + PPPoE Mikrotik here - http://chng.it/v7Xjm42GsG

Who is online

Users browsing this forum: gutekpl, holla29, paulororke and 92 guests