Community discussions

MikroTik App
 
mohammadyou
just joined
Topic Author
Posts: 11
Joined: Fri Aug 07, 2015 2:08 am

Radius Server is not responding message

Fri Aug 25, 2017 3:02 am

I would be appreciate if you help me to solve the radius configuration for a hotspot as depicted below.

https://ibb.co/cuo8K5
Image
 
User avatar
pukkita
Trainer
Trainer
Posts: 3038
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Radius Server is not responding message

Fri Aug 25, 2017 11:43 am

Try setting src-address in radius to 127.0.0.1.

I assume both user-manager and hotspot are installed on the same router.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
mohammadyou
just joined
Topic Author
Posts: 11
Joined: Fri Aug 07, 2015 2:08 am

Re: Radius Server is not responding message

Fri Aug 25, 2017 12:58 pm

Thanks Pukkita, Yes both of them installed on the same Router.
I have check it but nothing happened,
Instead of 127.0.0.1 (that I have always set it ) I set the Hotspot IP and problem solved
 
Stiflerakos
just joined
Posts: 20
Joined: Sat Jan 14, 2017 1:28 pm

Re: Radius Server is not responding message

Fri Aug 25, 2017 1:28 pm

I will suggest you to setup your radius server on a different ip.
Pls make a new bridge interface and name it as "LOOPBACK"
Give IP address 192.168.89.1/32
Change this ip to all relevant sections and you must be ok
 
mohammadyou
just joined
Topic Author
Posts: 11
Joined: Fri Aug 07, 2015 2:08 am

Re: Radius Server is not responding message

Mon Aug 28, 2017 3:21 pm

I face the problem again.
Thanks Stiflerakos I did as you said but same problem again
/interface bridge
add name=LOOPBACK
add name=bridge1
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 password=***** use-peer-dns=yes user=\
    *****
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3

/ip hotspot profile
add dns-name=log.hotelsamen.ir hotspot-address=192.168.10.1 http-cookie-lifetime=1d name=hsprof1 \
    radius-interim-update=10s use-radius=yes
/ip hotspot
add address-pool=dhcp_pool0 addresses-per-mac=1 disabled=no interface=bridge1 name=hotspot1 profile=hsprof1
/ip hotspot user profile
add name=free rate-limit=64K/64K shared-users=unlimited
/ip hotspot user
add name=admin password=Mosh1234
add disabled=yes name=free password=free profile=free


/tool user-manager customer
set admin access=own-routers,own-users,own-profiles,own-limits,config-payment-gw password=Mosh1234
/tool user-manager profile
add name=Group-Ultimate name-for-users="" override-shared-users=off owner=admin price=0 starts-at=logon \
    validity=0s
add name=Group-User name-for-users="" override-shared-users=off owner=admin price=0 starts-at=logon validity=0s
/tool user-manager profile limitation
add address-list="" download-limit=0B group-name="" ip-pool="" name=Max-Download owner=admin transfer-limit=\
    536870912B upload-limit=0B uptime-limit=0s
add address-list="" download-limit=0B group-name="" ip-pool="" name=Max-Spead owner=admin rate-limit-min-rx=\
    131072B rate-limit-min-tx=131072B rate-limit-rx=262144B rate-limit-tx=262144B transfer-limit=0B \
    upload-limit=0B uptime-limit=0s
add address-list="" download-limit=0B group-name="" ip-pool="" name=Mixed owner=admin rate-limit-min-rx=65536B \
    rate-limit-min-tx=65536B rate-limit-rx=65536B rate-limit-tx=65536B transfer-limit=536870912B upload-limit=\
    0B uptime-limit=0s
/tool user-manager database
set db-path=user-manager
/tool user-manager profile profile-limitation
add from-time=0s limitation=Max-Spead profile=Group-User till-time=23h59m59s weekdays=\
    sunday,monday,tuesday,wednesday,thursday,friday,saturday
add from-time=0s till-time=23h59m59s weekdays=sunday,monday,tuesday,wednesday,thursday,friday,saturday
add from-time=0s limitation=Max-Spead profile=Group-User till-time=23h59m59s weekdays=\
    sunday,monday,tuesday,wednesday,thursday,friday,saturday
/tool user-manager router
add coa-port=3799 customer=admin disabled=no ip-address=192.168.89.1 log="" name=Local shared-secret=Mosh123 \
    use-coa=yes
/tool user-manager user
add customer=admin disabled=no password=4060 shared-users=1 username=test wireless-enc-algo=none \
    wireless-enc-key="" wireless-psk=""

/radius
add address=192.168.89.1 secret=Mosh123 service=hotspot src-address=192.168.89.1
/radius incoming
set accept=yes
 
marklodge
Member Candidate
Member Candidate
Posts: 251
Joined: Sun Jun 21, 2009 6:15 pm

Re: Radius Server is not responding message

Tue Oct 03, 2017 2:48 am

The default Firewall rules drops traffic not coming from LAN, disable this rule and it will work
 
Marvisonline
just joined
Posts: 2
Joined: Thu Aug 02, 2018 7:50 pm

Re: Radius Server is not responding message

Fri May 24, 2019 12:45 am

The default Firewall rules drops traffic not coming from LAN, disable this rule and it will work
thanks alot this post solved my 1yr problem, 2 diff router.

Who is online

Users browsing this forum: No registered users and 12 guests