Page 1 of 1

/user/signup Error 404: Not found

Posted: Sat May 16, 2020 1:28 am
by FutureProof
Hi fellas,

I have a RBwAPGR-5HacD2HnD which works a treat up to the point, where users should be able to signup for the hotspot usage.
The setup is: I have two VLANs configured, one for business and one for guests

[admin@rb-kobalt-club] > /interface export
# may/15/2020 22:41:08 by RouterOS 6.46.6
# software id = FT66-3VXT
#
# model = RBwAPGR-5HacD2HnD
# serial number = B7380B355865
/interface bridge
add name=Loopback
add name=brBusiness
add admin-mac=C4:AD:34:6E:47:C6 auto-mac=no name=brGuest
/interface lte
set [ find ] mtu=1480 name=lte1
/interface vlan
add interface=ether1 name=vlBusiness vlan-id=48
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] apn=web.carrier.tld
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed mode=dynamic-keys name=secure supplicant-identity="" \
wpa2-pre-shared-key=whatever
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX country=germany disabled=no distance=indoors frequency=auto hide-ssid=yes \
mode=ap-bridge name=ap2 security-profile=temp ssid=2Mgmt wireless-protocol=802.11
add disabled=no keepalive-frames=disabled master-interface=ap2 multicast-buffering=disabled name=ap2Guest \
ssid="Guests" wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
add disabled=no hide-ssid=yes keepalive-frames=disabled master-interface=ap2 multicast-buffering=disabled name=\
ap2Mgmt security-profile=secure ssid=Mgmt wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
set [ find default-name=wlan2 ] band=5ghz-a/n/ac country=germany disabled=no distance=indoors frequency=auto hide-ssid=yes mode=ap-bridge name=\
ap5 security-profile=temp ssid=5Mgmt wireless-protocol=802.11
add disabled=no keepalive-frames=disabled master-interface=ap5 multicast-buffering=disabled name=ap5Guest \
ssid="Guests" wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
add disabled=no hide-ssid=yes keepalive-frames=disabled master-interface=ap5 multicast-buffering=disabled name=\
ap5Mgmt security-profile=secure ssid=Mgmt wds-cost-range=0 wds-default-cost=0 wps-mode=disabled

/interface bridge port
add bridge=brGuest interface=ether2
add bridge=brGuest interface=ap5Guest
add bridge=brGuest interface=ap2Guest
add bridge=brBusiness interface=ap2Mgmt
add bridge=brBusiness interface=ap5Mgmt
add bridge=brBusiness interface=vlBusiness
/interface list member
add interface=lte1 list=WAN
add interface=brBusiness list=LAN
[admin@router] >

When I am connected to the Business VLAN I can access http://brGuestIP/user/signup (and http://brGuestIP/userman). But when I am connected to the guest wifi via hotspot, I get "Error 404: Not found".
I am not quite sure, why that is. I tried to sniff on client side and on the router side why this request behaves so different, but couldn't spot the error.

Can you please help me out?

The aim is to provide our guests the option to signup to the hotspot via the Usermanager's self signup form.

Cheers,
Stefan

Re: /user/signup Error 404: Not found

Posted: Thu May 28, 2020 12:07 am
by FutureProof
I added the IP to the walled garden and changed the www service port to something different than 80 .. yet, I still receive Error 404. Anyone's got an idea how to tackle this one?