Community discussions

 
deliaptech
just joined
Topic Author
Posts: 2
Joined: Fri May 25, 2007 6:24 pm

time limit based

Tue Jul 24, 2007 9:37 pm

hallo i am new in hotspot,

i just setup user with time limit. i set up a user for 3 hour.

but when i login to mikrotik user status. i see

3h 60.00 Jun/24/2007 07:38:53 2h:59m:59s Jun/24/2007 10:38:53

it's mean user can use internet acces 3 hour, it's begin from 07.38.53 until 10.38.53

when user login for 30 minutes and log out. can a user access internet in more than 10.38.53 (clock time)

because a user only use internet access 30 minutes, a user have 2.30 hour.

if it's correct, can i set up with hour used time not clock time or date time.


thank you
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: time limit based

Thu Jul 26, 2007 8:08 am

You are mixing uptime limit and credit time options,
you may read about them here,
http://wiki.mikrotik.com/wiki/User_Manager/Limiting
 
User avatar
dunga
Member Candidate
Member Candidate
Posts: 254
Joined: Fri Jan 23, 2009 9:51 am
Location: Nigeria

Re: time limit based

Thu Mar 24, 2011 3:32 pm

hello all,
I have been having this issues for a long time now about users credit limit and no answer has been given on it.

Let me redefine the question the 1st user asked. I created 1hr credit for some users, and in the uptime limit, i specified 2days. here are the problems i am facing:
1. A user who bought 1hr credit logs in and logout after using the time for just 30mins, when he comes back to use it again, it will log the user in again, rather it displays credit limit reached.

Just as in others, when a user gets airtime, after logging out, he can come back after 2days to use it as far as the expired days has not reached and this is tsill time left in the ticket.

HOW WILL THIS PROBLEM BE OVERCOMED OR HOW DO WE SOLVE THIS PROBLEM. as it is causing alot of problems between us and the users.

I need detailed steps on how to solve this problem or the problem is not solvable


Thanks while expecting your reply
 
usmany
Member Candidate
Member Candidate
Posts: 141
Joined: Sun Dec 20, 2009 3:20 pm
Location: Nigeria
Contact:

Re: time limit based

Tue Apr 05, 2011 11:21 am

hallo i am new in hotspot,

i just setup user with time limit. i set up a user for 3 hour.

but when i login to mikrotik user status. i see

3h 60.00 Jun/24/2007 07:38:53 2h:59m:59s Jun/24/2007 10:38:53

it's mean user can use internet acces 3 hour, it's begin from 07.38.53 until 10.38.53

when user login for 30 minutes and log out. can a user access internet in more than 10.38.53 (clock time)

because a user only use internet access 30 minutes, a user have 2.30 hour.

if it's correct, can i set up with hour used time not clock time or date time.


thank you
Did you configure your NTP Client? if not, then try and see what will happen.
When the world turn back on you, you turn your back on the world...
 
User avatar
winagain
Member Candidate
Member Candidate
Posts: 244
Joined: Sat Jul 15, 2006 10:18 pm
Location: Botswana
Contact:

Re: time limit based

Wed Apr 20, 2011 11:14 am

Hi, I am having the same problem.

I use usermanager to control uptime, and have created batch users with a 1hr uptime limit. Yet I have had an instance where a client logged out, and time on the card that was used is only 28min, but upon client trying to reuse the card, the card is not accepted saying credit limit reached.

I have been using User Manager for some time, and this is the first time this has happened, and I would like to prevent it from happening again.

How can this be prevented from happening?

Thanks

[EDIT]

As said in the first post, I have gone back and checked logs, seem users that were only supposed to get 1hr, get to go past the uptime limit?

1 user actually got 3 hours from a 1hr card, why is this happening?
 
User avatar
dunga
Member Candidate
Member Candidate
Posts: 254
Joined: Fri Jan 23, 2009 9:51 am
Location: Nigeria

Re: time limit based

Wed Apr 20, 2011 12:19 pm

hello,
i think the solution as suggested in this forum elsewhere implies that you have to follow it this way.

Assuming, you want to create 1hr time limit for a user in user-manager.
Note the following: In credit, create 1hr as the name, time put 2d, since you want the 1hr to last or expire after 2days, then you add your amount.

After that, for yo to create a user or add batch, your attention should be centred only on the uptime limit. This place it is 0s by default, but after you have selected you credit for the user, just put in the uptime limit =1h.

This will all the user to use the card for 1hr in 2days time. If he logs out he can reuse the card again.

Another important thing is to enable ntp client in the router, so that yo local time will be synchronized with any ntp server time yo choose.
open winbox, click on system--->Ntp Client, check enable, mode=unicast, then put the ip of the ntp server (primary and seconday) if you have only one, then put it there and click apply.

After that, go to system clock and set the time zone of you side. Please choose manual time set.

incase of ntp servers, try this link http://www.pool.ntp.org/en/
Then choose yo region, africa, asia
 
User avatar
winagain
Member Candidate
Member Candidate
Posts: 244
Joined: Sat Jul 15, 2006 10:18 pm
Location: Botswana
Contact:

Re: time limit based

Wed Apr 20, 2011 12:29 pm

Thanks for the reply.

I have been doing what you have suggested, but the user uptime sometimes goes past the expiry limit which has been entered.

So after say 60min the system should stop the user from logging in and disconnect the user if the user is already logged it, this does not happen all the time, as some clients get 3hrs others only get 30min when they should get 1hr.

NTP is enabled and system time is set correctly.

on the other hand any pre-paid card made with time under 30min and under is not having this issue.
 
User avatar
dunga
Member Candidate
Member Candidate
Posts: 254
Joined: Fri Jan 23, 2009 9:51 am
Location: Nigeria

Re: time limit based

Wed Apr 20, 2011 1:09 pm

Hello winagain,
I suggest you paste your hotspot configuration here, so that we can view it and iron out where the problem might be from.

/ip hotspot/export
 
User avatar
winagain
Member Candidate
Member Candidate
Posts: 244
Joined: Sat Jul 15, 2006 10:18 pm
Location: Botswana
Contact:

Re: time limit based

Wed Apr 20, 2011 6:18 pm

/ip hotspot profile
set default dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot \
    http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap \
    name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
    use-radius=no
add dns-name=internet.usage hotspot-address=192.168.111.1 html-directory=\
    hotspot http-proxy=0.0.0.0:0 login-by=http-chap name=hsprof1 \
    nas-port-type=wireless-802.11 radius-accounting=yes \
    radius-default-domain="" radius-interim-update=received \
    radius-location-id="" radius-location-name="" radius-mac-format=\
    XX:XX:XX:XX:XX:XX rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
    use-radius=yes
add dns-name=internet.usage hotspot-address=192.168.112.1 html-directory=\
    hotspot http-proxy=0.0.0.0:0 login-by=http-chap name=hsprof2 \
    nas-port-type=wireless-802.11 radius-accounting=yes \
    radius-default-domain="" radius-interim-update=received \
    radius-location-id="" radius-location-name="" radius-mac-format=\
    XX:XX:XX:XX:XX:XX rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
    use-radius=yes
add dns-name=internet.usage hotspot-address=192.168.114.1 html-directory=\
    hotspot http-proxy=0.0.0.0:0 login-by=http-chap name=hsprof3 \
    nas-port-type=wireless-802.11 radius-accounting=yes \
    radius-default-domain="" radius-interim-update=received \
    radius-location-id="" radius-location-name="" radius-mac-format=\
    XX:XX:XX:XX:XX:XX rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
    use-radius=yes
/ip hotspot
add address-pool=hs-pool-4 addresses-per-mac=6 disabled=no idle-timeout=none \
    interface="Bridge - WNG1" keepalive-timeout=none name=hotspot1 profile=\
    hsprof1
add address-pool=hs-pool-5 addresses-per-mac=6 disabled=no idle-timeout=none \
    interface="Bridge - WNG2" keepalive-timeout=none name="hs-Bridge - WNG2" \
    profile=hsprof2
add address-pool=hs-pool-7 addresses-per-mac=6 disabled=no idle-timeout=none \
    interface="Bridge - WNG4" keepalive-timeout=none name="hs-Bridge - WNG4" \
    profile=hsprof3
/ip hotspot user profile
set default advertise=no idle-timeout=none keepalive-timeout=2m name=default \
    open-status-page=always shared-users=4 status-autorefresh=1m \
    transparent-proxy=yes
/ip hotspot service-port
set ftp disabled=no ports=21
I do not believe the problem to be hotspot based. I believe the problem is user-manager based, and thus the reason for posting in user-manager forum.
 
User avatar
dunga
Member Candidate
Member Candidate
Posts: 254
Joined: Fri Jan 23, 2009 9:51 am
Location: Nigeria

Re: time limit based

Wed Oct 05, 2011 1:15 am

I don't know if you have solved tis isue but here is a suggestion
Thanks for the reply.

I have been doing what you have suggested, but the user uptime sometimes goes past the expiry limit which has been entered.

You have to take time and check your credit you created in user manager. That is where the issue lies, and check your uptime limit

So after say 60min the system should stop the user from logging in and disconnect the user if the user is already logged it, this does not happen all the time, as some clients get 3hrs others only get 30min when they should get 1hr.

This is based on your settings.
.
 
User avatar
winagain
Member Candidate
Member Candidate
Posts: 244
Joined: Sat Jul 15, 2006 10:18 pm
Location: Botswana
Contact:

Re: time limit based

Wed Oct 05, 2011 9:02 am

I didn't quite get a suggestion.

I have not resolved the problem, however I don't need to any more, as I don't generate prepaid units anymore, I create using unlimited profile, with the 30m uptime limit, then the system works, and disconnects on time.

Who is online

Users browsing this forum: No registered users and 4 guests