Page 1 of 1

Problem Adding credits after time purchase expires

Posted: Fri Nov 23, 2007 10:18 pm
by skye1
My hotspot system works well in combination with userman and paypal payments. The problem I am seeing is
1 - user purchases time using paypal OK
2 - user logs in and uses time OK
3 - user time expires too bad OK
4 - user proceeds to https:\\host.domain.com\user to add credits OK
5 - user selects credit amount and proceeds to paypal and pays OK
6 - money is received into my account VERY MUCH OK
7 - user payment shows as successful in \user OK
8 - user time still shows as expired in userman and user is denied logon NOT OK

Any thoughts or suggestions on this would be appreciated.
Thanks
Robert

Re: Problem Adding credits after time purchase expires

Posted: Tue Nov 27, 2007 4:26 am
by kvan64
I have not goten the paypal payment to work yet but it appears that I also have the same problem adding credit AFTER expiration. The user can not logon if credit/time was added after expiration. "Reset counters" would not work either.

The next one may be off topic but it would be great if you could help give me some light about how to make the paypal payment work. I know that a certificate is require and I tried to purchase one from CA. However, it asked me for the CSR information. How did you obtain yours?

Regards,
DK

Re: Problem Adding credits after time purchase expires

Posted: Wed Nov 28, 2007 10:37 pm
by sergejs
Check carefully that correct credits are sold to the customer.
Contact support (support@mikrotik.com), if you thing User-Manager Paypal communication goes in incorrect way.

Re: Problem Adding credits after time purchase expires

Posted: Thu Nov 29, 2007 2:24 pm
by insel
Hi Robert.

Just to be sure. Are you useing the newest version of RouterOS and Usermanager? I'm asking because of:
What's new in 2.9.48:
*) user manager - fixed bug for credit extension using PayPal payments;
(see http://www.mikrotik.com/download/CHANGELOG_full)

Maybe it's helpful for you.

Insel