Community discussions

MUM Europe 2020
 
shrick
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 85
Joined: Fri Sep 05, 2008 2:15 pm

PPtP and User Manager

Mon Oct 20, 2008 2:48 am

Hi there

Can somebody please help me to configure RouterOS to authenticate PPtP connections via User Manager. I've already got User Manager going with PPPoE, want to use it for PPtP.

Would really appreciate help.

Thx
 
sophal
newbie
Posts: 34
Joined: Thu Aug 07, 2008 6:09 am
Location: Cambodia

Re: PPtP and User Manager

Mon Dec 15, 2008 10:01 am

pptp + user manager

/ppp profile
add change-tcp-mss=yes comment="" local-address=192.168.10.2 name=ppptp only-one=default remote-address=pool-pptp use-compression=default use-encryption=\
required use-vj-compression=default

/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=ppptp enabled=yes keepalive-timeout=disabled max-mru=1460 max-mtu=1460 mrru=disabled

/ppp aaa
set accounting=yes interim-update=0s use-radius=yes

/radius
add accounting-backup=no accounting-port=1813 address=192.168.0.1 authentication-port=1812 called-id="" comment="" disabled=no domain="" realm="" secret=\
123456 service=ppp timeout=3s

/tool user-manager router
add comment="" disabled=no ip-address=192.168.0.1 log="" name=sophal shared-secret=123456 subscriber=admin
Last edited by sophal on Fri Jan 30, 2009 8:42 am, edited 1 time in total.
Regards
Lor Sophal
lor.sophal@gmail.com
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: PPtP and User Manager

Wed Dec 17, 2008 11:45 am

for the User Manager and PPTP server on the same router,
use 127.0.0.1 address for RADIUS client and tool user-manager router.
 
vmedek
just joined
Posts: 8
Joined: Tue Jun 12, 2007 12:05 pm
Location: Czech Republic

Re: PPtP and User Manager

Thu Oct 15, 2009 2:38 pm

Hi,

when I try to log, I receive "error 628" in VPN client and folowing in log:
Oct 15 13:02:20 192.168.11.1 pptp,info TCP connection established from 192.168.11.76
Oct 15 13:02:20 192.168.11.1 pptp,ppp,info <pptp-0>: waiting for call...
Oct 15 13:02:21 192.168.11.1 pptp,ppp,info <pptp-0>: authenticated
Oct 15 13:02:21 192.168.11.1 pptp,ppp,info <pptp-0>: terminating... - call cleared
Oct 15 13:02:21 192.168.11.1 pptp,ppp,info <pptp-0>: disconnected


in usermanager log I see no error:

1 user 0.0.0.0 192.168.11.1 Oct/15/2009 13:02:20 authorization success
2 user 192.168.12.197 192.168.11.1 Oct/15/2009 13:02:21 accounting success
3 user 192.168.12.197 192.168.11.1 Oct/15/2009 13:02:21 accounting success

in user manager session also no visible problem:

1 user 192.168.12.197 192.168.11.1 Oct/15/2009 13:02:21 Oct/15/2009 13:02:21 0s

user is AUTHENTICATED, in radius server status I see request value = accepts value, 0 in rejects and timeouts.
When I try to add user to PPP - secrets, everything works.

Any idea what is wrong?

(version was 3.30, now I updated to 4.0 - without any change)
 
cael
just joined
Posts: 1
Joined: Mon May 27, 2013 2:44 pm

Re: PPtP and User Manager

Mon May 27, 2013 2:51 pm

now I have the exact problem with vmedek, can anybody help me? thanks! Any insight is appreciated!

I really need help, please! I've been googling this problem for several days!

edit: I'm now using version 5.22

can anyone tell me if it's a bug or not? It's driving me creazy!!

Who is online

Users browsing this forum: No registered users and 4 guests