Page 1 of 1

HELP!!!! PLEASE HELP!!!!

Posted: Sat Nov 15, 2008 12:36 pm
by dannyboy
Hello,

I have a problem with my usermanager, I had someone configure it for me and the unit was working great... Today I had finished setting every AP and was ready to start charging on my hospot... MY USERMANAGER IS NOT WORKING!!!!!.

This is whats happening:

I have the username manager at my house and the remote MT at the location of the hotspot. The person that configure my router told me how to make the remote MT talked to the Usermanager... It was working fine now is not.

I am able to goto sign up page, I can create user and I can even goto paypal and pay for the service I want.

Once this happends it sends me back to my login page. When I put the user login and password it tells me invalid username or password..... I habe tried to buy credit and create a user many time and is not working.

I went into the usermanager and I was able to see that the users were created but the service they bought was not assing to them.. So I created a user on the users at the usermanager box. I tried to login with this new user and I get the samething... Invalid username and password..

If you can help me I can give you my ips and username and passwords so you van take a look...

PLEASE I REALY NEED THIS BY MORING!!! IS NOT 5:30 AM and been up allnite doing this!!!!

Thanks,

DannyBoy

Re: HELP!!!! PLEASE HELP!!!!

Posted: Sun Nov 16, 2008 8:04 am
by csickles
It sounds like hotspot is not listening to the radius derver (User Manager)

Check RADIUS settings.. at both radius and hotspot..

Re: HELP!!!! PLEASE HELP!!!!

Posted: Sun Nov 16, 2008 11:04 am
by dannyboy
Hello,

Thanks for your response,
Anyway I got the two servers to work correctly on the authentication, after doing more test I was able to make that part work. No thanks to the user manual....

Now this is what I got;

If I create a user manualy on the user manager and and apply a credit to it and than goto my hotspot, I am able to login using radius... This is working perfect now.

I now setup the user sign up section, I am able to goto the singup section signup for an account and even PAY for it via paypal!!! When I go back to the user manager users link, I can see that the account was created, i see the login name and password, the email too. Now the problem that I am getting now is that it is not applying the credits to that account... Paypal sents me an email with the reciept and everything.

So for some reason I am not getting the response from paypal.....I do have the Secure Response checked on the Customers configuration.

Ao there is where I am stuck and not making any money because of this issue. I dont know what else to do and I have no money to pay someone to reconfigure this for me.. Anyway from what I have been doing seems like it should work...

Any ideas that I can try?

Thanks

Daniel

Re: HELP!!!! PLEASE HELP!!!!

Posted: Mon Nov 17, 2008 4:08 pm
by csickles
Check some of the other posts RE paypal..

Some have said that some of the payment replys are comming from ebay...

Re: HELP!!!! PLEASE HELP!!!!

Posted: Tue Nov 18, 2008 12:36 pm
by vince
Hi,

I had this automatic PayPal payments working properly for more than a year now. And a few days ago stopped working. Without doing any change on the usermanager or paypal account. So something has changed. I'm affraid Paypal is sending replays that Usermanager doesn't recognize for some reason. And a clear difference is that the responses from PayPal come from an Ebay host now. So it is clear that PayPal has done some changes.

Mikrotik support has some information about my problem. I hope they can see what's wrong with PayPal payment confirmation.

The problem isn't exactly that you can not make money. It is worse. Customer pays but the service is not enabled until you do it manually. And that is an anoying situation for most customers.

Regards.

Re: HELP!!!! PLEASE HELP!!!!

Posted: Tue Nov 18, 2008 4:42 pm
by csickles
As I said...

Others are reporting that some of the replys are comming back from ebay instead of paypal...this will break the whole payment process, as the usermanager is expecting the reply from paypal and assumes the message is a spoof attempt...

This is caused by ebay which owns paypal causing the issue..

check other threads and there may be a work arround untill fixed...

Re: HELP!!!! PLEASE HELP!!!!

Posted: Tue Nov 18, 2008 8:32 pm
by vince
Thanks Csickles

It is good to know that someone else thinks that this responses from ebay instead of Paypal will break the payment system. But the other post talking about this was initiated by me and noone else reported the same problem.

Even worse it was reported to Mikrotik and they are analising the support file but said that it is working for them. So may be it is only happening on some regions what will make it more dificult to solve.

Regards.

Re: HELP!!!! PLEASE HELP!!!!

Posted: Tue Nov 18, 2008 11:43 pm
by csickles
Oh...

I didnt see the other thread was yours !!!

I was reporting what I was reading...

I dont use paypal.. I use pre-printed...

I will see what I can do to reproduce it...

Re: HELP!!!! PLEASE HELP!!!!

Posted: Wed Nov 19, 2008 12:28 am
by phil@nowires.com.au
mine is broken too. ALL payments have the status "PayPal response error: socket error"

Re: HELP!!!! PLEASE HELP!!!!

Posted: Wed Nov 19, 2008 11:16 pm
by skye1
Mine has broken as well same symptoms, started about three days ago has worked great for almost two years. My location is south florida USA if that may be of use.
I have verified my usermanager config is OK.
No reply from ping to http://www.paypal.com, but name resolves good.
Latency does not seem to be a problem, but I do not know at what threshold this would be an issue?
User is created and payment is received, but the account is not activated.

I have found in the last couple of months that DNS on Internet (at least from my carriers) has been very unreliable. I queried various DNS servers for host name of my usermanager and am seeing mixed results some servers are Ok and some can not find the host.
Am I correct in seeing that this problem appears to have begun around 16 NOV?

Re: HELP!!!! PLEASE HELP!!!!

Posted: Thu Nov 20, 2008 12:26 am
by vince
Hi Skye1,

I'm aware of this a little bit earlier. We had the first unrecognised payment on 12 NOV at 19:32:36 CET

I tried to report the problem to Paypal. But this is crazy. When I try to explain them, that their servers send a confirmation when the payment is completed. They think it is the e-mail they send to inform of the payment.

Kind regards.

Re: HELP!!!! PLEASE HELP!!!!

Posted: Thu Nov 20, 2008 6:26 am
by skye1
The question then becomes, what, if anything will be done to fix this issue. I am more inclined at this point to consider a configuration change by paypal as the most logical cause for this issue.

Re: HELP!!!! PLEASE HELP!!!!

Posted: Thu Nov 20, 2008 9:05 am
by vince
Good morning,

Last time I had a similar problem, it was fixed by Mikrotik very fast. The problem is that Mikrotik is not saying anything. So I don't know if they are working on it or not. Usually, when they don't say anything for a few days after reporting a problems, it means they are working on it.

But in the mean time, I'm in the process to open an account on Authorize.net. Just in case.

Re: HELP!!!! PLEASE HELP!!!!

Posted: Fri Nov 21, 2008 12:16 pm
by sergejs
We were able to find the problems with Paypal payments and User Manager. The issue is fixed in v3.17.
New version will be released soon, if you need User Manager to work with Paypal payments urgently, please contact support (support@mikrotik.com).

Re: HELP!!!! PLEASE HELP!!!!

Posted: Fri Nov 21, 2008 2:21 pm
by skye1
Thank you sergejs and the Mikrotik team.