Community discussions

MikroTik App
 
jwelebd
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 72
Joined: Wed May 31, 2006 12:20 am
Location: Dhaka
Contact:

recharge an userman account with pin & password

Mon Aug 20, 2012 6:57 am

Dear,
I want to use mikrotik usermanager, as it has some user
following username like jwelebd or any other else which
indicates specific user, and already allowed for 30 days
only. Now I want to generate several pin & pass in batch
whick i can use to recharge user more 30 days.
Is it possible in mikrotik & how?
I can generate pin & pass normally. But I want to use
specific userid for user.

Thanks
 
User avatar
dotnet
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Tue Feb 26, 2013 11:41 am
Location: Chittagong, Bangladesh.

Re: recharge an userman account with pin & password

Thu Feb 28, 2013 1:21 pm

I don't know what's your configuration? PPPoE or Hotspot ..
i am described here only PPPoE & user manager setup for your pin & password

This guide will illustrate howto create PPPoE server in MIKROTIK RouterOS (I used v 5.21 in this example). This article will also demonstrate on how you can create your automated pre-paid billing solution for users using Mikrotik’s User Manager. This basic RADIUS Server USERMAN can be used for any ppp service like PPPoE/HOTSPOT.

1) PPPoE Server (Basic Settings)
2) User Manager Billing Setup

In this example Mikrotik have two Lan cards.
1) ether1 = ip 10.0.0.1 / LAN Interface hosting PPPoE Server
2) ether2 = ip 192.168.0.1 / WAN interface connected with Fiber.

First we will add PPPoE Server using CLI (command interface)
/interface pppoe-server server
add authentication=pap default-profile=default disabled=no interface=ether1 keepalive-timeout=10 max-mru=1480 max-mtu=1480 max-sessions=1 mrru=disabled one-session-per-host=yes service-name=dotnet

Now we will add IP Pool for pppoe-users (ips that user will get after successful dialing)
/ip pool add name=pppoe-users-pool ranges=172.16.0.1-172.16.0.254

Now we will add new profile for pppoe users.
/ppp profile add change-tcp-mss=default dns-server=10.0.0.1 local-address=10.0.0.1 name=pppoe-profile only-one=default remote-address=pppoe-users-pool use-compression=default use-encryption=default use-vj-compression=default

Add following rule to allow internet.
/ip firewall nat add action=masquerade chain=srcnat disabled=no src-address=172.16.0.1-172.16.0.255

(In above masquerading rule, I have added src-address to 172.16.0.x ip pool, so that ONLY pppoe connected users internet will work)

Add DNS server so users can resolve internet hostnames.
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8, 8.8.4.4

Now finally we will add local user to test the pppoe server status.
/ppp secret add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=suman password=1234 profile=pppoe-profile routes="" service=pppoe

Now at user end, create a pppoe dialer and connect with the id = suman and password = 1234
If all goes fine, you will start surfing the internet smoothly

Now we will move to mikrotik billing system using its built-in radius called USER MANAGER.

MIKROTIK USER MANAGER WITH BILLING SETUP

We can setup a RADIUS server in mikrotik using its built-in radius server called User Manager. UM is a nice web-based billing manager package to compliment hotspot / pppoe authentication solution in RouterOS. It is RADIUS based component so it can provide centralised management to single or multiple RouterOS based NASes.

Now we will first configure user manager and then later we will integrate it with our pppoe server so all authentication will be done via UM.

Open your web browser and point it to http://10.0.0.1/userman
You will see user manager authentication screen, Now enter admin id and password and you will be forwarded to main UM screen like this.
Note: If default admin password doesn’t work out, change the password by following command

/tool user-manager customer set admin password=PASSWORD
***or***
/tool user-manager customer print

Now click on Profiles, on your right window, click on + sign (beside profile)

For test purposes, we will add one profile with 256Kbps speed limit, and 30 days UP Time limit. You can add many packages as per your requirements later, once you understand how thins works here)

Now we want to add 256Kb / 30days Limit Package, Name it 256k.

* in ‘Name for users‘ type ‘256k’
* in ‘Validity‘, type ’4w2d’ (for 1 month validity)
* in ‘Starts‘ , select ‘At First Logon‘ (User time will start when users first login)
* in ‘Price’ enter the amount at which you sell this package to users. e.g 1000
* in ‘Shared Users’ select ’1′ (so single ID cannot be used from multiple computers simultaneously)
---------------------
Now Save Profile.

Now We want to add Bandwidth Limitation to this profile, goto ‘Limitations’ and click on ADD ,
A new window will appear

* in ‘Name’ type ’256k’
* in ‘Rate Limit’ in RX ’128k’ in TX ’256k’ ,
---------------------
Now click on SAVE.

Now go back to Profiles Section. Here you will see your created 256k
Profile, clien on ‘Add New Limitation’ and and click on ’256k Limit’ and
click ‘ADD’ button.
-----------------------
Done, your first package with 256k Limit and 30 Days uptime limit is created. Now we will Add new user and tag them with this new 256k profile.

Goto Users, and click on ADD / One (to add single user).

* in ‘Username’ type ‘suman’
* in ‘Password’ type ’1234′
* in ‘Constraints’ check on ‘Called ID’ Bindon first use. This options is good if you want to bind user id with first detected MAC address, if you don’t want to bind , leave this option as it is.
* in ‘Assign profile’ select ’256k’ profile and click on ADD button to finish.

Now that we have finished our basic work with UM, its time to integrate it with Mikrotik, so that all Mikrotik PPPoE authentication will be done via UM.

We have to modify some settings, both on UM and Mikrotik as well.

In UM we have to add Mikrotik Router.
* In UM, Goto Routers , ADD, NEW, name it Mikrotik,
* in ‘IP Address’ tpye you server IP address, 10.0.0.1
* in ‘Shared Secret’ type ’1234′
Now click ADD to finish.

UM section is complete , now moving on to MIKROTIK to complete the RADIUS setup.
ADDING RADIUS SUPPORT IN MIKROTIK
Open Mikrotik Terminal, and type
/radius add accounting-backup=no accounting-port=1813 address=10.0.0.1 authentication-port=1812 called-id="" disabled=no domain="" realm="" secret=1234 service=ppp,hotspot timeout=300ms
/ppp aaa set accounting=yes interim-update=0s use-radius=yes
/radius incoming set accept=yes port=3799

Make sure you change the ip address as per your local configuration.
COMPLETED

Now open your browser and enter your LAN or WAN IP with/userman e.g 10.0.0.1/userman
It will prompt you to a login screen, enter your login details that we used in New terminal window e.g username:admin Password:1234.
Click Login.

Now from client end, connect with Users id ‘suman’ and password ’1234′ that you created via UM. It should connect fine. After first connect, this ID will expires in 30 days and bandwidth limit will be 256kb download and 128kb upload.
To view status/change password etc, from client side, point the browser to
http://10.0.0.1/user

[depend on your ip series]

If you need any assistance, Do let me know.

Mikrotik Voucher
Mikrotik Voucher Template or mikrotik scratch system are the two names of a same thing. Mikrotik User manager offers a very useful and interesting feature of Voucher template which is used to print the scratch cards of your network. Where user can buy your Internet card from your authorized retailer and can use your internet. Isn’t it very cool?you are fully free, no tension of bill collection and user complaints.You can sleep with both eyes closed. It generates your customers automatically. Mikrotik Voucher Template is the fully automated system which will print your vouchers and you just have to place them at the retail stores in your network area.
But there is a little drawback of Mikrotik Voucher Template system that it does not give serial numbers to the cards which can print a card for two times but no worries,I have an idea taken from Syed Jahanzaib, you can import ID Passwords from .csv file into MS Access and use a search function to avoid duplication. I know you can manage it and Mikrotik will also think about it.

So, let’s start our work.
First open your Mikrotik User manager and go to settings > templates and click on vouchers.
Header code for Mikrotik Voucher Template

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml"> <head> <title>Vouchers</title> <style> @media print { .noprint { display: none; } .pagebreak { page-break-after: always; } }
body {
font-family: 'Lucida Grande', 'Helvetica Neue', Helvetica, Arial, sans-serif;
padding: 100px;
font-size: 13px;
}

div.box {

background: rgb(230,240,163); /* Old browsers */
background: -moz-linear-gradient(-45deg, rgba(230,240,163,1) 0%, rgba(210,230,56,1) 50%, rgba(195,216,37,1) 51%, rgba(219,240,67,1) 100%); /* FF3.6+ */
background: -webkit-gradient(linear, left top, right bottom, color-stop(0%,rgba(230,240,163,1)), color-stop(50%,rgba(210,230,56,1)), color-stop(51%,rgba(195,216,37,1)), color-stop(100%,rgba(219,240,67,1))); /* Chrome,Safari4+ */
background: -webkit-linear-gradient(-45deg, rgba(230,240,163,1) 0%,rgba(210,230,56,1) 50%,rgba(195,216,37,1) 51%,rgba(219,240,67,1) 100%); /* Chrome10+,Safari5.1+ */
background: -o-linear-gradient(-45deg, rgba(230,240,163,1) 0%,rgba(210,230,56,1) 50%,rgba(195,216,37,1) 51%,rgba(219,240,67,1) 100%); /* Opera 11.10+ */
background: -ms-linear-gradient(-45deg, rgba(230,240,163,1) 0%,rgba(210,230,56,1) 50%,rgba(195,216,37,1) 51%,rgba(219,240,67,1) 100%); /* IE10+ */
background: linear-gradient(135deg, rgba(230,240,163,1) 0%,rgba(210,230,56,1) 50%,rgba(195,216,37,1) 51%,rgba(219,240,67,1) 100%); /* W3C */
filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#e6f0a3', endColorstr='#dbf043',GradientType=1 ); /* IE6-9 fallback on horizontal gradient */

width: 3.6in;
height: 2.1in;
padding: 0 17px 18px 12px;
margin: 10px 0;
border: solid 1px #D9D9D9;
border-radius: 10px;
-webkit-border-radius: 2px;
-moz-border-radius: 2px;
}

div.box h2 {

background: rgb(30,87,153); /* Old browsers */
background: -moz-linear-gradient(top, rgba(30,87,153,1) 0%, rgba(41,137,216,1) 50%, rgba(32,124,202,1) 51%, rgba(125,185,232,1) 100%); /* FF3.6+ */
background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,rgba(30,87,153,1)), color-stop(50%,rgba(41,137,216,1)), color-stop(51%,rgba(32,124,202,1)), color-stop(100%,rgba(125,185,232,1))); /* Chrome,Safari4+ */
background: -webkit-linear-gradient(top, rgba(30,87,153,1) 0%,rgba(41,137,216,1) 50%,rgba(32,124,202,1) 51%,rgba(125,185,232,1) 100%); /* Chrome10+,Safari5.1+ */
background: -o-linear-gradient(top, rgba(30,87,153,1) 0%,rgba(41,137,216,1) 50%,rgba(32,124,202,1) 51%,rgba(125,185,232,1) 100%); /* Opera 11.10+ */
background: -ms-linear-gradient(top, rgba(30,87,153,1) 0%,rgba(41,137,216,1) 50%,rgba(32,124,202,1) 51%,rgba(125,185,232,1) 100%); /* IE10+ */
background: linear-gradient(to bottom, rgba(30,87,153,1) 0%,rgba(41,137,216,1) 50%,rgba(32,124,202,1) 51%,rgba(125,185,232,1) 100%); /* W3C */
filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#1e5799', endColorstr='#7db9e8',GradientType=0 ); /* IE6-9 */

margin: 0 -17px 1px -12px;
padding: 15px 0px 0 10px;
height: 20px;
border-top-left-radius: 10px;
border-top-right-radius: 10px;
-webkit-border-radius: 2px;
-moz-border-radius: 2px;
font: bold 18px/0.2 Arial;
color: #fff;
text-shadow: red 0.1em 0.1em 0.6em}

div.box h3 {
background-color: #FFF8DC;
border-color: #000;
border-style:solid;
border-width:1px;
margin: -35px 0 0 70px;
padding: 12px 50px 3px 10px;
height: 8px;
width: 30px;
font: bold 12px/0 Arial;
color: #000;
}
div.box h4 {

background: rgb(174,188,191); /* Old browsers */
background: -moz-linear-gradient(top, rgba(174,188,191,1) 0%, rgba(110,119,116,1) 50%, rgba(10,14,10,1) 51%, rgba(10,8,9,1) 100%); /* FF3.6+ */
background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,rgba(174,188,191,1)), color-stop(50%,rgba(110,119,116,1)), color-stop(51%,rgba(10,14,10,1)), color-stop(100%,rgba(10,8,9,1))); /* Chrome,Safari4+ */
background: -webkit-linear-gradient(top, rgba(174,188,191,1) 0%,rgba(110,119,116,1) 50%,rgba(10,14,10,1) 51%,rgba(10,8,9,1) 100%); /* Chrome10+,Safari5.1+ */
background: -o-linear-gradient(top, rgba(174,188,191,1) 0%,rgba(110,119,116,1) 50%,rgba(10,14,10,1) 51%,rgba(10,8,9,1) 100%); /* Opera 11.10+ */
background: -ms-linear-gradient(top, rgba(174,188,191,1) 0%,rgba(110,119,116,1) 50%,rgba(10,14,10,1) 51%,rgba(10,8,9,1) 100%); /* IE10+ */
background: linear-gradient(to bottom, rgba(174,188,191,1) 0%,rgba(110,119,116,1) 50%,rgba(10,14,10,1) 51%,rgba(10,8,9,1) 100%); /* W3C */
filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#aebcbf', endColorstr='#0a0809',GradientType=0 ); /* IE6-9 */
margin: 0px -17px 0px -12px;
padding: 10px 10px 5px 10px;
height: 10px;
font: bold 14px/0.2 Arial;
color: #fff;
text-shadow: white 0.1em 0.1em 0.6em

}
.txtbox {
background-color: transparent;
width: 330px;

}




</style> </head> <body>

Now click on Row, select the whole code, delete it and paste the following code.
Row code for Mikrotik Voucher Template.

<div class="box">
<h2>usage.dotnet.com - Internet Card Rs %u_moneyPaid%</h2>
<div class="txtbox">
How to use this card? <br> Find <b>Dotner</b> Connect and open you webbrowser <br> Put the <b>UsreName</b> & <b>Password</b> in required field <b>click login button.</b> </br>
</div>
<p align="left"> UserName: <h3>%u_username%</h3> </p>
<p align="left"> Password: <h3>%u_password%</h3></p>
<h5 style="margin-top: -70px; margin-left: 230px; font: bold 30px Arial; color: #fff; text-shadow: black 0.1em 0.1em 0.6em;">%u_timeLeft%</h5>
<p style="margin-top: -40px; margin-left: 250px;"> Price: %u_moneyPaid%</p>
<h4>Contact for more info. suman.barman@gmail.com</h4>
</div>

Click Save.
After doing this, now move to the Users section,
We will create users in bulk (Batch users)
Click on Users > Add > Batch

Number of users: Enter the number how many users you want to create.
Username prefix:Enter the letters you want in every username.
Username length:Select the length of username characters.
Password Length:Select the length of password.
Select a profile for these users and click on add.

We have created 10 users(You an create as many as you want same like this) and we will create their Mikrotik Voucher Template or voucher card.
Select the users for whom you want to create cards.
Click on Generate > Vouchers
---------------
Click on Generate
-------------------
and it will pop up a window.(you can click on download as file to download them in an HTML File.)
-----------------------
Now print these cards and place them to a retail shop and enjoy your free life……


best regards
Suman

Dotnet
(Mini ISP)
 
mfrabbibd
Member Candidate
Member Candidate
Posts: 105
Joined: Sat Feb 22, 2014 9:25 pm

Re: recharge an userman account with pin & password

Thu Oct 01, 2015 5:01 am

I don't know what's your configuration? PPPoE or Hotspot ..
i am described here only PPPoE & user manager setup for your pin & password

This guide will illustrate howto create PPPoE server in MIKROTIK RouterOS (I used v 5.21 in this example). This article will also demonstrate on how you can create your automated pre-paid billing solution for users using Mikrotik’s User Manager. This basic RADIUS Server USERMAN can be used for any ppp service like PPPoE/HOTSPOT.

1) PPPoE Server (Basic Settings)
2) User Manager Billing Setup

In this example Mikrotik have two Lan cards.
1) ether1 = ip 10.0.0.1 / LAN Interface hosting PPPoE Server
2) ether2 = ip 192.168.0.1 / WAN interface connected with Fiber.

First we will add PPPoE Server using CLI (command interface)
/interface pppoe-server server
add authentication=pap default-profile=default disabled=no interface=ether1 keepalive-timeout=10 max-mru=1480 max-mtu=1480 max-sessions=1 mrru=disabled one-session-per-host=yes service-name=dotnet

Now we will add IP Pool for pppoe-users (ips that user will get after successful dialing)
/ip pool add name=pppoe-users-pool ranges=172.16.0.1-172.16.0.254

Now we will add new profile for pppoe users.
/ppp profile add change-tcp-mss=default dns-server=10.0.0.1 local-address=10.0.0.1 name=pppoe-profile only-one=default remote-address=pppoe-users-pool use-compression=default use-encryption=default use-vj-compression=default

Add following rule to allow internet.
/ip firewall nat add action=masquerade chain=srcnat disabled=no src-address=172.16.0.1-172.16.0.255

(In above masquerading rule, I have added src-address to 172.16.0.x ip pool, so that ONLY pppoe connected users internet will work)

Add DNS server so users can resolve internet hostnames.
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8, 8.8.4.4

Now finally we will add local user to test the pppoe server status.
/ppp secret add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=suman password=1234 profile=pppoe-profile routes="" service=pppoe

Now at user end, create a pppoe dialer and connect with the id = suman and password = 1234
If all goes fine, you will start surfing the internet smoothly

Now we will move to mikrotik billing system using its built-in radius called USER MANAGER.

MIKROTIK USER MANAGER WITH BILLING SETUP

We can setup a RADIUS server in mikrotik using its built-in radius server called User Manager. UM is a nice web-based billing manager package to compliment hotspot / pppoe authentication solution in RouterOS. It is RADIUS based component so it can provide centralised management to single or multiple RouterOS based NASes.

Now we will first configure user manager and then later we will integrate it with our pppoe server so all authentication will be done via UM.

Open your web browser and point it to http://10.0.0.1/userman
You will see user manager authentication screen, Now enter admin id and password and you will be forwarded to main UM screen like this.
Note: If default admin password doesn’t work out, change the password by following command

/tool user-manager customer set admin password=PASSWORD
***or***
/tool user-manager customer print

Now click on Profiles, on your right window, click on + sign (beside profile)

For test purposes, we will add one profile with 256Kbps speed limit, and 30 days UP Time limit. You can add many packages as per your requirements later, once you understand how thins works here)

Now we want to add 256Kb / 30days Limit Package, Name it 256k.

* in ‘Name for users‘ type ‘256k’
* in ‘Validity‘, type ’4w2d’ (for 1 month validity)
* in ‘Starts‘ , select ‘At First Logon‘ (User time will start when users first login)
* in ‘Price’ enter the amount at which you sell this package to users. e.g 1000
* in ‘Shared Users’ select ’1′ (so single ID cannot be used from multiple computers simultaneously)
---------------------
Now Save Profile.

Now We want to add Bandwidth Limitation to this profile, goto ‘Limitations’ and click on ADD ,
A new window will appear

* in ‘Name’ type ’256k’
* in ‘Rate Limit’ in RX ’128k’ in TX ’256k’ ,
---------------------
Now click on SAVE.

Now go back to Profiles Section. Here you will see your created 256k
Profile, clien on ‘Add New Limitation’ and and click on ’256k Limit’ and
click ‘ADD’ button.
-----------------------
Done, your first package with 256k Limit and 30 Days uptime limit is created. Now we will Add new user and tag them with this new 256k profile.

Goto Users, and click on ADD / One (to add single user).

* in ‘Username’ type ‘suman’
* in ‘Password’ type ’1234′
* in ‘Constraints’ check on ‘Called ID’ Bindon first use. This options is good if you want to bind user id with first detected MAC address, if you don’t want to bind , leave this option as it is.
* in ‘Assign profile’ select ’256k’ profile and click on ADD button to finish.

Now that we have finished our basic work with UM, its time to integrate it with Mikrotik, so that all Mikrotik PPPoE authentication will be done via UM.

We have to modify some settings, both on UM and Mikrotik as well.

In UM we have to add Mikrotik Router.
* In UM, Goto Routers , ADD, NEW, name it Mikrotik,
* in ‘IP Address’ tpye you server IP address, 10.0.0.1
* in ‘Shared Secret’ type ’1234′
Now click ADD to finish.

UM section is complete , now moving on to MIKROTIK to complete the RADIUS setup.
ADDING RADIUS SUPPORT IN MIKROTIK
Open Mikrotik Terminal, and type
/radius add accounting-backup=no accounting-port=1813 address=10.0.0.1 authentication-port=1812 called-id="" disabled=no domain="" realm="" secret=1234 service=ppp,hotspot timeout=300ms
/ppp aaa set accounting=yes interim-update=0s use-radius=yes
/radius incoming set accept=yes port=3799

Make sure you change the ip address as per your local configuration.
COMPLETED

Now open your browser and enter your LAN or WAN IP with/userman e.g 10.0.0.1/userman
It will prompt you to a login screen, enter your login details that we used in New terminal window e.g username:admin Password:1234.
Click Login.

Now from client end, connect with Users id ‘suman’ and password ’1234′ that you created via UM. It should connect fine. After first connect, this ID will expires in 30 days and bandwidth limit will be 256kb download and 128kb upload.
To view status/change password etc, from client side, point the browser to
http://10.0.0.1/user

[depend on your ip series]

If you need any assistance, Do let me know.

Mikrotik Voucher
Mikrotik Voucher Template or mikrotik scratch system are the two names of a same thing. Mikrotik User manager offers a very useful and interesting feature of Voucher template which is used to print the scratch cards of your network. Where user can buy your Internet card from your authorized retailer and can use your internet. Isn’t it very cool?you are fully free, no tension of bill collection and user complaints.You can sleep with both eyes closed. It generates your customers automatically. Mikrotik Voucher Template is the fully automated system which will print your vouchers and you just have to place them at the retail stores in your network area.
But there is a little drawback of Mikrotik Voucher Template system that it does not give serial numbers to the cards which can print a card for two times but no worries,I have an idea taken from Syed Jahanzaib, you can import ID Passwords from .csv file into MS Access and use a search function to avoid duplication. I know you can manage it and Mikrotik will also think about it.

So, let’s start our work.
First open your Mikrotik User manager and go to settings > templates and click on vouchers.
Header code for Mikrotik Voucher Template

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml"> <head> <title>Vouchers</title> <style> @media print { .noprint { display: none; } .pagebreak { page-break-after: always; } }
body {
font-family: 'Lucida Grande', 'Helvetica Neue', Helvetica, Arial, sans-serif;
padding: 100px;
font-size: 13px;
}

div.box {

background: rgb(230,240,163); /* Old browsers */
background: -moz-linear-gradient(-45deg, rgba(230,240,163,1) 0%, rgba(210,230,56,1) 50%, rgba(195,216,37,1) 51%, rgba(219,240,67,1) 100%); /* FF3.6+ */
background: -webkit-gradient(linear, left top, right bottom, color-stop(0%,rgba(230,240,163,1)), color-stop(50%,rgba(210,230,56,1)), color-stop(51%,rgba(195,216,37,1)), color-stop(100%,rgba(219,240,67,1))); /* Chrome,Safari4+ */
background: -webkit-linear-gradient(-45deg, rgba(230,240,163,1) 0%,rgba(210,230,56,1) 50%,rgba(195,216,37,1) 51%,rgba(219,240,67,1) 100%); /* Chrome10+,Safari5.1+ */
background: -o-linear-gradient(-45deg, rgba(230,240,163,1) 0%,rgba(210,230,56,1) 50%,rgba(195,216,37,1) 51%,rgba(219,240,67,1) 100%); /* Opera 11.10+ */
background: -ms-linear-gradient(-45deg, rgba(230,240,163,1) 0%,rgba(210,230,56,1) 50%,rgba(195,216,37,1) 51%,rgba(219,240,67,1) 100%); /* IE10+ */
background: linear-gradient(135deg, rgba(230,240,163,1) 0%,rgba(210,230,56,1) 50%,rgba(195,216,37,1) 51%,rgba(219,240,67,1) 100%); /* W3C */
filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#e6f0a3', endColorstr='#dbf043',GradientType=1 ); /* IE6-9 fallback on horizontal gradient */

width: 3.6in;
height: 2.1in;
padding: 0 17px 18px 12px;
margin: 10px 0;
border: solid 1px #D9D9D9;
border-radius: 10px;
-webkit-border-radius: 2px;
-moz-border-radius: 2px;
}

div.box h2 {

background: rgb(30,87,153); /* Old browsers */
background: -moz-linear-gradient(top, rgba(30,87,153,1) 0%, rgba(41,137,216,1) 50%, rgba(32,124,202,1) 51%, rgba(125,185,232,1) 100%); /* FF3.6+ */
background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,rgba(30,87,153,1)), color-stop(50%,rgba(41,137,216,1)), color-stop(51%,rgba(32,124,202,1)), color-stop(100%,rgba(125,185,232,1))); /* Chrome,Safari4+ */
background: -webkit-linear-gradient(top, rgba(30,87,153,1) 0%,rgba(41,137,216,1) 50%,rgba(32,124,202,1) 51%,rgba(125,185,232,1) 100%); /* Chrome10+,Safari5.1+ */
background: -o-linear-gradient(top, rgba(30,87,153,1) 0%,rgba(41,137,216,1) 50%,rgba(32,124,202,1) 51%,rgba(125,185,232,1) 100%); /* Opera 11.10+ */
background: -ms-linear-gradient(top, rgba(30,87,153,1) 0%,rgba(41,137,216,1) 50%,rgba(32,124,202,1) 51%,rgba(125,185,232,1) 100%); /* IE10+ */
background: linear-gradient(to bottom, rgba(30,87,153,1) 0%,rgba(41,137,216,1) 50%,rgba(32,124,202,1) 51%,rgba(125,185,232,1) 100%); /* W3C */
filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#1e5799', endColorstr='#7db9e8',GradientType=0 ); /* IE6-9 */

margin: 0 -17px 1px -12px;
padding: 15px 0px 0 10px;
height: 20px;
border-top-left-radius: 10px;
border-top-right-radius: 10px;
-webkit-border-radius: 2px;
-moz-border-radius: 2px;
font: bold 18px/0.2 Arial;
color: #fff;
text-shadow: red 0.1em 0.1em 0.6em}

div.box h3 {
background-color: #FFF8DC;
border-color: #000;
border-style:solid;
border-width:1px;
margin: -35px 0 0 70px;
padding: 12px 50px 3px 10px;
height: 8px;
width: 30px;
font: bold 12px/0 Arial;
color: #000;
}
div.box h4 {

background: rgb(174,188,191); /* Old browsers */
background: -moz-linear-gradient(top, rgba(174,188,191,1) 0%, rgba(110,119,116,1) 50%, rgba(10,14,10,1) 51%, rgba(10,8,9,1) 100%); /* FF3.6+ */
background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,rgba(174,188,191,1)), color-stop(50%,rgba(110,119,116,1)), color-stop(51%,rgba(10,14,10,1)), color-stop(100%,rgba(10,8,9,1))); /* Chrome,Safari4+ */
background: -webkit-linear-gradient(top, rgba(174,188,191,1) 0%,rgba(110,119,116,1) 50%,rgba(10,14,10,1) 51%,rgba(10,8,9,1) 100%); /* Chrome10+,Safari5.1+ */
background: -o-linear-gradient(top, rgba(174,188,191,1) 0%,rgba(110,119,116,1) 50%,rgba(10,14,10,1) 51%,rgba(10,8,9,1) 100%); /* Opera 11.10+ */
background: -ms-linear-gradient(top, rgba(174,188,191,1) 0%,rgba(110,119,116,1) 50%,rgba(10,14,10,1) 51%,rgba(10,8,9,1) 100%); /* IE10+ */
background: linear-gradient(to bottom, rgba(174,188,191,1) 0%,rgba(110,119,116,1) 50%,rgba(10,14,10,1) 51%,rgba(10,8,9,1) 100%); /* W3C */
filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#aebcbf', endColorstr='#0a0809',GradientType=0 ); /* IE6-9 */
margin: 0px -17px 0px -12px;
padding: 10px 10px 5px 10px;
height: 10px;
font: bold 14px/0.2 Arial;
color: #fff;
text-shadow: white 0.1em 0.1em 0.6em

}
.txtbox {
background-color: transparent;
width: 330px;

}




</style> </head> <body>

Now click on Row, select the whole code, delete it and paste the following code.
Row code for Mikrotik Voucher Template.

<div class="box">
<h2>usage.dotnet.com - Internet Card Rs %u_moneyPaid%</h2>
<div class="txtbox">
How to use this card? <br> Find <b>Dotner</b> Connect and open you webbrowser <br> Put the <b>UsreName</b> & <b>Password</b> in required field <b>click login button.</b> </br>
</div>
<p align="left"> UserName: <h3>%u_username%</h3> </p>
<p align="left"> Password: <h3>%u_password%</h3></p>
<h5 style="margin-top: -70px; margin-left: 230px; font: bold 30px Arial; color: #fff; text-shadow: black 0.1em 0.1em 0.6em;">%u_timeLeft%</h5>
<p style="margin-top: -40px; margin-left: 250px;"> Price: %u_moneyPaid%</p>
<h4>Contact for more info. suman.barman@gmail.com</h4>
</div>

Click Save.
After doing this, now move to the Users section,
We will create users in bulk (Batch users)
Click on Users > Add > Batch

Number of users: Enter the number how many users you want to create.
Username prefix:Enter the letters you want in every username.
Username length:Select the length of username characters.
Password Length:Select the length of password.
Select a profile for these users and click on add.

We have created 10 users(You an create as many as you want same like this) and we will create their Mikrotik Voucher Template or voucher card.
Select the users for whom you want to create cards.
Click on Generate > Vouchers
---------------
Click on Generate
-------------------
and it will pop up a window.(you can click on download as file to download them in an HTML File.)
-----------------------
Now print these cards and place them to a retail shop and enjoy your free life……


best regards




Bro, can I have your contact number? Thanks.
 
User avatar
skyctgbd
just joined
Posts: 13
Joined: Thu Oct 01, 2015 3:48 pm
Location: Chittagong, Bangladesh.

Re: recharge an userman account with pin & password

Thu Oct 01, 2015 3:56 pm


Bro, can I have your contact number? Thanks.

you can contact with me by mail: skyctgbd@gmail.com
 
sabqatraja
just joined
Posts: 1
Joined: Wed Dec 02, 2020 10:30 am

Re: recharge an userman account with pin & password

Wed Dec 02, 2020 10:39 am

Hi All,

1- if any way to create Users/ Passwords in bulk.
2- if any way to regenerate after a certain time period voucher code password for users to use internet
3- We can use Mikrotik router as POE switch to give power to AP's

Please i need help as i am new in MikroTik platform.

Thank you in advance for your cooperation.

Regards,
Raja Sabqat
+971507748164
rajasabqat@gmail.com

Who is online

Users browsing this forum: No registered users and 10 guests