Community discussions

MUM Europe 2020
 
geoff
just joined
Topic Author
Posts: 11
Joined: Tue Dec 07, 2010 1:54 pm

PayPal - bad http response

Fri Sep 28, 2012 6:18 pm

I've been running mikrotik (x86) hotspot + usermanager + paypal for 3 years, but as of September 5th I've been having paypal issues.

When a customer signs up to make a new account and pays with paypal, the funds are transfered to my paypal account, but no time is credited to the customers usermanager account. Looking through the logs I see:

/tool user-manager payment print without-paging

686 user=test103 customer=fair price=1 currency="CAD" trans-start=sep/28/2012 15:04:20 trans-end=sep/28/2012 15:04:52
trans-status=error result-code=0 result-msg="PayPal - bad http response" method=paypal

Over the last three weeks I'm seeing the "PayPal - bad http response" error happen on about 90% of all transactions. This is really annoying as the customer gets billed, we receive payment, but the usermanager just errors out. From the customer's perspective everything looks fine from signup to the paypal redirect back to the router, until they try to log in with their new account and get an "Invalid username or password error.

Has something changed with paypal's API in the last few weeks? We haven't changed anything on our setup, network and software-wise. I've tried upgrading from 4.17 -> 5.20 and the problem is still occuring. Is anyone else having this issue?????
 
geoff
just joined
Topic Author
Posts: 11
Joined: Tue Dec 07, 2010 1:54 pm

Re: PayPal - bad http response

Fri Sep 28, 2012 8:44 pm

Here's a packet capture of a (rare) successful paypal transaction between my mikrotik and paypal (paypal is doing a POST callback to the mikrotik):

POST /user?serviceId=MWT.Payment&method=2 HTTP/1.0
Content-Type: application/x-www-form-urlencoded
Host: xxx.xxxx.com
Content-Length: 722

transaction_subject=test&payment_date=09%3A22%3A45+Sep+28%2C+2012+PDT&txn_type=web_accept&last_name=Patterson&residence_country=CA&item_name=test&payment_gross=&mc_currency=CAD&business=xxxx.paypal%40xxxx.com&payment_type=instant&protection_eligibility=Ineligible&verify_sign=AyHn0McMTB95zR4zKdlj5Q5MX6JVAWez1W3zUcww7Ql85atP7TNOyEEI&payer_status=verified&tax=0.00&payer_email=open%40xxxxxx.com&txn_id=3PB10273Y9429593Y&quantity=1&receiver_email=xxxx.paypal%40xxxx.com&first_name=Nancy&payer_id=MG9BVVGVC9HSN&receiver_id=BJ7XCAYEKN6LY&item_number=416&handling_amount=0.00&payment_status=Completed&payment_fee=&mc_fee=0.01&shipping=0.00&mc_gross=0.01&custom=&charset=windows-1252&notify_version=3.7&ipn_track_id=7f9e6a33fa42

HTTP/1.0 200 OK
Connection: close
Date: Fri, 28 Sep 2012 16:22:50 GMT
Expires: 0

=======================================

And here's a failed one:

POST /user?serviceId=MWT.Payment&method=2 HTTP/1.0
Content-Type: application/x-www-form-urlencoded
Host: xxx.xxxx.com
Content-Length: 723

transaction_subject=test&payment_date=10%3A35%3A18+Sep+28%2C+2012+PDT&txn_type=web_accept&last_name=Patterson&residence_country=CA&item_name=test&payment_gross=&mc_currency=CAD&business=xxxx.paypal%40xxxx.com&payment_type=instant&protection_eligibility=Ineligible&verify_sign=AKhddjoDmroI5a0-syFcLzr-ztdQAb5SHNgcc0nM6SimR3cjD3oY6uwz&payer_status=verified&tax=0.00&payer_email=open%40xxxxxx.com&txn_id=9AY364132Y189800P&quantity=1&receiver_email=xxxx.paypal%40xxxx.com&first_name=Nancy&payer_id=MG9BKVGVCQHSN&receiver_id=BJ7XCASEKY6LY&item_number=420&handling_amount=0.00&payment_status=Completed&payment_fee=&mc_fee=0.01&shipping=0.00&mc_gross=0.01&custom=&charset=windows-1252&notify_version=3.7&ipn_track_id=c8b905caaf784

HTTP/1.0 200 OK
Connection: close
Content-Length: 42
Content-Type: text/plain
Date: Fri, 28 Sep 2012 17:35:25 GMT
Expires: 0

FAILED: Internal error (invalid customer)
 
v-sat
just joined
Posts: 7
Joined: Sat Sep 29, 2007 1:29 pm

Re: PayPal - bad http response

Wed Oct 03, 2012 9:51 pm

Hi Geoff

we have been getting exactly the same problem.....from the same time.

We are located Spain...just in case this is a "local" issue.

Have you found a solution?

it is driving me crazy....and we are having to refund alot of unhappy clients!!!

David
 
octavio
just joined
Posts: 3
Joined: Mon Jun 04, 2007 12:30 pm

Re: PayPal - bad http response

Mon Oct 08, 2012 10:44 am

Hi

We also have the same problem for about a month.

I've sent an e-mail to support@mikrotik.com. I hope we have a solution soon.

Octavio
 
octavio
just joined
Posts: 3
Joined: Mon Jun 04, 2007 12:30 pm

Re: PayPal - bad http response

Tue Oct 23, 2012 12:26 pm

Since we have upgraded user-manager to 5.21, the number of "PayPal - bad http response" errors is much lower, but we still have some errors.

Octavio
 
v-sat
just joined
Posts: 7
Joined: Sat Sep 29, 2007 1:29 pm

Re: PayPal - bad http response

Tue Oct 23, 2012 10:33 pm

Still getting load of issues. 8 out of 10 transactions fail!!!!

Pointless to upgrade if the problem is still there......and no one cares!!!

We are building a Radiusmanager radius server. It is almost ready...just a couple of last things to iron out but it looks superb!!

Can´t wait to switch over
 
chichanaga
just joined
Posts: 1
Joined: Fri Jul 20, 2012 3:51 pm

Re: PayPal - bad http response

Tue Oct 30, 2012 12:03 pm

I have the same issue . From last month I have more than 60% bad http response . I have 5.21. What happen with Mikrotik?
 
User avatar
nest
Forum Veteran
Forum Veteran
Posts: 816
Joined: Tue Feb 27, 2007 1:52 am
Location: UK
Contact:

Re: PayPal - bad http response

Wed Nov 07, 2012 5:58 pm

This is affecting more than Mikrotik UM users... http://support.shopsite.com/KBase/questions/2548/ and http://www.tipsandtricks-hq.com/forum/t ... s-of-oct-1 and http://www.lexiconn.com/blog/2012/09/dr ... -standard/

This is also a useful page to reference : https://ppmts.custhelp.com/app/answers/detail/a_id/92

From PayPal : "We will also drop support for non-SSL secured IPN postback (via port 80). You *must* post back to https://www.paypal.com/cgi-bin/webscr?c ... y-validate over port 443 from now on."

Seems PayPal changed their IPN call back method in September, which is when User Manager started to fail - quite likely when they moved everything to Akamai.

Octavio - do you have the support ticket number so I can send Mikrotik some more information on this change by PayPal as they may not read this post?

We have lost a lot of reputation on our Hotspots in Guernsey as every payment went through, but PayPal was no longer communicating with UM in the same way anymore and have now had to switch over to a "24/7 trial" setting on Hotspot as User Manager no longer works with PayPal. :-(

Thanks once again, PayPal!!
Ron Touw - Mikrotik Certified Trainer
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/category/166
Largest Official UK MikroTik Distributor
IRC channel: #routerboard on irc.z.je (IPv4), 6.irc.z.je (IPv6)
 
v-sat
just joined
Posts: 7
Joined: Sat Sep 29, 2007 1:29 pm

Re: PayPal - bad http response

Wed Nov 07, 2012 10:07 pm

Nest
thank you for shedding some light on this.
We have had to monitor every transaction (keeping an eye on emails) to quickly manually fix each account and notify the clients as soon as possible.
Fortunately we lost only a few.

Rolling out Radiusmanager 4 on monday. cant wait. Highly recommended. Viktors support and speed in replying is priceless!!!!
 
User avatar
nest
Forum Veteran
Forum Veteran
Posts: 816
Joined: Tue Feb 27, 2007 1:52 am
Location: UK
Contact:

Re: PayPal - bad http response

Thu Nov 08, 2012 12:15 am

v-sat. We bought Radius Manager (v3) a couple of years back, but we were never able to get our billing method to work with it. We were assured again and again in emails it would do it (and Viktor IS very good at support) however despite all the assurances, it did not do what he told us it would. I believe this was a break down in understanding our requirement or a language barrier as like I said, his responses were fast but sadly, in the end, unhelpful. So we are now stuck with a system we have paid for and never used and we went back to using User Manager!

All we wanted to do, is what every other Hotspot in Europe I have ever used does. A client pays for say, "1 hour" and from the time they first login, the clock starts. If they don't use it, they lose it! The problem we had was that Radmanager, as brilliant as it is (and we recommend and support it for any WISPS selling fixed connections), cannot cut someone off after they have been online or not after that 1hr. A voucher or account that has say 1hr should run out after 1hr, however what actually happens is that they can connect for 5 mins, switch off for a year and then they still have another 55mins left to go before they are cut off. In fact, if a client only uses it for 5 mins a day, they make their money go a long way. We want it so that once they first login, that time starts and just keeps on going until the time they bought runs out. Even if they are not using it.

The other problem was that if a client bought a day of time at 23:59, he only actually got 6 mins of online time as at 00:05, his account was promptly cut off as Rad Manager looked at the date and it as it was now 1 more day further on, it thinks that the account is now a day older and expires their account!

We don't want that. User Manager understands our method of usage (as that is how every other Hotspot I have ever used works!) and supports it. Except of course, it no longer works at all with PayPal now. :-(

Now, if someone can tell me if v4 of Radius manager can do this billing method (and give me service settings to demonstrate it on our own server we still have it running on!) we will stop using UM immediately as we need to get this sorted asap.
Ron Touw - Mikrotik Certified Trainer
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/category/166
Largest Official UK MikroTik Distributor
IRC channel: #routerboard on irc.z.je (IPv4), 6.irc.z.je (IPv6)
 
octavio
just joined
Posts: 3
Joined: Mon Jun 04, 2007 12:30 pm

Re: PayPal - bad http response

Thu Nov 08, 2012 10:45 am

Nest, the support ticket number is #2012100366000581.

They told me to upgrade UM to 5.21 to solve the problem, but I haven't any notice from Mikrotik after upgrade it.

Thanks!!!
 
skye1
newbie
Posts: 29
Joined: Thu May 17, 2007 5:10 am

Re: PayPal - bad http response

Sat Nov 24, 2012 4:05 pm

The changes that paypal made to their system is the reason for the failures. My system has been experiencing the same problems for the same amount of time. Here are two links from paypal that describe their change.
https://ppmts.custhelp.com/app/answers/detail/a_id/92
and
https://www.x.com/node/217895/
The problem I am still having is I added the address ipnpb.paypal.com to the walled gardens, but still get bad http response error. The silence from MT on this forum regarding this issue has been deafening. Perhaps because it was not their change that broke the system. I am going to open a support ticket with MT and see where it leads. All of my other efforts to this point have not been successful. If someone has figured out the required adjustment it would be great if it were posted.
 
patrickmkt
Member Candidate
Member Candidate
Posts: 157
Joined: Sat Jul 28, 2012 5:21 pm

Re: PayPal - bad http response

Sat Nov 24, 2012 4:18 pm

What's new in 5.22 (2012-Nov-23 09:28):

*) userman - fix PayPal "bad HTTP response";

Who is online

Users browsing this forum: No registered users and 7 guests