Community discussions

MikroTik App
 
kmullen
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 57
Joined: Thu Dec 30, 2004 9:48 pm

Mass Email to Usermanager clients

Thu Jun 27, 2013 10:12 pm

I would like to be able to send periodic, emails to all clients in the usermanager database, or at least to be able to extract all email addresses in csv file.

I want to use this email to notify of network outages and maintenance as well as system changes.

Any help on this?
 
User avatar
nest
Forum Veteran
Forum Veteran
Posts: 822
Joined: Tue Feb 27, 2007 1:52 am
Location: UK
Contact:

Re: Mass Email to Usermanager clients

Thu Jul 04, 2013 3:24 pm

Not possible via the web interface sadly, but you could try this from a script?
:local text ("This is a message I want every one to get");
:local recipient;

:set text ($text . "\n");
:foreach i in=[/tool user-manager user find disabled=no] do={
  :set recipient ([/tool user-manager user get $i email]);
  :if ($recipient !="") do={
  /tool e-mail send body="$text" to=$recipient subject="Your subject";
  }
};
If you want to personalise the extraction and body content, you could also extract their First Names (variable is "first-name") and insert that at the start of the email body text.

As it is a script, you can then automate the running of the script based upon some other outage alert.

Who is online

Users browsing this forum: No registered users and 37 guests