Community discussions

MikroTik App
 
Prejudice
just joined
Topic Author
Posts: 1
Joined: Mon May 10, 2021 2:22 pm

Port Forwarding Not Working on Default Configuration

Mon May 10, 2021 2:31 pm

Hello there,

I work off a wireless network from a dish on my roof (wlan) to a tower with a fibre backbone. My network configuration is as follows,

Dish/Wlan/Router/Radio on roof (This is where the DHCP server is) (192.168.0.1)
|
POE (power the dish/radio)
|
Access point (192.168.0.250)

Now I have a static Public IP with my ISP and want to port forward ports 7777 and 7778 (TCP and UDP) to my desktop computer with IP 192.168.0.253

However in winbox when I navigate to IP > Firewall > NAT and set up the rule for dst-nat I try opening the server and nobody outside the LAN can connect which clearly shows the port forwarding isn't connecting. The internet comes in through WLAN then runs through Ethernet to the access point then to the other devices on the network.

I've been recommended to use a DMZ but im not sure how to set this up on my router, I also just tried generic port forwarding using my public ip as a destination address, the WLAN as the In interface and then the ports on TCP and UDP to my local ip address and still doesn't work.

Do I also need to allow the connection on the actual firewall? Because there is no other rules there currently. The only rule I see by default is the Masquerade rule under NAT.

I've asked my ISP to have a look but I have not received anything back from them for 2-3 days now.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 7415
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: Port Forwarding Not Working on Default Configuration

Wed May 12, 2021 1:33 pm

Post the configs for the dish/WLAN router and for the access point
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
User avatar
SecCon
newbie
Posts: 48
Joined: Mon May 03, 2021 10:52 am
Location: Skåne, Sweden

Re: Port Forwarding Not Working on Default Configuration

Wed May 12, 2021 8:50 pm

Now I have a static Public IP with my ISP
Not sure about the configuration details but...

I can get fixed IP from my ISP as well but they also tell me that Port Forwarding via that IP may have issues, despite the "fixed" IP. And it did so I reverted to regular assignment, despite having Fiber.
How about just trying a free DNS forwarding service, even if just for testing?
CLI is so 1984 and should be obsolete
- - -
My Mikrotik Devices:
  • Router RB1100AHx4 Dude Edition
  • Switch CRS326-24G-2S+RM

Who is online

Users browsing this forum: No registered users and 60 guests