Community discussions

MikroTik App
 
slimprize
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 89
Joined: Thu Aug 09, 2012 2:43 am

Coping with slow download speeds on my home LAN

Wed Jun 16, 2021 12:58 pm

Hi all,

Users on my home LAN if they are connected to one of the access point's are experiencing significantly reduced download speeds. The way my LAN is designed is as follows.

1. There is a Huawei+adsl+modem+hg532d which is ISP supplied. This is set to bridge mode. It has an incoming fibre optic line which is split into a telephone line and a fibre line via a splitter.
2. My Mikrotik router is connected to this model with a CAT6 cable. The router's model is as follows.
board-name: hAP ac^2

3. My primary desktop and a range of other devices are connected to the ports of the router.
4. There is also a 1GBPS witch that is connected to one of the ports of the router.

The problem is in my bedroom where there is a netgear access point. It is giving me an upload speed of 415MBPS but a download speed of 48MBPS. This is beyond strange because on my primary desktop, I get speeds of 850MBPS down and 927MBPS up.

I have checked the cables and as far as I can tell, they are ok and show 1GBPS. I appreciate there is a speed reduction as you add devices but this is a drastic reduction.

When I talk about speed, I mean speed while browsing the internet. I checked the speed by connecting to the access point in the bedroom with a cable and running the speed test at http://www.speedtest.net.

Where do I start troubleshooting? My router logs do not tell me anything useful and the ISP checked the speed which is ok.

here is the router config.
rc_conf_rsc.txt

Pranav
You do not have the required permissions to view the files attached to this post.
 
mkx
Forum Guru
Forum Guru
Posts: 6169
Joined: Thu Mar 03, 2016 10:23 pm

Re: Coping with slow download speeds on my home LAN

Wed Jun 16, 2021 1:59 pm

A few errors in your configuration:
/ip address
add address=192.168.2.1/24 interface=ether4 network=192.168.2.0
add address=192.168.3.1/24 interface=ether4 network=192.168.3.0
If you really need these two subnets, then you really should set addresses on bridge and not on member port (ether4).

/ip firewall nat
add action=redirect chain=dstnat comment=\
    "force all local traffic to us ethe router as a dns server" \
    dst-address-type=!local dst-port=53 protocol=udp to-addresses=0.0.0.0 \
    to-ports=53
add action=redirect chain=dstnat dst-port=53 protocol=udp to-ports=53
These two are complete and utter rubbish. If you explain (in plain words) what you want to accomplish, you may get an useful advice.


None of these explain the slow downlink you're seeing via your netgear AP. It's not clear to me: how exactly is netgear connected to hAP ac2? Do you use wired connection directly from netgear to hAP ac2 (or via mentioned gigabit switch) or something else? And how exactly was connection (which devices and what was between them) while testing speed?
BR,
Metod
 
slimprize
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 89
Joined: Thu Aug 09, 2012 2:43 am

Re: Coping with slow download speeds on my home LAN

Wed Jun 16, 2021 2:29 pm

Hi @Metod,
1. I want to ensure that all devices use only the router for querying dns hence those rules relating to port 53.
2. The Netgear access point is connected to the Gigabit switch via a cat 6 cable. The switch is then connected to the router.
3. I do nee the sub nets because I have a dedicated server sub net and a dedicated sub net for IP cameras. I have left the default bridge alone so far. How should I add sub nets to them?

Pranav
 
mkx
Forum Guru
Forum Guru
Posts: 6169
Joined: Thu Mar 03, 2016 10:23 pm

Re: Coping with slow download speeds on my home LAN

Wed Jun 16, 2021 6:54 pm

Just one more check: is netgear AP acting only as switch/AP and clients, connected to it, receive IP addresses from mikrotik LAN address space? And when you ran tests, you connected PC eith UTP cable and netgear acted as a switch? If you connect PC to the wire otherwise used to connect netgear, do you see slow download as well?

From ethernet point of view bridge acts as a switch (hence ether4 is not separated from e.g. ether3 witj published configuration). OTOH bridge also provides interface forROS to interact with connected subnet(s). Therefore it is not correct to bind IP setup to port member of bridge (ether4). If you intend to dedicate ether4 to other subnets, you have to remove ether4 from bridge.
BR,
Metod
 
slimprize
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 89
Joined: Thu Aug 09, 2012 2:43 am

Re: Coping with slow download speeds on my home LAN

Thu Jun 17, 2021 2:36 am

Hi Metod,
The Netgear access points act as switches. All IP address assignments are done by the mikrotik.
I have now changed the assignments of the sub nets to interface=bridge.
Many thanks for that pointer.

I had connected the pc to the Netgear access point via a LAN cable.
Pranav
 
mkx
Forum Guru
Forum Guru
Posts: 6169
Joined: Thu Mar 03, 2016 10:23 pm

Re: Coping with slow download speeds on my home LAN

Thu Jun 17, 2021 9:22 am

Did you try speedtest by connecting PC instead of netgear AP? The goal is to narrow down posible problems. If speedtest without netgear in the way shows decent speeds, this would indicate either problem with netgear itself or some interaction problem between netgear and mikrotik. If speedtest is still bad, then the problem might be either with particular UTP cable or with mikrotik (this way or another). Or PC.
BR,
Metod
 
slimprize
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 89
Joined: Thu Aug 09, 2012 2:43 am

Re: Coping with slow download speeds on my home LAN

Thu Jun 17, 2021 11:42 am

Hi Metod,

Yes, I tried with the pc connected directly to the mikrotik and get about 700MBPS as download and 925MBPS as upload which is what I expect.
I have tried changing cables without any change. I have tried on wireless and we are getting 500MBPS download and a similar number as upload.

Could it be a Netgear and Mikrotik issue? If so, what access points work best with Mikrotik?
Pranav
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 4657
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: Coping with slow download speeds on my home LAN

Thu Jun 17, 2021 11:45 am

what access points work best with Mikrotik?
MikroTik?
 
slimprize
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 89
Joined: Thu Aug 09, 2012 2:43 am

Re: Coping with slow download speeds on my home LAN

Thu Jun 17, 2021 1:47 pm

Hi rextended,
I should have seen that coming. <smile

I am confused by the mikrotik website. May be it is just me but it is hard to determine which of their devices are routers and which are access points. Could you perhaps share a link to one access point? I am hoping for something that can support 1GBPS over wireless but I suspect that is beyond my budget.

Pranav

Who is online

Users browsing this forum: jvanhambelgium, Lukasz85 and 30 guests