Community discussions

MikroTik App
 
erwinvr
just joined
Topic Author
Posts: 2
Joined: Sat Sep 05, 2015 11:03 pm

802.3ad between crs109-8g-1s-2hnd-in and esxi 6

Sun Sep 06, 2015 6:36 am

Dear all,

I have a vmware lab with 2 esxi 6 connected to a crs109-8g-1s-2hnd-in, have some trunks and vlan working (i dont know if the config is correct but is working) :D
But my bounding (802.3ad is not working), the speed is from 1 link, and when 1 link i down i lost connectivity

This is my config:
[erwinvr@Tik_LAB] > /interface print 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2
 0  RS ;;; ESX0_VNIC0
       ether1                              ether            1500  1
 1  RS ;;; ESX0_VNIC1
       ether2                              ether            1500  1
 2   S ;;; ESX1_VNIC0
       ether3                              ether            1500  1
 3   S ;;; ESX1_VNIC1
       ether4                              ether            1500  1
 4     ether5                              ether            1500  1
 5     ether6                              ether            1500  1
 6  RS ;;; LAPTOP
       ether7                              ether            1500  1
 7  RS ;;; IPMI
       ether8                              ether            1500  1
 8     sfp1                                ether            1500  1
 9  RS wlan1                               wlan             1500  1
10  R  BRIDGE_WLAN                         bridge           1500  1
11  R  IPMI                                bridge           1500  1
12  R  VLAN99_ESX_MGMT                     bridge           1500  1
13  R  VLAN200_ESX_SRV                     bridge           1500  1
14  R  VLAN201_ESX_ISCSI                   bridge           1500  1
15  R  bound-esx0                          bond             1500
16     bound-esx1                          bond             1500
17  RS vlan99_esx0_vnic0                   vlan             1500  1
18  RS vlan99_esx0_vnic1                   vlan             1500  1
19   S vlan99_esx1_vnic0                   vlan             1500  1
20   S vlan99_esx1_vnic1                   vlan             1500  1
21  RS vlan200_esx0_vnic0                  vlan             1500  1
22  RS vlan200_esx0_vnic1                  vlan             1500  1
23   S vlan200_esx1_vnic0                  vlan             1500  1
24   S vlan200_esx1_vnic1                  vlan             1500  1
25  RS vlan201_esx0_vnic0                  vlan             1500  1
26  RS vlan201_esx0_vnic1                  vlan             1500  1
[erwinvr@Tik_LAB] > interface vlan print
Flags: X - disabled, R - running, S - slave 
 #    NAME                               MTU ARP        VLAN-ID INTERFACE                           
 0 R  vlan99_esx0_vnic0                 1500 enabled         99 ether1                              
 1 R  vlan99_esx0_vnic1                 1500 enabled         99 ether2                              
 2    vlan99_esx1_vnic0                 1500 enabled         99 ether3                              
 3    vlan99_esx1_vnic1                 1500 enabled         99 ether4                              
 4 R  vlan200_esx0_vnic0                1500 enabled        200 ether1                              
 5 R  vlan200_esx0_vnic1                1500 enabled        200 ether2                              
 6    vlan200_esx1_vnic0                1500 enabled        200 ether3                              
 7    vlan200_esx1_vnic1                1500 enabled        200 ether4                              
 8 R  vlan201_esx0_vnic0                1500 enabled        201 ether1                              
 9 R  vlan201_esx0_vnic1                1500 enabled        201 ether2 
[erwinvr@Tik_LAB] > /interface bridge print 
Flags: X - disabled, R - running 
 0  R name="BRIDGE_WLAN" mtu=auto actual-mtu=1500 l2mtu=1600 arp=enabled 
      mac-address=D4:CA:6D:CA:8B:48 protocol-mode=rstp priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 
      ageing-time=5m 

 1  R name="IPMI" mtu=auto actual-mtu=1500 l2mtu=1588 arp=enabled mac-address=D4:CA:6D:CA:8B:45 
      protocol-mode=rstp priority=0x8000 auto-mac=yes admin-mac=00:00:00:00:00:00 
      max-message-age=20s forward-delay=15s transmit-hold-count=6 ageing-time=5m 

 2  R name="VLAN99_ESX_MGMT" mtu=auto actual-mtu=1500 l2mtu=1584 arp=enabled 
      mac-address=D4:CA:6D:CA:8B:3F protocol-mode=rstp priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 
      ageing-time=5m 

 3  R name="VLAN200_ESX_SRV" mtu=auto actual-mtu=1500 l2mtu=1584 arp=enabled 
      mac-address=D4:CA:6D:CA:8B:3F protocol-mode=rstp priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 
      ageing-time=5m 

 4  R name="VLAN201_ESX_ISCSI" mtu=auto actual-mtu=1500 l2mtu=1584 arp=enabled 
      mac-address=D4:CA:6D:CA:8B:3F protocol-mode=rstp priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 
      ageing-time=5m 
Image

I really dont know why this config appears automatically
Image

Any help i really will be happy!
Thanks!
 
TonyJr
Member Candidate
Member Candidate
Posts: 204
Joined: Sat Nov 12, 2011 1:30 am
Location: UK
Contact:

Re: 802.3ad between crs109-8g-1s-2hnd-in and esxi 6

Wed Sep 09, 2015 3:41 am

Dear all,

I have a vmware lab with 2 esxi 6 connected to a crs109-8g-1s-2hnd-in, have some trunks and vlan working (i dont know if the config is correct but is working) :D
But my bounding (802.3ad is not working), the speed is from 1 link, and when 1 link i down i lost connectivity

This is my config:
[erwinvr@Tik_LAB] > /interface print 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2
 0  RS ;;; ESX0_VNIC0
       ether1                              ether            1500  1
 1  RS ;;; ESX0_VNIC1
       ether2                              ether            1500  1
 2   S ;;; ESX1_VNIC0
       ether3                              ether            1500  1
 3   S ;;; ESX1_VNIC1
       ether4                              ether            1500  1
 4     ether5                              ether            1500  1
 5     ether6                              ether            1500  1
 6  RS ;;; LAPTOP
       ether7                              ether            1500  1
 7  RS ;;; IPMI
       ether8                              ether            1500  1
 8     sfp1                                ether            1500  1
 9  RS wlan1                               wlan             1500  1
10  R  BRIDGE_WLAN                         bridge           1500  1
11  R  IPMI                                bridge           1500  1
12  R  VLAN99_ESX_MGMT                     bridge           1500  1
13  R  VLAN200_ESX_SRV                     bridge           1500  1
14  R  VLAN201_ESX_ISCSI                   bridge           1500  1
15  R  bound-esx0                          bond             1500
16     bound-esx1                          bond             1500
17  RS vlan99_esx0_vnic0                   vlan             1500  1
18  RS vlan99_esx0_vnic1                   vlan             1500  1
19   S vlan99_esx1_vnic0                   vlan             1500  1
20   S vlan99_esx1_vnic1                   vlan             1500  1
21  RS vlan200_esx0_vnic0                  vlan             1500  1
22  RS vlan200_esx0_vnic1                  vlan             1500  1
23   S vlan200_esx1_vnic0                  vlan             1500  1
24   S vlan200_esx1_vnic1                  vlan             1500  1
25  RS vlan201_esx0_vnic0                  vlan             1500  1
26  RS vlan201_esx0_vnic1                  vlan             1500  1
[erwinvr@Tik_LAB] > interface vlan print
Flags: X - disabled, R - running, S - slave 
 #    NAME                               MTU ARP        VLAN-ID INTERFACE                           
 0 R  vlan99_esx0_vnic0                 1500 enabled         99 ether1                              
 1 R  vlan99_esx0_vnic1                 1500 enabled         99 ether2                              
 2    vlan99_esx1_vnic0                 1500 enabled         99 ether3                              
 3    vlan99_esx1_vnic1                 1500 enabled         99 ether4                              
 4 R  vlan200_esx0_vnic0                1500 enabled        200 ether1                              
 5 R  vlan200_esx0_vnic1                1500 enabled        200 ether2                              
 6    vlan200_esx1_vnic0                1500 enabled        200 ether3                              
 7    vlan200_esx1_vnic1                1500 enabled        200 ether4                              
 8 R  vlan201_esx0_vnic0                1500 enabled        201 ether1                              
 9 R  vlan201_esx0_vnic1                1500 enabled        201 ether2 
[erwinvr@Tik_LAB] > /interface bridge print 
Flags: X - disabled, R - running 
 0  R name="BRIDGE_WLAN" mtu=auto actual-mtu=1500 l2mtu=1600 arp=enabled 
      mac-address=D4:CA:6D:CA:8B:48 protocol-mode=rstp priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 
      ageing-time=5m 

 1  R name="IPMI" mtu=auto actual-mtu=1500 l2mtu=1588 arp=enabled mac-address=D4:CA:6D:CA:8B:45 
      protocol-mode=rstp priority=0x8000 auto-mac=yes admin-mac=00:00:00:00:00:00 
      max-message-age=20s forward-delay=15s transmit-hold-count=6 ageing-time=5m 

 2  R name="VLAN99_ESX_MGMT" mtu=auto actual-mtu=1500 l2mtu=1584 arp=enabled 
      mac-address=D4:CA:6D:CA:8B:3F protocol-mode=rstp priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 
      ageing-time=5m 

 3  R name="VLAN200_ESX_SRV" mtu=auto actual-mtu=1500 l2mtu=1584 arp=enabled 
      mac-address=D4:CA:6D:CA:8B:3F protocol-mode=rstp priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 
      ageing-time=5m 

 4  R name="VLAN201_ESX_ISCSI" mtu=auto actual-mtu=1500 l2mtu=1584 arp=enabled 
      mac-address=D4:CA:6D:CA:8B:3F protocol-mode=rstp priority=0x8000 auto-mac=yes 
      admin-mac=00:00:00:00:00:00 max-message-age=20s forward-delay=15s transmit-hold-count=6 
      ageing-time=5m 
Image

I really dont know why this config appears automatically
Image

Any help i really will be happy!
Thanks!
I ran into this problem with 5.5 - you have to have vCenter and use it to configure an LACP link on a Distributed Switch ANNND an Enterprise Plus license in order for it to work. I spent hours of my time trying many configurations and many different beers to get this one working. Then I read the licensing/features section of VMware's site.

TonyJr

Who is online

Users browsing this forum: Baidu [Spider], reman6110 and 50 guests