Community discussions

 
intrigue
just joined
Topic Author
Posts: 3
Joined: Sun Oct 18, 2015 1:41 am

SIP Phones not registering

Sun Oct 18, 2015 1:53 am

Hello, I'm hoping someone can help. I'm new to MikroTik and I recently purchased the CRS125-24G-1S running RouterOS 6.32

I've managed to get everything on my network configured and properly communicating with each other (file servers, printers, domain controllers, etc) but we have SIP phones which connect to a hosted pbx solution that will not register. I've disabled all firewall rules and disabled sip helper as suggested on a few posts but still no luck. When I attempt to force the registration I can see the phones activity in connections but it just fails to complete the registration. Works fine on the old router, which is a Watchguard Firebox Edge.
I think my issue is not firewall related but instead a NAT problem but I have not been able to find the solution. Any help is appreciated.
 
Van9018
Long time Member
Long time Member
Posts: 505
Joined: Mon Jun 16, 2014 6:26 pm
Location: Canada - Abbotsford

Re: SIP Phones not registering

Mon Oct 19, 2015 9:59 am

You can use Tools > Packet Capture and capture packets from a test phone. See if the hosted PBX is replying.

Is the Mikrotik using the same public IP as the old router does? Maybe a firewall on hosted PBX side.

Registrations happen over UDP Port 5060 and don't require port forwarding, so no NAT rules required (other than the standard default masquerade rule). The SIP Helper only helps audio connections get established.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2982
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: SIP Phones not registering

Mon Oct 19, 2015 10:42 am

Does the CRS125 have the public IP? or Are you doing double NAT?

There's any relevant log on the PBX side?
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
marrold
Member
Member
Posts: 406
Joined: Wed Sep 04, 2013 10:45 am

Re: SIP Phones not registering

Mon Oct 19, 2015 10:43 am

A packet capture should help.
I'm a SIP / VoIP engineer. Feel free to ask questions...
 
intrigue
just joined
Topic Author
Posts: 3
Joined: Sun Oct 18, 2015 1:41 am

Re: SIP Phones not registering

Tue Oct 20, 2015 1:07 am

Thanks everyone for your suggestions. I was able to fix the problem, unfortunately I have no idea what was the cause was. To correct the issue I cleared all configurations and started over from scratch. Everything, including the phones, came up with no issues.
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: SIP Phones not registering

Wed Oct 21, 2015 11:37 pm

FYI Under "/ip firewall services" you will find a SIP ALG enabled by default. Sometimes disabling this can also help according to some of our local SIP Providers.
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz

Who is online

Users browsing this forum: No registered users and 24 guests