Community discussions

 
nickel78
just joined
Topic Author
Posts: 2
Joined: Wed Feb 24, 2016 12:58 am

Cannot get port forwarding to work

Wed Feb 24, 2016 1:17 am

This is my first time using a Mikrotik device and cannot get it to do the port forwarding properly. I know that I just don't have the proper settings but after searching, I cannot find anything online that will work for me. I am trying to setup remote access to my Plex server. My previous router had simple port forwarding and was easily setup. This is the screen I get when trying to setup the forwarding. I am a beginner on these routers, so I know almost nothing.
You do not have the required permissions to view the files attached to this post.
 
pateutz
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Jan 11, 2012 5:55 pm

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 3:15 am

So port forward,



Firewall -> NAT -> (+ Sign ) will open the new window and introduce the following :
Step1
General Tab you will fill in:

Chain ( dstnat ) - destination chain
Protocol ( tcp or upd ) depending of the service ..
DSt port ..
and in Interface ( external interface )

Step 2
Action
dst-nat
to address ( local addrres from you private interface )
to ports ( the port number of the app that running on internal server )

Finally select OK
PortForward.jpg
Best Regards,

Daniel
You do not have the required permissions to view the files attached to this post.
 
nickel78
just joined
Topic Author
Posts: 2
Joined: Wed Feb 24, 2016 12:58 am

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 3:30 am

Thank you for your quick reply. I tried what you suggested an I am still getting the same results. Is there anything else that could be missing?
 
kiaunel
Member Candidate
Member Candidate
Posts: 211
Joined: Mon Jul 21, 2014 7:59 pm
Location: Romania

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 7:33 am

Post your firewall rules here.
In terminal :
ip firewall nat export
 
pateutz
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Jan 11, 2012 5:55 pm

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 8:10 am

Thank you for your quick reply. I tried what you suggested an I am still getting the same results. Is there anything else that could be missing?
Hi,

if the Plex server it's taking ip through DHCP server from Mikrotik ?

Please send us the NAT configuration that you done it, using the cli or pictures .

Best Regards,

Daniel
 
Revelation
Member
Member
Posts: 338
Joined: Fri Dec 25, 2015 5:59 am

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 5:19 pm

You actually don't need to setup remote access on Plex, which is payware...

Follow pateutz's advice.

Your dst-nat should look something like:
chain=dst-nat action=dstnat in-interface="WAN" dst-port=23444 to-address=192.168.1.5 to-port=32400
 
fompt
just joined
Posts: 2
Joined: Wed Feb 24, 2016 5:42 pm

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 5:52 pm

Hi guys,

I've just tried to forward port on my hAP router, and couldn't get it to work, through testing found something that did worked, but is kinda weird:

change incoming interface from ether1-gateway to all ethernet. don't quite understand it but now it forwards correctly.
Any idea why?

Image

Update: now I've changed it back to ether1-gateway and it is working. Really weird.
 
pateutz
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Jan 11, 2012 5:55 pm

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 7:14 pm

Hi guys,

I've just tried to forward port on my hAP router, and couldn't get it to work, through testing found something that did worked, but is kinda weird:

change incoming interface from ether1-gateway to all ethernet. don't quite understand it but now it forwards correctly.
Any idea why?

Image

Update: now I've changed it back to ether1-gateway and it is working. Really weird.
So now it's ok !?

For more understanding please read the documentation from :

http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/NAT
or some presentations:

https://www.youtube.com/watch?v=LXoai9COaDM
https://www.youtube.com/watch?v=YEXGqt5QG08

Best Regards,

Daniel
 
fompt
just joined
Posts: 2
Joined: Wed Feb 24, 2016 5:42 pm

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 8:30 pm

Yep, now its working, I understand how firewall works (but thank you for links :) ), I don't get why "all ethernet" unblocked it somehow.
 
pateutz
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Jan 11, 2012 5:55 pm

Re: Cannot get port forwarding to work

Wed Feb 24, 2016 9:07 pm

Yep, now its working, I understand how firewall works (but thank you for links :) ), I don't get why "all ethernet" unblocked it somehow.
Hi ,

i don't know relay. Sometime the OS it's not behave has should be.
Normally when i am seeing this kind of things i am running a reset configuration and starting over with the configuration.

But in this special setup that you have done it decently should work just with ether1-gateway not will all Ethernet.

Best Regards,

Daniel
 
kd6icz
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Wed Jun 15, 2016 11:29 pm

Re: Cannot get port forwarding to work

Fri Jun 24, 2016 12:03 am

I am so confused.....
I am not a router expert by any means and I have been reading all these different threads on how to make my Plex server available to the outside of my network....  Everything I try doesn't work.
Isn't there a simple way to make this happen????
Please?

Who is online

Users browsing this forum: MSN [Bot] and 12 guests