Community discussions

MUM Europe 2020
 
ast
just joined
Topic Author
Posts: 4
Joined: Sat Mar 05, 2016 7:51 pm

Device with pre-configured IP address

Sat Mar 05, 2016 7:57 pm

Hello,

I have just configured my MikroTik RB2011UiAS-IN and I need to connect with it my alarm that has a pre-configured static IP address in it: 192.168.0.100, which I cannot change.

My router uses by default the addresses of format 192.168.88.x.

Could somebody please suggest how to configure router to accept this static IP address from my alarm?

Thanks a lot!
 
kiaunel
Member Candidate
Member Candidate
Posts: 211
Joined: Mon Jul 21, 2014 7:59 pm
Location: Romania

Re: Device with pre-configured IP address

Sat Mar 05, 2016 9:22 pm

Add an address on interface connected to alarm system.
ip address add address=192.168.0.1/24 interface=lan network=192.168.0.0
 
ast
just joined
Topic Author
Posts: 4
Joined: Sat Mar 05, 2016 7:51 pm

Re: Device with pre-configured IP address

Sat Mar 05, 2016 11:42 pm

Thanks a lot.

Done.

But instead of routing me to my alarm by this address I access the router itself. E.g. if I type in my browser http://192.168.0.100 I get Mikrotik admin page...

Any suggestions when am I doing wrong?
 
kiaunel
Member Candidate
Member Candidate
Posts: 211
Joined: Mon Jul 21, 2014 7:59 pm
Location: Romania

Sun Mar 06, 2016 12:54 am

Post your config


Sent from my Lenovo K50-t5 using Tapatalk
 
ast
just joined
Topic Author
Posts: 4
Joined: Sat Mar 05, 2016 7:51 pm

Re: Device with pre-configured IP address

Sun Mar 06, 2016 1:31 am

Here it goes

# mar/05/2016 20:48:44 by RouterOS 6.30.4
#
/interface bridge
add admin-mac=ZZZ auto-mac=no name=bridge-local
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local \
name=ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local \
name=ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local \
name=ether5-slave-local
set [ find default-name=ether6 ] name=ether6-master-local
set [ find default-name=ether7 ] master-port=ether6-master-local \
name=ether7-slave-local
set [ find default-name=ether8 ] master-port=ether6-master-local \
name=ether8-slave-local
set [ find default-name=ether9 ] master-port=ether6-master-local \
name=ether9-slave-local
set [ find default-name=ether10 ] master-port=ether6-master-local \
name=ether10-slave-local
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1-gateway name=\
pppoe-out1 password=XXX use-peer-dns=yes user=YYY
/ip neighbor discovery
set ether1-gateway discover=no
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge-local name=default
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=ether6-master-local
add bridge=bridge-local interface=sfp1
/ip address
add address=192.168.88.1/24 comment="default configuration" \
interface=ether2-master-local network=192.168.88.0
add address=192.168.0.100/24 interface=ether7-slave-local network=\
192.168.0.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid \
interface=ether1-gateway
/ip dhcp-server lease
add address=192.168.88.254 client-id=XXX mac-address=\
YYY server=default
add address=192.168.88.251 mac-address=ZZZ server=\
default
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" gateway=\
192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=\
established,related
add action=drop chain=input comment="default configuration" \
in-interface=ether1-gateway
add action=fasttrack-connection chain=forward comment=\
"default configuration" connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
established,related
add action=drop chain=forward comment="default configuration" \
connection-state=invalid
add action=drop chain=forward comment="default configuration" \
connection-nat-state=!dstnat connection-state=new in-interface=\
ether1-gateway
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
out-interface=pppoe-out1
/system clock
set time-zone-name=Europe
/system routerboard settings
set protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=ether6-master-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=sfp1
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=ether6-master-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=sfp1
add interface=bridge-local
/tool romon port
add
 
User avatar
ZeroByte
Forum Guru
Forum Guru
Posts: 4051
Joined: Wed May 11, 2011 6:08 pm

Re: Device with pre-configured IP address

Sun Mar 06, 2016 3:34 am

You used the wrong IP address for the secondary LAN address.

You configured 192.168.0.100/24 as the Mikrotik's IP - change this to 192.168.0.1/24
The network is correct so don't change that.
When given a spoon,
you should not cling to your fork.
The soup will get cold.
 
kiaunel
Member Candidate
Member Candidate
Posts: 211
Joined: Mon Jul 21, 2014 7:59 pm
Location: Romania

Re: Device with pre-configured IP address

Sun Mar 06, 2016 7:40 am

Yes, i said 0.1 not 0.100 :)
 
ast
just joined
Topic Author
Posts: 4
Joined: Sat Mar 05, 2016 7:51 pm

Re: Device with pre-configured IP address

Sun Mar 06, 2016 11:27 am

Thank you very much. It finally works!

Who is online

Users browsing this forum: No registered users and 31 guests