Community discussions

MUM Europe 2020
 
th0massin0
Member Candidate
Member Candidate
Topic Author
Posts: 144
Joined: Sun May 11, 2014 4:16 am
Location: Poland

Intervlan speed problem with RB2011 and CRS125

Tue Mar 08, 2016 3:20 pm

Hello,
I have a problem with not enough speed in vlan routing and high cpu usage between RB2011 and CRS125.
The devices are connected between ourselves on eth1.

Defined vlans (on 2011):
/interface vlan
add interface=eth1 name=vlan_SVRs vlan-id=10
add interface=eth1 name=vlan_CLIs vlan-id=11
RB2011 acts as DHCP and DNS server too


Switch chip config (on CRS):
/interface ethernet switch egress-vlan-tag
add tagged-ports=eth1 vlan-id=10
add tagged-ports=eth1 vlan-id=11
/interface ethernet switch ingress-vlan-translation
add new-customer-vid=10 ports=eth2,eth3,eth4,eth5,eth6,eth7,eth8
add new-customer-vid=11 ports=eth9,eth10,eth11,eth12,eth13,eth14,eth15,eth16
/interface ethernet switch vlan
add learn=no ports=eth1,eth2,eth3,eth4,eth5,eth6,eth7,eth8 vlan-id=10
add learn=no ports=eth1,eth9,eth10,eth11,eth12,eth13,eth14,eth15,eth16 vlan-id=11
When I am copying file from client host to server host, I am getting aprox 34 MB/s instead of expected 90 MB/s and the 2011's CPU load is high.

Image

Is there any posibility to use vlans in this configuration without the problem mentioned above ?
Please help.
 
mpreissner
Member
Member
Posts: 356
Joined: Tue Mar 11, 2014 11:16 pm
Location: Columbia, MD

Re: Intervlan speed problem with RB2011 and CRS125

Tue Mar 08, 2016 4:22 pm

A few things to keep in mind about this setup...

The RB2011 is only capable of between about 700 mbps and 1500 mbps (1.5 gbps) depending on how you have it configured. Additionally, you have a single cable carrying both VLANs to the router. This means they have to contend for bandwidth. Also, the block diagram of the RB2011 indicates that the gigabit ports all share a common 1 Gbps link to the CPU, where the routing is done. By design, this severely limits the total achievable throughput.

You ought to be able to get better throughput with some configuration tweaks, but don't have high expectations. The RB2011 is a much less capable model than others.
Michael Preissner
CISSP, CCSP, CEH, PMP
 
th0massin0
Member Candidate
Member Candidate
Topic Author
Posts: 144
Joined: Sun May 11, 2014 4:16 am
Location: Poland

Re: Intervlan speed problem with RB2011 and CRS125

Wed Mar 09, 2016 3:03 pm

.. so wire-speed inter vlan communication is impossible with CRS125 ??
 
mpreissner
Member
Member
Posts: 356
Joined: Tue Mar 11, 2014 11:16 pm
Location: Columbia, MD

Re: Intervlan speed problem with RB2011 and CRS125

Wed Mar 09, 2016 3:25 pm

The CRS is intended as a wire-speed switch (layer 2). It has minimal layer 3 capabilities. If you check the performance metrics on routerboard.com, you'll see that it's only capable of a maximum of 984 mbps bridging/routing, and that's assuming that ALL packets are 1500 bytes. More realistic numbers would be 950/860 with no firewalling, which drops to 352/425 with a reasonable number of firewall rules. It is not meant to be used as a router, and it's very limited for bridging as well. If you want 24 gbps worth of bridging/routing capability, you need to look at the CCR routers. The CRS simply doesn't have enough CPU to support wire-speed inter-VLAN traffic.
Michael Preissner
CISSP, CCSP, CEH, PMP

Who is online

Users browsing this forum: No registered users and 34 guests