Community discussions

MikroTik App
 
zosselp
just joined
Topic Author
Posts: 7
Joined: Wed Feb 03, 2016 9:03 am

OpenVPN routing

Thu Mar 31, 2016 5:43 pm

Hi,

I have some issues setting up my OpenVPN network. I can make succesfull OpenVPN connection from my MikroTik client router to my MikroTik server router. Moreover I can ping OpenVPN server (10.10.10.1) from my MikroTik client (10.10.10.5) but I can't ping server from inside of LAN ( 8.7.1.0 ).

This is what I'm trying to achieve:
Image

And this is my current setup:

/ip firewall nat
 chain=srcnat action=masquerade out-interface=wlan1-local log=no log-prefix="" 
 chain=srcnat action=masquerade src-address=10.8.7.0/24 out-interface=OpenVPN log=no log-prefix="" 
/ip firewall mangle
chain=prerouting action=mark-routing new-routing-mark=OpenVPN passthrough=yes src-address=10.8.7.0/24 log=no log-prefix="" 
Routing table
 0 A S  0.0.0.0/0                          10.10.10.1                1
 1 ADS  0.0.0.0/0                          192.168.43.1              1
 2 ADC  10.8.7.0/24        10.8.7.1        ether1-gateway            0
 3 ADC  10.10.10.1/32      10.10.10.5      OpenVPN                   0
 4 ADC  192.168.43.0/24    192.168.43.110  wlan1-local               0
I would be very grateful for any feedback.
 
olkitu
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Sat Feb 20, 2016 7:04 pm

Re: OpenVPN routing

Sun Apr 03, 2016 6:57 pm

Add this to 10 10.10.1 Mikrotik Router:
/ip route add dst-address=8.7.1.0/24 gateway=10.10.10 5
Remove NAT on OpenVPN interface.

And add 10.10.10.5 Mikrotik Router:
/ip route add dst-address=192.168.0.0/24 gateway=10.10.10.1
Network Specialist

Need know where is cellular tower? Try CellMapper to get know where is cellular tower:
https://www.cellmapper.net/map

Who is online

Users browsing this forum: Google [Bot] and 35 guests