Community discussions

MUM Europe 2020
 
ajtudela
just joined
Topic Author
Posts: 11
Joined: Sat Jun 06, 2015 12:06 am

PPPOE disconnect until DHCP assigned

Sat Apr 02, 2016 2:03 pm

Hi everyone, in the past two weeks I've been experimenting a weird problem with my router. My PPPOE connection with the ISP disconnect until the dhcp server assigned the my sister's computer IP.

It's so weird that I don't know where the problem is or where begin to look for.

Thanks

Al
 
kiaunel
Member Candidate
Member Candidate
Posts: 211
Joined: Mon Jul 21, 2014 7:59 pm
Location: Romania

Re: PPPOE disconnect until DHCP assigned

Sat Apr 02, 2016 3:38 pm

Start looking at logs
Enable dubug pppoe connection logs :
/system logging add topics=pppoe
/system logging add topics=dhcp
then post here some logs regarding disconection.
Also an export config will help to anybody guide you to a solution:
export hide-sensitive
 
ajtudela
just joined
Topic Author
Posts: 11
Joined: Sat Jun 06, 2015 12:06 am

Re: PPPOE disconnect until DHCP assigned

Mon Apr 04, 2016 2:21 am

Start looking at logs
Enable dubug pppoe connection logs :
/system logging add topics=pppoe
/system logging add topics=dhcp
then post here some logs regarding disconection.
Also an export config will help to anybody guide you to a solution:
export hide-sensitive
I did that with the ppoe conection. It turns out that today it's disconnect with my sister's computer on.

So, thi is the pppoe log:
https://dl.dropboxusercontent.com/u/11602465/log.0.txt
https://dl.dropboxusercontent.com/u/11602465/log.1.txt
https://dl.dropboxusercontent.com/u/11602465/log.2.txt

I don't understand
 
kiaunel
Member Candidate
Member Candidate
Posts: 211
Joined: Mon Jul 21, 2014 7:59 pm
Location: Romania

Re: PPPOE disconnect until DHCP assigned

Mon Apr 04, 2016 11:04 pm

Your problem seems to be this:
Apr/02/2016 12:36:56 pppoe,debug vlan6: terminating sessions: interface state changed
Somehow your vlan interface goes up and down? Is it assigned to a bridge with dinamic interfaces?
May i ask why is pppoe-client assigned to a vlan an not an interface?
Post your config too by
export hide-sensitive
command in terminal.
 
ajtudela
just joined
Topic Author
Posts: 11
Joined: Sat Jun 06, 2015 12:06 am

Re: PPPOE disconnect until DHCP assigned

Tue Apr 05, 2016 2:35 am

Your problem seems to be this:
Apr/02/2016 12:36:56 pppoe,debug vlan6: terminating sessions: interface state changed
Somehow your vlan interface goes up and down? Is it assigned to a bridge with dinamic interfaces?
May i ask why is pppoe-client assigned to a vlan an not an interface?
Post your config too by
export hide-sensitive
command in terminal.

Here it goes: https://dl.dropboxusercontent.com/u/11602465/sen.rsc

Vlan6 is assigned to ether1 and it's always connected. I don't know why pppoe is assigned to vlan6, if I assign it to other interface, it's doesnt work, maybe it's my isp thing.

Who is online

Users browsing this forum: MSN [Bot] and 28 guests