Community discussions

 
dominicbatty
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 91
Joined: Wed Jul 07, 2010 12:26 pm

VLAN trunk is not passing traffic - config attached, can anyone take a quick look?

Mon Apr 25, 2016 5:33 pm

Hi guys, can anyone give me some help with a VLAN configuration on a CRS. Three ports being tested ...

ether22 and ether23 - traffic comes in untagged and gets tagged to VLAN=1000
ether24 - traffic leaves the router tagged.

If I connected devices to ether22 and ether23 they can see each other but if I connect a device running on VLAN=1000 to port ether24 it does not get any traffic. I think my problem is that the CRS is not sending tagged traffic out of ether24 and I cannot see why ...

Thanks in advance, I've tried absolutely everything and I cannot get to the bottom of this ... :-(

#
# All interfaces mastered to first ethernet port
#
/interface ethernet
set [ find default-name=ether1 ] name=ether01-master-local
set [ find default-name=ether2 ] master-port=ether01-master-local name=ether02-slave-local
set [ find default-name=ether3 ] master-port=ether01-master-local name=ether03-slave-local
set [ find default-name=ether4 ] master-port=ether01-master-local name=ether04-slave-local
set [ find default-name=ether5 ] master-port=ether01-master-local name=ether05-slave-local
set [ find default-name=ether6 ] master-port=ether01-master-local name=ether06-slave-local
set [ find default-name=ether7 ] master-port=ether01-master-local name=ether07-slave-local
set [ find default-name=ether8 ] master-port=ether01-master-local name=ether08-slave-local
set [ find default-name=ether9 ] master-port=ether01-master-local name=ether09-slave-local
set [ find default-name=ether10 ] master-port=ether01-master-local name=ether10-slave-local
set [ find default-name=ether11 ] master-port=ether01-master-local name=ether11-slave-local
set [ find default-name=ether12 ] master-port=ether01-master-local name=ether12-slave-local
set [ find default-name=ether13 ] master-port=ether01-master-local name=ether13-slave-local
set [ find default-name=ether14 ] master-port=ether01-master-local name=ether14-slave-local
set [ find default-name=ether15 ] master-port=ether01-master-local name=ether15-slave-local
set [ find default-name=ether16 ] master-port=ether01-master-local name=ether16-slave-local
set [ find default-name=ether17 ] master-port=ether01-master-local name=ether17-slave-local
set [ find default-name=ether18 ] master-port=ether01-master-local name=ether18-slave-local
set [ find default-name=ether19 ] master-port=ether01-master-local name=ether19-slave-local
set [ find default-name=ether20 ] master-port=ether01-master-local name=ether20-slave-local
set [ find default-name=ether21 ] master-port=ether01-master-local name=ether21-slave-local
set [ find default-name=ether22 ] master-port=ether01-master-local name=ether22-slave-local
set [ find default-name=ether23 ] master-port=ether01-master-local name=ether23-slave-local
set [ find default-name=ether24 ] master-port=ether01-master-local name=ether24-slave-local
set [ find default-name=sfp-sfpplus1 ] master-port=ether01-master-local name=sfp01-slave-local
set [ find default-name=sfpplus2 ] master-port=ether01-master-local name=sfp02-slave-local

#
# drop invalid packets of VLAN on ports 22,23,24
#
/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports=ether22-slave-local,ether23-slave-local,ether24-slave-local drop-if-no-vlan-assignment-on-ports=ether22-slave-local,ether23-slave-local,ether24-slave-local

#
# Allow packets to leave ether24 tagged with VLAN=1000
#
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether24-slave-local vlan-id=1000

#
# Traffic received on port 22 and 23 with VLAN=0, tag with VLAN=1000 as they enter the router
#
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=1000 ports=ether22-slave-local,ether23-slave-local

#
# Allow ether22,23 and 24 to take part in the VLAN=1000
#
/interface ethernet switch vlan
add ports=ether22-slave-local,ether23-slave-local,ether24-slave-local vlan-id=1000
 
becs
MikroTik Support
MikroTik Support
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: VLAN trunk is not passing traffic - config attached, can anyone take a quick look?

Tue Apr 26, 2016 8:29 am

"drop-if-no-vlan-assignment-on-ports" is not necessary for "ether24-slave-local" port.
Now that option is dropping packets on ether24 port because it does not have an Ingress VLAN translation rule configured.

Who is online

Users browsing this forum: No registered users and 31 guests