Community discussions

MUM Europe 2020
 
usman123
newbie
Topic Author
Posts: 33
Joined: Mon May 16, 2016 4:15 pm

vlan load balancing

Mon May 16, 2016 4:20 pm

5 wan ports needed and i have only 2 wan ports
Is it possible to increase wan ports form VLANs.
 
tiftok
newbie
Posts: 40
Joined: Thu Apr 07, 2016 1:40 pm

Re: vlan load balancing

Mon May 16, 2016 11:23 pm

if your modem support vlan you can do load balancing
Khaled mulsi ->>> I love mikrotik :D --TIFTOK--
 
usman123
newbie
Topic Author
Posts: 33
Joined: Mon May 16, 2016 4:15 pm

vlan load balancing

Tue May 17, 2016 3:29 pm

plz can u guide me configuration of vlan load balancing?
 
tiftok
newbie
Posts: 40
Joined: Thu Apr 07, 2016 1:40 pm

Re: vlan load balancing

Wed May 18, 2016 9:19 am

hello
first make vlan interface
/interface  set [ find default-name=ether1 ] name=WAN
/interface vlan
add interface=WAN name=WAN1 vlan-id=1
add interface=WAN name=WAN2 vlan-id=2
add interface=WAN name=WAN3 vlan-id=3
add interface=WAN name=WAN4 vlan-id=4
go to your modem and active vlan and make vlan id in adsl modem Like mikirotike ..modem1 id 1.

set your modem ip
192.168.1.1
192.168.2.1
192.168.3.1
192.168.4.1

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
add address=192.168.3.2/24 network=192.168.3.0 broadcast=192.168.3.255 interface=WAN3
add address=192.168.4.2/24 network=192.168.4.0 broadcast=192.168.4.255 interface=WAN4

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=WAN3_conn
add chain=input in-interface=WAN4 action=mark-connection new-connection-mark=WAN4_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
add chain=output connection-mark=WAN4_conn action=mark-routing new-routing-mark=to_WAN4

add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.3.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.4.0/24 action=accept in-interface=Local

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/2 action=mark-connection new-connection-mark=WAN3_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/3 action=mark-connection new-connection-mark=WAN4_conn passthrough=yes
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
add chain=prerouting connection-mark=WAN3_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN3
add chain=prerouting connection-mark=WAN4_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN4

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_WAN3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=to_WAN4 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 distance=3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 distance=4 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
add chain=srcnat out-interface=WAN3 action=masquerade
add chain=srcnat out-interface=WAN4 action=masquerade

Khaled mulsi ->>> I love mikrotik :D --TIFTOK--
 
usman123
newbie
Topic Author
Posts: 33
Joined: Mon May 16, 2016 4:15 pm

Re: vlan load balancing

Fri May 20, 2016 1:24 pm

i am confuse how do i connect the cable i have only two physical interface.
 
tiftok
newbie
Posts: 40
Joined: Thu Apr 07, 2016 1:40 pm

Re: vlan load balancing

Sat May 21, 2016 1:51 am

if your modem support vlan you can use switch
Khaled mulsi ->>> I love mikrotik :D --TIFTOK--
 
usman123
newbie
Topic Author
Posts: 33
Joined: Mon May 16, 2016 4:15 pm

2 wan loadbalancing

Wed Jun 22, 2016 9:02 am

when i do 2 wan loadbalancing in mikrotik 1wan work is ok but 2wan routes blue.kindly help me.

Who is online

Users browsing this forum: MSN [Bot] and 17 guests