Community discussions

 
ssb
just joined
Topic Author
Posts: 6
Joined: Sat Jul 14, 2012 9:13 pm

2 wan static ip on RB1100AHx2

Thu Jun 16, 2016 12:49 am

Example:
WAN1 = 82.82.82.82/22 Gate = 82.82.82.1
WAN2 = 72.72.72.72/19 Gate = 72.72.72.1
LAN1 = 192.168.1.0/24
LAN2=172.16.0.1/24

 Id like to be able to srcnat
LAN1 to WAN1
LAN2 to WAN2

Thank you!
 
User avatar
dgnevans
Member
Member
Posts: 463
Joined: Fri Mar 08, 2013 11:24 am
Location: Zimbabwe
Contact:

Re: 2 wan static ip on RB1100AHx2

Thu Jun 16, 2016 8:16 pm

Create srcnat for each connection with source ip as the ip of the lan you would to use for that wan. Put the out interface as the interface of the wan yo uwould like to use. Then setup router marks in the mangle and then your routes.  
 
ssb
just joined
Topic Author
Posts: 6
Joined: Sat Jul 14, 2012 9:13 pm

Re: 2 wan static ip on RB1100AHx2

Thu Jun 16, 2016 10:41 pm

Create srcnat for each connection with source ip as the ip of the lan you would to use for that wan. Put the out interface as the interface of the wan yo uwould like to use. Then setup router marks in the mangle and then your routes.  
It can be an example to my settings

Thank you!
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: 2 wan static ip on RB1100AHx2

Fri Jun 17, 2016 7:50 am

/ip firewall mangle
add action=route chain=prerouting in-interface=LAN1 route-dst=82.82.82.1
try this i dont know if its gonna work or not  !!!
cause there is no wiki  for action=route
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
ssb
just joined
Topic Author
Posts: 6
Joined: Sat Jul 14, 2012 9:13 pm

Re: 2 wan static ip on RB1100AHx2

Fri Jun 17, 2016 8:31 am

/ip firewall mangle
add action=route chain=prerouting in-interface=LAN1 route-dst=82.82.82.1
try this i dont know if its gonna work or not  !!!
cause there is no wiki  for action=route
Thank you. Does not work
Help me please !!!
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: 2 wan static ip on RB1100AHx2

Fri Jun 17, 2016 8:36 am

Use routing mar
/ip firewall mangle
add action=mark-routing chain=prerouting in-interface=LAN1 new-routing-mark=to_Wan1
add action=mark-routing chain=prerouting in-interface=LAN2 new-routing-mark=to_Wan2

/ip route
add distance=1 gateway=82.82.82.1 routing-mark=to_Wan1
add distance=1 gateway=72.72.72.1 routing-mark=to_Wan2


MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE

Who is online

Users browsing this forum: No registered users and 32 guests